You are on page 1of 8

1

UNIAJC
INGENIERIA DE SISTEMAS
PRACTICA BASICA DE LABORATORIO
PRACTICA No. 3 – EL SWITCH y VLANs
PROFESOR: Ing. VICTOR A. CUSPOCA C.

OBJETIVOS:

 Aplicar conceptos de Modelo OSI Capas 1 y 2
 Comprender la utilización de un sistema de cableado estructurado.
 Comprender la utilización de un dispositivo de capa 2 Switch.
 Aplicar el uso de las Normas TIA-568A/TIA-568B
 Aplicar el proceso de asignación de direcciones IP (SUBNETTING) en un
ambiente de red local (LAN)
 Configurar los parámetros necesarios en un switch para implementar una red de
área local (LAN) mediante VLANs distribuidas.
 Repasar los conceptos vistos de Segmentación, dominio de broadcas y dominio
de colisión.
 Aprender a configurar terminales remotas (gestión remota)
 Aprender a mejorar los niveles de seguridad de los dispositivos.

CONOCIMIENTOS PREVIOS REQUERIDOS:

 Modelo OSI capa 1 y 2
 Funcionamiento del Switch
 Fundamentos de VLANs
 Normas TIA 568/A-TIA568/B
 Lectura Evolución de arquitecturas por Álvaro Pachón
 Lectura Tutoriales Packet Tracer 5.2.pdf
 Subnetting

CASO A RESOLVER:

La Empresa “FENIX S.A” ha contratado a los estudiantes de Ingeniería de Sistemas,
porque desea implementar su red de datos y VozIP, para lo cual cuenta con TRES
SWITCHES administrables, que ha adquirido y se encuentran ubicados en tres
pisos diferentes (Piso 1,2 y 3) de su edificio. La empresa desea segmentar el tráfico
entre sus áreas las cuales están claramente definidas como ADMINISTRATIVA,
OPERATIVA Y GERENCIAL y se encuentran distribuidos en los 3 pisos, para la
implementación se ha subcontratado al Ing. Victor Cuspoca para la elaboración del
diseño de la red quien sugirió el diseño presentado en la FIGURA No.1 (Anexo).
Para el desarrollo del proyecto la empresa cuenta con la dirección IP
192.168.200.0/24

Los REQUERIMIENTOS que se deben cumplir en el montaje son los siguientes:

1. Se debe crear TRES VLANs (por cada área funcional) en cada switch, deberá
tener en cuenta el esquema de direccionamiento a utilizar (SUBNETTING).
2. Las direcciones IP de los switches deben pertenecer a la VLAN1 (como
habitualmente se hace).
2

3. Se debe poder gestionar los switches remotamente (desde cualquier lugar) para
lo cual deberá configurar lo necesario en cada uno de estos, garantizando el
control de acceso y los niveles de seguridad de los dispositivos.
4. Las conexiones de PCs y entre switches se tienen que realizar con base el
diseño de la FIGURA No. 1
5. Establecer qué tipo de conexiones (Norma 568A/568B) deberá utilizar para
conectar TODOS (SWITCH-SWITCH, SWITCH-PCs) los elementos y así lograr
conectividad.
6. Inicialmente solo podrá haber comunicación (ping) entre equipos de una misma
VLANs, entre diferente VLANs no deberá compartirse tráfico.
7. Tener listo para la próxima clase todo el direccionamiento IP (Subnetting)
necesario, de tal modo que solo sea llegar al
laboratorio a realizar el montaje de la topología y demás configuraciones.


PROCEDIMIENTO:

Deberá tener en cuenta conectar físicamente los equipos a los puertos de los
switches de acuerdo a la siguiente tabla:

TABLA No. 1
SwitchCisco1 Equipo SwitchCisco2 Equipo
Puerto 1 VLAN1-1 Puerto 1 VLAN1-2
Puerto 4 VLAN2-1 Puerto 4 VLAN2-2
Puerto 9 VLAN3-1 Puerto 9 VLAN3-2
Puerto 11 AL Switch3550 Puerto 12 AL Switch3550


Switch3550 Equipo
Puerto 1 VLAN1-3
Puerto 4 VLAN2-3
Puerto 9 VLAN3-3
Puerto 11* SwitchCisco1
Puerto 12 * SwitchCisco2
*Aun no realice esta conexión sino hasta que configure individualmente cada uno de
los SwitchCisco1 y SwitchCisco2.

Para el buen desarrollo de la práctica se requiere que trabaje de manera
sincronizada y ordenada, siguiendo las siguientes RECOMENDACIONES:

a) El direccionamiento IP deberá ser claro dependiendo de los requerimientos de la
practica (en caso que existan marcadas diferencias entre los estudiantes, el
docente establecerá un único direccionamiento estándar para que todos lo sigan
como modelo, de tal modo que se pueda hablar en el mismo idioma, lo anterior
no exime de realizar la tarea individualmente y subirla a Moodle como está
establecido en el punto 7).
3

b) Después de la asignación de direcciones de PCs y Switches cada estudiante
deberá realizar primero sus conexiones de Switches Cisco 1 y Cisco 2, verificar
que todo esté bien, esto es le deben poder realizar telnet a cada switch.
c) Después que todo este correcto y haya configurado los SwitchCisco1 y
SwitchCisco2, cada uno deberá conectar con el cable adecuado estos
switches al Switch de Core (Switch3560).
d) Para switches Cisco 1 y Cisco 2 sugiero referencia Cisco 2950-24
e) La práctica habrá finalizado EXITOSAMENTE si puede realizar ping para
verificar interconectividad entre los equipos de una misma VLAN.

CONOCIMIENTO PREVIO PARA CONFIGURACION SWITCH CATALIST:

Antes de iniciar la configuración, deberá primero saber que existen 3 modos en los
cuales se puede configurar un dispositivo CISCO: (Switch, Router)

1. Modo Usuario: En este modo NO se tiene control total del dispositivo. Algunos
de los comandos disponibles en este modo son: enable, exit, logout, ping,
show, telnet y traceroute.
Lo reconocerá cuando esté el prompt asi:

Switch>

2. Modo Privilegiado (enable mode): En este modo habilita el proceso de
configuración y debug, permite cambiar la configuración del dispositivo, es
prerrequisito para entrar a otros modos. Algunos de los comandos disponibles
en este modo son: configure, clock, debug, clear, enable, disable, exit, logout,
no, ping, reload, show, telnet, traceroute, vlan, write y copy.
Lo reconocerá cuando esté el prompt asi:

Switch#

3. Modo de Configuración Global: En este modo lo que se configure afecta a
todo el dispositivo, se debe ingresar a este modo para acceder a modos de
configuración específicos.
Lo reconocerá cuando la subinterfaz del prompt esté asi:

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#


DESARROLLO - COMANDOS A UTILIZAR:

Estos comandos deberán ser ejecutados en cada uno de los SwitchesCisco:
NOTA: ESTA GUIA SOLO MOSTRARA COMO HACERLO EN UN SOLO
SWITCHE.

Pasar a modo privilegiado:
Switch>
Switch>enable
Switch#
4

Pasar al modo de configuración global:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Cambiar el nombre a los dispositivos:
Switch(config)# hostname SwitchCisco1
SwitchCisco1(config)#

Colocar un Mensaje de Bienvenida para cuando se ingrese al dispositivo:
SwitchCisco1(config)# banner motd "BIENVENIDOS EMPRESA FENIX SWITCHCISCO1"
SwitchCisco1(config)#

CREAR VLANs (Ejemplo de cómo Crear VLAN 2):
SwitchCisco1# vlan database
% Warning: It is recommended to configure VLAN from config mode,
as VLAN database mode is being deprecated. Please consult user
documentation for configuring VTP/VLAN in config mode.

SwitchCisco1 (vlan)# vlan 2
VLAN 2 added:
Name: VLAN0002
SwitchCisco1 (vlan)# exit
APPLY completed.
Exiting....
SwitchCisco1#

NOTA: Si desea puede crear las VLANs con nombres y evitar que las cree con el
nombre por defecto (Ejp: VLAN0002). Por Ejemplo para crear la VLAN 2 con
nombre GERENCIA (no es sensible a mayúsculas) el comando deberá ser
ejecutado de la siguiente forma:
SwitchCisco1 (vlan)#vlan 2 name GERENCIA
VLAN 2 added:
Name: GERENCIA

Asignar puertos a cada VLANs; en cada SwitchCisco deberá hacer la respectiva
asignación de puerto a cada VLANs según TABLA No. 1 (Ejemplo de asignación de
del puerto 4 a la VLAN2 en SwitchCisco1):
SwitchCisco1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SwitchCisco1(config)# interface fastEthernet 0/4
SwitchCisco1(config-if)# switchport access vlan 2
SwitchCisco1(config-if)# exit

Revisar VLANs creadas y puertos asociados a VLANs:
SwitchCisco1# show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3,
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
2 VLAN0002 active Fa0/4
5

1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
. . .
--More--

ASIGNANDO DIRECCIONES IP A LOS SWITCHES:
Configurar la dirección IP del SwitchCisco1 y los demás (SwitchCisco1 y
Switch3560) y hacer COMENTARIOS a la interfaz (normalmente la IP de cada
switch se asocia a la VLAN1 que es de administración o gestión); Recuerde que la
VLAN1 y todas las direcciones IP de los demás switches deberán pertenecer a la
SubRed 192.168.200.0/26 que corresponde a VLAN ADMINISTRATIVA:
SwitchCisco1(config)# interface vlan 1
SwitchCisco1(config-if)# ip address 192.168.200.2 255.255.255.192
SwitchCisco1(config-if)# description VLAN ADMINISTRATIVA

Nota: Lo mismo deberá hacer con los demás switches:

SwitchCisco2(config)# interface vlan 1
SwitchCisco2(config-if)# ip address 192.168.200.3 255.255.255.192
SwitchCisco2(config-if)# description VLAN ADMINISTRATIVA

Switch3560(config)# interface vlan 1
Switch3560(config-if)# ip address 192.168.200.4 255.255.255.192
Switch3560(config-if)# description VLAN ADMINISTRATIVA

Habilitar la interfaz (“subirla”):
SwitchCisco1(config-if)# no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
SwitchCisco1(config-if)# exit
SwitchCisco1(config)#

Configurar la dirección IP del Gateway (el Gateway es la pasarela, es decir la puerta
de enlace para poder salir a otras redes), solo se configura en los switcheCisco1 y
switcheCisco2:
SwitchCisco1(config)# ip default-gateway 192.168.200.4

CONFIGURAR TODOS LOS PASSWORDS:

Fijar Password para pasar a modo privilegiado: (Cuando se hace de esta forma el
password no queda encriptado):
SwitchCisco1(config)# enable password password

NOTA: Para todos los laboratorios, talleres y proyectos la CLAVE que se manejará
siempre será “password” (en minúscula y sin comillas) y será de carácter
obligatorio.

Fijar Password Encriptado para pasar a modo privilegiado: (Cuando se hace de ésta
forma el password queda encriptado y además prevalece sobre cualquier otra
clave, es preferible y casi que obligatorio establecerlo de ésta forma)
SwitchCisco1(config)# enable secret password
6


Configurar Terminales Virtuales (para gestión remota) y fijar password: (Note que no
se activaran hasta que se fije el password)
SwitchCisco1(config)# line vty 0 4
SwitchCisco1(config-line)# login
% Login disabled on line 1, until 'password' is set
% Login disabled on line 2, until 'password' is set
% Login disabled on line 3, until 'password' is set
% Login disabled on line 4, until 'password' is set
% Login disabled on line 5, until 'password' is set
SwitchCisco1(config-line)# password password

Configurar Password para conexión por Consola: (para conexion del PC al
dispositivo con cable de consola DB9 o DB25 Roll Over. Note que no se activará
hasta que se fije el password):
SwitchCisco1(config)# line console 0
SwitchCisco1(config-line)# login
% Login disabled on line 0, until 'password' is set
SwitchCisco1(config-line)# pass
SwitchCisco1(config-line)# password password

Configure el time-out para la consola: Opcional (Lo mismo puede hacer con las
terminales virtuales):
SwitchCisco1(config)# line console 0
SwitchCisco1(config-line)# exec-timeout 0 0

Sincronizar los mensajes de consola para que no interrumpan la digitación de
comandos: (opcional)
SwitchCisco1(config)# line console 0
SwitchCisco1(config-line)# exec-timeout 0 0

Salvando la configuración a la NVRAM: (comando Opcional write mem)
SwitchCisco1# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
SwitchCisco1#

Revisando la configuración:
SwitchCisco1# sh running-config
Building configuration...

Current configuration : 993 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
SwitchCisco1# sh startup-config
Using 993 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
7

interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
--More--
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
--More--

Tenga en cuenta que mientras no salve todo va quedando en la RAM (Volátil), una
vez salvado pasa a la NVRAM (Memoria RAM No Volátil).


CONFIGURACION PUERTOS TRUNK EN CADA SWITCH:

Una vez conectado switchcisco1 y switchcisco2 al switch de core (switch3560)
deberá configurar los Puertos Trunk (Puerto Troncales) de la siguiente manera:

SwitchCisco1:
SwitchCisco1(config)# interface fastEthernet 0/11
SwitchCisco1(config-if)# switchport mode trunk

SwitchCisco2:
SwitchCisco2(config)# interface fastEthernet 0/12
SwitchCisco2(config-if)# switchport mode trunk

Switch3550:
Switch3550(config)# interface fastEthernet 0/11
Switch3550(config-if)# switchport mode trunk
Switch3550(config-if)# exit
Switch3550(config)# interface fastEthernet 0/12
Switch3550(config-if)# switchport mode trunk
Switch3550(config-if)# exit


CONFIGURACION DE ESTACIONES PCs:

Una vez configurado cada Switch, deberá realizar la configuración de DIRECCION
IP, MASCARA DE RED, GATEWAY (PUERTA DE ENLACE) Y HOSTNAME de
cada PC.

Al finalizar todas las configuraciones deberá poder hacer ping entre equipos que
pertenezcan a la misma VLAN, de lo contrario deberá volver a revisar y reconfigurar
los dispositivos.


Elaborado por:


Ing. VICTOR A. CUSPOCA C.
Docente
Especialista en Redes y Comunicaciones ICESI
8

FIGURA No. 1

VLAN3-1
VLAN1-3
VLAN1-1 VLAN2-1
VLAN1-2
VLAN3-2
VLAN2-2
VLAN2-3 VLAN3-3
SwitchCisco1
IP:____________________
Switch3550
IP:____________________
SwitchCisco2
IP:____________________
IP:__________________
IP:__________________ IP:__________________ IP:__________________ IP:__________________
IP:__________________
IP:__________________
IP:__________________
IP:__________________