You are on page 1of 6

1.

Desarrollar algoritmo y diagrama de flujo para los siguientes ejercicios:
a. Dado el costo de un computador portátil y la cantidad de dinero entregado por el cliente,
calcule e imprima el cambio que debe devolvérsele al cliente.
Algoritmo:
INICIO Declarar variables:
Precio=0
Dinero=0
Cambio=0
Escribir 'Ingrese el Valor del portátil'
Leer precio
Escribir 'Ingrese el valor pagado $'
Leer Dinero
Si (Precio>0) Entonces
(
Si (Dinero>0) Entonces
Cambio=Dinero-Precio
(
Si (Cambio>,=0) Entonces
Escribir 'Gracias por su compra, su cambio es: $', Cambio
Sino
Escribir 'Falta dinero'
Fin Si
Sino
Escribir 'El valor del pago debe ser mayor que cero'
Fin Si
Sino
Escribir 'El valor del computador debe ser mayor que cero'
Fin Si
Fin
Diagrama de flujo
























Inicio
Precio=0
Dinero=0
Cambio=0
Precio
Dinero
Precio
>0
Dinero
>0
Cambio
>,=0
Cambio=Dinero-Precio
'Gracias por su compra, su
cambio es: Cambio
El valor del computador debe
ser mayor que cero'
'El valor del pago debe ser
mayor que cero'
'Falta dinero'
No
No
No
Fin
b. Leer e imprimir los datos correspondientes a una línea de directorio telefónico.
Algoritmo:
Inicio
Declarar variables
Nombre, Dirección “texto”
NumeroTelefono “numero”
Leer Nombre, dirección, NúmeroTelefóno
Imprimir Nombre, dirección, NúmeroTelefóno
Fin
Diagrama de Flujo
















Nombre,
Dirección,
NúmeroTelefóno
Nombre, Dirección,
NúmeroTelefóno
Inicio
Fin
2. Investigue en una empresa, en el área de sistemas lo siguiente:
a. Con cuantos equipos de cómputo cuenta, y cuáles son sus
especificaciones;
Trabajo en el área de tecnología de una entidad financiera, esta área cuenta con 140
máquinas, con las siguientes características: 3 GB Ram 280gb disco duro procesador intel
Celeron i3 a 2.8 ghz. Windows 7 professional
b. Describa un proceso de la empresa y realice el algoritmo y el diagrama de
flujo.
Proveer y mantener los sistemas de información para satisfacer los requerimientos de la
organización de acuerdo con las necesidades y tendencias del mercado, solicitadas por
las diferentes áreas de la organización para su normal operación
Algoritmo
Inicio:
Ingreso del requerimiento
Si Es aprobado por el comité funcional
Se realiza definición y evaluación de costo
Si Se aprueba presupuesto
Se realiza la ejecución del proyecto
Fin
Si no Se Cancela
Si no, se cancela
Fin













Inicio
Ingreso del requerimiento

Aprobado por
el comité
funcional
Aprueba
presupuesto
Definición y evaluación de
costo
Ejecución Proyecto
Fin
Cancelado
3. Resuelva las siguientes preguntas.
a. Enuncie las características de un algoritmo
 Carácter finito. Un algoritmo siempre debe terminar después de un
número finito de pasos.
 Precisión. Cada paso de un algoritmo debe estar precisamente
definido se deben omitir las ambigüedades.
 Entrada. Un algoritmo tiene cero o más entradas: cantidades que le
son dadas antes de que el algoritmo comience, o dinámicamente
mientras el algoritmo corre.
 Salida. Un algoritmo tiene una o más salidas, las cuales tienen una
relación específica con las entradas.
 Eficacia: un algoritmo debe ser eficaz, en el sentido de que todas
las operaciones a realizar en un algoritmo deben ser
suficientemente básicas como para que en principio puedan ser
hechas de manera exacta y en un tiempo finito.

b. Describa las diferencias entre los tipos de algoritmos.
 Cualitativos son aquellos en los que se describen los pasos
utilizando palabras,
 Cuantitativos son en los que se utilizan cálculos numéricos para
definir los pasos del proceso.

4. Diseñe los algoritmos que resuelven los siguientes problemas.

a. Pagar una multa para una infracción de carro. Determinar el tipo de
infracción y el posible valor a pagar.







b. Escribir un algoritmo que encuentre todos los números primos menores de
30.