You are on page 1of 3

Reliance DataCard on ubuntu (Model:EC168C)

e-mail: nobal_2@yahoo.com

Step 1: you need to install wvdial software or GNOME PPP software.But, my suggestion go for
wvdial.

Step 2: Edit wvdial.conf file in /etc/wvdial.conf by gedit.Replace with the following code
[Dialer Defaults]
Modem = /dev/ttyUSB0
Username = yournumber
Phone = #777
Password = yournumber
New PPPD = yes
Stupid mode = yes

Replace yournumber with your number.

Step 3: goto terminal type as follows:


nobal@nobal-laptop:~$ sudo su
[sudo] password for nobal:XXXXXXXX
root@nobal-laptop:/home/nobal# wvdialconf wvdial.conf
Editing `wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3


WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- Manufacturer: +GMI: HUAWEI TECHNOLOGIES CO.,
LTD
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB2<*1>: ATQ0 V1 E1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2<*1>: Modem Identifier: ATI -- Manufacturer: +GMI: HUAWEI TECHNOLOGIES CO.,
LTD
ttyUSB2<*1>: Speed 9600: AT -- OK
ttyUSB2<*1>: Max speed is 9600; that should be safe.
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB3<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB3<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB3<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Found a modem on /dev/ttyUSB0.


Modem configuration written to wvdial.conf.
ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB2<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

Setp 4: root@nobal-laptop:/home/nobal# wvdial


--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Tue Dec 22 13:59:01 2009
--> Pid of pppd: 17826
--> Using interface ppp0
--> pppd: �ad �Xd
--> pppd: �ad �Xd
--> pppd: �ad �Xd
--> pppd: �ad �Xd
--> local IP address XXX.XXX.XXX.XXX
--> pppd: �ad �Xd
--> remote IP address XXX.XXX.XXX.XXX
--> primary DNS address XXX.XXX.XXX.XXX
--> pppd: �ad �Xd
--> secondary DNS address XXX.XXX.XXX.XXX
--> pppd: �ad �Xd
Explanation:

sudo su: command to become root user


XXXXXXXX : your root password
wvdialconf wvdial.conf: command to scan ports for USB modem
wvdial : start the connection
XXX.XXX.XXX.XXX: you will be assigned IP address,DNS address etc...by your ISP