You are on page 1of 14

MODES OF CONFIGURATION

1. USER EXEC : >
2. PRIVELEGE EXEC : #
3. GLOBAL CONFIG : (CONFIG)#
i. Line: consol and vty (for telnet)
ii. Interface: vlan and fast eathernet

























()# actually = (config)# means global config mode
MODES OF CONFIG
USER PRIVELEGE
Interface
Line
Consol Vty (telnet)
GC (Global config)
()# line ?
()# interface ?
()# line consol ?
()# line vty ?
VLAN Fast eathernet
()# interface fa ?
()# interface vlan ?
COMMANDS

Press enter after every line
>enable // to go to priv mode
# config terminal // to go to GC (global config mode)
(config)# // GC mode
(config)# hostname abc
(config)# no shutdown // no administratively down
(config)# no hostname (negation command)
(config)# enable ?
(config)# enable secret cisco // password
(config)# line consol ?
(config)# line consol 0
(config-line)# login // this will prompt for password
otherwise no importance of password!!
(config)# line vty ?
(config)# line vty 0 15
(config-line)# password cisco

(config)# service password-encryption
(config)# exec-timeout 0 0 // no time out
(config)# logging synchronous // to avoid interruption of shitty messages

BACKUP OF CONFIGURATION
#show running conf // copy that and paste in notepad, then later in
GC mode and press enter to re-save config

OR
(config)# copy running-config startup-config
Or
(config)# write command
(config)# interface range fa 0/1 – 10
(config-if)# shutdown
(config-if)# do show ip interface brief
(config)# banner motd +unauthorized access prohibited+
config)# ip default-gateway 10.1.1.1
config)# interface fa 0/0
GIVE IP ADDRESS TO AN INTERFACE
config)# interface fa 0/0
(config-if)# ip address 10.1.1.2 255.0.0.0





Copied:
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Zt0l$2KXg0zn9Mg2tYwqt/wUQ/.
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.3 255.0.0.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip default-gateway 10.1.1.1
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password 7 02050D480809
logging synchronous
login
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
password 7 070C285F4D06
login
line vty 5 15
password 7 070C285F4D06
login
!
!
end


__________________________________-


MORE COMMANDS:

*Mar 1 00:15:51.495: %SYS-5-CONFIG_I: Configured from console by
console
Router#show run
Building configuration...

Current configuration : 1086 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Zt0l$2KXg0zn9Mg2tYwqt/wUQ/.
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.3 255.0.0.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip default-gateway 10.1.1.1
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password 7 02050D480809
logging synchronous
login
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
password 7 070C285F4D06
login
line vty 5 15
password 7 070C285F4D06
login