EJEMPLOS DE DIAGRAMAS DE

FLUJO
TAMBIEN TE PUEDE INTERESAR
Programa Para Crear Diagramas de Flujo
Fundamentos de Programacion
Lenguajes de Programacion
ActionScript 3.0
Esquemas
Nuevas Tecnologias y Productos Tecnologicos
Noticias Sobre Tecnologia
Tecnologia en Imagenes

COMPARTE
EJEMPLOS DIAGRAMAS DE FLUJO

Comparte www.areatecnologia.com

OTRAS WEBS INTERESANTES

Tecnologia Industrial
Tecnologias
Ciencias
Blog de Tecnologia

Aquí os dejamos una serie de ejercicios resueltos (14 en total) y con
su explicación a modo de ejemplos de construcción de diagramas
de flujo de procesos. Si no tienes claro la teoría te recomendamos
primero
que
veas
este
enlace: Diagramas
de
Flujo.
1. Hacer el diagrama de flujo para sumar dos números leídos por
teclado
y
escribir
el
resultado.

y

2. Hacer un diagrama de flujo que permita leer 2 números diferentes
nos
diga
cual
es
el
mayor
de
los
2
números.

El

pseudocódigo

para

este

diagrama

sería:

3. Crear un diagrama de flujo de procesos en el que se almacenen 3
números en 3 variables A, B y C. El diagrama debe decidir cual es el
mayor
y
cual
es
el
menor

4. conocidos su dos catetos. . Realizar el diagrama de flujo para que nos calcule la hipotenusa de un triángulo rectángulo.

5. Diagrama de Flujo para sumar 100 números leídos por teclado. .

. calculamos la suma. Vamos a ver paso a paso como funciona.. -1. (1) I=100 (números a (2) S=0 (suma. ahora (4) (5) (6) ¿I=0? ® sumar) es 7.. Supongamos que los datos son: 7. leer temporalmente cada número.Explicación: - En I contamos los En S A se emplea para números que quedan por sumar. . inicialmente 0) (3) Leer A. luego A=7 S=S+A=0+7=7 ® NO A=-1 S=S+A=7-1=6 I=I-1=99-1=98 NO Cuando I=0 habremos sumado los 100 números y pasaremos a: (7) Escribir S que será la suma. El primero (4) (5) I=I-1=100-1=99 (6) ¿I=0? (3) Leer A. 8. 5.

. Hacer un diagrama de flujo que permita escribir los 100 primeros pares. Modificar el anterior para que permita sumar N números. El valor de N se debe leer previamente por teclado.6. 7.

Necesitamos un bucle para contar 100 veces y dentro de él escribimos el par e incrementamos para obtener el siguiente. El proceso es similar al anterior. Hacer el diagrama de flujo para sumar los N primeros impares. I: Contador de pares que quedan por escribir. Realizar después uno que haga lo mismo con los pares y otro con los múltiplos de 3.Explicación de la solución: P: Variable para contener el siguiente par que se debe escribir. 8. .

.9. Hacer un diagrama de flujo que simule un reloj.

Hacer un organigrama que lea N números. . calcule y escriba la suma de los pares y el producto de los impares.10.

Calcular el máximo de N números leídos desde teclado.11. .

Vamos a ejecutarlo paso a paso para N=4.Explicación del Ejemplo de Diagrama: Vamos a almacenar en M el máximo de los números que se hayan leído. 7. el primero va directamente a M y los N-1 restantes los leemos en A. Al 3. final se escribe el resultado. -1. empleando como datos: 2. comparamos con M y si son mayores cambiamos el máximo temporal. (1) Leer N ® N=4 .

que sólo son bisiestos cuando son múltiplos además de 400. pero el año 2000 si lo será. Por ejemplo 28 es perfecto. pues sus divisores (excluido elv28) son: 1. 4. . 2. Dados dos números enteros positivos N y D. 7 y 14 y su suma es 1+2+4+7+14=28. Hacer un organigrama que dado un número N nos diga si es o no perfecto. Se dice que un número N es perfecto si la suma de sus divisores (excluido el propio N) es N. Hacer un organigrama que dado un año A nos diga si es o no bisiesto. por ejemplo el año 1900 no fue bisiesto. 13.(2) (4) (8) Leer Leer A ¿I=0? ® M (3) A=3 (5) ¿A>M? ® (7) ® NO (4) Leer ® SI A M=2 I=N-1=3 (6) M=A=3 I=I-1=3-I=2 ® A=-1 12. exceptuando los múltiplos de 100. Un año es bisiesto si es múltiplo de 4. se dice que D es un divisor de N si el resto de dividir N entre D es 0.

Realiza el diagrama de flujo que simule una caja registradora.14. .

El pseudocódigo para esta caja registradora es: .

. Y si te ha Gustado Haz clic arriba a la derecha en Me gusta.Arriba a la derecha y en el menú superior tienes más enlaces relacionados que te pueden interesar. Gracias.

Definición del problema: Entrada: A. A+B) Paso6-Fin_algoritmo_suma. 2. Algoritmo: 1. 2 3. B Proceso: A+B Salida: Resultados de suma Validación: No aplica c.Diagramas de flujo (página 2) Enviado por sanheymar_1@hotmail.com Partes: 1. Elaborar un algoritmo que sume dos números b. B) Paso5-("El resultado es:". Diagrama de flujo: Inicio . Problemas resueltos con diagramas de flujo.Inicio _ algoritmo _suma Paso2-Declarar variables A y B de tipo numérico Paso3-Escribir ("Ingrese el valor de A y B respectivamente ") Paso4-Leer (A. Diseño del algoritmo: Paso1. Análisis del problema: d. Elabore un algoritmo que sume dos números : a.

Algoritmo: 1. Diseño del algoritmo: Paso1-Inicio_algoritmo_área _triángulo Paso2-Declarar base. Análisis del problema: d. Escribir un algoritmo que calcule el área de triángulo b. Diagrama de flujo: . 2. Escribir un algoritmo que calcule el área de un triángulo. área) Paso7-Fin_algoritmo_área_triángulo. altura) Paso5-a=base*altura/2 Paso6-Escribir ("El resultado es: ". altura y área de tipo real Paso3-Escribir ("Ingrese el valor de base y altura respectivamente") Paso4-Leer (base. Definición del problema: Entrada: base*altura Proceso: base*altura/2 Salida: área Validaciones: No aplica c. a.

o bien una lista de nombres en orden alfabético. se podría disponer de una lista de valores numéricos en orden ascendente o descendente. Por ejemplo. El método de ordenación por burbuja es el mas conocido y popular entre estudiantes y aprendices de programación. La colocación en orden de una lista de valores se le llama ordenación. es la clasificación u ordenación de los mismos. ya que se van comparando de dos en dos los elementos de la tabla (vector).4. Si nosotros deseamos ordenar dicha tabla de menor a mayor (ascendente) al realizar la comparación entre dos elementos se produce el intercambio en el momento en que el primer elemento es mayor que el segundo. De esta forma los elementos más grandes pasan a estar en el último . Ventajas y desventajas. Definición y explicación del método de ordenación por burbuja. Este método se basa en la ordenación por cambios de elementos. El ordenamiento es uno de los procesos más comunes y útiles en el procesamiento de datos.

Esta mejora consiste en terminar el bucle principal en el momento en el que detectemos que en una pasada. 5. se dejan los valores como están. Búsqueda secuencial: La búsqueda secuencial. La técnica consiste en hacer varias pasadas a través de la tabla. para realizar cualquier otro calculo dentro de la aplicación. Supongamos que tenemos una tabla de un total de 50 elementos y que desde un principio esta ordenada. normalmente. Podemos ver que es un método un poco rudimentario y un poco largo según el caso. Diferencias. Si una pareja esta en orden creciente (o los valores son idénticos). El algoritmo básico de búsqueda secuencial consiste en empezar al inicio de la lista e ir a través de cada registro hasta encontrar la clave indicada (k) o hasta el final de la lista. esto quiere decir que la tabla esta completamente ordenada. también se le conoce como búsqueda lineal. Ventaja: Este método es fácil de comprender. ventajas y desventajas entre ambos. se aprende su técnica pero no se utiliza. Desventaja: Su desventaja principal. Como te puedes imaginar el programa esta empleando un tiempo que nos puede ser útil. Piensa que con una tabla de 50 elementos el programa pasara por el bucle principal 49 veces. sus valores se intercambian en la tabla. El elemento sube por la tabla al igual que una burbuja en un recipiente. Este método dentro de lo sencillo.lugar de la tabla. La búsqueda es una operación que tiene por objeto la localización de un elemento dentro de la estructura de datos. Siendo el array de una dimensión o lista una estructura de acceso directo y a su vez de acceso secuencial. Supongamos una colección de registros organizados como una lista lineal. Definición y explicación de los métodos de búsqueda secuencial y binaria. de ahí proviene su nombre. es que nos permite una mejora. por todo lo largo de la tabla no ha habido ningún cambio. A menudo un programador estará trabajando con grandes cantidades de datos almacenados en arreglos y pudiera resultar necesario determinar si un arreglo contiene un valor que coincide con algún valor clave o buscado. pero eso nosotros no lo sabemos. por lo que sometemos la tabla a una ordenación. para encontrar elementos dentro de un array: Búsqueda secuencial y búsqueda binaria. es uno de los menos eficientes y por ello. encontramos dos técnicas que utilizan estos dos métodos de acceso. en cada pasada se comparan parejas sucesivas de elementos. programar y es el más extendido. . Si una pareja esta en orden decreciente.

El método de búsqueda lineal funciona bien con arreglos pequeños o para arreglos no ordenados. y será la posición del elemento buscado o cero. Ventaja: . Por lo tanto. Se empieza con la primera casilla del vector y se observa una casilla tras otra hasta que se encuentre el elemento buscado o se han visto todas las casillas. el programa tendrá que comparar el valor buscado con la mitad de los elementos del vector. Dado que el vector o arreglo no esta en ningún orden en particular.Este método consiste en recorrer el arreglo o vector elemento a elemento e ir comparando con el valor buscado (clave). existe la misma probabilidad de que el valor se encuentra ya se en el primer elemento. El resultado de la búsqueda es un solo valor. como en el ultimo. en promedio.

Si ambos coinciden finaliza la búsqueda. si el elemento buscado es menor que el contenido de la casilla central. Se repite el proceso en esa parte. El proceso comienza comparando el elemento central del arreglo con el elemento buscado. se debe cambiar el segmento a considerar al segmento que está a la izquierda de tal sitio central. el elemento buscado será mayor o menor en sentido estricto que el elemento central del arreglo. . no nos ayudaría en nada. donde si el arreglo o vector esta bien ordenado.   Una forma razonable de dividir el conjunto de elementos es mantener los elementos ordenados y después utilizar los índices del arreglo ordenado para determinar la parte del arreglo sobre la que se va a trabajar. Ventajas: Se puede aplicar tanto a datos en listas lineales como en árboles binarios de búsqueda. este método. Si el elemento buscado es mayor se procede a hacer búsqueda binaria en el subarray superior. el tiempo de búsqueda se puede reducir utilizando el siguiente algoritmo de tipo divide y vencerás: 1. se reduce sucesivamente la operación eliminando repetidas veces la mitad de la lista restante. Desventajas: Este método funciona solamente con arreglos ordenados. 2. Si no ocurre así. Se divide el elemento en dos partes. Este método se puede aplicar tanto a datos en listas lineales como en árboles binarios de búsqueda. para encontrar todos los elementos con una clave particular. se requiere buscar en todo el arreglo.       Es un método sumamente simple que resulta útil cuando se tiene un conjunto de datos pequeños (Hasta aproximadamente 500 elementos) Es fácil adaptar la búsqueda secuencial para que utilice una lista enlazada ordenada. lo que hace el proceso muy largo. en un orden especifico de acuerdo al valor de la clave. Si los datos buscados no están en orden es el único método que puede emplearse para hacer dichas búsquedas. Si el conjunto de elementos es grande. 3. lo que hace la búsqueda más eficaz. Es el método más eficiente para encontrar elementos en un arreglo ordenado. Desventaja: Este método tiende hacer muy lento. Se determina la parte que debe contener la clave buscada. Los pre – requisitos para la búsqueda binaria son: La lista debe estar ordenada. Si los valores de la clave no son únicos. Debe conocerse el número de elementos. por lo cual si nos encontramos con arreglos que no están en orden. Búsqueda Binaria: La búsqueda binaria es el método.

formulación. Su utilización en estos ámbitos es tan importante. se dejan los valores como están.Diferencias entre ambos métodos: En el caso del método de búsqueda binaria. consiste en hacer varias pasadas a través del array. y solución del problema. se comparan parejas sucesivas de elementos. Debe conocerse el número de elementos. . Conclusión:   En la actualidad los diagramas de flujo son considerados en la mayoría de las empresas o departamentos de sistemas como uno de los principales instrumentos en la realización de cualquier método o sistema. Los diagramas de flujo le ayudan en la definición. como se planteo anteriormente. bien distribuida en las personas. En segundo orden. En cada pasada. Es fácil adaptar la búsqueda secuencial para que utilice una lista enlazada ordenada. podemos ver que el método de búsqueda binaria. Es fácil mantener el orden insertando cada registro en el lugar donde termina una búsqueda sin éxito y cada búsqueda termina cuando se encuentra un registro con una clave no menor que la clave de búsqueda. lo prerrequisitos principales para dicha búsqueda son: La lista debe estar ordenada en un orden específico de acuerdo al valor de la clave (elemento a buscar). Si una pareja está en orden decreciente. por su parte el método de búsqueda secuencial o lineal. es el método más eficiente para encontrar elementos en un arreglo ordenado. debido a que permiten la visualización de las actividades innecesarios y verifica si la distribución del trabajo está equilibrada. como en aquellos que no están ordenados. Si una pareja está en orden creciente (o los valores son idénticos). En cuanto a la técnica de ordenación por el método de burbuja. queda claro que la técnica mejor usada para dicho método. pero si los datos no están en orden es el único método que puede emplearse para hacer las búsquedas. pero si los datos no están en el orden es el único método que puede emplearse para hacer las búsquedas. La búsqueda secuencial también la podemos conocer o encontrar con el termino de "Búsqueda Lineal". lo que hace la búsqueda más eficaz. los arreglos deben estar únicamente ordenados. sus valores se intercambian en el array. Para el método de búsqueda Binaria. sin sobrecargo para algunas mientras que otros trabajan con mucha holgura. Este método de búsqueda es muy lento. análisis. puede emplearse tanto en arreglos pequeños. Recomendaciones: 1. o sea. lo contrario sucede con el método de búsqueda secuencial ya que este es muy lento.

3. como de incrementar la existencia de sistemas de información para la administración. En el método de ordenación por burbuja. 4. si al terminar el bucle principal en el momento que se detecte que en una pasada por todo lo largo de la tabla no ha habido ningún cambio esto le indicara que la tabla está completamente ordenada. Insertar cada elemento al final del arreglo o lita Recorrer o iterar sobre el arreglo o lista hasta conseguir el elemento requerido. Bibliografía: Leer más: http://www.2.shtml#ixzz3AO0yNjJj .com/trabajos42/diagrama-de-flujo/diagrama-deflujo2. o Se repite el proceso en esa parte. se recomienda utilizar el siguiente algoritmo de tipo divide y vencerás. ayudara a analizar esas etapas con el fin tanto de mejorarlas. o Se divide el elemento en 2 partes. o Se determina la parte que debe contener la clave buscada. El diagrama de flujo le ayudara con el análisis a comprender el sistema de información de acuerdo con las operaciones de procedimientos. si el conjunto de elementos es grande.monografias. para reducir su tiempo de búsqueda: 5. Para que el método de búsqueda secuencial resulte sumamente útil se recomienda hacer lo siguiente:    Almacenar todo los elementos en un arreglo o lista. En el método de búsqueda binaria.

Mientras num < 200 Hacer Escribir num. pseudocodigo miércoles. FinMientras FinProceso Publicado por George Tacuri en 1:03 2 comentarios Enlaces a esta entrada Etiquetas: diagrama de f lujo.0. Pseudocódigo Proceso CienPrimerosPares Escribir "Los 100 primeros pares son".Realizar un diagrama de flujo para escribir los 100 primeros pares Realizar un diagrama de flujo de un programa que permita escribir en pantalla los 100 primeros números pares. PSeInt. num <. num <. 17 de abril de 2013 . programacion estructurada .num +2.

Escribir "Ingresar la altura". . Diagrama de flujo: El volumen de un prisma recto es el producto del área de una de las bases por la distancia entre ellas (altura) Pseudocódigo Proceso volumenPrisma Escribir "VOLUMEN DE UN PRISMA RECTO". Leer abase. volumen <. Escribir "Ingresar el area de la base".abase*altura.Diagrama de Flujo Realizar el algoritmo y diagrama de flujo para calcular el volumen de un prisma recto. Leer altura.Volumen de un Prisma .

Diagrama de Flujo Realizar el diagrama de flujo de un algoritmo que lea N números e imprima el porcentaje de números pares e impares. PSeInt. FinProceso Publicado por George Tacuri en 23:46 0 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo .Escribir "El volumen del prisma es: ". pseudocodigo jueves. volumen. Pseudocódigo Proceso PorcentajeNumeros Escribir "Ingrese la cantidad de numeros:". 4 de abril de 2013 Porcentaje numeros pares e impares . .

Escribir " . porcentaje. FinProceso Publicado por George Tacuri en 23:33 0 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo miércoles.Leer cant.par/cant*100.par + 1. Escribir "El porcentaje de : ". Leer num. Si num%2 = 0 Entonces par <.0. Para i<-1 Hasta cant Con Paso 1 Hacer Escribir "Ingrese el numero ". i. Escribir " . FinSi FinPara porcentaje <.numeros impares: ". " :". 100 . par <-0.porcentaje.numeros pares: ". 27 de marzo de 2013 .

Pseudocódigo Proceso PerimetroTriangulo Escribir "PERIMETRO DE UN TRIANGULO".Diagrama de Flujo Ejercicio: Realizar el diagrama de flujo para hallar el perímetro de un triangulo.Perímetro de un triangulo . el valor de los lados del triangulo se debe ingresar por teclado. . Escribir "Ingresar los lados: ".

public static void main(String[] args) { 7. int cant = teclado.in). Leer L1.Scanner. Código Fuente en Java view plainprint? 1. package DFD. 12. System.print("Ingresar la cantidad de numeros: "). perimetro <.Código Java Escribir en Java un programa para calcular la media armónica de n números ingresados por teclado.nextInt().perimetro. pseudocodigo martes. 10. 4. public class MediaArmonica { 6. 8. } . Escribir "Lado 2: ".out./num. i++){ 14. Leer L2.out. i<=cant. System.util. 15.Escribir "Lado 1: ". FinProceso Publicado por George Tacuri en 14:16 3 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo . 17. 9. int num = teclado. suma = suma + 1.L1+L2+L3. for (int i=1. 16. PSeInt. 13. 5. 11. 2.nextInt(). 26 de marzo de 2013 Media armónica de n números . import java. Escribir "Perimetro = ". Leer L3. double suma =0. Escribir "Lado 3: ". 3. Scanner teclado = new Scanner(System.print("Nº"+i+": ").

. 20. 19. Java domingo.18.out.Diagrama de Flujo Realizar un diagrama de flujo de un programa que permita la carga de 10 valores por teclado y muestre la suma de los valores ingresados y su promedio. } System. 24 de marzo de 2013 Suma y promedio de 10 números . } Ejecución del programa Publicado por George Tacuri en 10:29 1 comentarios Enlaces a esta entrada Etiquetas: codigo fuente . 21.println("Media Armonica = " + cant/suma).

FinProceso . suma <.suma + numero.Pseudocódigo Proceso SumaNumeros suma<-0. suma/10. Escribir "El promedio es: ".suma. // se pide que se ingrese los numeros Para i<-1 Hasta cant Con Paso 10 Hacer Escribir "Ingrese el numero ". FinPara Escribir "La suma es: ".i. Leer numero.

20 de marzo de 2013 Suma de números pares en un rango .Diagrama de Flujo Elaborar el diagrama de flujo de un programa que realice la suma de los números pares en un rango dado. PSeInt. los números inferior y superior del rango deben ser ingresados por teclado.Publicado por George Tacuri en 7:50 1 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo . pseudocodigo miércoles. .

0. Escribir "Ingrese numero inferior: ".Pseudocodigo Proceso SumaNumerosPares Escribir "SUMA DE NUMEROS PARES EN UN RANGO". suma <. . Leer superior. Escribir "Ingrese numero superior: ". Mientras inferior < superior Hacer //averiguamos si el numero es par Si inferior%2=0 Entonces suma <.suma + inferior. Leer inferior.

FinProceso Publicado por George Tacuri en 23:55 1 comentar ios Enlaces a esta entrada Etiquetas: diagrama de flujo. pseudocodigo lunes.inferior + 1. PSeInt. suma.Diagrama de Flujo Código en C++ Cuatro enteros entre 0 y 100 representan las puntuaciones de un estudiante de un curso de informática. Escribir un programa para encontrar la media de estas puntuaciones y visualizar una tabla de notas de acuerdo al siguiente cuadro: MEDIA PUNTUACION 90-100 A 80-89 B 70-79 C 60-69 D . 18 de marzo de 2013 Media de las notas de un estudiante . FinMientras Escribir "La suma de numeros pares es: ".FinSi inferior <.

nota <. //se llena las notas en el arreglo Para i<-0 Hasta n-1 Con Paso 1 Hacer .4.0. // se declara un arreglo de n elementos Dimension notas[n].• Realizar análisis • Realizar diagrama de flujo de datos • Elaborar el programa en C++ Diagrama de Flujo Pseudocódigo Proceso MediaNotas //cantidad de notas n <.

FinPara nota <. i <." FinSi FinProceso A". FinSi Si nota>=90 Y nota<=100 Entonces Escribir nota." B". FinSi Si nota>=70 Y nota<=79 Entonces Escribir nota.i-1." D". FinSi Si nota>=80 Y nota<=89 Entonces Escribir nota." C".Escribir "Ingrese nota ". . //comprobamos que la nota ingresada sea correcta Si notas[i]>= 0 Y notas[i]<=100 Entonces Escribir "Nota OK". Sino Escribir "Nota incorrecta ".i+1. //imprimimos el resultado Escribir "MEDIA PUNTUACION".nota + notas[i].nota/n. //se busca equivalencia en la tabla Si nota>=60 Y nota<=69 Entonces Escribir nota. Leer notas[i]. FinSi FinPara //se calcula la media Para i<-0 Hasta n-1 Con Paso 1 Hacer nota <.

} else { cout<<"Nota incorrecta "<<endl. 41. 18. 24.Código Fuente en C++ view plainprint? 1.i++) { nota=nota+notas[i]. . 20. 15. 38. notas. 8. nota=0. 14. 28. diagrama de flujo . 27. cout<<"MEDIA PUNTUACION"<<endl.i<=n-1. 23. 4. int main() { float float float float i. codigo fuente .i++) { cout<<"Ingrese nota "<<i+1<<endl. 39. 16. 19. if (notas[i]>=0&&notas[i]<=100) { cout<<"Nota OK"<<endl. } nota=nota/n. 37. 25.i<=n-1. 6. 26. nota. 5. 13. 33. PSeInt. #include<iostream> using namespace std. 42. if (nota>=60&&nota<=69) { cout<<nota<<" D"<<endl. 43. 7. 21. 12. 32. } Publicado por George Tacuri en 9:48 0 comentarios Enlaces a esta entrada Etiquetas: C++. cin>>notas[i]. } if (nota>=90&&nota<=100) { cout<<nota<<" A"<<endl. } if (nota>=80&&nota<=89) { cout<<nota<<" B"<<endl.Diagrama de Flujo Realizar el diagrama de flujo de un programa para calcular la suma de los 10 primeros números pares. 10. 31. n. 40. 30. 9. 34. 36. 3. i=i-1. 22. for (i=0. n=4. } } for (i=0. 29. } return 0. 11. 2. } if (nota>=70&&nota<=79) { cout<<nota<<" C"<<endl. pseudocodigo Suma de los 10 primeros pares . 35. 17.

sum <.0.sum + num. programacion estructu rada. 16 de marzo de 2013 . Mientras num < 11 Hacer Si num%2 = 0 Entonces sum <. FinProceso Publicado por George Tacuri en 9:11 1 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo . pseudocodigo sábado. FinMientras Escribir "La suma de los 10 primeros pares es: ". FinSi num <.0.num + 1.En pseudocodigo: Proceso SumaPares num <.sum. PSeInt.

n2. Sino Escribir 'El numero '.n2. FinSi FinSi FinProceso .' es multiplo de '. Leer n2.' No es multiplo de '. Leer n1.Determinar si un numero es múltiplo de otro .n1. Si n1>n2 Entonces Si n1 MOD n2=0 Entonces Escribir 'El numero '.Diagrama de Flujo Hacer el diagrama de flujo de un programa que permita determinar si un numero es múltiplo de otro. Proceso MultiploDeOtro Escribir 'Ingrese un numero'.n2. FinSi Sino Si n2 MOD n1=0 Entonces Escribir 'El numero '.' No es multiplo de '.n2. Sino Escribir 'El numero '.' es multiplo de '.n1. Escribir 'Ingrese otro numero'.n1.n1.

#include <iostream> 2. cout << "\nFecha valida". } 26. else 27. else if(m!=2 && d<31) 33. bisiesto = true. i. 3. 25. cout << "\nFecha valida". 14. 5. if(y%4==0 && y%100!=100 || y%400==0) 18. //comprobamos si el año es bisiesto 17. cout << "Introduce el mes: ". 30. } 37. bool bisiesto = false. 13. 20. cin >> d. if(m==1 || m==3 || m==5 || m==7 || m==8 || m==10 || m==12) 23. int main() { 6. using namespace std.Código C++ Realizar un programa en c++ que valide la fecha ingresada por teclado.m. } 38. cout << "Introduce el dia: ". 7. 9. 10. else 35. pseudocodigo viernes. 15 de marzo de 2013 Validar fecha ingresada . 19. cout << "\nFecha no valida". else if(m==2 && d<29 && !bisiesto) 31. 8. cin >> m. { 24. 4. 16. 11. //comprobamos que los datos ingresados esten en un rango valido 21. int d. Código Fuente en C++ view plainprint? 1. cin >> y. cout << "\nFecha valida". 15. 12. cout << "Introduce el anio: ".Código fuente Publicado por George Tacuri en 13:53 0 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo . 36. if(d>0 && d<32 && m>0 && m<13 && y>0){ 22.y. 34. else . cout << "\nFecha valida". { 28. 32. if(m==2 && d<30 && bisiesto) 29.

Solución: PSEUDOCODIGO Proceso KilosLibras Escribir "CONVIERTE DE KILOS A LIBRAS". libras <. FinProceso .2. Leer kilos. } cout << "\nFecha no valida". 40. Publicado por George Tacuri en 10:09 0 comentari os Enlaces a esta entrada Etiquetas: C++. Escribir "Ingresar (Kg): ".libras. Escribir "=> ". codigo fuente martes.Diagrama de flujo Diseñar un diagrama de flujo de un programa que permita convertir una cantidad ingresada en kilogramos a libras.20462262*kilos." lb" . 12 de marzo de 2013 De kilos a libras .39.

package DFD.14159*radio*radio).Scanner.out.util. 9. 14. System. package DFD. radio = scanner. 7. Scanner scanner = new Scanner(System. 4. 13. 6. 10. 11. 8. 6.Código fuente en Java Realizar un programa en Java que permita convertir una cantidad expresada en libras a toneladas. 2.out.Publicado por George Tacuri en 17:00 0 comentarios Enlaces a e sta entrada Etiquetas: diagrama de flujo . 3. el usuario debe ingresar el valor del radio.Scanner. 3. System. } } Publicado por George Tacuri en 12:38 7 comentarios Enlaces a esta entrada Etiquetas: codigo fuente . El usuario debe ingresar por teclado la cantidad en libras y el programa imprimirá su equivalencia en toneladas. 5. 4. Java Convertir libras a toneladas . public class ConvertirAToneladas { public static void main(String[] args) { float libras. area. 2. 9 de marzo de 2013 Calcular área de un círculo en Java Realizar un programa en Java que permita calcular el área de un círculo. 5. import java. 12. 15. Código Fuente en Java view plainprint? 1.out. import java. public class ConvertirAToneladas { public static void main(String[] args) { double radio.println("HALLA EL AREA DE UN CIRCULO").in). System. programacion estructurada sábado. Codigo Fuente en Java view plainprint? 1.println("Area = " + area).nextFloat(). .util. area = (3.print("Ingresar el radio r = ").

libras = scanner. 8. 10. Publicado por George Tacuri en 12:31 0 comentarios Enlaces a esta entrada Etiquetas: codigo fuente . 15. } double toneladas. System.println("CONVIERTE DE LIBRAS A TONELADAS").out. 11.out.println("=> " + toneladas + " toneladas"). toneladas = 0.7. 12.nextFloat(). Java viernes. 13.in). a una potencia dada. 16.print("Ingresar libras (lb): "). } -Los usuarios buscaron: como calcular libras a toneladas en java codificación. System. System. 8 de marzo de 2013 Elevar un numero a una potencia . PSEUDOCÓDIGO Proceso ElevarPotencia . Scanner scanner = new Scanner(System.00045359237*libras. 9.out. 14.Diagrama de Flujo Realizar el diagrama de flujo de un programa que permita elevar un numero entero ingresado por teclado.

Mientras pot>1 Hacer rpta <.pot . Sino Escribir "El numero NO es divisible por tres".1. FinProceso Publicado por George Tacuri en 19:09 5 comentarios Enlaces a esta entrada Etiquetas: diagrama de flujo . .Escribir "Ingrese un numero: ".rpta * num. rpta <. Leer num. Leer pot. rpta . Si (num % 3) = 0 Entonces Escribir "El numero SI es divisible por tres".num. FinMientras Escribir "El resultado es: ".Diagrama de Flujo Realizar el pseudocodigo y el diagrama de flujo para indicar si un numero ingresado es divisible por tres. Proceso NumerosDivisibles Escribir "Ingrese un numero: ". PSeInt Números divisibles por tres . Leer num. Escribir "Ingrese la potencia: ". pot <.

FinSi FinProceso .