You are on page 1of 199

Voz y Video sobre IP

(TEVV03)

Profesor:
Luis Flores
Ingeniero en Telecomunicaciones, Conectividad y Redes
CCNA (Cisco Certified Network Associate)
CCIP (Cisco Certified Internetwork Professional)
CSCO10657424

20 aos de experiencia en Telecomunicaciones.


luis.flores63@inacapmail.cl

DESCRIPCIN DE LA ASIGNATURA:
Asignatura prctica de especialidad cuyo propsito es desarrollar aprendizajes en la instalacin,
operacin de sistemas de telecomunicaciones integrados de voz y video.
La asignatura entrega conocimientos en hardware y software destinados a la codificacin de voz y
video para su aplicacin en sistemas de telefona y video sobre redes IP.
Estas capacidades permitirn adems, dar asistencia y asesoramiento tcnico a la comercializacin
de soluciones de este tipo a clientes; as como tambin, la documentacin tcnica asociada.
La metodologa considera actividades prcticas, clases expositivas con demostraciones,
implementacin de servicios de voz y video y solucin de ejercicios y problemas.

COMPETENCIAS:

Instala hardware, software y conexiones asociadas, mediante el uso de instructivos, manuales,


normas tcnicas y herramientas de instalacin; a travs de pruebas y correccin de fallas de
funcionamiento satisface las solicitudes de usuarios o clientes; contribuyendo, en caso de ser
necesario, con la investigacin de problemas y fallas relacionadas con la instalacin.

UNIDADES

Fundamentos de tecnologas y servicios de comunicaciones de voz y video

25 %

Componentes y equipos para soluciones de voz y video sobre red IP.

25%

Instalacin y operacin de sistemas de telefona y video sobre redes IP.

25 %

Asistencia tcnica a la comercializacin de soluciones de telefona y video


sobre redes IP.
Asistencia

25 %

Voz IP

Cdec
La voz debe codificarse para poder ser transmitida por la red IP.
Para ello se hace uso de cdecs que garantizan la codificacin y compresin del audio o del
video para su posterior decodificacin y descompresin antes de poder generar un sonido o
imagen utilizable.
Estos Codecs tienen los siguientes anchos de banda de codificacin:

Cdecs

Requisitos de una Red :


1) Ancho de Banda
2) Latencia < 150ms
3) Jitter < 100ms
4) Prdida de paquetes < 1%

Estndar de QoS y SLA.

Protocolos y sealizacin: H248, H323 y SIP.

Requisitos de una Red


SIP (Session Initiation Protocol )
El protocolo SIP se concentra en el establecimiento, modificacin y terminacin de
las sesiones.
Las funciones bsicas del protocolo incluyen:
Determinar la ubicacin de los usuarios, aportando movilidad.
Establecer, modificar y terminar sesiones multipartitas entre usuarios.
Los servidores, por defecto, utilizan el puerto 5060 en TCP (Transmission Control
Protocol) y UDP (User Datagram Protocol) para recibir las peticiones de los clientes
SIP. En caso de mandar la sealizacin encriptada, SIP usa el puerto 5061.

Funcionamiento del SIP

1. Agentes de Usuario
2. Servidores de Registro o Registrar
3. Servidores Proxy y de Redireccin

El Cliente
El cliente establece y origina las llamadas voz, esta informacin se recibe
a travs del micrfono del usuario (entrada de informacin )se codifica,
se encapsula y, de la misma forma, esta informacin se decodifica.

Un cliente puede ser:


ATAs (Adaptadores de telfonos analgicos)
Telfonos IP
Softphones

Los Gateways
Brindan un puente de comunicacin entre todos los usuarios, su funcin principal es
la de proveer interfaces con la telefona tradicional adecuada, la cual funcionara
como una plataforma para los usuarios (clientes) virtuales.

Los Servidores

Los servidores se encargan de manejar operaciones de base de datos, realizado en


un tiempo real como en uno fuera de l.
Entre estas operaciones: el enrutamiento, la administracin y control del servicio, el
registro de los usuarios.

Solucin de Voz IP

Voz y Video sobre IP

IP

Una direccin IP es una etiqueta numrica que identifica, de manera lgica y


jerrquica, a una interfaz de un dispositivo.

Direcciones IPv4
Las direcciones IPv4 se expresan por un nmero binario de 32 bits, permitiendo
un espacio de direcciones de hasta 4.294.967.296 (232) direcciones posibles.

Direcciones IPv6

La funcin de la direccin IPv6 es exactamente la misma que la de su predecesor IPv4,


pero dentro del protocolo IPv6.
Est compuesta por 128 bits y se expresa en una notacin hexadecimal de 32 dgitos.

Ejemplo: 2001:0123:0004:00ab:0cde:3403:0001:0063

Datagrama IPv6
Head

Cuales son los requisitos de la red para Voz IP ?

Ancho de Banda:
En telecomunicaciones, es el bit rate o tasa de transferencia que define el
nmero de bits que se transmiten por unidad de tiempo a travs de un
dispositivo.
kbit/s o kbps (kb/s, kilobit/s o mil bits por segundo)

Mbit/s o Mbps(Mb/s, Megabit/s o un milln de bits por segundo)


Gbit/s o Gbps (Gb/s, Gigabit, mil millones de bits)

Ancho de Banda:

Tasas de bits de compresin a MP3:

4 kbit/s Mnimo para reconocer el habla.


8 kbit/s Calidad telefnica convencional
32 kbit/s Radio AM
96 kbit/s Radio FM
128 kbit/s Sonido calidad semi CD, muy comn en MP3
192 kbit/s Sonido calidad CD en formato MP3
320 kbit/s Mxima calidad para formato MP3

Ancho de Banda:

Netflix
0,5 megabits por segundo: velocidad de conexin de banda ancha requerida
1,5 megabits por segundo: velocidad de conexin de banda ancha recomendada
3 megabits por segundo: velocidad recomendada para calidad de DVD
5 megabits por segundo: velocidad recomendada para calidad HD

7.0 megabits por segundo: velocidad recomendada para calidad Super HD


12 megabits por segundo: velocidad recomendada para calidad 3D
Calidad de video HD
Las pelculas y series disponibles en alta definicin se reproducen en 720p, o una
calidad superior, con una conexin a Internet suficientemente rpida.

Latencia (Delay):
La latencia se refiere a cualquier tipo de periodos de inactividad y retrasos
producidos durante la transmisin de paquetes de datos y el procesamiento de
datos recibidos o preparados para ser enviados.
A menudo se puede encontrar tambin la nocin de 'lag' ('retraso' en ingles), muy
popular en los crculos de aficionados a los juegos.

Latencia (Delay):

Juegos de ordenador .
La experiencia demuestra que un retraso de 100 milisegundos es todava aceptable,
no obstante por encima de ese lmite, especialmente en el caso de los juegos de
accin rpida, tales retrasos pueden dificultar el juego.
Video - ver pelculas en lnea, como por ejemplo mediante el servicio de YouTube
requiere un nivel de la velocidad de transmisin relativamente alto.
Latencia de 300-500 milisegundos podra resultar en las interrupciones de la
pelcula, la prdida de sincronizacin entre imagen y sonido, o en algunos casos
causar la distorsin de imagen.

Jitter:
Se denomina jitter en ingles fluctuacin, a la variabilidad temporal durante el
envo de seales digitales.
El jitter suele considerarse como una seal de ruido no deseada.
En las telecomunicaciones se denomina jitter a la variabilidad del tiempo de
ejecucin de los paquetes.
Este efecto es especialmente molesto en aplicaciones multimedia en Internet
como radio por Internet o telefona IP, ya que provoca que algunos paquetes
lleguen demasiado pronto o tarde para poder entregarlos a tiempo.
El efecto puede reducirse con un bfer de jitter, un bfer de datos, pero a costa
de un tiempo de ejecucin mayor.
Si el jitter es demasiado grande, no puede asegurarse que las informaciones
crticas de proceso lleguen a tiempo.

Jitter:

Packet loss:

Requerimientos.
1)
2)
3)
4)

Empresa ACME necesita habilitar VoIP para 40 usuarios.


Actualmente tiene un enlace de 10Mbps
40 computadores que cada uno utiliza de ancho de banda 600Kbps para Internet.
1 Servidores web que utiliza de ancho de banda 1Mbps

Es necesario aplicar Calidad de Servicio?


Si es si,
Cuanto de ancho de banda es necesario para 20 telfonos IP utilizando
simultneamente el servicio de voz con el Cdec G.711?
Cuanto es el ancho de banda que quedaran los computadores tomando en
cuenta que tambin hay que asegurar el ancho de banda al Servidor?
Con cuantas colas QoS (Queue) quedara la solucin.?

Requerimientos.
1)
2)
3)
4)
5)

Empresa ACME necesita habilitar VoIP para 50 usuarios.


Actualmente tiene un enlace de 20Mbps
50 computadores que cada uno utiliza de ancho de banda 630Kbps para Internet.
5 Servidores web que utiliza de ancho de banda 2,5Mbps
Tambien se transmite un canal institucional en calidad HD.

Es necesario aplicar Calidad de Servicio?


Si es si,
Cuanto de ancho de banda es necesario para asegurar el correcto funcionamiento
Del servicio de voz para 50 telfonos IP, pero solo 25 usuarios hablando a la vez
con el Cdec G.711 ?
Cuanto es el ancho de banda necesario para asegurar el correcto
funcionamiento del canal institucional ?

Con cuantas colas QoS (Queue) quedara la solucin.?

QoS
Calidad de Servicio

Voz 2.5 Mbps


y priorizamos
Canal de videos (streaming)
5 Mbps
Servidores, Intranet
2,5 Mbps
Best Effort

QoS
Calidad de Servicio
Asterisk
Servidor
Streaming

IP Multicast
224.10.10.10

Voz 2.5 Mbps


y priorizamos

Canal de videos (streaming)


5 Mbps
Servidores, Intranet
2,5 Mbps
Best Effort

Router
ACME
20 Mbps

100 Mbps

10.10.10.0/24

F0/1.10

MPLS

F0/1.20

100 Mbps

Servidores

Vlan de datos
10

Vlan de voz
20

Internet

QoS
class-map match-all voz
match input-interface FastEthernet0/1.20
class-map match-all datos
match input-interface FastEthernet0/1.10
class-map match-all servidores
match access-group 10
class-map match-all video
match access-group 20
!
policy-map QoS
class voz
priority 2500
class video
bandwidth 5000
class servidores
bandwidth 2500
class datos

IP ROUTE 0.0.0.0. 0.0.0.0 200.200.200.100


!

QoS
Calidad de Servicio
Interfaces
interface FastEthernet0/0
description WAN_MPLS
ip address 200.200.200.10 255.255.255.0
service-policy output QoS
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1.10
description vlan_datos
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/1.20
description vlan_voz
encapsulation dot1Q 20
ip address 2.2.2.1 255.255.255.0
!
interface FastEthernet1/0
description Servidores
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto

Acces-list
access-list 10 permit 10.10.10.0 0.0.0.255
access-list 20 permit host 224.10.10.10

Cisco IOS IP SLAs

Delay (both round-trip and one-way)

Packet sequencing (packet ordering)

Jitter (directional)

Path (per hop)

Packet loss (directional)

Connectivity (directional)
Server or website download time

Cisco IOS IP SLAs

Cisco IOS IP SLAs

Switch(config)# ip sla 12
Switch(config-ip-sla)# icmp-echo 172.29.139.134

Switch(config-ip-sla-echo)# frequency 30
Switch(config-ip-sla-echo)# exit
Switch(config)# ip sla schedule 5 start-time now life forever

Switch(config)# end

QoS
Calidad de Servicio
Asterisk
Servidor
Streaming

IP Multicast
224.10.10.10

Voz 2.5 Mbps


y priorizamos

Canal de videos (streaming)


5 Mbps
Servidores, Intranet
2,5 Mbps
Best Effort

Router
ACME
20 Mbps

100 Mbps

10.10.10.0/24

F0/1.10

MPLS

F0/1.20

100 Mbps

Servidores

Vlan de datos
10

Vlan de voz
20

Internet

Cisco IOS QoS


VoIP
class-map match-all voz
match access-group name VOZ
class-map match-all datos
match access-group name DATOS
class-map match-all servidores
match access-group 10
class-map match-all video
match access-group 20
!
policy-map QoS
class voz
priority 2500
class video
bandwidth 5000
class servidores
bandwidth 2500
class datos
!

access-list 10 permit 10.10.10.0 0.0.0.255


access-list 20 permit host 224.10.10.10
ip access-list standard VOZ
permit 2.2.2.0 0.0.0.255
ip access-list standard DATOS
permit 1.1.1.0 0.0.0.255

Cisco IOS QoS


VoIP
interface FastEthernet0/0
description WAN_MPLS
bandwidth 20000
ip address 200.200.200.1 255.255.255.0
service-policy output QoS
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!

interface FastEthernet0/1.10
description vlan_datos
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/1.20
description vlan_voz
encapsulation dot1Q 20
ip address 2.2.2.1 255.255.255.0
!
interface FastEthernet1/0
description Servidores
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto

1.1.1.0/24
Red Datos

F0/1.10
F0/1.20

.10 F0

F0/1.10
F0/1.20

.11 F0

2.2.2.0/24
Red Voz

F0/1.10
F0/1.20

.12

F0

200.200.200.0/24
Red Wan

SW 4

F0/1.10
F0/1.20

.13

F0/1.10
F0/1.20

F0

.14

SW 3

F0

RTP/RTCP
RTP Real-time Transport Protocol.
Es un estndar creado por la IETF para la transmisin confiable de voz y video a travs de
Internet.

RTP es transportado usando UDP.


RTP implementa dos mecanismos principales para garantizar una transmisin de voz:
El uso de Nmero de secuencia y un Registro de tiempo.

RTP/RTCP
RTP Real-time Transport Protocol.

Los campos ms importantes en el encabezado RTP son los siguientes:


Nmero de secuencia: de 2 bytes, es un nmero que se incrementa por cada paquete enviado.
Es usado para determinar prdida de paquetes y recuperar correctamente la secuencia de voz.
Registro de tiempo: Mejor conocido como Timestamp, es un campo de 32 bits asignado en el
momento del envo con base en un reloj del sistema.
El valor inicial es seleccionado aleatoriamente para evitar confusin con otras secuencias RTP
presentes.
Existe la posibilidad de sincronizar los relojes de envo y recepcin usando el protocolo NTP.

RTP/RTCP
RTP Real-time Transport Protocol.

RTP/RTCP
RTP Real-time Transport Protocol.

RTP/RTCP
RTP Real-time Transport Protocol.

En aplicaciones de Voz sobre IP los protocolos utilizados son:


RTP: es el protocolo responsable de la transmisin de los datos.
CODEC : Realiza digitalizacin y compresin de la voz y el video
SIP: Para el manejo de sealizacin o establecimiento de llamada existe.

Requerimientos.
1)
2)
3)
4)
5)

Empresa Interec necesita habilitar VoIP para 50 usuarios.


Actualmente tiene un enlace de 25Mbps
50 computadores que cada uno utiliza de ancho de banda 615Kbps para Internet.
5 Servidores web que utiliza de ancho de banda 2,5Mbps
Tambien se transmite un canal institucional en calidad FULL HD.

Es necesario aplicar Calidad de Servicio?


Si es si,
Cuanto de ancho de banda es necesario para asegurar el correcto funcionamiento
Del servicio de voz para 50 telfonos IP, pero solo 30 usuarios hablando a la vez
con el Cdec G.711 ?

Cuanto es el ancho de banda necesario para asegurar el correcto


funcionamiento del canal institucional ?
Con cuantas colas QoS (Queue) quedara la solucin.?

Solucin

Voz 3Mbps
y priorizamos

Canal de videos (streaming)


7 Mbps
Servidores, Intranet
2,5 Mbps

Datos
Best Effort

Solucin
Voz 3Mbps
y priorizamos

Servidor
Streaming y Video

Asterisk Gateway

Canal de videos (streaming)


5 Mbps

Servidores, Intranet
2,5 Mbps
Datos
Best Effort

IP Multicast
224.10.10.10

100.100.100.0/24

Router
ACME

200.200.200.0/24
25 Mbps

100 Mbps
F0/1.10

MPLS

F0/1.20

100 Mbps
Vlan de datos ID 10
10.10.10.0/24

Servidores

Vlan de voz ID 20
20.20.20.0/24

Internet

Solucin

Pasos para configurar QoS:

1.

Listas de acceso

2.

Class Map

3.

Policy Map

4.

Aplicar QoS

Solucin

1. Lista de accesos

ip access-list standard VOZ


permit 20.20.20.0 0.0.0.255

ip access-list standard DATOS


permit 10.10.10.0 0.0.0.255

ip access-list standard SERVIDORES


permit 100.100.100.0 0.0.0.255

ip access-list standard CANAL


permit host 224.10.10.10

Solucin

2. Class Map

class-map match-all voz


match access-group name VOZ
class-map match-all datos
match access-group name DATOS
class-map match-all servidores
match access-group name SERVIDORES
class-map match-all video
match access-group name CANAL

Solucin

3. Policy Map

policy-map QoS
class voz
priority 3000
class video
bandwidth 5000
class servidores
bandwidth 2500
class datos

Solucin

4. Aplicar QoS

interface FastEthernet0/0
description WAN_MPLS
bandwidth 25000
ip address 200.200.200.1 255.255.255.0
service-policy output QoS
duplex auto
speed auto
!

Ejercicio en Clases
1. Cuales son los protocolos necesarios para VoIP e indique sus caractersticas?
2. Indique los Cdec para VoIP y sus caractersticas.
3. Cuales son los parmetros necesarios o requisitos para asegurar la VoIP en una red?

4. Indique los pasos para configurar QoS en un router


5. Indique las diferencias de unicast y multicast
6. Indique el Wilcard:
192.168.123.128 255.255.255.128

192.168.123.0 255.255.255.0
192.168.123.0 255.255.255.248
192.168.123.16 255.255.255.240

Cisco Call Manager (CCM),


Es un software basado en un sistema para administrar telefona sobre IP, desarrollado
por Cisco Systems.

Cisco Call Manager Express

LAB PT
VoIP
192.168.123.10/24

192.168.123.4/24

192.168.123.1/24

192.168.123.2/24

DATOS VLAN 10
10.10.10.128/25

DATOS VLAN 10
10.10.10.0/25

VOZ VLAN 20
20.20.20.0/25

EIGRP 123

VOZ VLAN 20
20.20.20.128/25

IPTV
La Televisin sobre el Protocolo IP o IPTV
video-streaming
Es una tecnologa que permite que los servicios de televisin sean
emitidos a travs de la banda ancha de una red de paquete de
datos privados, usando el protocolo IP.

IPTV
La Televisin sobre el Protocolo IP o IPTV

Por otra parte, la Televisin por Internet o Televisin


Online (Internet TV) es un servicio de transmisin de televisin
distribuido a travs de la Internet.
Muchas veces la IPTV es confundida con la emisin de la Televisin
por Internet.

IPTV
TV Cable Banda Ancha

TV Online Internet

Multicast

Unicast

Decodificador digital

Pc, Tablet; Smartphone

Red Privada del Proveedor

Internet

Pago

Gratis

Calidad de Servicio

Sin Calidad de Servicio

IPTV
Podemos diferenciar dos tipos de canal:
Definicin estndar SDTV

1.5 Mbps
Alta definicin HDTV.
8 Mbps

IPTV
Para Habilitar el servicio se necesita:
1.
2.
3.
4.
5.

Adquisicin de la seal de video


Almacenamiento y servidores de video
Distribucin de contenido
Equipo de acceso y suscriptor
Software

IPTV
Los formatos empleados por IPTV ms usualmente son:
H.261: Se utiliz para videoconferencia y video telefona y sirve como base para otros.
MPEG-1: Logra calidad similar a VHS y adems es compatible con todos los ordenadores y
casi todos los DVD.
MPEG-2: Es el usado en los DVD y permite imagen a pantalla completa con buena calidad.
H.263: Permite bajas tasas con una calidad aceptable. Usado en especial para
videoconferencia y videotelefona.
MPEG-4 parte 2: Calidad mejorada respecto a MPEG-2
MPEG-4 parte 10: Tambin llamado H264. Es el ms usado actualmente por una gran
variedad de aplicaciones.
WMV: Se utiliza tanto para video de poca calidad a travs de internet con conexiones
lentas, como para video de alta definicin. Mientras que MPEG-4 est respaldado por
JVT* el formato WMV es un formato de compresin de video propietario de Microsoft.
(JVT) Joint Video Team es la unin de ITU-T Video Coding Experts Group (VCEG) y de
ISO/IEC Moving Picture Experts Group (MPEG).

IPTV
Los servidores deben realizar:
1. Almacenamiento y respaldo de los contenidos
2. Gestin del video bajo demanda
1. Streaming de alta velocidad

IPTV
Los servidores utilizan IP, basados en los sistemas operativos que
permiten enviar distintos flujos de video a la vez.

IPTV

IPTV
1 Televisor SDTV
1 Televisor HDTV

Canal 13

Youtube
VoIP

Asterisk
PBX Asterisk
Asterisk es una aplicacin que controla y gestiona comunicaciones de cualquier tipo,
ya sean analgicas, digitales o VoIP mediante todos los protocolos VoIP que
implementa.

Asterisk es Open Source basada en GPL y por lo tanto con las ventajas que ello
representa, lo que lo hace libre para desarrollar sistemas de comunicaciones
profesionales de gran calidad, seguridad y versatilidad.
Funciona como una central telefnica (PBX), es decir que permite conectar
terminales telefnicas de forma independiente al proveedor de telefona.
De esta forma se consigue que todas las llamadas internas de una misma empresa
sean conmutadas directamente sin necesidad de salir al exterior por la red pblica de
telefona.

Asterisk
Licencias

Los programas de ordenador suelen distribuirse con licencias propietarias o cerradas.


Estas licencias son intransferibles y no exclusivas, es decir, no eres propietario del
programa, slo tienes derecho a usarlo en un ordenador o tantos como permita
expresamente la licencia y no puedes modificar el programa ni distribuirlo.
La licencia GPL o General Public License, desarrollada por la FSF o Free Software
Foundation, es completamente diferente.
Puedes instalar y usar un programa GPL en un ordenador o en tantos como te
apetezca, sin limitacin.
Tambin puedes modificar el programa para adaptarlo a lo que tu quieras que haga.
Adems, podrs distribuir el programa GPL tal cual o despus de haberlo modificado.

Asterisk
PBX
Private Branch Exchange

PABX
Private Automatic Branch Exchange

Asterisk
Funcionamiento:
Dispositivos fsicos que administran el trfico de llamadas, contabiliza las llamadas para
uso financiero y de facturacin.
Generalmente el usuario conecta el PBX por un nico enlace digital, como E1 T1 hacia
la Central Publica del proveedor de Telefonia.

E1:
El formato de la seal E1 lleva datos en una tasa de 2,048 millones de bits por segundo y
puede llevar 32 canales de 64 Kbps * cada uno, de los cuales treinta y uno son canales
activos simultneos para voz o datos en SS7 (Sistema de Sealizacin Nmero 7).
T1
Una conexin T1 es un paquete compuesto por 24 canales de multiplexado por divisin
de tiempo (TDM) de 64 kbps (DS0) a travs de circuito de cobre de cuatro hilos.
Esto crea un ancho de banda total de 1.544 mbps.

Asterisk
Funcionamiento:

1. Llamadas entrantes
Acceso por nmero nico
Acceso directo a extensiones

2. Llamadas salientes

3. Llamadas internas

Asterisk
Asterisk soporta muchos protocolos VoIP comop ueden ser SIP, H.323, IAX y MGCP, entre
otros.
Caractersticas Asterisk pese a ser una aplicacin software ofrece las mismas
caractersticas que un PBX hardware:

Reduccin de costos no solo por realizar las llamadas sobre la misma red de datos, si no
por ser una aplicacin de cdigo abierto.
Facilita la integracin y desarrollo de nuevos servicios.

Compatible con una gran cantidad de protocolos VoIP y cdecs.

Asterisk
SIP
Acrnimo de Session Initiation Protocol.
Este protocolo considera a cada conexin como un par y se encarga de negociar las
capacidades entre ellos.

Tiene una sintaxis simple, similar a HTTP o SMTP.


Posee un sistema de autenticacin de pregunta/respuesta.
Tiene mtodos para minimizar los efectos de DoS.
No tiene un adecuado direccionamiento de informacin para el funcionamiento con NAT.

Asterisk
IAX
Acrnimo de Inter Asterisk eXchange.

IAX es un protocolo abierto, es decir que se puede descargar y desarrollar libremente.


An no es un estndar.
Es un protocolo de transporte, que utiliza el puerto UDP 4569 tanto para sealizacin de
canal como para RTP (Protocolo de transporte en tiempo real).
Puede encapsular o empaquetar mltiples sesiones dentro de un flujo de datos, as
requiere de menos ancho de banda y permite mayor nmero de canales entre
terminales.

En seguridad, permite la autenticacin, pero no hay cifrado entre terminales.


El IAX puede usar cifrado (aes128), siempre sobre canales con autentificacin MD5.

Asterisk
H.323
Originalmente fue diseado para el transporte de vdeo conferencia.
Su especificacin es compleja.

H.323 es un protocolo relativamente seguro, ya que utiliza RTP.


Tiene dificultades con NAT, por ejemplo para recibir llamadas se necesita direccionar el
puerto TCP 1720 al cliente, adems de direccionar los puertos UDP para la media de RTP
y los flujos de control de RTCP.
Para ms clientes detrs de un dispositivo NAT se necesita gatekeeper en modo proxy.

Asterisk
MGCP

Acrnimo de Media Gateway Control Protocol.


Inicialmente diseado para simplificar en lo posible la comunicacin con terminales
como los telfonos.

MGCP utiliza un modelo centralizado (arquitectura cliente-servidor), de tal forma que un


telfono necesita conectarse a un controlador antes de conectarse con otro telfono, as
la comunicacin no es directa.
Tiene tres componentes un MGC (Media Gateway Controller), uno o varios MG (Media
Gateway) y uno o varios SG (Signaling Gateway), el primero tambin denominado
dispositivo maestro controla al segundo tambin denominado esclavo.

No es un protocolo estndar.

Asterisk
SCCP

Acrnimo de Skinny Call Control Protocol (en algunas fuentes se enuncia como "Skinny
Client Control Protocol).
Es un protocolo propietario de Cisco.
Es el protocolo por defecto para terminales con el servidor Cisco Call Manager PBX que
es el similar a Asterisk PBX.
El cliente Skinny usa TCP/IP para transmitir y recibir llamadas.
Para el audio utiliza RTP, UDP e IP.
Los mensajes Skinny son transmitidos sobre TCP y usa el puerto 2000.

Asterisk

Asterisk est formado por un ncleo principal encargado de gestionar todo el sistema
PBX.
Sus funciones principales son:

Interconectar de forma automtica cada llamada entre los usuarios tomando en cuenta
el tipo de protocolo utilizado por cada terminal.
Lanzar los servicios cuando sean necesarios.

Traducir y adaptar cada cdec a cada terminal involucrado en la comunicacin

Asterisk
Codificadores de audio:

La seal de audio ha de ser digitalizada, comprimida y codificada antes de ser transmitida


por la red IP.
Para ello se utilizan algoritmos matemticos implementados en software llamados
cdecs.
Existen diferentes modelos de cdecs de audio utilizados en VoIP, y dependiendo del
algoritmo escogido en la transmisin, variara la calidad de la voz.
Algunos de los cdecs ms utilizados son los siguientes

Asterisk
Protocolo de sealizacin
La sealizacin en VoIP tiene un papel muy importante en la red, ya que es la encargada
de establecer, mantener, administrar y finalizar una conversacin entre dos puntos.
Adems de ofrecer funciones de supervisin, marcado y QoS en cada canal de
transmisin.

Asterisk
A continuacin se describen los protocolos de sealizacin ms usados actualmente.

PROTOCOLO

CARACTERISTICAS

SIP

Protocolo para el control de llamas multimedia y la implementacin de


servicios telefnicos avanzados.
Est basado en HTTP adoptando las caractersticas ms importantes de este
estndar como son la sencillez de sus sintaxis y una estructura
cliente/servidor.
El gran potencial de SIP reside en su flexibilidad

IAX

Fue desarrollado por Digium para la comunicacin entre centralitas Asterisk


aunque actualmente se ha implementado clientes que tambin soportan
este protocolo.
Su principal objetivo es minimizar el ancho de banda utilizado en la
transmisin de voz y video a travs de la red IP

Asterisk

RedHat
Suse
Debian
Ubuntu
Centos

NetBSD
OpenBSD

Asterisk

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk
Maquina Virtual

Asterisk

Asterisk

Asterisk

Asterisk

Asterisk

Asterisk

Asterisk

Asterisk

SSID: Laboratorio Cisco


Clave: a1b2c3d4f5

X-Lite SoftPhone

ASTERISK LAB
ASTERISK

3CX, SmartPhone

Entronque entre PBX Asterisk

ASTERISK
Ip: 192.168.1.x

ASTERISK
Ip: 192.168.1.x

Trunk
IAX

SIP

SIP

RTP
201
Codec G711

301
Codec G711

Cliente
ip: 192.168.1.x

Cliente
ip: 192.168.1.x

Entronque entre PBX Asterisk

IAX (Inter-Asterisk eXchange protocol) es uno de los protocolos utilizado por


Asterisk
Es utilizado para manejar conexiones VoIP entre servidores Asterisk, y entre
servidores y clientes que tambin utilizan protocolo IAX.

El protocolo IAX ahora se refiere generalmente al IAX2, la segunda versin del


protocolo IAX.

El protocolo original ha quedado obsoleto en favor de IAX2.

Entronque entre PBX Asterisk

El principal objetivo de IAX ha sido minimizar el ancho de banda utilizado en la


transmisin de voz y vdeo a travs de la red IP.

Soporte nativo para ser transparente a NAT. La estructura bsica de IAX se


fundamenta en la multiplexacin de la sealizacin y del flujo de datos sobre un
simple puerto UDP entre dos sistemas.

Entronque entre PBX Asterisk

IAX vs SIP
Las principales diferencias ente IAX y SIP son las siguientes:
Ancho de banda.
IAX utiliza un menor ancho de banda que SIP ya que los mensajes son codificados de
forma binaria mientras que en SIP son mensajes de texto. Asimismo, IAX intenta reducir
al mximo la informacin de las cabeceras de los mensajes reduciendo tambin el
ancho de banda
NAT
En IAX la sealizacin y los datos viajan conjuntamente con lo cual se evitan los
problemas de NAT que frecuentemente aparecen en SIP. En SIP la sealizacin y los
datos viajan de manera separada y por eso aparecen problemas de NAT en el flujo de
audio cuando este flujo debe superar los routers y firewalls. SIP suele necesitar un
servidor STUN para estos problemas

Entronque entre PBX Asterisk

IAX vs SIP
Estandarizacin
SIP es un protocolo estandarizado por la IETF (Internet Engineering Task Force) hace bastante
tiempo y que es ampliamente implementado por todos los fabricantes de equipos y
software.

IAX est aun siendo estandarizado y es por ello que no se encuentra en muchos
dispositivos existentes en el mercado.
Utilizacin de puertos
IAX utiliza un solo puerto (4569) para mandar la informacin de sealizacin y los datos
de todas sus llamadas. Para ello utiliza un mecanismo de multiplexin o "trunking".

SIP, sin embargo utiliza un puerto (5060) para sealizacin y 2 puertos RTP por cada
conexin de audio (como mnimo 3 puertos).
Por ejemplo para 100 llamadas simultaneas con SIP se usaran 200 puertos (RTP) ms el
puerto 5060 de sealizacin.
IAX utilizara slo un puerto para todo (4569)

Entronque entre PBX Asterisk

IAX vs SIP
Flujo de audio al utilizar un servidor
En SIP si utilizamos un servidor la sealizacin de control pasa siempre por el servidor
pero la informacin de audio (flujo RTP) puede viajar extremo a extremo sin tener que
pasar necesariamente por el servidor SIP.
En IAX al viajar la sealizacin y los datos de forma conjunta todo el trfico de audio
debe pasar obligatoriamente por el servidor IAX. Esto produce una aumento en el uso
del ancho de banda que deben soportar los servidores IAX sobretodo cuando hay
muchas llamadas simulataneas.

Entronque entre PBX Asterisk

IAX vs SIP

Internet

Trunk
IAX

Trunk
IAX

Trabajo en Clases
1)

Que es IPTV?

2)

Cual es la diferencia entre IPTV y TV Online Internet?

3)

Para IPTV cual es el ancho de banda para SDTV y HDTV?

4)

Cuales son los formatos para IPTV e indique cual es el mas utilizado y porque?

5)

Los Servidores para IPTV que deben realizar?

6)

Asterisk que tipo de licencia tiene?

7)

Que tipo de enlaces digitales se conecta entre la PBX y la central publica?

8)

Asterisk bajo que SO funciona?

9)

Indique cuales son los Cdec que necesitan licencia?

10) Porque es necesario desconfigurar el NAT para utilizar SIP?

ASTERISK
Completar diagrama de conexin Asterisk

ASTERISK
Ip: 192.168.1.55

ASTERISK
Ip: 192.168.1.56

Trunk
IAX

SIP

SIP

RTP
201
Codec G711

301
Codec G711

Cliente
ip: 192.168.1.10

Cliente
ip: 192.168.1.20

ASTERISK
Completar diagrama de conexin Asterisk

Call Manager Cisco


Ip: 192.168.1.55

ASTERISK
Ip: 192.168.1.56

Trunk
IAX

SIP

SIP

RTP
201
Codec G711

301
Codec G711

Cliente
ip: 192.168.1.10

Cliente
ip: 192.168.1.20

Entronque entre PBX Asterisk

IAX vs SIP

Internet

Trunk
IAX

Trunk
IAX

Entronque entre PBX Asterisk

Arquitectura VoIP
Publica

Privada
SWITH LAN
LAYER 2

PSTN
E1

PBX-IP
ASTERISK
NGN

IP

(Internet o MPLS)

FXO

PSTN

GATEWAY

Telfono IP

Entronque entre PBX Asterisk

FXS (Foreing Exchange Station) es una interfaz de un dispositivo que permite conectar
un telfono anlogo

FXO (Foreign Exchange Office) es una interfaz del dispositivo que permite conectar la
central publica telefnica.

NGN (Next Generation Networking ) refiere a la evolucin de la actual infraestructura de


redes de telecomunicacin y acceso telefnico con el objetivo de lograr la convergencia
tecnolgica de los nuevos servicios multimedia (voz, datos, video.)

Trabajo de investigacin y exposicin sobre proveedores de VoIP y Videoconferencia


(09 de mayo)
Equipos utilizados, marca , modelo, arquitectura, QoS, clientes (residencial,pyme,empresas)
Debe incluir caractersticas y especificaciones tcnicas de los equipos.
Grupo Integrantes

1
2
3
4
5

6
7
8
9
10

Empresa

LAB Entronque
PBX Asterisk

PBX-IP Villalon
192.168.1.51

PBX-IP Buccioni
192.168.1.50

Trunk
SIP

IAX
SIP

741 10

741 11

Extensiones
741 10 741 19

SIP
SIP

741 20

741 21

Extensiones
741 20 741 29

LAB Entronque
Configuracin

Nombre

PBX-IP Buccioni

PBX-IP Villaln

ip

192.168.1.50

192.168.1.51

Rango extensin

741 10 741 19

741 20 741 29

LAB Entronque
Configuracin de Trunk
Crear Trunk en PBX-IP Buccioni

LAB Entronque
Configuracin de Trunk

LAB Entronque
Configuracin de Trunk

Componentes H.323
H.323 establece los estndares para la compresin y descompresin de audio y
vdeo, asegurando que los equipos de distintos fabricantes se intercomuniquen.
As, los usuarios no se tienen que preocupar de cmo el equipo receptor acta,
siempre y cuando cumpla este estndar.
Por ejemplo, la gestin del ancho de banda disponible para evitar que la LAN se
colapse con la comunicacin de audio y vdeo tambin est contemplada en el
estndar, esto se realiza limitando el nmero de conexiones simultneas.

Componentes H.323

Tambin la norma H.323 hace uso de los procedimientos de sealizacin de los canales
lgicos contenidos en la norma H.245, en los que el contenido de cada uno de los
canales se define cuando se abre.

Componentes H.323
El estndar define un amplio conjunto de caractersticas y funciones, algunas son
necesarias y otras opcionales.
Pero el H.323 define mucho ms que las funciones, este estndar define los siguientes
componentes ms relevantes:
Terminal
GateWay
Gatekeeper
Unidad de Control Multipunto
Controlador Multipunto
Procesador Multipunto
Proxy H.323

Componentes H.323

Componentes H.323

1. Terminal
Un terminal H.323 es un extremo de la red que proporciona comunicaciones
bidireccionales en tiempo real con otro terminal H.323, gateway o unidad de control
multipunto (MCU).
Esta comunicacin consta de seales de control, indicaciones, audio, imagen en color
en movimiento y /o datos entre los dos terminales.
Conforme a la especificacin, un terminal H.323 puede proporcionar slo voz, voz y
datos, voz y vdeo, o voz, datos y vdeo.

Componentes H.323

Un terminal H.323 consta de las interfaces del equipo de usuario, el cdec de video, el
cdec de audio, el equipo telemtico, la capa H.225, las funciones de control del sistema
y la interfaz con la red por paquetes.
a. Equipos de adquisicin de informacin:
Es un conjunto de cmaras, monitores, dispositivos de audio (micrfono y
altavoces) y aplicaciones de datos, e interfaces de usuario asociados a cada uno de
ellos.

b. Cdec de audio:
Todos los terminales debern disponer de un cdec de audio, para codificar y
decodificar seales vocales (G.711), y ser capaces de transmitir y recibir ley A y ley
.
Un terminal puede, opcionalmente, ser capaz de codificar y decodificar seales
vocales.
El terminal H.323 puede, opcionalmente, enviar ms de un canal de audio al
mismo tiempo, por ejemplo, para hacer posible la difusin de 2 idiomas.

Componentes H.323

c. Cdec de video: En los terminales H.323 es opcional.


d. Canal de datos: Uno o ms canales de datos son opcionales. Pueden
ser unidireccionales o bidireccionales.
e. Retardo en el trayecto de recepcin: Incluye el retardo aadido a las
tramas para mantener la sincronizacin, y tener en cuenta la fluctuacin
de las llegadas de paquetes. No suele usarse en la transmisin sino en
recepcin, para aadir el retardo necesario en el
trayecto de audio para, por ejemplo, lograr la sincronizacin con el
movimiento de los labios en una videoconferencia.
f. Unidad de control del sistema: Proporciona la sealizacin necesaria
para el funcionamiento adecuado del terminal. Est formada por tres
bloques principales: Funcin de control H.245, funcin de sealizacin
de llamada H.225 y funcin de sealizacin RAS.

Componentes H.323

2. Gateway

Un gateway H.323 es un extremo que proporciona comunicaciones bidireccionales en


tiempo real entre terminales H.323 en la red IP y otros terminales o gateways en una
red conmutada.
En general, el propsito del gateway es reflejar transparentemente las caractersticas
de un extremo en la red IP a otro en una red conmutada y viceversa.

Componentes H.323
3. Gatekeeper

El gatekeeper es una entidad que proporciona la traduccin de direcciones y el control


de acceso a la red de los terminales H.323, gateways y MCUs.
El gatekeeper puede tambin ofrecer otros servicios a los terminales, gateways y MCUs,
tales como gestin del ancho de banda y localizacin de los gateways.

Componentes H.323

4. MCU
La Unidad de Control Multipunto est diseada para soportar la conferencia entre tres o
ms puntos, bajo el estndar H.323, llevando la negociacin entre terminales para
determinar las capacidades comunes para el proceso de audio y vdeo y controlar la
multidifusin.
5. CONTROLADOR MULTIPUNTO
Un controlador multipunto es un componente de H.323 que provee capacidad de
negociacin con todos los terminales para llevar a cabo niveles de comunicaciones.
Tambin puede controlar recursos de conferencia tales como multicasting de vdeo. El
Controlador Multipunto no ejecuta mezcla o conmutacin de audio, vdeo o datos.

Componentes H.323
6. PROCESADOR MULTIPUNTO
Un procesador multipunto es un componente de H.323 de hardware y software
especializado, mezcla, conmuta y procesa audio, vdeo y / o flujo de datos para los
participantes de una conferencia multipunto de tal forma que los procesadores del
terminal no sean pesadamente utilizados. El procesador multipunto puede procesar un
flujo medio nico o flujos medio mltiples dependiendo de
la conferencia soportada.
7. PROXY H.323
Un proxy H.323 es un servidor que provee a los usuarios acceso a redes seguras de unas a
otras confiando en la informacin que conforma la recomendacin H.323.El Proxy H.323
se comporta como dos puntos remotos H.323 que envan mensajes call set up, e
informacin en tiempo real a un destino del lado seguro del firewall.

Componentes H.323

Call Signalling Q.931


Protocolo de control de conexiones ISDN. No provee control de flujo ni realiza
retransmisiones.
Es una recomendacin de la ITU. Q.931 no provee control de flujo ni retransmisin.
Q.931 define mltiples mensajes como:
1. SETUP: indica el establecimiento de una conexin.

2. CALL PROCEEDING: indica que la llamada est siendo procesada por la terminal
destino.

3. ALERTING: indica que la terminal destino est llamando.


4. CONNECT: indica a la parte que llama, que el destino esperado ha contestado la
llamada.

5. RELEASE COMPLETE: indica que la llamada ha sido terminada. Lo puede enviar tanto
la fuente como el destino.

Call Signalling Q.931

Directorios de Asterisk
Los directorios que utiliza Asterisk para su funcionamiento son los siguientes:

/etc/asterisk: directorio donde se alojan todos los ficheros de configuracin del servicio.
/usr/lib/asterisk/modules: contiene todos los mdulos que podr cargar Asterisk para
aadir funcionalidades. Algunos de ellos son format_wav.so, codec_alaw.so, chan_sip.so
entre muchos otros.
/var/lib/asterisk: directorio que contiene las claves, msica en espera y todos los
sonidos que vienen por defecto con Asterisk.
/var/spool/asterisk: almacena los mensajes grabados en el buzn de voz, las
conferencias grabadas, etc.
/var/run/asterisk: contiene el fichero pid del proceso Asterisk en ejecucin.
/var/log/asterisk: directorio de almacenamiento de ficheros de logs del servicio.

Ficheros de configuracin
/etc/asterisk/

asterisk.conf: el fichero de configuracin donde se configuran todos los


componentes de Asterisk (ficheros de log, ficheros de configuracin, etc).
Tambin es posible configurar parmetros generales en Asterisk.
sip.conf: es el fichero donde configuraremos los clientes SIP que podrn
conectarse a nuestra centralita Asterisk.
extensions.conf: uno de los ficheros ms utilizados y ms importantes en
Asterisk. En resumidas cuentas, es donde configuraremos el comportamiento de
nuestra centralita, por eso es uno de los ms importantes.
voicemail.conf: donde configuraremos el buzn de voz para cada uno de nuestros
clientes SIP.
meetme.conf: nos permite configurar salas de conferencias, es decir, podremos
crear una sala donde haya varios participantes.

Asterisk

Centos

GNU/Linux
GNU/Linux es uno de los trminos empleados para referirse a la combinacin del ncleo
o kernel libre similar a Unix denominado Linux con el sistema GNU.

GNU/Linux
Su desarrollo es uno de los ejemplos ms prominentes de software libre; todo su cdigo
fuente puede ser utilizado, modificado y redistribuido libremente por cualquiera bajo los
trminos de la GPL (Licencia Pblica General de GNU, en ingls: General Public License) y
otra serie de licencias libres.

GNU/Linux

GNU/Linux
Particiones y sistemas de archivos en Linux

Particionar un disco es como dividirlo en discos ms


pequeos contenidos dentro de la misma carcasa.

Las particiones pueden ser de dos tipos: primarias


lgicas, las particiones lgicas se crean dentro de
una particin primaria especial llamada extendida.

GNU/Linux
Sistemas de archivos en Linux
Existen diferentes sistemas de archivos y cada sistema operativo soporta diferentes
sistemas de ficheros, algunos de ellos son los siguientes:
Ext2 el primer sistema de archivos diseado expresamente para Linux.
Ext3 versin mejorada de Ext2, ampliamente utilizada en distribuciones Linux

Ext4nuevo sistema de ficheros para Linux evolucionado de Ext3 algunas de sus ventajas
con respecto a este ltimo son:
Aumento del tamao del sistema de ficheros a 1 Exabay = 2^20 Terabyte y del
tamao mximo por archivo (16 Tb).
Nmero ilimitado de directorios frente a los 32.000 de Ext3
Mayor velocidad en la creacin y borrado de ficheros

GNU/Linux
Sistemas de archivos en Linux
XFS Implementado para sistemas Unix, rpido acceso para grandes cantidades de datos
y altas velocidades, pero lento en ficheros pequeos. Se utiliza en grandes servidores y
donde se maneje mucha informacin.
ReiserFS Sistema de archivos diseado e implementado por la empresa Namesys,
liderado por Hans Reiser. Es soportado por Linux y otros sistemas operativos (algunos a
travs de implementaciones muy inestables).
Fat16/Fat32 Sistemas Dos/Windows 95, Windows 98, este sistema de archivos produce
una gran fragmentacin del disco.
NTFS sistema de archivos implementado para los sistemas operativos Windows
Xp/2000/2003 server y Vista.

GNU/Linux
Sistemas de archivos en Linux

GNU/Linux
Directorios Linux

GNU/Linux
Directorios Linux

GNU/Linux
Directorios Linux

GNU/Linux
Directorios Linux

GNU/Linux
Directorios Linux

GNU/Linux
Directorios Linux Asterisk

GNU/Linux
Directorios Linux Asterisk

Trunk IAX Solucionado

LAB Entronque
PBX Asterisk

PBX-IP 2
192.168.1.51

PBX-IP 1
192.168.1.50

Trunk
SIP

IAX
SIP

741 10

741 11

SIP
SIP

741 20

741 21

Extensiones
741 10 741 19

Extensiones
741 20 741 29

Buzon de Voz

Buzon de Voz

Asterisk es el lder mundial en plataformas de telefona de cdigo abierto.


Asterisk es un software que puede convertir un ordenador de propsito general en un
sofisticado servidor de comunicaciones VoIP.
Es un sistema de centralita IP utilizado por empresas de todos los tamaos para mejorar
su comunicacin, incluyendo a Google, Yahoo, IBM, e incluso el Ejrcito de EE.UU.

Asterisk: Principales ventajas


Funcionalidad
Asterisk dispone de todas las funcionalidades de las grandes centralitas propietarias (Cisco,
Avaya, Alcatel, Siemens, etc). Desde las ms bsicas (desvios, capturas, transferencias, multiconferencias, ) hasta las ms avanzadas (Buzones de voz, IVR, CTI, ACD).
Escalabilidad
El sistema puede dar servicio desde 10 usuarios en una sede de una pequea empresa, hasta
10.000 de una multinacional repartidos en mltiples sedes.

Competitividad en costo
No solo por ser un sistema de cdigo abierto (Open Source) sino gracias a su arquitectura
hardware: utiliza plataforma servidor estndar (de propsito no especfico) y tarjetas PCI
para los interfaces de telefona, que por la competencia del mercado se han ido abaratando
progresivamente.

Asterisk: Funcionalidades bsicas y avanzadas


Funciones bsicas:
Transferencias (directa o consultiva): Permite transferir una llamada en curso a otra
extensin.
Existen dos formas:
Transferencia atendida: consultando al nuevo destino si quiere que le pasen la llamada.

Transferencia directa: pasando la llamada sin consultar al destinatario.


Desvos: Permiten la transferencia automtica de una llamada entrante hacia un nmero
determinado (interno o externo) cuando se cumplen determinadas condiciones: por ejemplo
si el nmero esta ocupado, si no contesta, etc.
Capturas (de grupo o de extensin): La captura permite coger una llamada que se esta
recibiendo en una extensin desde otra distinta.

Asterisk: Funcionalidades bsicas y avanzadas


Captura de grupo: se predefinen unos deteminados grupos de extensiones de modo que al
marcar un codigo de asterisk - por defecto el *8 - cualquier llamada que est recibiendo el
grupo en el que estamos.

Conferencia mltiple: En funcin del modelo de terminal se podr establecer una


comunicacin entre mltiples usuarios de la PBX
Llamada directa a extensin: Si adems del nmero de cabecera disponemos de diferentes
nmeros pblicos , podremos enrutar directamente la llamada entrante a uno de los anexos,
a una extensin de la PBX
Ring groups: grupos de llamadas. Una llamada entrante podr ser dirigida directamente a un
ring group, que es un grupo de extensiones que sonaran de acuerdo a una determinada
estrategia previamente establecida.
DND (Do not disturbe): Opcin de no molestar, que podr ser configurado en Asterisk
mediante un cdigo o directamente en el terminal.

Asterisk: Funcionalidades bsicas y avanzadas


Funciones avanzadas:
Correo Vocal (Voicemail) integrado con correo electrnico. En caso de que el usuario no
pueda atender una llamada, se puede programar que se transfiera a un sistema de buzn de
voz. En caso de que se deje un mensaje, se enviar un correo electrnico avisando del mismo
al usuario destinatario.
Operadora Automtica (IVR): Una operadora automtica o IVR es una aplicacin de telefona
que permite interactuar con el usuario que realiza la llamada, de forma que ste pueda
pulsar opciones previamente anunciadas y acceder de forma automtica a los destinos
programados.

Msica en espera con archivos WAV: Asterisk nos permite introducir categoras de msica
en espera basadas en archivos .wav y mp3. De este modo podremos poner diferentes
melodas para ser reproducidas como msica en espera.

Asterisk: Funcionalidades bsicas y avanzadas


Colas de Llamadas (ACD) : Un sistema de colas o ACD es una aplicacin que distribuye las
llamadas entrantes a un grupo especfico de agentes de acuerdo a una determinada
estrategia. Si la llamada no puede ser descolgada, no se pierde y puede ser transferida a otro
destino.
Salas de Audio-Conferencias: Una sala de audioconferencias es un sistema que permite
conectar a multiples usuarios en una misma conversacin telefonica. Los usuarios pueden
acceder a la sala desde una extensin interna, o bien desde el exterior (a traves de un
nmero directo o bien a traves de un IVR). Es un sistema muy til para hacer reuniones
internas (por ejemplo seguimiento de ventas) o bien con clientes o proveedores.
Informes detallados de llamadas (CDR): Detalle de llamadas realizadas/recibidas por
extensin, para realizar cobros, por cliente o incluso para facturacin.

Integracin CTI: Integracin de la telefona con sistemas informatizados de gestin comercial


o de atencin a cliente (CRM). Estos sistemas permiten por ejemplo ejecutar una llamada
desde el PC o bien recibir informacin sobre una llamada entrante en la pantalla.

Conexin Empresarial
VoIP

PBX-IP
ASTERISK

E1

PSTN

Soporte

27410100
27410200

Ingeniera

INTERNET

NGN
SoftSwitch
DMZ

PSTN

Sucursales

Server
DHCP

Ventas

IVR ASTERISK
PBX-IP

Si no marca ninguna opcin debe volver al men


solo una vez mas.
Si nadie contesta en Soporte o estn ocupados
reenviar la llamada a Soporte de la PBX
de su compaero.

0211
Soporte

Si nadie contesta en Ventas o estn ocupados


reenviar la llamada a Ventas de la PBX
de su compaero.

Entronque
IAX

0213
0214

Si nadie contesta en Ingeniera poner grabacin

Ingeniera

PBX-IP
Entronque
SIP

Menu IVR

27410200

0215

27410210 - 27410219
0216

Bienvenidos

NGN

0212

1. Marque 1 para Ventas


2. Marque 2 para Ingeniera
3. Marque 3 para Soporte

0217
Ventas

0218
0219

IVR ASTERISK
ANEXO
2741 0010
2741 0020
2741 0030
2741 0040
2741 0050
2741 0060
2741 0070
2741 0080
2741 0090
2741 0100
2741 0110
2741 0120
2741 0130
2741 0140
2741 0150
2741 0160
2741 0170
2741 0180
2741 0190

19
29
39
49
59
69
79
89
99
109
119
129
139
149
159
169
179
189
199

Nombre
Claudio Andreas Buccioni Torrejon
Fernando Esteban Villalon Castro
Samuel Fabrizio Sbraga Rodriguez
Juan Alberto Caceres Lopez
Giordano Antonio Leita Santibez
Hernan Alexander Ponce Contreras
Edgardo Alfredo Marin Barraza
Claudio Abel Huerta Perez
Daniel Ignacio Pinto Irarrazabal
Airon Brian Veliz Diaz
Hernan Ignacio Lineros Araya
Cristobal Sebastian Saavedra Cortes
Franco Jordano Vicencio Rojas
Fernando Javier Lopez Casanga
Alex Mauricio Andaur Osorio
Patricio Alejandro Rojas Carreras
Matias Ignacio Vera Caballero
Pablo Ignacio Torres Rojas
Vicente Antonio Gutierrez Raggi

IVR ASTERISK

Anexo

2751
2751
2751
2751
2751
2751
2751
2751
2751
2751
2751
2751
2751
2751
2751

0010
0020
0030
0040
0050
0060
0070
0080
0090
0100
0110
0120
0130
0140
0150

Nombre

19 Pedro Andrs Guzman Rojas


29 Alejandro Ignacio Toro Alvarez
39 Cristobal Aleksandar Lenac Belmar
49 Angel Patricio Carvajal Flores
59 Cesar Alejandro Velasquez Avila
69 Franco Eduardo Aros Alfaro
79 Patricio Alejandro Rojas Carreras
89 Francisco Alberto Salas Acuna
99 Patricio Eduardo Arancibia Robles
109 Roman David Carvajal Rodriguez
119 Juan Alejandro Silva Arancibia
129 Jorge Francisco Olivares Villalobos
139 Rodrigo Andres Rojas Andrade
149 Jose Ignacio Felipe Valderrama Henriquez
159 Michael Bravo

IVR ASTERISK (Presentacin Practica Viernes 6 de Junio)


IVR

1. Grupos de llamadas (Ring Group) 3 Anexos (10 Pts)


2. Cola de llamadas (MusicHold) 3 Anexos (10 Pts)
3. Grabacin (10 Pts) Original
4. IVR (10 Pts)
5. Crear anexo virtual para el IVR (debe ser el primer numero asignado) (10 Pts)

6. Videollamada (10 Pts)


7. Entronque (IAX-SIP) (10 Pts)
8. Desvio de llamada a Entronque (10 Pts)
9. Diagrama de implementacin (10 Pts)
10. Plan de Llamada, Dial Plan (10 Pts)

Conexin Residencial

PSTN

Internet
MPLS
BACKBONE

Planta Externa
DSLAM
Spliter

Modem
ADSL

BRAS

Conexin Residencial
VoIP ADSL
BRAS

Internet
MPLS
BACKBONE

Planta Externa
CU

DSLAM

Modem
ADSL

NGN

PSTN

Conexin Residencial
VoIP FTTH
BRAS

Internet
MPLS
BACKBONE

NGN

PSTN

Video llamadas
Asterisk

Codec
H.263 es un estndar de la Unin Internacional de Telecomunicaciones
(ITU) para la codificacin de vdeos con compresin que data de
1995/1996, documento en el cual tambin se detalla, en su segunda
parte, el estndar MPEG-4 de la Moving Picture Experts Group.
Est optimizado para una tasa de bits baja (bajo 64 kbit/s, es decir,
velocidad ISDN) y un movimiento relativo reducido.

Video llamadas
Asterisk

Codec
H.264 o MPEG-4 parte 10
Es una norma que define un cdec de vdeo de alta
compresin, desarrollada conjuntamente por el ITU-T Video
Coding Experts Group (VCEG) y el ISO/IEC Moving Picture
Experts Group (MPEG).
Adaptacin a la red:
Conceptualmente los algoritmos estn divididos en dos capas:
una primera capa de codificacin de vdeo VCL (Video Coding
Layer) que se ocupa de representar eficazmente el contenido
de vdeo y una capa de adaptacin a la red NAL (Network
Adaptacin Layer) que est dirigida ms particularmente a
adaptar el formato de datos de vdeo al soporte de transmisin.

Con la ley ya promulgada, se oficializa que el sistema de TV Digital chileno utilizar la norma
ISDB-T con MPEG 4, creada por Japn y modificada por Brasil para el desarrollo de su
televisin digital.
http://www.emol.com/noticias/tecnologia/2014/05/22/661448/presidenta-bachelet-promulga-la-ley-de-televisiondigital-y-valora-su-pluralidad.html

ESTANDARES DIGITALES

ESTANDARES DIGITALES
TRABAJO DE INVESTIGACION ESTANDARES DIGITALES

1) Presentacin Lunes 9.
2) Comparacin entre los estndares
3) Estndar implementado en Chile (ISDB-T con MPEG 4)

Caractersticas, cambio a realizar los proveedores de cable y la transmisin televisin abierta.


Calidad de imagen, diferencia entre la actual y el nuevo estndar.

Video llamadas
Asterisk
Ancho de Banda Utilizando el Codec H.264

Video llamadas
Asterisk
En un escenario entre pares:
1) Los extremos envan secuencias de audio solo cuando los usuarios
hablan.
2) Ambos participantes reciben secuencias de audio.
3) Si se utiliza video, ambos extremos envan y reciben secuencias de

vdeo durante toda la llamada.


4) Para las escenas de video con poco o nada de movimiento, la velocidad
de bits real puede ser temporalmente muy baja debido a que el cdec
de video omitir las regiones de codificacin del video sin cambio.

Video llamadas
Asterisk
En un escenario de conferencias:
1) Los extremos envan secuencias de audio solo cuando los usuarios
hablan.
2) Todos los participantes reciben secuencias de audio.
3) Adems del ancho de banda requerido para el trfico de protocolo
seguro en tiempo real (RTP) para los medios de audio o video, el ancho
de banda es necesario para el protocolo de control de transporte en
tiempo real (RTCP). El RTCP se utiliza para informar estadsticas y
control fuera de banda de la secuencia RTP. Para la planificacin, use
los nmeros del ancho de banda en la tabla siguiente para el trfico
RTCP. Estos valores representan el ancho de banda mximo para RTCP
y difieren entre las secuencias de audio y vdeo debido a las diferencias
en los datos de control

Video llamadas
Asterisk
Calcular Ancho de Banda h.264
Velocidad Mxima y Mnima
a) 3 Video llamadas utilizando, 480x270 (16:9)
b) 2 Video llamadas utilizando, 1920x1080 (16:9)
c) 1 Video llamada utilizando, 320x180 (16:9)

Video llamadas
Asterisk
Requerimientos para voz y video:

1) Empresa ACME necesita habilitar Voz y Video llamadas sobre IP.


2) Actualmente tiene un enlace de 50Mbps
3) 50 computadores utilizan de ancho de banda 615Kbps para Internet en
promedio.
4) 5 Servidores Web que utiliza de ancho de banda en total de 2Mbps en

promedio.
5) Transmiten un canal institucional en calidad FULL HD.

Video llamadas
Asterisk
Es necesario aplicar Calidad de Servicio?

Cuanto de ancho de banda es necesario para asegurar el correcto


funcionamiento del servicio de Voz para 50 telfonos IP, pero solo 30
usuarios hablando a la vez con el Cdec G.711 ?
Cuanto de ancho de banda es necesario para asegurar el correcto
funcionamiento de 5 video llamadas utilizando h.264 con resolucin
1280x720(16:9) y cdec de voz G7.11?
Cuanto es el ancho de banda necesario para asegurar el correcto
funcionamiento del canal institucional ?
Con cuantas colas (Queue) de QoS son necesarias implementar en la red
del cliente ?

Video llamadas
Asterisk

CONFERENCIA
Asterisk

Queue
Asterisk

Queue
Asterisk

Empresa de Voz y
Video IP
Asterisk
Solucin de Voz y Video IP
Informe Tcnico Comercial
Arquitectura de la solucin, servicios ofrecidos Ejemplo: IVR,
Conferencia, video llamada, etc.
Equipos a utilizar ejemplo : Servidores , ATA, Telfonos IP,
telfonos anlogos, SoftPhone.
Costo de Solucin
Catalogo del producto
Presentacin
Se evaluaran Avances