You are on page 1of 5

Protocolo de

Enrutamiento Rip
Basados en el algoritmo de Bellman-Ford distribuido. Los nodos intercambian
informacin de la tabla de enrutamiento con sus vecinos.

RIP utiliza una mtrica simple para determinar las distancias entre un origen y
un destino. Esta mtrica se mide en 15 saltos. Cada salto esta determinados
por cada router que atraviesa la informacin. Con cada salto desde el origen
hacia el destino es aumentado en uno un contador. Cuando un router recibe una
actualizacin de enrutamiento que contiene una nueva ruta o algn cambio con
respecto a sus propias tablas, el router modifica sus tablas, y luego agrega un
valor a la mtrica, esto indica que las tablas han sido actualizadas, la direccin
IP del origen ser utilizada para el prximo salto.
Rip actualiza a sus vecinos mediante Los routing-update timer establecen el
intervalo entre las actualizaciones de tablas de enrutamiento peridicas. Por lo
general, este valor esta en 30 segundos, con un rango muy pequeo de
segundos agregados a cada tiempo para prevenir colisiones.
En las actualizaciones que se envan a los dems routers podemos encontrar:
Peticin: Enviados por algn enrutador recientemente iniciado que solicita
informacin de los enrutadores vecinos.
Respuesta: mensajes con la actualizacin de las tablas de enrutamiento.
Existen tres tipos:
Mensajes ordinarios: Se envan cada 30 segundos. Para indicar que el enlace y
la ruta siguen activos.
Mensajes enviados como respuesta a mensajes de peticin.
Mensajes enviados cuando cambia algn coste. Se enva toda la tabla de
routing.

* RIPv1, al igual que sus antecesores propietarios es un protocolo de routing


que fue diseado para funcionar como protocolo vector distancia. RIPv1 fue
diseado para funcionar en redes pequeas de pasarela interior. RIPv1 est
basado segn el autor del RFC en la versin 4.3 de la distribucin de UNIX de
Berkeley.

*RIPv2 establece una serie de mejoras muy importantes con su antecesor que
son las siguientes:

Autenticacin para la transmisin de informacin de RIP entre vecinos.

Utilizacin de mscaras de red, con lo que ya es posible utilizar VLSM.

Utilizacin de mscaras de red en la eleccin del siguiente salto, lo cual nos


puede permitir

La utilizacin de arquitecturas de red discontinuas.

Envo de actualizaciones de tablas de RIP mediante la direccin de


multicast 224.0.0.9.

Inclusin de RIPv2 en los bloques de informacin de gestin (MIB).

Sintaxis de configuracin es:

router(config)#router rip
router(config-router)#network a.a.a.a
router(config-router)#network b.b.b.b
router(config-router)#network c.c.c.c

Ejemplo:
Tomando como base la siguiente Maqueta

Configuracin bsica de los dispositivos.


R1:
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#clock rate 56000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R2:
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 2/0


R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 3/0


R2(config-if)#ip address 192.168.4.1 255.255.255.0
R2(config-if)#clock rate 56000
R2(config-if)#no shutdown
R2(config-if)#exit

R3:
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 192.168.5.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial 2/0
R3(config-if)#ip address 192.168.4.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config-if)#
CONFIGURACIN DEL PROTOCOLO RIP
Para el router R1
R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#exit
R1(config)#
Para el router R2
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#exit
R2(config)#
Para el router R3
R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.0
R3(config-router)#exit
R3(config)#