You are on page 1of 3

Cómo Buscar a partir de dos variables en Excel

Una de las consultas que con más frecuencia suelo recibir es cómo realizar búsquedas en una tabla de datos
simple empleando dos criterios. La verdad es que también he notado que esta es una consulta muy frecuente
en foros y otras fuentes e inglés, pero en español existe poco material al respecto, así que en este artículo
detallaré como podemos hacer este tipo de búsquedas, de un forma rápida y fácil.
Supongamos que tenemos como punto de inicio una tabla de datos organizada como la de la figura adjunta,
es decir una tabla no organizada como una base de datos sino cómo un sumario de datos por categorías. La
primera fila y la primera columna describen el contenido de cada fila y columna respectivamente. Nuestro
objetivo será conocer cuál es el valor intersección entre dos variables, por ejemplo, cuál es el valor de
alcanzado en Julio en América.

Para conocer el valor intersección de dos variables emplearemos la función Excel ÍNDICE para localizar entre
el área de datos la fila y columna de nuestro interés. Para conocer cuál es la fila y columna de nuestro interés
emplearemos la función Excel COINCIDIR.
En la celda donde deseemos realizar nuestra búsqueda aplicaremos la siguiente fórmula:

Fórmula para Buscar a partir de dos Variables
=INDICE(Rango_donde_se_hará_la_búsqueda;
COINCIDIR(Valor_Columna_a_Buscar;Rango_Primera_Columna;0);
COINCIDIR(Valor_Fila_a_Buscar;Rango_Primera_Fila;0))
En esta fórmula:

Rango_donde_se hará_la_búsqueda, es igual al rango donde deseamos realizar nuestra búsqueda a

partir de dos variables, excluyendo la primera fila y la primera columna que empleamos para identificar
nuestros datos.
Valor_Columna_a_Buscar, es la variable que deseamos buscar en una columna específica. Puede

ser una referencia a una celda, un valor numérico o de texto
Rango_Primera_Columna, es el rango donde se encuentra la columna que etiqueta nuestros datos.

tal como la zona sombreada en verde en la imagen anexa.COINCIDIR(“Julio”.0)) Donde: El Rango_donde_se hará_la_búsqueda. tal como la zona sombreada en verde en la imagen anexa.0). Puede ser una referencia a una celda. El Valor_Columna_a_buscar. En nuestro ejemplo práctico la fórmula aplicada fue: =INDICE($B$2:$F$13. es el rango donde se encuentra la fila que etiqueta nuestros datos. es igual al rango $B$2:$F$13. en nuestro caso es igual al rango $A$2:$A$13. es la variable que deseamos buscar en una fila específica. un valor numérico o de texto Rango_Primera_Fila. es el valor de texto “Julio”. . conforme la Primera_Columna.  Valor_Fila_a_Buscar.COINCIDIR(“América”.$A$2:$A$13.$B$1:$F$1.

en nuestro caso es igual al rango $B$1:$F$1. Una vez aplicada esta fórmula podremos realizar búsquedas de dos variables en Excel con tan solo cambiar los argumentos de los valores de fila y columna a buscar. .El Valor_Fila_a_buscar. ¿Es muy sencillo aplicarlo verdad? De cualquier forma no dudes en comentar este artículo si te queda alguna duda o deseas compartir otro método que conozcas para buscar a partir de dos variables en Excel. conforme el Rango_Primera_Fila. tal como la zona sombreada en verde en la imagen anexa. es el valor de texto “América”.