You are on page 1of 61

MTC

2001/2002

Frmulas e Funes
Frmulas
MS EXCEL - Frmulas e Funes

Operadores e regras de prioridade; Tipos de Valores; Referncias a clulas

Funes Pr-definidas
Sintaxe da funo; Funes aninhadas ou embricadas; O Assistente de Funes

Exemplos com algumas das Funes bsicas mais utilizadas


SOMA, SOMA.SE, SOMARPRODUTO, ARRED, CONTAR, CONTAR.SE,
MXIMO, MAIOR, MDIA, E, OU, NO, SE

Frmulas Matriciais
As vrias categorias de Funes
Matemtica, Lgica, Data e Hora, Estatstica, Texto, Financeiras, Informao,
Consulta e Referncia, Base de Dados
Pg.

Referenciar clulas atravs de NOMES e Rtulos

MTC
2001/2002

Frmulas
Frmulas

Uma Frmula uma sequncia de valores, operadores, referncias a clulas


MS EXCEL - Frmulas e Funes

e funes pr-definidas. Esta sequncia est contida numa clula e produz um valor.
Todo e qualquer valor pertence a um tipo (tipo de dados).
Construo de Frmulas:
1. Uma frmula sempre iniciada pelo caracter =
2. Dispomos de um conjunto de operadores e respectivas regras de prioridade
3. Podemos utilizar valores constantes dos tipos: Texto; Numrico; Data; Hora; Lgico
4. Utilizamos REFERNCIAS a clulas
5. Utilizamos FUNES pr-definidas

Pg.

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

1. Os operadores disponveis

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

2. O clculo de frmulas => Regras de prioridade

MTC
2001/2002

3. Tipos de valores

MS EXCEL - Frmulas e Funes


Pg.

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

3.1. Os valores de erro

MTC
2001/2002

3.2. Valores constantes em frmulas

MS EXCEL - Frmulas e Funes


Pg.

MTC
2001/2002

4. Referncias a clulas
Numa frmula de uma folha de clculo, uma Referncia identifica:
- uma clula ou um intervalo de clulas

MS EXCEL - Frmulas e Funes

- esta(s) clula(s) esto numa folha de clculo ou em vrias folhas de clculo (3D)
- estas folhas de clculo por sua vez podem pertencer ao mesmo livro de trabalho
da frmula ou a um outro livro de trabalho que no contenha a frmula (externa)

Estilo

10

Localizao

A1

Relativa

Interna (mesmo livro):

L1C1

Absoluta

nomes

Mista

- mesma folha
- outra folha

rtulos

Pg.

Tipo

Externa

At agora temos utilizado referncias a clulas da mesma folha


onde se localiza a frmula

MTC
2001/2002

4.1. Estilo da referncia

MS EXCEL - Frmulas e Funes


Pg.

11

MTC
2001/2002

4.2. Referncias a clulas de outras folhas do mesmo Livro

absoluta

relativa / absoluta / mista

MS EXCEL - Frmulas e Funes

Nome da Folha!Referncia da Clula(s)

Exemplos:
=Folha4!A1

=Folha4!$A$1

=SOMA(Folha4!A1:B10)

=Folha4!$A1

=Folha4!A$1

=SOMA(Folha4!$A$1:$B$10)

=A3+B5+5+SOMA(Folha4!A1:B10)
=Folha num2!A1
Pg.

12

o nome da folha caso tenha espaos em branco


tem de estar entre (aspas)

MTC
2001/2002

4.3. Referncias a clulas de outras folhas de outro Livro - Referncia Externa

absoluta

relativa / absoluta / mista

MS EXCEL - Frmulas e Funes

Localizao do Ficheiro[Nome do Livro]Nome da Folha!Referncia da Clula

Exemplos:
='[Frmulas e funes.xls]Estilos de referncia'!$A$10
='C:\Temp\[Frmulas e funes.xls]Estilos de referncia'!$A$10

Pg.

13

MTC
2001/2002

Quando um livro contm referncias externas,


coloca-se a questo de saber o que acontece quando:
- o livro (externo) que contm a informao necessria est fechado
MS EXCEL - Frmulas e Funes
Pg.

14

- a informao externa foi entretanto alterada


O Excel detecta ao abrir um livro quando este contm ligaes externas.
Nesse caso pergunta se se pretende actualizar essas ligaes, ou seja,
resolver as duas questes anteriores.

MTC
2001/2002

4.4. Referncias 3-D e construo de Referncias de forma rpida e segura


Referenciar em simultneo reas de vrias folhas.
Estas reas tm de ter as mesmas referncias.

Equivale a referenciar uma


MATRIZ a TRS DIMENSES

MS EXCEL - Frmulas e Funes

Nome da Folha:Nome da Folha!Referncia da Clula(s)

absoluta

relativa / absoluta / mista

Exemplos: =SOMA(Folha3:Folha8!A1:B12)
Construo de Referncias

Mtodo 1: Rato
Quando estamos a editar uma frmula, as aces com o rato so
interpretadas nesse contexto, pelo que, ao fazer clique sobre uma
clula, o seu endereo ir aparecer na frmula
Mtodo 2: Colar especial => Colar ligao
Pg.

Exemplo de construo de uma frmula com referncias externas

15

MTC
2001/2002

Funes
Funes Pr-definidas
Pr-definidas
O Excel possui um conjunto vasto de funes incorporadas.
Uma funo uma frmula pr-definida ou incorporada no Excel,

MS EXCEL - Frmulas e Funes

que permite executar clculos complexos de forma simplificada (reutilizao).


A sintaxe de uma funo, define a forma como esta deve ser utilizada.
Uma funo apenas pode ser utilizada em frmulas
Entidades da funo:
Argumentos - valores sobre os quais a funo efectua as operaes
e cujo tipo esperado especificado pela funo
Resultado - valor que a funo origina (retorna), aps o clculo das operaes a que
corresponde, mediante os valores dos parmetros associados

Pg.

16

Sintaxe - a regra gramatical que define a sua utilizao


(i.e., descrio textual de como invocar a funo)

MTC
2001/2002

1. Sintaxe da Funo

Nome_da_Funo(Argumento1;Argumento2;...)

MS EXCEL - Frmulas e Funes

- os argumentos (operandos) so separados por ; ou , (dependendo da configurao do s.o.)


e podem ser obrigatrios ou opcionais
- a ordem dos argumentos tem de ser respeitada aquando da sua utilizao
- os tipos de argumentos so:
- valor constante
- endereo de clula
- endereo de regio de clulas
- nome de clula/clulas
- texto ( colocado entre aspas )
- outras funes (funes aninhadas, i.e., funes dentro de funes)

Pg.

17

MTC
2001/2002

Exemplo: Funo Round


Sistema de ajuda para a funo

MS EXCEL - Frmulas e Funes


Pg.

18

MTC
2001/2002

2. Funes embutidas ou encastrada

=> diz-se que uma funo se encontra embutida (aninhada), quando utilizada
como argumento (operando) de outra funo
MS EXCEL - Frmulas e Funes

Exemplo:

=SOMA(2;3;4;A1:B7;A9)

O Excel suporta at
SETE nveis de ANINHAMENTO

d o mesmo resultado de

=SOMA(2;SOMA(3;4);SOMA(A1:B7);A9)
1 nvel de aninhamento

=SOMA(2;SOMA(SOMA(3;4);SOMA(A1:B7));A9)
2 nveis de aninhamento
Pg.

19

MTC
2001/2002

3. Utilizao do Assistente de Funes

As funes podem ser digitadas:


- directamente na folha de clculo
MS EXCEL - Frmulas e Funes

- ou atravs do Assistente de Funes que d acesso listagem das funes,


ajudando tambm a construir a invocao da funo
Assistente de Funes
=> d acesso listagem das funes disponveis
=> e ajuda a construir a invocao da funo seleccionada

Abertura do Assistente de Funes


Pg.

20

MTC
2001/2002

3.1. Invocao de funo


Exemplo: em B1 construir a frmula

=ARRED(A1;2)

Passo1:
Passo1: Activao
Activaodo
doAssistente
Assistenteeeescolha
escolhada
dafuno
funo(ARRED)
(ARRED)
MS EXCEL - Frmulas e Funes

Descrio
da funo

Pg.

21

MTC
2001/2002

Passo2:
Passo2: Invocao
Invocaoda
daFuno
Funo

MS EXCEL - Frmulas e Funes


Pg.

22

Sistema de ajuda
acerca da funo

RESULTADO
FINAL

MTC
2001/2002

3.2. Alterar a invocao de funo


Ao activar o Assistente de Funes
se a clula activa contiver a invocao de uma funo

MS EXCEL - Frmulas e Funes

o Assistente de Funes aberto em MODO de EDIO

Pg.

23

MTC
2001/2002

3.3. Invocao de funo aninhada

Exemplo: em B1 construir a frmula

=ARRED(MXIMO(A1:A10);2)
funo aninhada

MS EXCEL - Frmulas e Funes


Pg.

24

Passo1:
Passo1: Invocar
InvocaraaFuno
FunoARRED
ARRED

Introduzir todos
os argumentos
com excepo
da funo aninhada

MTC
2001/2002

Passo2:
Passo2: Invocar
InvocaraaFuno
FunoMXIMO
MXIMOcomo
comoargumento
argumentoda
dafuno
funoARRED
ARRED

MS EXCEL - Frmulas e Funes

Na Caixa de Nomes
escolher a
funo a aninhar

activado o Assistente
sobre a funo seleccionada

Pg.

25

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

26

Exemplos
Exemplos com
com algumas
algumas das
das
Funes
Funes bsicas
bsicas mais
mais utilizadas
utilizadas

28

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

27

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

30

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

29

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

32

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

31

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

34

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

33

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

36

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

35

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

38

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

37

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

40

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

39

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

42

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

41

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

43

MTC
2001/2002

1. Exemplos de utilizao de Funes Lgicas: SE, E e OU


Verificar se o valor contido na clula A1 pertence ao intervalo [10,20]

=E(A1>=10;A1<=20)
MS EXCEL - Frmulas e Funes

Verificar se o valor contido na clula A1 pertence ao intervalo [10,20] ou ao intervalo [30,40]

=OU(E(A1>=10;A1<=20);E(A1>=30;A1<=40))

Se o valor contido na clula A1 pertence intervalo [10,20],


ento retornar esse valor, seno retornar 0 (zero)

=SE(E(A1>=10;A1<=20);A1;0)
=SE(A1>=10;SE(A1<=20;A1;0);0)

Pg.

44

MTC
2001/2002

2. Exemplo de utilizao das Funes SE, SOMA, MDIA, MXIMO e MNIMO

MS EXCEL - Frmulas e Funes


Pg.

45

SE horas em deslocao for maior ou igual a 8 ENTO Alojamento = 7.500 SENO Alojamento = 0

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

46

SE horas em deslocao for maior ou igual a 8


ENTO Alojamento = 7.500 SENO Alojamento = 0

=SE(G10>=$I$7;$D$7;0)

=SOMA(E10:E16)

=MDIA(E10:E16)

=MNIMO(E10:E16)

=MXIMO(E10:E16)

MTC
2001/2002

3. Exemplo de utilizao da Funo SE

MS EXCEL - Frmulas e Funes


Pg.

47

MTC
2001/2002

MS EXCEL - Frmulas e Funes

=G14*1,5*$C$5+SE(G14>2;(G14-2)*0,5*$C$5;0)
=SE(E14>=$I$7;$E$7;0)
Pg.

48

=SE((E14-$I$7)>0;E14-$I$7;0)

MTC
2001/2002

5. Exemplo de utilizao das Funes: SE, OU, E, CONTAR, CONTAR.SE, SOMA.SE

MS EXCEL - Frmulas e Funes


Pg.

49

MTC
2001/2002

MS EXCEL - Frmulas e Funes

=SE(B7="Ord";
SE(E7>0,3*$D$4;"Reprovado";SE(F7<9,5;"Exame";ARRED(F7;0)));
SE(F7<9,5;"Exame";ARRED(F7;0)))

=SE(OU(B7="TE";B7="DA;B7=MI);
SE(F7<9,5;"Exame";ARRED(F7;0));
SE(E7>0,3*$D$4;"Reprovado";SE(F7<9,5;"Exame";ARRED(F7;0))))

Pg.

50

=SE(E(B7="Ord";E7>0,3*$D$4);
"Reprovado";
SE(F7<9,5;"Exame";ARRED(F7;0)))

MTC
2001/2002

=> Funes CONTAR e CONTAR.SE


Contagem do nmero de alunos que esto Reprovados

=CONTAR.SE($G$7:$G$19;$I7)
MS EXCEL - Frmulas e Funes

Contagem do nmero de alunos que vo a Exame

=CONTAR.SE($G$7:$G$19;$I8)
Contagem do nmero de alunos que esto Reprovados

=CONTAR($G$7:$G$19)
=> Funo MDIA
Mdia do nmero de Faltas =MDIA($E$7:$E$19)
Mdia do valor das Notas

=MDIA($F$7:$F$19)

Obs: os alunos que no tm nota no so considerados

Mdia do valor das Notas Finais


=MDIA($G$7:$G$19)
Obs: no so considerados os alunos Reprovados e

Pg.

51

os que vo a exame

MTC
2001/2002

=> Funes SOMA.SE e CONTAR.SE

Mdias
Mdiasdas
dasclulas
clulasque
quesatisfazem
satisfazem
um
determinado
um determinadocritrio
critrio
dentro
dentrode
deum
umintervalo
intervalode
declulas
clulas

MS EXCEL - Frmulas e Funes

Mdia =

soma dos valores


nmero de elementos

Mdia do nmero de Faltas dos alunos com regime Ord

=SOMA.SE($B$7:$B$19;$I17;$E$7:$E$19)/CONTAR.SE($B$7:$B$19;$I17)
Mdia do valor das Notas dos alunos com regime Ord

=SOMA.SE($B$7:$B$19;$I17;$F$7:$F$19)/CONTAR.SE($B$7:$B$19;$I17)

Pg.

52

Obs: os alunos que no tm nota, so considerados no clculo da mdia como tendo a nota 0
=> so contabilizados pela funo CONTAR.SE

MTC
2001/2002

5. Critrios complexos nas Funes CONTAR.SE, SOMA.SE

CONTAR.SE(intervalo;critrio)
CONTAR.SE(intervalo;critrio)
MS EXCEL - Frmulas e Funes

d como resultado
o nmero de clulas em intervalo
que obedecem ao critrio especificado
critrio
critriopode
podeser
serexpresso:
expresso:
A1
=>
A1
=>igual
igualao
aocontedo
contedoda
daclula
clulaA1
A1
32
=>
igual
ao
valor
32
32
=> igual ao valor 32
32
32
=>
=>igual
igualao
aovalor
valor32
32
>32
>32
=>
=>maior
maiorque
queoovalor
valor32
32
>=32
>=32 =>
=>maior
maiorou
ouigual
igualao
aovalor
valor32
32
<>32
<>32 =>
=>diferente
diferentedo
dovalor
valor32
32
Ord
Ord
=>
=>igual
igualao
aotexto
textoOrd
Ord
<>Ord
=>
diferente
<>Ord => diferentedo
doao
aotexto
textoOrd
Ord

Pg.

53

MTC
2001/2002

=CONTAR.SE($B$4:$B$17;"Ord")
=CONTAR.SE($E$4:$E$17;"Reprovado")
=CONTAR.SE($E$4:$E$17;">0)
MS EXCEL - Frmulas e Funes

=CONTAR.SE($E$4:$E$17;"Reprovado")+CONTAR.SE($E$4:$E$17;"Exame")

=CONTAR.SE($E$4:$E$17;10)
=CONTAR.SE($E$4:$E$17;">=12")
=CONTAR.SE($E$4:$E$17;">10")-CONTAR.SE($E$4:$E$17;">15")

Limitaes
Limitaes
Pg.

54

no possvel fazer clculos do tipo:

- Nmero de alunos do regime ORD e Reprovados


- Nmero de alunos Reprovados mas que tinham Nota >= 9,5

Frmulas
Frmulas
Matriciais
Matriciais

MTC
2001/2002

Frmulas
Frmulas Matriciais
Matriciais
So Frmulas que efectuam clculos mltiplos e devolvem um ou mltiplos resultados.

MS EXCEL - Frmulas e Funes

Vamos trabalhar com

=> Frmulas Matriciais que devolvem um nico resultado

{=SOMA(SE(B4:B6>0;E4:E6;0))}

=> os intervalos de clulas (Matrizes)


que fazem parte da Frmula,
tm de ter todos a mesma dimenso
B4:B6 e E4:E6 tm a mesma dimenso

igual a

=SOMA(SE(B4>0;E4;0);SE(B5>0;E5;0);SE(B6>0;E6;0))

Pg.

55

MTC
2001/2002

=> Frmulas Matriciais para o exemplo em anlise

MS EXCEL - Frmulas e Funes

{=SOMA(SE(B4:B17="Ord";SE(E4:E17="Reprovado";1;0);0))}

{=SOMA(SE(B4:B17="Ord";SE(E4:E17="Reprovado";C4:C17;0);0))}
=> Introduzir uma Frmula de Matriz
1. introduzir a frmula sem as chavetas { }
2. em vez de terminar a edio da frmula (tecla Enter), premir a
sequncia de teclas CTRL+SHIFT+ENTER

=> Transformar uma Frmula Normal numa Frmula de Matriz


Pg.

56

1. activar modo de edio da Frmula (tecla F2)


2. premir a sequncia de teclas CTRL+SHIFT+ENTER

MTC
2001/2002

As
As vrias
vrias categorias
categorias de
de Funes
Funes

Funes de Matemtica e Trigonometria


MS EXCEL - Frmulas e Funes

Funes de Lgica
Funes de Data e Hora
Funes de Engenharia
Funes de Estatstica
Funes de Texto
Funes Financeiras
Funes de Informao
Funes de Consulta e Referncia
Funes de Base de Dados
Funes definidas pelo Utilizador

Pg.

57

MTC
2001/2002

0. Suplementos: Ferramentas de Anlise

MS EXCEL - Frmulas e Funes

Suplementos so programas que adicionam comandos e funes opcionais ao Excel.


Um suplemento para poder ser utilizado, tem primeiro de ser instalado no computador e, em
seguida, carregado no Excel.
Por defeito, os suplementos (ficheiros *.xla) so instalados na pasta Biblioteca da pasta do Excel.
O carregamento de um determinado suplemento disponibiliza essa funo no Excel e adiciona
todos os comandos associados aos menus apropriados (normalmente ao Menu Ferramentas).
Pg.

58

60

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

59

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

61

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

62

1. Funes de Matemtica e Trigonometria

MTC
2001/2002

=ARRED.EXCESSO(A4;5000)
=ARRED(A4;-4)

MS EXCEL - Frmulas e Funes


Pg.

63

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

64

=ARRED(A4;-3)

=ARRED.PARA.BAIXO(A4;0)

66

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

65

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

68

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

67

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

69

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

70

2. Funes de Data e Hora

MTC
2001/2002

3. Funes de Texto

MS EXCEL - Frmulas e Funes


Pg.

71

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

72

4. Funes de Estatstica

74

MS EXCEL - Frmulas e Funes

Pg.

MTC

2001/2002

73

Pg.

MTC

2001/2002

MS EXCEL - Frmulas e Funes

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

75

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

76

5. Funes de Informao

MTC
2001/2002

6. Funes de Procura e Referncia


Quando necessrio localizar valores em listas ou tabelas
ou quando necessrio localizar a referncia de uma clula.

MS EXCEL - Frmulas e Funes


Pg.

77

MTC
2001/2002

6.1. PROCH
Localiza um valor especfico na linha superior de uma matriz e devolve o valor na clula indicada.
PROCH(valor_procurado; matriz_tabela; nm_ndice_lin; localiza_intervalo)

MS EXCEL - Frmulas e Funes

Valor_procurado o valor a ser localizado na primeira linha da tabela.


Matriz_tabela uma tabela de informaes (intervalo de clulas) onde os dados devem ser procurados.
Textos com maisculas ou minsculas so equivalentes.
Nm_ndice_lin o nmero da linha em matriz_tabela de onde o valor correspondente deve ser retirado.
Localiza_intervalo um valor lgico que especifica se localizada uma correspondncia exacta ou aproximada.
Se FALSO, PROCH localizar uma correspondncia exacta.
Se nenhuma correspondncia for encontrada, devolver o valor de erro #N/D.
Se VERDADEIRO ou omitido, devolve uma correspondncia aproximada;
Se uma correspondncia exacta no for encontrada, devolver o maior valor seguinte
que seja menor que o valor_procurado.
Ateno:
Se localiza_intervalo for VERDADEIRO, os valores na primeira linha de matriz_tabela devero ser colocados
em ordem ascendente, seno, PROCH pode no devolver o valor correcto.
Se localiza_intervalo for FALSO, os valores na primeira coluna de matriz_tabela no precisaro ser ordenados

Pg.

78

MTC
2001/2002

Aps introduzir o nome do vendedor e o respectivo valor das vendas,


a classificao, a comisso e o valor da comisso so calculados automaticamente
em funo dos dados da tabela de parmetros

MS EXCEL - Frmulas e Funes

=C11*D11

Pg.

=PROCH($B11;$B$2:$F$4;2;VERDADEIRO)

=PROCH($B11;$B$2:$F$4;3;VERDADEIRO)

79

MTC
2001/2002

6.2. PROCV
Localiza um valor na 1 coluna esquerda de uma matriz, e devolve o valor na clula indicada.
Utilizar PROCV quando os valores da comparao estiverem numa coluna esquerda ou direita dos dados a procurar

PROCV(valor_procurado; matriz_tabela; nm_ndice_col; localiza_intervalo)


MS EXCEL - Frmulas e Funes
Pg.

80

Valor_procurado o valor a ser localizado na primeira coluna da tabela.


Matriz_tabela uma tabela de informaes (intervalo de clulas) onde os dados devem ser procurados.
Textos com maisculas ou minsculas so equivalentes.
Nm_ndice_col o nmero da coluna em matriz_tabela de onde o valor correspondente deve ser retirado.
Localiza_intervalo um valor lgico que especifica se localizada uma correspondncia exacta ou aproximada.
Se FALSO, PROCH localizar uma correspondncia exacta.
Se nenhuma correspondncia for encontrada, devolver o valor de erro #N/D.
Se VERDADEIRO ou omitido, devolve uma correspondncia aproximada;
Se uma correspondncia exacta no for encontrada, devolver o maior valor seguinte
que seja menor que o valor_procurado.
Ateno:
Se localiza_intervalo for VERDADEIRO, os valores na primeira coluna de matriz_tabela devero ser colocados
em ordem ascendente, seno, PROCV pode no devolver o valor correcto.
Se localiza_intervalo for FALSO, os valores na primeira coluna de matriz_tabela no precisaro ser ordenados

MTC
2001/2002

6.3. INDICE
Devolve a referncia da clula na interseco da linha e coluna especificadas.
NDICE(ref; nm_linha; nm_coluna; nm_rea)

MS EXCEL - Frmulas e Funes

Ref uma referncia a um ou mais intervalos de clula.


Se estiver a introduzir uma seleco no adjacente para ref, coloque ref entre parnteses.
Nm_linha o nmero da linha em ref a partir da qual ser fornecida uma referncia.
Nm_coluna o nmero da coluna em ref a partir da qual ser fornecida uma referncia.
Nm_rea selecciona um intervalo em ref a partir do qual deve ser fornecida a interseco de nm_linha com
nm_coluna. A primeira rea seleccionada tem o nmero 1, a segunda o nmero 2,...
Se nm_rea for omitido, NDICE utilizar a rea 1.

Pg.

81

MTC
2001/2002

6.4. CORRESP
Devolve a posio relativa de um elemento numa matriz que coincide com um valor especificado
na forma especificada.
Utilize CORRESP em vez de uma das funes PROC quando precisar da posio de um item correspondente
em vez do item propriamente dito.

MS EXCEL - Frmulas e Funes


Pg.

82

CORRESP(valor_procurado; matriz_procurada; tipo_correspondncia)


Valor_procurado o valor utilizado para localizar o valor desejado numa tabela.
Matriz_procurada um intervalo contguo de clulas que contm valores possveis de procura.
Tipo_correspondncia o nmero -1, 0 ou 1. Tipo_correspondncia especifica como o Excel corresponde o
valor_procurado com os valores contidos em matriz_procurada. Se tipo_correspondncia for:
1, CORRESP procurar o maior valor que for menor ou igual a valor_procurado.
Matriz_procurada deve ser posicionada por ordem ascendente
0, CORRESP procurar o primeiro valor que for exactamente igual a valor_procurado.
Matriz_procurada pode ser colocada em qualquer ordem.
-1, CORRESP procurar o menor valor que for maior ou igual a valor_procurado.
Matriz_procurada deve ser posicionada em ordem descendente:
VERDADEIRO, FALSO, Z-A,...2, 1, 0, -1, -2,... e assim por diante.
omitido, ser equivalente a 1.

MTC
2001/2002

6.5. Exemplo com PROCV, NDICE e CORRESP

MS EXCEL - Frmulas e Funes

O nome do vendedor
introduzido e as vendas
desse vendedor surgem
automaticamente para
cada modelo.

=PROCV($A$12;$A$3:$E$7;2;0)

=PROCV($A$12;$A$3:$E$7;5;0)

Pg.

83

MTC
2001/2002

Para cada modelo, calcular o


nome do melhor vendedor
desse modelo
MS EXCEL - Frmulas e Funes

=NDICE($A$3:$A$7;CORRESP(MXIMO($B$3:$B$7);$B$3:$B$7;0))

=NDICE($A$3:$A$7;CORRESP(MXIMO($E$3:$E$7);$E$3:$E$7;0))

Pg.

84

MTC
2001/2002

6.6. PROC
Um vector uma matriz que contm apenas uma linha ou uma coluna.

Procura um valor num vector, move-se para a posio correspondente num segundo vector,
e devolve este valor.
Utilize PROC quando desejar especificar o intervalo que contenha os valores que se deseja corresponder.
MS EXCEL - Frmulas e Funes

PROC(valor_procurado; vector_proc; vector_result)


Valor_procurado o valor que PROC procura no primeiro vector.
Vector_proc o intervalo que contm apenas uma linha ou coluna.
Os valores em vector_proc tm de estar por ordem ascendente: ...,-2, -1, 0, 1, 2, ..., A-Z,
caso contrrio, PROC pode no devolver o valor correcto.
Textos em maisculas e minsculas so equivalentes.
Vector_result um intervalo que contm uma linha ou coluna. Tem de ter o mesmo tamanho de vector_proc.
Se PROC no localizar o valor_procurado, ele corresponder ao maior valor em vector_proc que seja
menor ou igual a valor_procurado.
Se valor_procurado for menor que o menor valor em vector_proc, PROC devolver o valor de erro #N/D.

Pg.

85

MTC
2001/2002

7. Funes de gesto de listas e bases de dados


Tabela de Dados = Registos (linhas) x Campos (colunas)

MS EXCEL - Frmulas e Funes


Pg.

86

Sero analisadas
posteriormente

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

87

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

88

8. Funes Financeiras => Clculo Financeiro

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

89

MTC
2001/2002

MS EXCEL - Frmulas e Funes

=AMORT(B4;D4;C4)

=EFECTIVA(A10;B10)

=NOMINAL(A15;B15)
Pg.

90

MTC
2001/2002

PGTO(taxa;nper;pv;fv;tipo)
Taxa a taxa de juro por perodo.

Devolve o pagamento peridico de uma anuidade de


acordo com pagamentos constantes e com uma
taxa de juro constante.

Nper o nmero total de perodos de pagamento de uma anuidade.


Pgto o pagamento feito a cada perodo e no pode mudar durante a vigncia da anuidade.
MS EXCEL - Frmulas e Funes

Vf

o valor futuro ou um saldo de caixa, que deseja obter depois do ltimo pagamento.
Se vf for omitido, ser considerado 0

Tipo o nmero 0 ou 1 e indica as datas de vencimento dos pagamentos.


1=>No incio do perodo

0 ou omitido=>No final do perodo

Exemplo:
Emprstimo para um carro com uma taxa de juro de 10% ao ano com pagamentos mensais,
A taxa de juro mensal ser 10%/12 ou 0,83%.
Na frmula Taxa= 10%/12 ou 0,83% ou 0,0083
Exemplo:
Emprstimo de quatro anos com pagamentos mensais. O emprstimo ter 4*12 (ou 48) perodos
Na frmula Nper= 4*12 ou 48

Pg.

91

Exemplo:
Os pagamentos mensais por um emprstimo para o carro de 10.000$00 de quatro anos a 12%
so 263$33. Na frmula Pgto = -263,33

MTC
2001/2002

MS EXCEL - Frmulas e Funes


Pg.

92

=PGTO(C24/12;B24*12;-A24;0;0)

MTC
2001/2002

MS EXCEL - Frmulas e Funes

=PGTOCAPACUM($C33/12;$B33*12;$A33;1;1;0)
=PGTOJURACUM($C33/12;$B33*12;$A33;1;1;0)

Pg.

93

MTC
2001/2002

MS EXCEL - Frmulas e Funes

=PGTOCAPACUM($C$40/12;$B$40*12;$A$40;1;D43*12;0)
=PGTOJURACUM($C$40/12;$B$40*12;$A$40;1;D43*12;0)

Pg.

94

MTC
2001/2002

Referenciar
Referenciar clulas
clulas atravs
atravs de
de
NOMES
NOMES

MS EXCEL - Frmulas e Funes

Clulas ou conjuntos de clulas (intervalos) podem ser


referenciados numa frmula atravs de nomes ou atravs de rtulos.
Objectivo: Tornar a construo, leitura e compreenso de frmulas mais fcil

Pg.

95

MTC
2001/2002

1. Rtulos
As folhas de clculo tm frequentemente Rtulos no TOPO de cada COLUNA
e ESQUERDA de cada LINHA, descrevendo os dados que a folha de clculo contm.
Estes rtulos:

MS EXCEL - Frmulas e Funes

- ficam disponveis automaticamente (no necessitam de ser criados), para


- serem utilizados em frmulas da mesma FC para referenciar clulas e intervalos de clulas

Neste exemplo os rtulos e os intervalos que representam so (em princpio):


Janeiro=C3:C7 Fevereiro=D3:D7 Maro=E3:E7 ..... Junho=H3:H7
gua=C3:H3 ou gua=B4:B7 Electricidade=C4:H4 ..... Total=C7:H7
Pg.

96

Gastos=B3:B7

MTC
2001/2002

1.1. Exemplos com Frmulas que utilizam rtulos

MS EXCEL - Frmulas e Funes

Obs: o espao o operador de interseco


entre intervalos de clulas

Pg.

97

MTC
2001/2002

2. Nomes
Os nomes so uma forma alternativa aos rtulos
para referenciar conjuntos de clulas utilizando identificadores.

MS EXCEL - Frmulas e Funes

Os rtulos no necessitam de ser criados (j se encontram disponveis),


apenas tm de ser usados na folha de clculo onde esto definidos.

Os nomes, ao contrrio dos rtulos, tm de ser criados para poderem ser utilizados.
Os nomes so no entanto muito mais versteis que os rtulos.
No esto limitados uma folha de clculo.

Regras para criar nomes:


- os nomes tm uma dimenso mxima de 255 caracteres podendo conter
letras, nmeros, pontos e caracteres de sublinhado
- os nomes tm de comear por uma letra ou pelo caracter _ (sublinhado)
- os nomes no podem ter espaos nem vrgulas nem podem ser idnticos a referncias de clulas
- os nomes podem ter letras maisculas e minsculas.

Pg.

98

Nos nomes, o Excel no faz distino entre caracteres maisculos e minsculos

MTC
2001/2002

Vantagens na Utilizao de Nomes:


Os nomes substituem as referncias das clulas em qualquer situao,
quer na construo de frmulas quer em caixas de dilogo;
MS EXCEL - Frmulas e Funes

A utilizao de nomes na construo de frmulas,


torna as frmulas mais simples e perceptveis para o utilizador;
Caso se altere a estrutura da Folha de Clculo, basta alterar a referncia associada a um nome
para que todas as frmulas que utilizam o nome sejam automaticamente actualizadas;
O Excel 97 pode criar nomes, automaticamente, em funo dos ttulos (rtulos)
das linhas e das colunas das tabelas presentes na Folha de Clculo.
Os nomes podem ainda ser definidos pelo utilizador.
Aps ter sido definido um nome, o Excel pode substituir automaticamente em todas as
frmulas das folhas de clculo do livro, as referncias s clulas referenciadas pelo nome
pelo prprio nome.

Pg.

99

MTC
2001/2002

2.1. Exemplos demonstrativos das vantagens na utilizao de nomes

Exemplo 1: Aplicao de diferentes escales do IVA


MS EXCEL - Frmulas e Funes

Problema: Alteraes nos valores dos escales do IVA


obrigam alterao de todas as frmulas
que calculam o Custo Total
Pg.

100

MTC
2001/2002

Soluo 1: os valores dos escales do IVA so constantes contidas em clulas

MS EXCEL - Frmulas e Funes

os escales do IVA so colocados numa Folha


passando assim a ser globais ao livro.

Pg.

101

Resolve o problema de ao ter vrias facturas num mesmo livro,


se houver alterao nos valores dos escales,
estas sero facilmente localizadas e realizadas.

Com esta soluo, se houver alteraes nos valores dos escales do IVA,
no so necessrias alteraes s frmulas que calculam o Custo Total

MTC
2001/2002

Soluo 2: utilizando nomes


Os nomes definidos, referenciam as clulas que
contm os valores dos escales do IVA
MS EXCEL - Frmulas e Funes
Pg.

102

Com esta soluo, as frmulas passam a ser mais legveis

MTC
2001/2002

Exemplo 2: Pagamentos semanais de Horas Extra e Sub. Refeio

MS EXCEL - Frmulas e Funes

Nomes definidos
que referenciam
os parmetros globais
Pg.

103

MTC
2001/2002

Soluo 1: no utilizando nomes

MS EXCEL - Frmulas e Funes

=SE(E6>=Ex2.1!$B$9;Ex2.1!$B$7;0)
=SE(E6>=Ex2.1!$B$9;E6-Ex2.1!$B$9;0)
=G6*1,5*Ex2.1!$B$5+SE(G6>2;(G6-2)*0,5*Ex2.1!$B$5;0)
Pg.

104

=(E6-G6)*Ex2.1!$B$5+H6+F6

MTC

Com esta soluo, as


frmulas so mais legveis

2001/2002

Soluo 2: utilizando nomes

MS EXCEL - Frmulas e Funes

=SE(E6>=horrio_completo;valor_SR;0)
=SE(E6>=horrio_completo;E6-horrio_completo;0)
=G6*1,5*valor_H+SE(G6>2;(G6-2)*0,5*valor_H;0)
Pg.

105

MTC
2001/2002

=(E6-G6)*valor_H+H6+F6

2.2. Propriedades dos NOMES


Um nome pode referenciar:
uma Clula

MS EXCEL - Frmulas e Funes

Intervalo de clulas (a 2D e a 3D)


um conjunto de clulas (intervalos descontnuos)
Constante
Frmula
Os endereos das clulas referenciadas por um nome podem ser:
Relativas; Absolutas; Mistas

(por predefinio, so Absolutas)

Quando um nome criado, pode ficar disponvel:


Para todas as Folhas do Livro
Apenas na Folha de trabalho onde foi criado, i.e., podemos ter
Pg.

106

um mesmo nome definido com valores diferentes para vrias folhas do m.m livro

MTC
2001/2002

2.3. Alternativas para a definio de NOMES

1.
1.Caixa
Caixade
deNomes
Nomes
MS EXCEL - Frmulas e Funes

1- Seleccionar a clula ou intervalo de clulas que se pretendem referenciar


atravs de um nome
2- Na caixa nome, introduzir o nome pretendido (terminar com Enter)
Pg.

107

MTC
2001/2002

A caixa nome tambm indica se existe


um nome definido para a clula activa.
Neste caso, o nome valor_SR
referencia a clula B7.
MS EXCEL - Frmulas e Funes

A caixa nome
tambm apresenta
a lista de alguns
dos nomes definidos
Pg.

108

MTC
2001/2002

2.
2.Comando
ComandoDefinir
DefinirNome
Nome

MS EXCEL - Frmulas e Funes

Cria um nome para uma clula, intervalo ou valor constante,


que pode ser utilizado para referenciar a clula, intervalo ou valor.

O nome valor_H refere-se


clula $B$5
da folha Ex2.1

ALTERAR as
referncias
de um nome

ALTERAR as
referncias
na caixa Refere-se a:

Pg.

109

MTC
2001/2002

Definir um nome para um intervalo

MS EXCEL - Frmulas e Funes

O nome Produto_A refere-se


ao intervalo $B$4:$E$4
da folha Ex3.1
Pg.

110

MTC
2001/2002

3.
3.Comando
ComandoCriar
CriarNome
Nome

Cria nomes utilizando rtulos num intervalo seleccionado.


MS EXCEL - Frmulas e Funes

So criados os
seguintes Nomes

Pg.

111

MTC
2001/2002

2.4. O que um NOME pode referenciar


Genericamente, a um Nome associada uma Frmula.
O Nome referencia/representa o resultado dessa frmula.

MS EXCEL - Frmulas e Funes


Pg.

112

Um Nome pode referenciar:

no aparecem na
caixa de nomes

MTC
2001/2002

MS EXCEL - Frmulas e Funes

possvel editar a frmula associada ao nome.

Pg.

113

MTC
2001/2002

2.5. Visibilidade dos NOMES


Estes nomes sero conhecidos apenas na Folha onde foram criados

MS EXCEL - Frmulas e Funes

Nome_da_Folha!Nome

No caso de um mesmo nome ser definido


quer ao nvel da folha quer ao nvel do livro
Pg.

114

Nomes definidos ao nvel da Folha


tm Precedncia sobre
Nomes definidos ao nvel do Livro

MTC
2001/2002

2.5.1. Nomes definidos ao nvel do Livro

Estes nomes sero conhecidos em todas as Folhas do Livro onde foram criados.
So os nomes que temos definido at agora
MS EXCEL - Frmulas e Funes

Nome

Pg.

115

MTC
2001/2002

2.5.2. Nomes definidos ao nvel da Folha

Estes nomes sero conhecidos apenas na Folha onde foram criados

MS EXCEL - Frmulas e Funes

Nome_da_Folha!Nome

No caso de um mesmo nome ser definido


quer ao nvel da folha quer ao nvel do livro

Nomes definidos ao nvel da Folha


tm Precedncia sobre
Pg.

116

Nomes definidos ao nvel do Livro

MTC
2001/2002

MS EXCEL - Frmulas e Funes

indica que
nome_local um nome
definido localmente para
a Folha2

Pg.

117

MTC
2001/2002

2.6. Utilizar NOMES em Frmulas

1.
1.Comando
ComandoColar
ColarNome
Nome

MS EXCEL - Frmulas e Funes

Resultado Final
Pg.

118

MTC
2001/2002

2.
2.Comando
ComandoColar
ColarLista
Lista

MS EXCEL - Frmulas e Funes

Atravs do comando Colar lista temos uma lista dos nomes disponveis no Livro.
Esta lista composta por duas colunas (contendo texto):
- uma com os nomes
Pg.

119

- outra com a descrio dos nomes

MTC
2001/2002

4.
4.Interseco
Intersecoimplcita
implcita--Nomes
Nomesque
quereferenciam
referenciamintervalos
intervalos

MS EXCEL - Frmulas e Funes

=Trim1+Trim2

=Produto_A+Produto_B

=SOMA(Produto_B)

=Trim2 Produto_C
=Produto_C+Produto_D
Pg.

120

Interseco implcita - interseco do intervalo


referenciado pelo nome com a linha/coluna da
clula onde o nome referenciado

Interseco explicita
(espao = Operador de interseco)

MTC
2001/2002

5.
5.Aplicar
AplicarNOMES
NOMESaaFRMULAS
FRMULAS

MS EXCEL - Frmulas e Funes

Substituir referncias a clulas e intervalos de clulas em frmulas


por nomes que referenciem estas clulas ou intervalos casos existam.
Com este comando, so localizadas em frmulas todas as referncias
a clulas ou intervalos para os quais existem nomes

Aplicao:
- Se Intervalo seleccionado ==> o comando aplicado ao intervalo
- Seno ==> o comando aplicado Folha activa

Pg.

121

MTC
2001/2002

MS EXCEL - Frmulas e Funes

Seleccionar os nomes a aplicar

Substituir mesmo que as referncias


sejam de tipo diferente
Substitui referncias de clulas que
resultam da interseco de intervalos

Controlar a utilizao dos


nomes de linhas e colunas

Pg.

122