You are on page 1of 4

Laboratorio de DHCP con helper address

Ya sabemos que los routers no dejan pasar los broadcasts, por lo que no podramos tener
un servidor de DHCP fuera del {es:Dominio_de_difusin|dominio de broadcast} local. Si
no hubiese una solucin factible como la que vamos a presentar ahora tendramos la
necesidad de tener un server escuchando en cada subred de nuestra LAN.
Cisco propone una solucin que bsicamente lo que hace es atrapar los broadcasts (que
llegan a las interfaces que a nosotros nos interesen) y reenviarlos como {es:Unicast|
unicast} a una direccin IP que nosotros indiquemos.
En este caso tenemos la siguiente distribucin de equipos:

R2 es un servidor DHCP que tiene varios pooles configurados.

R0 es un router de trnsito que har la conversin broadcast/unicast antes


mencionada.

R1 emula un equipo que quiere aprender la direccin IP de dos de sus interfaces


mediante DHCP.

Veamos las configuraciones:

R2:
ip dhcp excluded-address 192.168.10.1
ip dhcp excluded-address 192.168.11.1
!
ip dhcp pool pepito
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
domain-name pepito
!
ip dhcp pool juancito
network 192.168.11.0 255.255.255.0
domain-name juancito
default-router 192.168.11.1

!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
!
ip route 192.168.10.0 255.255.255.0 192.168.1.1
ip route 192.168.11.0 255.255.255.0 192.168.1.1

R0:
interface FastEthernet0/0
description Enlace a R1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
description VLAN 10 de R1
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.1.2
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
description VLAN 11 de R1
ip address 192.168.11.1 255.255.255.0
ip helper-address 192.168.1.2
!
interface FastEthernet0/1
description Enlace a R2
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!

R1:
interface FastEthernet0/0
description Enlace a R0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
description VLAN 10 de R0
ip address dhcp
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
description VLAN 10 de R0
ip address dhcp
!

El comando ip helper-address configurado en las interfaces de R0 hace que este


reenve las peticiones DHCP (y por defecto otros protocolos ms) hacia la IP

192.168.1.2 que es el servidor DHCP.


Es muy importante notar que para que R2 entregue las direcciones DHCP tiene
que saber como llegar a las redes que entrega, por esto las rutas estticas que se
configuraron en R2 son fundamentales, y en caso de no conocerse dichas redes el
servidor DHCP no funcionar.
Ahora vemos que pasa en R1 al momento de levantar las interfaces:
R1#
*Mar 1 00:13:03.315: %SYS-5-CONFIG_I: Configured from console by
console
R1#sh ip int bri
Interface
IP-Address
OK? Method Status
Protocol
FastEthernet0/0
unassigned
YES unset up
up
FastEthernet0/0.10
unassigned
YES DHCP
up
up
FastEthernet0/0.11
unassigned
YES DHCP
up
up
FastEthernet0/1
unassigned
YES unset up
up
R1#
*Mar 1 00:15:18.907: %DHCP-6-ADDRESS_ASSIGN: Interface
FastEthernet0/0.10
assigned DHCP address 192.168.10.2, mask 255.255.255.0, hostname R1
R1#
*Mar 1 00:15:23.091: %DHCP-6-ADDRESS_ASSIGN: Interface
FastEthernet0/0.11
assigned DHCP address 192.168.11.2, mask 255.255.255.0, hostname R1
R1#show ip interface brief
Interface
IP-Address
Protocol
FastEthernet0/0
unassigned
up
FastEthernet0/0.10
192.168.10.2
up
FastEthernet0/0.11
192.168.11.2
up
FastEthernet0/1
unassigned
up

Ahora vemos el lease en R2:


R2#show ip dhcp pool
Pool pepito :
Utilization mark (high/low)
: 100 / 0
Subnet size (first/next)
: 0 / 0
Total addresses
: 254
Leased addresses
: 1
Pending event
: none
1 subnet is currently in the pool :

OK? Method Status


YES unset

up

YES DHCP

up

YES DHCP

up

YES unset

up

Current index
addresses
192.168.10.3

IP address range
192.168.10.1

Leased
- 192.168.10.254

Pool juancito :
Utilization mark (high/low)
: 100 / 0
Subnet size (first/next)
: 0 / 0
Total addresses
: 254
Leased addresses
: 1
Pending event
: none
1 subnet is currently in the pool :
Current index
IP address range
addresses
192.168.11.3
192.168.11.1
- 192.168.11.254

Leased
1

R2#show ip dhcp binding


Bindings from all pools not associated with VRF:
IP address
Client-ID/
Lease expiration
Type
Hardware address/
User name
192.168.10.2
0063.6973.636f.2d63.
Mar 02 2002 12:15 AM
Automatic
3430.312e.3039.3266.
2e30.3030.302d.4661.
302f.302e.3130
192.168.11.2
0063.6973.636f.2d63.
Mar 02 2002 12:15 AM
Automatic
3430.312e.3039.3266.
2e30.3030.302d.4661.
302f.302e.3131

Espero que lo implementen pronto.


Hasta la prxima!