You are on page 1of 7

UNSa - Seminario de Informtica

Planilla de Clculo

La Funcin "SI"
INTRODUCCION
La funcin SI posee tres argumentos:
El primer argumento es la
prueba lgica

El segundo argumento indica la accin a realizar


por la funcin SI, si la prueba lgica del primer
argumento es verdadera

El tercer argumento indica la accin a realizar


por la funcin SI, si la prueba lgica del primer
argumento es falsa

ARGUMENTOS
Los argumentos son valores, frmulas o funciones que sirven como parmetros para la ejecucin de una funcin.
PRUEBA LOGICA
La prueba lgica es una operacin que se vale de los operadores =, >, < o una combinacin de ellos, entre dos valores, frmulas o funciones.
VALORES
Al hablar de valores, estos pueden ser nmeros, letras, fechas o referencias a celdas que contengan algunos de estos valores.

Pgina 1 de 7

UNSa - Seminario de Informtica

Planilla de Clculo

EJEMPLO 1
ENUNCIADO TRABAJO PRACTICO N 2
El enunciado establece que la fruta tiene un descuento de 8% y la verdura de 10%, se puede "programar" (aunque en rigor estamos automatizando
la planilla) para que se indique el porcentaje de descuento en funcin del tipo de producto. La funcin se ingresara de la siguiente manera:

=SI(E39="Fruta";10%;8%)
Desglose de la funcin:
"=SI" --> es la funcin. Toda funcin se introduce precedida del signo IGUAL (=) o MAS (+) y el nombre de la funcin. En este caso el nombre
de la funcin es SI.
"E39="Fruta" --> es el primer argumento de esta funcin, la prueba lgica. En el ejemplo una igualdad entre una referencia y un texto. Observese que
el texto est encerrado entre comillas. Esto es obligatorio para que pueda efectuar la comparacin.
"10%" --> es el segundo argumento de la funcion a mostrar, si la prueba lgica es verdadera. En este caso es el valor 10%
"8%" --> es el tercer argumento de la funcin a mostrar si la prueba lgica es falsa. En este caso es el valor 8%

Pgina 2 de 7

UNSa - Seminario de Informtica

Planilla de Clculo

As en el prctico podemos determinar el porcentaje de descuento en funcin del tipo de producto.


(Previamente hay que determinar que tipo de producto es cada uno)
tem
1

Descripcin
Alcaucil

Cantidad en Kg
3

$/Kg

Tipo

1.5

Verdura

Apio

Verdura

Arveja

25

0.95

Verdura

Batata

Verdura

Berenjena

Verdura

Brcoli

Verdura

Brote de soja

55

Verdura

Cayote

Fruta

Cebolla

10

1.6

Verdura

10

Championes

30

Verdura

11

Chaucha

2.5

Verdura

12

Ciruela

Fruta

% Dcto.

% Dcto.

8.00%
8.00%
8.00%
8.00%
8.00%
8.00%
8.00%
10.00%
8.00%
8.00%
8.00%
10.00%

0.00%
0.00%
8.00%
0.00%
0.00%
0.00%
0.00%
0.00%
8.00%
0.00%
0.00%
10.00%

=SI(E39="Fruta";10%;8%)

Ahora vamos a dar un paso ms, para resolver el caso planteado. El descuento es procedente cuando se compra ms de 5 Kg.
Si bien la funcin es potente y muy til no nos soluciona cuando las condiciones son dos (como en el prctico) o ms.
Para ello se utiliza la combinacin de funciones.
Antes de pasar a la sintaxis de la funcin vamos a construir una tabla de decisin que nos ayudar en la ingreso de la frmula:
Tabla de Decisin
Condicin
Es Fruta ?
Es ms 5 Kg.?
Accin
Sin descuento
Descuento 8%
Descuento 10%

Regla 1 Regla 2
si
si
si
no
X

X
-

Regla 3
no
si
X
-

Regla 4
no
no
X
-

Como se puede apreciar, de las combinaciones posibles hay dos que no llevan descuento.

Pgina 3 de 7

UNSa - Seminario de Informtica

Planilla de Clculo

Esto lo podemos expresar de la siguiente forma:

=SI(Y(E50="Fruta";C50>5);10%;SI(Y(E50="Verdura";C50>5);8%;0%))
Desglose de la funcin:
"=SI" --> es la funcin SI
"Y(E50="Fruta";C50>5" --> es la prueba lgica, en este caso se utiliza la funcin Y que agrupa dos condiciones separadas por ";" (punto y coma).
"10%" --> es el segundo argumento de la funcion. En este caso es el valor 10%
"SI(Y(E50="Verdura";C50>5);8%;0%)" --> es el tercer argumento de la funcin. En este caso es nuevamente la funcin SI anidada como
argumento de otra funcin SI.
Si la analizamos por separado y utilizando los mismos colores tenemos:

=SI(Y(E50="Verdura";C50>5);8%;0%))
Desglose de la funcin:
"=SI" --> es la funcin SI
"Y(E50="Verdura";C50>5" --> es la prueba lgica, en este caso se utiliza la funcin Y que agrupa dos condiciones separadas por ";" (punto y coma).
"8%" --> es el segundo argumento de la funcion. En este caso es el valor 8%.
"0%" --> es el tercer argumento de la funcin. En este caso con un valor de 0%.
De esta manera podemos potenciar la funcin "SI" combinndola con otras funciones "SI" y con el operador lgico "Y" u "O".
Para finalizar vamos a utilizar la combinacin de funciones " SI" para determinar el impuesto a las ganancias a pagar, dada la ganancia neta imponible:

Pgina 4 de 7

UNSa - Seminario de Informtica

Planilla de Clculo

EJEMPLO 2
ESCALA DE IMPUESTO APLICABLE A PARTIR DEL PERIODO FISCAL 2000. ARTICULO 90 - LEY IMPUESTO A LAS GANANCIAS.
Ganancia Neta
Imponible Acumulada

Pagarn

Pagarn (Tabla
Simplificada)

Ms de $

a$

Ms el %

Sobre
excedente de
$

10,000

---

(0,09 x G) 0

10,000

20,000

900

14

10,000

(0,14 x G) 500

20,000

30,000

2,300

19

20,000

(0,19 x G) 1.500

30,000

60,000

4,200

23

30,000

(0,23 x G) 2.700

60,000

90,000

11,100

27

60,000

(0,27 x G) 5.100

90,000

120,000

19,200

31

90,000

(0,31 x G) 8.700

120,000

en adelante

28,500

35

120,000

(0,35 x G) 13.500

(G = Ganancia Neta Imponible Acumulada)


Fuente: http://biblioteca.afip.gov.ar/afipres/ganancias_coeficientes_y_montos.htm

Ganancia Neta
Imponible Acumulada
9,000.00
10,000.00
11,000.00
20,000.00
21,000.00
30,000.00
30,001.00
60,000.00
89,999.00
90,000.00
95,000.00
120,000.00
120,001.00

Impuesto
Determinado
810.00
900.00
1,040.00
2,300.00
2,490.00
4,200.00
4,200.23
11,100.00
19,199.73
19,200.00
20,750.00
28,500.00
28,500.35
Pgina 5 de 7

UNSa - Seminario de Informtica

1,000,000.00
10,000,000.00

Planilla de Clculo

336,500.00
3,486,500.00

Pgina 6 de 7

UNSa - Seminario de Informtica

Planilla de Clculo

A continuacion se detalla la combinacin de funciones SI utilizada para determinar el impuesto:


=SI(B126<=10000;B126*9%-0;SI(B126<=20000;B126*14%-500;SI(B126<=30000;B126*19%-1500;SI(B126<=60000;B126*23%-2700;SI(B126<=90000;
B126*27%-5100;SI(B126<=120000;B126*31%-8700;B126*35%-13500))))))
La lgica de la frmula ingresada es la siguiente:
Pregunto primero si la ganancia neta es menor o igual a 10.000,00 (primer tramo de la escala). Si es verdadero hago el clculo del impuesto, si no
pregunto si, la ganancia neta es menor o igual a 20.000,00 (segundo tramo de la escala). Si es verdadero hago el clculo del impuesto, aplicando
el porcentaje del segundo tramo y descontando el monto fijo. Si no es verdadero vuelvo a preguntar si la ganancia neta es menor o igual a 30.000,00.
As sucesivamente en la misma frmula hasta que en el ltimo si, si la ganancia neta no es menor o igual a 120.000,00 se calcula aplicando el 35%
sobre la ganancia neta restando los 13,500,00.
En este caso se utilizaron 6 funciones SI anidadas. El mximo de funciones SI anidadas que permite Excel es de 7.
Fin.

Pgina 7 de 7