You are on page 1of 81

Universidad Nacional Autnoma de Nicaragua.

Unan-Len

Facultad de Ciencias y Tecnologa


Departamento de Computacin
Ingeniera en Telemtica

Monografa para optar al ttulo de Ingeniera en Telemtica:


Anlisis de software de open source routing, para su uso en los laboratorios
de Redes de Computadoras.

Integrantes:
Br. Lester Ramn Acevedo Hernndez.
Br. Jos Miguel Brcenas Flores.

Tutor:
MSc. Aldo Ren Martnez Delgadillo.

Len, Nicaragua 22 de Febrero del 2013.

AGRADECIMIENTO
En primer lugar damos gracias a Dios por darnos la fortaleza espiritual y fsica para ser
capaces de enfrentar cada dificultad que se nos present durante la realizacin de dicho
trabajo monogrfico.

A nuestros Padres por habernos apoyado tanto sentimental como econmicamente a lo largo
de nuestras vidas.

A nuestro tutor MSc. Aldo Rene Martnez Delgadillo, ya que con sus recomendaciones y el
tiempo que nos brind logramos finalizar nuestra tesis de forma exitosa.

Y finalmente a nuestros Maestros por habernos guiados durante estos cuatro aos para
llegar a ser los profesionales que hoy somos.

DEDICATORIA

Este trabajo lo dedicamos a nuestros padres que con mucho esfuerzo

Y dedicacin nos han apoyado a lo largo de nuestros estudios

Y nuestras vidas al poner toda su confianza en nosotros

Y lograr as que seamos unos excelentes profesionales.

Contenido:
TABLA DE CONTENIDO:
I REA DE TRABAJO ............................................................................................................................................................................... 1
TEMA : .................................................................................................................................................................................................. 1
II INTRODUCCIN . ................................................................................................................................................................................. 2
2.1 ANTECEDENTES . ............................................................................................................................................................................... 2
2.2 DEFINICIN DEL PROBLEMA. ............................................................................................................................................................. 3
2.3 JUSTIFICACIN.................................................................................................................................................................................. 5
2.4 O BJETIVOS. ...................................................................................................................................................................................... 6
2.4.1 General: ............................................................................................................................................................................ 6
2.4.2 Especficos: ...................................................................................................................................................................... 6
2.5 MARCO T ERICO. ............................................................................................................................................................................ 7
2.5.1VYATTA: ............................................................................................................................................................................. 7

2.5.2 XORP .................................................................................................................................................................................10


2.5.3 QUAGGA .............................................................................................................................................................................11
2.5.4 BIRD.....................................................................................................................................................................................12
2.5.5 ZEBRA .............................................................................................................................................................................14
III TECNOLOGAS IMPLEMEN TADAS. ...............................................................................................................................................16
IV DISEO METODOLGICO . ............................................................................................................................................................19
V CRONOGRAMA DE ACTIVIDADES. ................................................................................................................................................21
VI PRCTICAS DE LABO RATORIOS. ..................................................................................................................................................22
6.1 PRCTICA # 01 .........................................................................................................................................................................22
INSTALACIN Y CONFIGURACIN DE VYATTA 6.4 EN VMWARE W ORKSTATION 9 .............................................................22
6.2 PRCTICA # 02 .........................................................................................................................................................................28
CONFIGURACIN DE LAS INTERFACES DE RED DE NUESTRA MQUINA VIRTUAL EN VMWARE W ORKSTATION 9 ........28
6.3 PRCTICA # 03 .........................................................................................................................................................................33
IMPLEMENTACIN DHCP, NA T, PROXY .................................................................................................................................33
6.4 PRCTICA # 04 .........................................................................................................................................................................47
CONFIGURACIN VLAN IMPLEMENTADOS CON SWITCH C ISCO CATALYST 3560 ............................................................47
6.5 PRCTICA # 05 .........................................................................................................................................................................54
CONFIGURACIN DE P ROTOCOLOS DE E NCAMINAMIENTO BGP-RIP-OSPF....................................................................54
VII CONCLUSIONES Y F UTUROS TRABAJOS ....................................................................................................................................75
VIII BIBLIOGRAFA. ..............................................................................................................................................................................76

TABLA DE FIGURAS.
Figura1. Implementacin DHCP - NAT .............................................................................................. 33
Figura2. Configuracin de Interfaz Vyatta ......................................................................................... 35
Figura3. Configuracin VLAN con Switch Catalyst 3560 .................................................................. 48
Figura4. Implementacin Protocolos Enrutamiento BGP-OSPF-RIP ............................................... 55

Universidad Nacional Autnoma de Nicaragua UNAN- Len

I rea de Trabajo
Configuraciones.

Tema:

Anlisis de software de Open Source Routing, para su uso en los


laboratorios de Redes de Computadoras.

A la libertad, por la universidad

Pgina 1

Universidad Nacional Autnoma de Nicaragua UNAN- Len

II Introduccion.
2.1 ntecedentes.
Hasta el momento en el Departamento de Computacin, no se ha realizado ningn trabajo
monogrfico relacionado con anlisis de Open Source Routing.
El trabajo ms similar al nuestro, es la monografa titulada Prcticas de Laboratorio para
la Asignatura de Redes de Ordenadores II realizada, empleando el simulador
PacketTracer en el ao 2008.

El rea de Redes de la Carrera de Telemtica de la Unan-Len, cuenta con 4 equipos


fsicos hasta el momento. Este es un enorme problema que tiene el Departamento de
Computacin, debido a que no se logran realizar pruebas de laboratorio reales, lo que se
implementa son simuladores como PacketTracer que este es de gran ayuda pero no
permite interaccin entre el software y el equipo fsico, simplemente este permite hacer una
simulacin de segmentos de redes, pero tiene protocolos que no los permite como es el
caso de BGP, ISIS, etc. Tambin se utiliza GNS3 pero este consume demasiados recursos
de hardware.

Para solucionar un poco este problema surge la necesidad de implementar herramientas


libres que ayuden a solucionar prcticas de laboratorio, por tal se empez a utilizar
herramientas

libres

como

Pfsense,

Zeroshell,

Monowall; estas

son herramientas

de distribucin personalizada de FreeBSD (Berkeley Software Distribution) adaptado para


su uso como Firewall y Router y no consumen muchos recursos de hardware.

Se utiliza licencia BSD hasta el momento porque tiene menos restricciones en comparacin
con otras como la GPL (General Public License) estando muy cercana al dominio pblico.

A la libertad, por la universidad

Pgina 2

Universidad Nacional Autnoma de Nicaragua UNAN- Len

2.2 Definicion del problema.


Es viable utilizar herramientas de software open source routing para realizar las prcticas
de laboratorios de Redes de Computadoras?
A pesar que el Departamento de Computacin de la Unan-Len cuenta con 4 laboratorios
ampliamente equipados, para la carrera de Ingeniera en Telemtica especficamente el
rea de Redes de Computadoras, no se cuenta con equipos necesarios para realizar
prcticas de laboratorios reales debido a que no se cuenta con los suficientes equipos
fsicos como (Routers, Switches, etc).

Por tal razn, para sustentar un poco la carencia de equipos se implementa virtualizacin
en Linux con VirtualBox o VmWare, de esta forma se logra hacer simulaciones de
segmentos de redes un poco ms complejas, pero al no contar con los equipos reales es
ac donde entra en juego el concepto de open source routing.

Ya mencionbamos las herramientas de software libre que implementan el rea de


Telemtica hasta hoy: (Pfsense, Zeroshell, Monowall), por supuesto todo virtualizado. A
pesar que estas cuentan con interfaz grfica ninguno de ellos tiene similitud para realizar
configuraciones como un router real. Adems se realizan prcticas con simuladores entre
ellos el ms importante PacketTracer.

No podemos olvidar esto porque en la vida real son equipos fsicos los que manipulamos.
Con esto lo que se pretende es dar nocin al estudiante de trabajar con equipos reales,
para estar mejor preparados a la hora de asignar algn trabajo.

Por ende, primero se har una comparacin de las diferentes herramientas de open source
routing entre ellas VYATTA, ZEBRA, XORP, QUAGGA, BIRD etc. Adems haremos una
breve explicacin de qu es cada herramienta, cmo surgi, qu servicios ofrece, si est
constantemente en desarrollo, etc.
A la libertad, por la universidad

Pgina 3

Universidad Nacional Autnoma de Nicaragua UNAN- Len

A continuacin, se realizar un breve tutorial del sistema que nosotros consideremos que
es mejor haciendo enrutamiento o implementando algn protocolo de red. Adems, se
comentarn todos los servicios, los que se usarn en las prcticas y los que no, explicando
en qu consisten y cmo se configuraran con este software.

Por ltimo, se realizarn algunas prcticas de la asignatura Laboratorio enfocadas a Redes


de Computadoras, analizando si se pueden sustituir los Routers por el sistema elegido en
su momento.

A la libertad, por la universidad

Pgina 4

Universidad Nacional Autnoma de Nicaragua UNAN- Len

2.3 Justificacion.
En base a los problemas antes planteados se hace necesario hacer un anlisis de
alternativas de Open Source Routing, luego hacer una comparacin exhaustiva de las
diferentes herramientas, para as escoger y seleccionar la mejor para ser usadas en las
asignaturas relacionadas con Redes de Computadoras.

Esta solucin sera idnea ya que solo sera necesario un equipo comn con una serie de
caractersticas, que posteriormente se enunciarn.

A la libertad, por la universidad

Pgina 5

Universidad Nacional Autnoma de Nicaragua UNAN- Len

2.4 Objetivos.
2.4.1

General:

Analizar las diferentes herramientas de software de Open Source Routing, para su


uso en los laboratorios de asignaturas relacionadas con Redes de Computadoras.

2.4.2 Especficos:
Comparar herramientas de Open Source Routing y seleccionar la mejor en base
a la cantidad de implementacin de protocolos de enrutamiento que posean.
Describir el funcionamiento de la herramienta de enrutamiento seleccionada y
mostrar los requerimientos necesarios para su instalacin y configuracin.
Desarrollar prcticas de laboratorios que sirvan de gua para utilizar esa
herramienta.
Demostrar las capacidades de la herramienta seleccionada y sus funcionalidades
en las distintas capas del protocolo TCP/IP.

A la libertad, por la universidad

Pgina 6

Universidad Nacional Autnoma de Nicaragua UNAN- Len

2.5 Marco Teorico.


A partir de este momento mostramos algunas de las propuestas mencionadas anteriormente
para de esta forma inclinarnos a la que nosotros consideremos la mejor haciendo
enrutamiento.
2.5.1VYATTA:
Vyatta ha creado una de las mejores soluciones de red, la cual est optimizada para ofrecer
seguridad integrada y funcionalidad de enrutamiento para entornos fsicos y virtuales. El
sistema Vyatta se dise con el propsito de reemplazar las versiones comerciales de Cisco,
desde la serie 1800 hasta la 7200, apoyndose en el bajo coste y flexibilidad de las
soluciones open source, y que adems al estar basado en Linux funcionara en la mayora
de sistemas basados en la tecnologa x86.

En la versin VC3, Vyatta empieza a utilizar XORP, en concreto su modelo de pila de


enrutamiento, y es patrocinado por ste durante 2 aos. Ms adelante, en la versin VC4, el
equipo de Vyatta toma la decisin de ir en otra direccin. A partir de ah ya no deciden
utilizar XORP, porque quieren dotar a Vyatta de ms funciones (firewall, VPN, DHCP, VLAN,
etc.) las cuales XORP no dispone.

A principios de 2007, Vyatta tena un gran nmero de clientes, los cuales comienzan a
utilizar el sistema en redes de proveedores de servicios, en los que haba que implementar
el protocolo BGP. Como el despliegue de redes era tan grande, se encontraron con una
serie de limitaciones en el cdigo fuente de XORP relacionados con la escalabilidad y el
rendimiento. Para solucionar esto, los ingenieros de Vyatta hicieron muchas reformas en el
cdigo fuente de XORP, y al final se determin que los costes eran mayores que si lo
desarrollaban ellos mismos, por lo que se inici el trabajo para realizar un nuevo diseo de
pila de enrutamiento. As naci la versin VC4 con la colaboracin de Quagga.

Vyatta ofrece dos opciones de uso, los dispositivos hardware o el software Vyatta Network
OS. Los aparatos hardware, integran el software Vyatta Network OS y software de
seguridad. Estos dispositivos estn basados en las plataformas estndar de hardware x86, y
A la libertad, por la universidad

Pgina 7

Universidad Nacional Autnoma de Nicaragua UNAN- Len


eliminan cualquier dependencia de hardware propietario. En concreto, ofrecen 4 tipos de
dispositivos hardware de diferentes caractersticas tcnicas, que varan segn las
necesidades del comprador.

Vyatta se puede instalar tanto sobre un servidor fsico como en una mquina virtual,
permitiendo disponer de servicios de seguridad de red en entornos virtualizados y entornos
en nube. Vyatta ofrece a los proveedores de los servicios de nube la opcin de asegurar y
gestionar sus complejas redes ofreciendo mucho ms que un simple firewall, en concreto,
VPN con IPsec, SSL en OpenVPN, prevencin de intrusiones de red, seguridad de filtrado
web y mucho ms.
El sistema Vyatta ofrece las siguientes funcionalidades:
Servicios IP [6]:
SSH.
Telnet.
DHCP.
DNS.
NAT.
Web caching.

Enrutamiento bsico:
Polticas de enrutamiento.
RIP.
BGP.
OSPF.

Servicios de seguridad:
Firewall: IPv4, IPv6.
Deteccin de intrusiones (snort) y filtrado web.
Servicios de Red Privada Virtual (VPN):
VPN Lan-to-Lan con IPSec.
Acceso remoto con PPTP.
A la libertad, por la universidad

Pgina 8

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Acceso remoto con L2TP e IPSec.
VPN Lan-to-Lan y acceso remoto con OpenVPN.

QoS (Quality of Services):


Traffic shape: permite controlar y restringir la anchura de banda (bandwith) de las
conexiones salientes.
Traffic lmite: permite controlar y restringir la anchura de banda (bandwith) de las
conexiones entrantes.

Servicios de alta disponibilidad:


WAN Load balancing: permite encriptar el trfico saliente a travs de diferentes
proveedores.
VRRP (Virtual Router Redundancy Protocol): permite que un cluster de Vyattas
acten como un nico dispositivo.
Clustering: permite disponer de alta disponibilidad entre dos servidores Vyatta.
Statefull NAT and Firewall Failover: permite replicar el estado de las conexiones entre
los servidores de un cluster, de manera que en caso de error de un nodo, las
conexiones de mantienen activas.
RAID 1: permite implementar RAID 1 de discos, tanto para hardware como para
software.
Configuration Synchronization: sincroniza la configuracin entre dos nodos en alta
disponibilidad.

Las caractersticas mnimas para instalar el software Vyatta en un PC son:


Procesador: Pentium III a 500 MHz
Memoria RAM: 384 MB
Disco Duro: 10 Gb

A la libertad, por la universidad

Pgina 9

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Como podemos comprobar las caractersticas mnimas para la instalacin del software de
Vyatta son ms exigentes que las dems opciones.

Al igual que las dems opciones open-source, todas las funciones son fcilmente
configurables mediante el uso de intuitivas instruccin desde la lnea de comandos, y
adems incluye una interfaz grfica web (GUI).
2.5.2 XORP

XORP (eXtensible Open Router Platform) es una plataforma de cdigo abierto que
proporciona todas las funciones que implementan los protocolos de enrutamiento IPv4 e
IPv6. Es la nica plataforma que ofrece una capacidad integrada de multidifusin.

El desarrollo del proyecto fue fundado por Mark Handley en el ao 2000. Recibi fondos de
Intel y Microsoft y el software se lanz al mercado por primera vez en julio del 2004. La
ltima actualizacin se hizo en enero del 2012, por lo que podemos comprobar que es un
software que est en constante desarrollo. Esto es importante, ya que los errores que
puedan surgir al usuario, se puedan solucionar en nuevas actualizaciones.

Entre sus principales objetivos de XORP, est la tarea de soportar todos los requisitos de los
Routers reales incluyendo los protocolos de enrutamiento, facilitar las APIs para crear
extensibilidad en los protocolos de enrutamiento, mejorar el rendimiento del router y hacerlo
robusto para que los paquetes no se colapsen o pierdan.

XORP puede convertirse en una alternativa de bajo coste en comparacin a las costosas
mquinas de Cisco Systems y otras empresas que dominan el mercado de enrutamiento, ya
que se puede montar sobre PCs convencionales.
La base de cdigo XORP consta de alrededor 670.000 lneas de cdigo escritas en lenguaje
C++ y desarrolladas principalmente en FreeBSD, pero totalmente compatibles con Linux y
OpenBSD.

A la libertad, por la universidad

Pgina 10

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Segn

sus

creadores

soporta

protocolos

como

RIP, BGP, OSPF

en procesos

independientes lo que significa que si un componente de software cae, no afectar a los


otros que estn utilizando el mismo hardware.
El proyecto soporta los siguientes protocolos de enrutamiento:
Enrutamiento esttico.
RIP-2 y RIPng.
BGP-4.
OSPFv2 y v3.
PIM-SM.
IGMP v1, v2 y v3
MLD v1 y v2.
VRRP v2.

El lenguaje de lneas de comandos es el modelo de plataforma de Junipers Networks el cual


funciona bajo el sistema operativo UNIX.

Por otra parte, hay algunas desventajas en XORP. Una de ellas es su rendimiento. Aunque
el software supuestamente gestiona ms de 700.000 paquetes por segundo en un PC
estndar, la mayora de los routers de alto rendimiento del mercado utilizan hardware
especializado para acelerar el envo de paquetes.

XORP est disponible para su descarga como un Live CD o como cdigo fuente a travs de
la pgina oficial del proyecto.

2.5.3 QUAGGA

Es un sistema ms fcilmente extensible, gestionado y modular. Quagga copia el estilo del


modo de trabajo del CISCO IOS y tiene un proceso independiente para cada protocolo. Un
sistema con Quagga instalado acta como un router dedicado.

A la libertad, por la universidad

Pgina 11

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Quagga intercambia informacin con otros routers mediante protocolos de routing,


utilizndola para actualizar el ncleo de las tablas de routing de forma que la informacin
correcta est en el lugar correcto. Quagga permite la configuracin dinmica y es posible ver
la informacin de la tabla de routing desde el interfaz de terminal de Quagga.
El proyecto soporta los siguientes protocolos de enrutamiento:
RIPv1, v2, RIPng.
BGP-4 y BGP-4 +.
OSPFv2 y v3.
Adems de soportar ipv4, tambin soporta ipv6. Posee una arquitectura avanzada que le
proporciona una gran calidad y potencia, con un motor multiservidor de encaminamiento.
Quagga tiene un interfaz de usuario interactivo para cada protocolo de routing.

Est diseado especialmente para NetBSD, FreeBSD, Solaris y Linux y solamente se tendr
que instalar el paquete quagga.

A diferencia de otros open source routing, slo se puede descargar los paquetes, que
posteriormente se tendrn que instalar en una distribucin de Linux, los cuales actuarn
como demonios independientes, en lugar de una distribucin Linux como ocurra en XORP.

Aunque se podra crear un LiveCD de un Linux con Quagga, esto podra ser un
inconveniente para alguien que no tenga mucha experiencia. Este software es una opcin
interesante debido a su estructura interna e instalacin por paquetes, aunque ofrece los
mismos servicios que su antecesor Zebra.

2.5.4 BIRD

El nombre de BIRD es un acrnimo de Internet Routing Daemon que significa demonio de


encaminamiento de internet.

BIRD se desarroll en la facultad de matemticas y fsica de la Universidad Charles en Praga,


como un proyecto estudiantil en 1999. El proyecto estuvo parado un tiempo hasta el 2003.
A la libertad, por la universidad

Pgina 12

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Puede ser libremente distribuido bajo los trminos de la Licencia Publica General GNU y es
una alternativa a Quagga/Zebra.

BIRD ha sido diseado para trabajar en todos los sistemas tipo UNIX, FreeBSD, NetBSD y
OpenBSD.

BIRD es un proyecto cuyo cometido es el desarrollo de un completo demonio de ruteo de IP,


cuyo modo de acceso es a travs de lnea de comando y diseado especialmente para
ajustarse a cualquier sistema operativo de tipo UNIX. BIRD es compatible con el protocolo
IPv4 o IPv6, aunque tendrn que ser compilados de forma separada ya que no son
compatibles al mismo tiempo.

Protocolos de enrutamiento soportados:


Rutas estticas.
RIPv2.
BGPv4.
OSPFv2 y v3.

BIRD brinda un mecanismo de configuracin realmente flexible y fcil de maniobrar, basado


en un fichero de configuracin, que se activar mediante un SIGHUP.
En definitiva, BIRD ofrece un potente lenguaje para la aplicacin de filtros de ruteo de IP
dinmica, pero tambin de rutas estticas, y con mltiples tablas de routing, ideal para
dominar el conjunto de protocolos de ruteo vigentes en la red de redes hoy en da.
Al igual que los proyectos anteriores, BIRD no nos ofrece todos los servicios que nos podra
ofrecer un router CISCO, como por ejemplo la seguridad. Adems, al igual que Quagga, solo
estn disponibles los paquetes, y las actualizaciones, que tendremos que compilar e instalar
en nuestra distribucin Linux.

A la libertad, por la universidad

Pgina 13

Universidad Nacional Autnoma de Nicaragua UNAN- Len

2.5.5 ZEBRA
GNU Zebra es un software libre que gestiona protocolos de enrutamiento basados en TCP/IP.
Es un proyecto libre, ya que forma parte del Proyecto GNU, y se distribuye bajo la Licencia
Pblica General GNU.

El proyecto Zebra se inici en 1996. La idea de Zebra vino originalmente de Kunihiro Ishiguro,
quien haba estado trabajando en NIS y en una empresa conjunta entre el ISP British Telecom
y Marubeni. Cuando estaba trabajando para un ISP, se dio cuenta de una gran necesidad de
un nuevo tipo de software de enrutamiento. Junto con Yoshinari Yoshikawa decidieron crear
un nuevo motor de enrutamiento basado en licencia pblica GNU.

Zebra es un software que permite montar routers sobre sistemas operativos tipo Unix. Este
software dispone de una interfaz de configuracin basada en el CISCO IOS, por lo que ser
til a los administradores familiarizados con routers CISCO.

Tradicionalmente, la configuracin de un router basado en UNIX se realizaba mediante los


comandos ifconfig y route. El estado de las tablas se poda mostrar mediante la utilidad
netstat. Estos comandos solamente se podan utilizar trabajando como root. Zebra, sin
embargo tiene otro mtodo de administracin. En Zebra existen dos modos de usuario. Uno
es modo normal y otro es el modo enable (habilitado). El usuario normal solo puede ver el
estado del sistema y el enable puede cambiar la configuracin del sistema. Como vemos esto
se asemeja al modo de trabajo de los routers CISCO, en el que tendremos que entrar en el
modo configuracin para poder realizar los cambios.

El software tradicional de routing est compuesto por un programa o un proceso nico que
proporciona todas las funcionalidades de los protocolos de routing. Zebra sin embargo tiene
una visin distinta. Est compuesto por una coleccin de varios demonios que trabajan juntos
para construir una tabla. El demonio ripd maneja el protocolo RIP, mientras que el demonio
ospfd controla el protocolo OSPFv2 y bgpd el protocolo BGP-4. Es sencillo aadir nuevos
demonios de routing sin afectar a otros.
A la libertad, por la universidad

Pgina 14

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Los protocolos de enrutamiento que Zebra soporta son:


RIPv1, v2, RIPng.
BGP-4 y BGP-4.
OSPFv2 y v3.

Esta opcin no ofrece todos los servicios ni protocolos de enrutamiento necesarios para
realizar las prcticas de LPR, y por lo tanto no se podra afirmar que este software podra
sustituir completamente a los router CISCO. Desde su ltima actualizacin en Septiembre del
2005 el desarrollo de Zebra se ha detenido para dar lugar a su nuevo sucesor, Quagga.

A la libertad, por la universidad

Pgina 15

Universidad Nacional Autnoma de Nicaragua UNAN- Len

III Tecnologas Implementadas.


A continuacin para mostrar parte de las tecnologas implementadas se muestra una tabla en
la que se ven reflejadas las distintas caractersticas de los Open Source Routing y una
versin del dispositivo comercial ms popular del mercado, CISCO.

XORP
1.8.5

QUAGUA
0.99.18

BIRD
1.3.2

VYATTA
VC 6.4

CISCO
2651

Sistema
Operativo
Open Source

Linux

Unix-like

Unix-like

Linux

CISCO IOS

SI

SI

SI

SI

NO

Instalacin

SI/NO

SI

SI

SI/NO

NO

Rutas
estticas
RIPv2

SI

SI

SI

SI

SI

SI

SI

SI

SI

SI

OSPFv3

SI

SI

SI

SI

SI

BGPv4

SI

SI

SI

SI

SI

NAT

SI

SI

NO

SI

SI

VRRP

SI

NO

NO

SI

SI

Mapas de
rutas
VPN IPsec

SI

SI

SI

SI

SI

NO

NO/Linux

NO

SI

SI

VPN SSL

NO

NO/Linux

NO

SI

NO

Cliente FTP

A la libertad, por la universidad

Pgina 16

Universidad Nacional Autnoma de Nicaragua UNAN- Len


XORP
1.8.5

QUAGUA
0.99.18

BIRD
1.3.2

VYATTA
VC 6.4

CISCO
2651

Cliente TFTP

NO/Linux

NO/Linux

NO/Linux

SI

SI

Telnet

SI

SI

SI

SI

SI

Server SSH

NO/Linux

NO/Linux

NO/Linux

SI

SI/NO

Server HTTP

NO

NO

NO

SI

SI

Server DHCP

NO/Linux

NO/Linux

NO/Linux

SI

SI

Server NTP

NO/Linux

NO/Linux

NO/Linux

NO

SI/NO

Cliente NTP

NO/Linux

NO/Linux

NO/Linux

SI

SI

SNMP

NO

NO

NO

SI

SI

ICMP

SI

SI

SI

SI

SI

Traceroute

SI

SI

SI

SI

SI

NOTAS:
Unix-like: es un sistema operativo que se comporta de manera similar a un sistema Unix,
aunque no necesariamente conforme a su certificacin.

No/Linux: significa que el software en cuestin no trae esa opcin, pero al funcionar sobre el
sistema operativo Linux, ste s que dispone de esa caracterstica.

Como conclusin hay decir que VYATTA posee las mismas funcionalidades que XORP,
QUAGGA Y BIRD, e incorpora en el software servicios IP como ssh, telnet, dhcp, dns, nat, ftp,
tftp. Al ser Quagga y Bird procesos de enrutamiento, no es de esperar que incluyan estos
servicios, ya que se supone que los podremos instalar en la mquina que actuar como
router.

A la libertad, por la universidad

Pgina 17

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Adems proporciona servicios de red privada virtual (VPN), QoS, VRRP, seguridad firewall y
deteccin de intrusiones. Todo esto hace que VYATTA sea un duro competidor para CISCO,
ya que posee casi todas las funcionalidades de ste.

Al final, despus de buscar y comparar las diferentes alternativas de software open source
routing, VYATTA es una, o quizs la mejor opcin para disponer de un router de manera
gratuita (solo nos hace falta un ordenador con unas caractersticas mnimas) y con una amplia
gama de posibilidades para el ruteo de datos y la proteccin en la red.

Con VYATTA se puede desplegar arquitecturas complejas de red a un coste muy competitivo
comparado con CISCO o Juniper por ejemplo. Adems, si se necesita de un apoyo, siempre
se puede contratar una suscripcin de soporte.

Por otro lado, ya son miles los usuarios que han decidido utilizar VYATTA, y cuenta con una
comunidad de cientos de usuarios certificados y con muchos renombrados negocios entre sus
clientes comerciales. Todo esto hace que cualquier problema que pueda surgir, se pueda
compartir con otras personas para su rpida solucin.

Debido a todo esto, nos disponemos a probar las diferentes opciones del software VYATTA
para su posterior comparacin con dispositivos CISCO.

A la libertad, por la universidad

Pgina 18

Universidad Nacional Autnoma de Nicaragua UNAN- Len

IV Diseno Metodologico.
Una solucin de Open Source Routing puede sustituir en algn momento a un router real en
un entorno de laboratorio.

Como primer paso se investig diferente software de enrutamiento de cdigo abierto que
existen, que tuvieran capacidad para trabajar con algunos protocolos que se utilizan para
resolver alguna practica asignada en los laboratorios Redes de Computadoras.

Luego de muchas pruebas exhaustiva se lleg a la conclusin de trabajar con VYATTA,


ZEBRA, XORP, QUAGGA, BIRD porque se considera cumplen con la mayora de protocolos
que se implementan en los laboratorios de Redes de Computadoras en el Departamento de
Computacin.

Cabe mencionar que adems de estos hay otros que de igual forman ayuda a realizar
enrutamiento como lo son:

Babel, B.A.T.M.A.N., OpenBGPD,

pero no cumplen los

requerimientos que se necesitan para realizar laboratorios de Redes de Computadoras por no


contar an con las suficientes herramientas de enrutamiento, esto no quiere decir que no
sirvan, simplemente no cumplen con las expectativas que se necesita en este campo.

Luego de comenzar a hacer algunas pruebas para verificar realmente el software que en su
momento fueron seleccionados, se pudo verificar que estos cuentan con los protocolos que se
mencionan, hasta este momento se han probado XORP, QUAQUA y VYATTA.

Cabe mencionar que XORP y QUAGUA son paquetes que se instalan en algn sistema Linux
en este caso se hizo pruebas sobre deban, a diferencia de VYATTA que este tiene su propio
LIVE CD de instalacin.

A la libertad, por la universidad

Pgina 19

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Luego de hacer pruebas se escogi VYATTA debido a que esta es una, o quizs la mejor
opcin para disponer de un router de manera gratuita.

Con VYATTA se puede desplegar arquitecturas complejas de red a un coste muy competitivo
recordemos que este nos brinda

los servicios que se necesitan para estar como si

estuviramos configurando un router real.


Parte de los Servicios con los que VYATTA cuenta:
SSH.
Telnet.
DHCP.
DNS.
NAT.
Web caching.

Enrutamiento bsico:
Polticas de enrutamiento.
RIP.
BGP.
OSPF.

Servicios de seguridad:
Firewall: IPv4, IPv6.

Debido a todo esto, nos disponemos a probar las diferentes opciones del software VYATTA
para su posterior comparacin con dispositivos CISCO.

A la libertad, por la universidad

Pgina 20

V Cronograma de ctividades.
ACTIVIADES

rea de trabajo y tema.


Antecedentes
Definicin del problema.
Justificacin.
Objetivos.
Marco terico.
Tecnologas implementadas
Etapas en las que se divide el trabajo.
Estudio OPEN-SOURCE ROUTING.
Seleccin entre gamas de herramientas.
Prueba sobre las 5 herramientas seleccionadas.
Prueba directa contra un equipo fsico de CISCO.
Generacin de algunas prcticas de laboratorios.
Entrega al 100% y presentacin del proyecto.

MESES(SEMANAS)
Agosto
Septiembre
Octubre
Noviembre Diciembre
Enero Febrero
1 2 3 4 1 2 1 2 1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4 1 2 3

Universidad Nacional Autnoma de Nicaragua UNAN- Len

VI Practicas de Laboratorios.
En esta parte vamos a desarrollar algunas prcticas de laboratorios la cual nos
servir de ayuda para hacer pruebas de configuraciones bsicas y tambin
avanzadas utilizando VYATTA 6.4. Cabe mencionar que todo este escenario es
probado bajo VMWARE WORSTATION 9 y Ubuntu 12.10.

6.1 Prctica # 01
Instalacin y configuracin de Vyatta 6.4 en VMware Workstation 9
a) Primero descargaremos el livecd de Vyatta del sitio web oficial ---- as mismo VMware.
http://www.vyatta.org/downloads
https://my.vmware.com/web/vmware/login
b) Instalar VMware Workstation 9 en nuestro sistema (Ubuntu 12.10).
c) Una vez instalado VMware procederemos a crear nuestra primera mquina virtual
de Vyatta. Ya iniciado VMware seleccionaremos la opcin Create a New Virtual
Machine.

d) Nos abrir la siguiente ventana en la cual seleccionaremos el tipo de configuracin


para nuestra VM (mquina virtual) y dejaremos la opcin por defecto que es la
recomendada:

A la libertad, por la universidad

Pgina 22

Universidad Nacional Autnoma de Nicaragua UNAN- Len

e) El siguiente paso es seleccionar la imagen de Vyatta con la cual instalaremos el


sistema en nuestra VM. Seleccionar Use ISO Image y buscar el Livecd en nuestro
ordenador.

f) Seleccionar el Sistema Operativo de nuestra VM el cual ser Linux y la versin


Deban 6.

g) Luego nos pedir el nombre de nuestra VM, la cual nombraremos R1. Tambin en
este paso podremos cambiar la localidad de nuestra VM, es recomendable dejar la
ruta por defecto o bien cambiarla si as lo gustan.

A la libertad, por la universidad

Pgina 23

Universidad Nacional Autnoma de Nicaragua UNAN- Len

h) Establecer el tamao mximo del disco. Le asignaremos un tamao de 8 GB (8.000).

i) La siguiente ventana nos mostrara las caractersticas o configuraciones de nuestra VM.

A la libertad, por la universidad

Pgina 24

Universidad Nacional Autnoma de Nicaragua UNAN- Len


j) Luego, ya que el tamao de memoria asignado por defecto es de 512 MB, lo
cambiamos a 128 MB ya que con esta capacidad de memoria es suficiente para

poner en marcha vyatta. Seleccionaremos el botn Customize Hardware, el cual


nos mostrara la siguiente ventana, en donde asignaremos la cantidad de memoria
antes mencionada:

k) Una vez finalizado este paso ya estamos listo para iniciar nuestra VM, la cual
iniciara automticamente al finalizar con la anterior configuracin. Tanto el usuario
como la contrasea sern Vyatta. Y luego se proceder con la instalacin del
sistema en el disco Duro de nuestra VM.

l) Ya dentro de la Vyatta necesitamos ser el usuario root para proceder con la


instalacin del SO. Para lo cual ejecutaremos los siguientes comandos:
1) Iniciar como el usuario root: sudo su.
A la libertad, por la universidad

Pgina 25

Universidad Nacional Autnoma de Nicaragua UNAN- Len


2) Instalar el Sistema: install system.
3) Responder Yes a la pregunta que a continuacin se presenta.

m) Luego nos preguntara si queremos que las particiones del

disco se realicen

automticamente o si queremos realizarlo manual, solo daremos enter ya q no


queremos particionar la unidad. Encontrar una nica particin y daremos enter
nuevamente para que en esta se instale el sistema.

n) Nos informara que el siguiente paso destruir todos los datos y si deseamos
continuar, respondemos yes, y presionamos enter una vez ms para indicar
que deseamos ocupar todo el tamao del disco para la instalacin.

A la libertad, por la universidad

Pgina 26

Universidad Nacional Autnoma de Nicaragua UNAN- Len


o) Cuando la instalacin del sistema de archivos finalice nos mostrara el archivo
de configuracin de Vyatta q se encuentra en el sistema y nos preguntara si de
seleccionar otro, ya que no es el caso solo daremos enter.

p) Luego nos pedir la contrasea para la cuenta del administrador del sistema, e
introducimos una de nuestro agrado.

q) Luego daremos enter para que se instale el GRUB Boot Loader y con esto ya
est nuestro sistema Vyatta instalado en la VM (Mquina Virtual).

A la libertad, por la universidad

Pgina 27

Universidad Nacional Autnoma de Nicaragua UNAN- Len

6.2 Prctica # 02
Configuracin de las interfaces de red de nuestra mquina virtual en VMware
Workstation 9
a) Seguir todos los pasos anteriores y crear otra VM de Vyatta la cual
nombraremos R2, con el propsito de comunicar R1 y R2 a travs de la interfaz
red a configurar.
b) Una vez creada configuraremos una interfaz de red Host only(Adaptador
Anfitrin), para esto en el men Edit seleccionares la opcin Virtual Network
Editor y se nos abrir la siguiente ventana:

c) Clic en el botn Add Network, y luego en la siguiente ventana seleccionamos


Host-Only y en el nombre de la red dejamos el que aparece por defecto que
en este caso ser vmnet1 y le damos en Add.

A la libertad, por la universidad

Pgina 28

Universidad Nacional Autnoma de Nicaragua UNAN- Len

d) Configuraremos la direccin de red a la que pertenece el adaptador la cual ser


192.168.0.0 y deshabilitaremos la asignacin de direcciones por DHCP.

A la libertad, por la universidad

Pgina 29

Universidad Nacional Autnoma de Nicaragua UNAN- Len

e) Encenderemos nuestras VMs tanto R1 como R2 y como usuario root


ejecutaremos el comando ifconfig para ver nuestra interfaz de red de nuestras
maquinas la cual no tendr direccin Ip.

f) Para configurar la direccin IP de nuestra interfaz necesitamos entrar en el


modo configuracin de Vyatta lo cual conseguimos ejecutando como root el
comando configure.

g) Ya en el modo configuracin asignaremos la direccin de nuestra interfaz de


red eth0 para la cual ejecutaremos los comandos que siguen a continuacin,
en el Router R1:
1) Para establecer la direccin de la interfaz eth0:
vyatta@R1:# set interfaces Ethernet eth0 address 192.168.0.10/24
2) Para confirmar la configuracin realizada:
vyatta@R1:# commit
vyatta@R1:# save

A la libertad, por la universidad

Pgina 30

Universidad Nacional Autnoma de Nicaragua UNAN- Len


3) Verificamos nuevamente la direccin de la interfaz, y veremos los cambios.

4) Realizar los mismos pasos para asignar la direccin ip 192.168.0.20 para el


router R2 y mostrar los resultados:
vyatta@R2:# set interfaces Ethernet eth0 address 192.168.0.10/24
vyatta@R2:# commit
vyatta@R2:# save

a. Verificamos la direccin de la interfaz eth0 para R2

5) Ahora realizaremos pruebas de conectividad entre nuestras mquinas virtuales


(ping de R1 a R2 y viceversa).
a. Ping de R1 a R2 (ping 19.168.0.20).

A la libertad, por la universidad

Pgina 31

Universidad Nacional Autnoma de Nicaragua UNAN- Len

b. Ping de R2 a R1 (ping 19.168.0.10).

Con estos pasos ya sabemos cmo comunicar nuestras mquinas virtuales


Vyatta 6.4 en VMware Workstation 9.

A la libertad, por la universidad

Pgina 32

Universidad Nacional Autnoma de Nicaragua UNAN- Len

6.3 Prctica # 03
Implementacin DHCP, NAT, PROXY

Figura1. Implementacin DHCP - NAT

A la libertad, por la universidad

Pgina 33

Universidad Nacional Autnoma de Nicaragua UNAN- Len


En la figura 1 mostramos un esquema muy sencillo el cual fue de mucha utilidad para
comprender configuracin bsica de VYATTA.

Primeramente comenzamos por instalar en una mquina virtual VYATTA, cabe mencionar
en este caso se hicieron pruebas tanto en VirtualBox, como en VMWARE el cual funciono
como se esperaba. Lo primero despus de instalar fue comenzar a configurar 3 interfaces
de Red a VYATTA, cabe recalcar que VirtualBox permite hacer esto utilizando o creando
adaptadores anfitriones.

Al arrancar VYATTA e introducir las credenciales, se muestra lo siguiente:

Es el modo operacional, con el que se pueden realizar tareas como mostrar informacin,
reiniciar y apagar el sistema, etc.

El siguiente paso que habr que mirar ser ver si el equipo acta como router. Aunque esta
opcin viene por defecto activada, se puede comprobar que realmente lo est con la siguiente
instruccin:

A lo que el sistema responde IP forwarding is on. Otra forma seria mostrando el ip_forward
que trae integrado vyatta.

Como se coment en la parte del manual, para realizar cualquier cambio en la configuracin
del router Vyatta, hay que entrar en modo configuracin mediante el comando:

A la libertad, por la universidad

Pgina 34

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Al realizar esa accin, ahora se ver el prompt as

A continuacin, se va a configurar la direccin IP de uno de los interfaces Ethernet. Al


contrario que en CISCO en el que se tena que pasar al modo de configuracin del interfaz
que se quera modificar y despus activarlo, en Vyatta, solamente mediante un comando se
realizar la configuracin.

En donde ethx corresponde al interfaz que se quiera modificar, IP a la direccin de red y


netmask a la mscara de red en formato CIDR.

Para realizar una prueba, se va a realizar el escenario de la figura 2.

Figura2. Configuracin de Interfaz Vyatta

A la libertad, por la universidad

Pgina 35

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Como est basado en GNU/Linux, la manera de nombrar las interfaces de red es mediante
ethX, con X igual a 0 para la primera interfaz que reconoce el sistema, 1 la segunda, etc. Para
saber las interfaces que tiene el router, se ejecutar el comando:

Este comando es muy til, ya que gracias a l se ver el estado de los interfaces, si tienen
asignada una direccin IP y alguna descripcin.

El siguiente paso es configurar las interfaces para asignarles una IP. Por ejemplo, para
asignar la direccin 192.168.0.10/24 a la interfaz eth0, 10.10.0.1/16 a la interfaz eth1,
10.20.0.1/16 a la interfaz eth2.
vyatta@vyatta:# set interfaces Ethernet eth0 address 192.168.0.10/24
vyatta@vyatta:# set interfaces Ethernet eth1 address 10.10.0.1/16
vyatta@vyatta:# set interfaces Ethernet eth2 address 10.20.0.1/16
Se puede configurar distintos parmetros como el nombre del host, el nombre de dominio, etc.

En este punto cabe destacar, que en el modo configuracin, la instruccin set sirve para
marcar cambios, pero stos no se hacen efectivos hasta que no se confirmen con commit.
Esto se hace como medida de seguridad. Con la instruccin show se podrn ver los cambios
que se hayan realizado, y aquellos que no estn confirmados aparecern con un smbolo +
por delante. Para comprobar todos los parmetros que se hayan configurado, se puede
utilizar la instruccin show, esto en modo no privilegiado.

A la libertad, por la universidad

Pgina 36

Universidad Nacional Autnoma de Nicaragua UNAN- Len


En concreto si se quiere ver la configuracin de los interfaces de red en modo privilegiado, se
ver algo como esto:

Como se ve, esta instruccin mostrara todas las caractersticas de las interfaces que se han
configurado. En este caso se muestra las 3 interfaz Ethernet eth0, eth1 y eth2.

Luego asignamos una IP a una PC prueba para verificar que funciona la comunicacin.

A la libertad, por la universidad

Pgina 37

Universidad Nacional Autnoma de Nicaragua UNAN- Len


En la figura anterior vemos que todo funciona correctamente. Ahora lo que vamos hacer
ser configurar un servicio por DHCP para que los equipos que se conecten a nuestro
VYATTA obtengan direccin de forma dinmica. Para eso haremos lo siguiente en
nuestro equipo VYATTA:

Lo que hicimos con los comandos mostrados anteriormente fue crear un dominio o pool
que en este caso le llamamos telemtica y le agregamos una subred 10.10.0.0/16,
adems decimos el rango de direcciones que este asignara en este caso 10.10.0.40 10.10.0.50 por defecto decimos que su Gateway ser 10.10.0.1, tambin tendr un dns
192.136.45.66 y por ultimo agregamos un tiempo de vida o lease a la direccin que
asigne. Ac solamente se muestra que se un solo pool para DHCP pero tendremos que
crear otro para luego verificar que hay comunicacin entre segmentos diferentes de red. A
este otro le llamaremos telemtica es lo mismo pero cambiamos los segmentos de red y
por ltimo es importante enviar las modificaciones que hallamos realizado con el comando
commit.

Ahora vamos verificar como quedo nuestro servicio DHCP configurado, para eso usamos
el siguiente comando:
A la libertad, por la universidad

Pgina 38

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Ahora verificamos que funcione bien en este caso PC1 lo agregamos al adaptador vmnet1
y PC2 al adaptador vmnet2 todo de tipo anfitrin esto en VMWARE, cabe mencionar que
el adaptador anfitrin ayuda a simular como si fuera un Switch.

A la libertad, por la universidad

Pgina 39

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Podemos notar que ambos equipos tienen asignado direccin IP correctamente, tambin
podemos mostrar el Gateway de cada equipo:

Hasta este momento tenemos configurado un servidor DHCP, pero falta algo muy
importante, debemos configurar NAT para que las PC que estn conectadas a nuestro
VYATTA puedan comunicarse entre diferentes segmentos y tambin puedan navegar
hacia internet sin problemas. Antes de continuar configurando NAT vamos a configurar el
servicio SSH en nuestro VYATTA esto para que podamos acceder de forma remota.

A la libertad, por la universidad

Pgina 40

Universidad Nacional Autnoma de Nicaragua UNAN- Len


vyatta@vyatta:# set services ssh port 2022
vyatta@vyatta:# set services allow-root
vyatta@vyatta:# commit
Verificamos lo que hicimos:

Por ultimo accedemos de forma remota, cabe mencionar que para tener mayor seguridad
cambiamos el puerto de acceso que por defecto es el 22.

A la libertad, por la universidad

Pgina 41

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Todo funcion perfectamente ahora seguimos con la configuracin de NAT, para esto lo
haremos usando excluded o exclusiones ya que a veces es deseable excluir los paquetes de
traduccin NAT que responden a ciertos criterios.

Lo primero creamos una regla de control de acceso.


vyatta@vyatta:# set nat source rule 10

Ahora aplicamos la regla a paquetes que vienen desde la direccin 10.0.0.0/8 con destino
192.168.0.0/24 a travs de la interfaz eth0.
vyatta@vyatta:# set nat source rule 10 source address 10.0.0.0/8
vyatta@vyatta:# set nat source rule 10 destination address 192.168.0.0/24
vyatta@vyatta:# set nat source rule 10 outbound-interface eth0

Ahora excluimos paquetes de NAT que vienen incluido en la regla 10.


vyatta@vyatta:# set nat source rule 10 exclude

Ahora creamos otra regla de acceso (20) y aplicamos la regla a paquetes que vienen desde la
direccin 10.0.0.0/8 que saldrn a travs de la interfaz eth0.
vyatta@vyatta:# set nat source rule 20
vyatta@vyatta:# set nat source rule 20 source address 10.0.0.0/8
vyatta@vyatta:# set nat source rule 20 outbound-interface eth0
Ahora se hace un enmascaramiento para que permita comunicacin entre segmentos de red y
haga una traduccin de paquetes a travs de la interfaz de salida y guardamos cambios.
vyatta@vyatta:# set nat source rule 20 translation address masquerade
vyatta@vyatta:# commit
Ahora podemos hacer algunas pruebas haciendo ping de las PC pruebas hacia google y gmail
para verificar que NAT est funcionando de forma correcta.

A la libertad, por la universidad

Pgina 42

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Tambin podemos verificar el servicio NAT en VYATTA escribiendo el comando show nat:

A la libertad, por la universidad

Pgina 43

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Ahora vamos a implementar SQUID en Vyatta esto con el fin de bloquear algunas url y
palabras no deseadas en nuestra red.

Lo primero es habilitar el servicio WEBPROXY en nuestro servidor.


vyatta@Central:# set service webproxy
A continuacin, configuramos por cual direccin IP el servicio se mantendr a la escucha de
las peticiones clientes. En nuestro caso, la direccin IP que se encuentra escuchando en la
red interna configurada en nuestro Vyatta es10.10.0.1. Para ello ejecutamos siguiente
comando:
vyatta@Central:# set service webproxy listen-address 10.10.0.1
vyatta@Central:#commit
vyatta@Central:#save

Si no desesemos dicho filtrado y slo un servidor proxy para mejorar el rendimiento de la


conexin a Internet usando la cache almacenada, sera suficiente con los pasos realizados.

El siguiente paso es descargar las listas negras que usar nuestro filtrado Web si las
activsemos. Para poder efectuar dicha descarga tenemos que estar fuera del modo
configuracin y ejecutar el comando update webproxy blacklists y confirmamos el mensaje.

A la libertad, por la universidad

Pgina 44

Universidad Nacional Autnoma de Nicaragua UNAN- Len

vyatta@Central:~$ update webproxy blacklists


vyatta@Central:#
Ahora vamos activar el filtrado Web esto con el fin de bloquear algunas pginas web.
vyatta@Central:# set service webproxy url-filtering squidguard
vyatta@Central:#commit
vyatta@Central:#save
El siguiente paso es configurar nuestro filtrado Web, nosotros activaremos todas las
categoras disponibles en las listas negras, para ello ejecutamos el comando set service
webproxy

url-filtering

squidguard

block-category

all.

Aplicamos

los

cambios

con commit y grabamos la configuracin con save.

vyatta@Central:# set
block-category all

service

webproxy

url-filtering

squidguard

vyatta@Central:#commit
vyatta@Central:#save

Con los pasos que hemos realizado ya tenemos disponible nuestro Vyatta con filtrado Web. Si
deseamos realizar otros tipos de configuraciones podemos utilizar los siguientes comandos
dentro de la sentencia set service webproxy url-filtering squidguard:
Ahora para filtrar www.youtube.com ejecutamos el siguiente comando:
vyatta@Central:# set service
local-block www.youtube.com

webproxy

url-filtering

squidguard

vyatta@Central:#commit
vyatta@Central:#save
Con esto es suficiente para bloquear YouTube, cuando un usuario quiera accede hacia esa
direccin el proxy lo re direccionar hacia google.

A la libertad, por la universidad

Pgina 45

Universidad Nacional Autnoma de Nicaragua UNAN- Len

en la figura anterior podemos observar que hay 3 pginas web bloqueadas y que estas
cuando quieran estas Re direccionadas hacia google. Cabe mencionar que no solamente se
pueden bloquear URL ac tenemos un ejemplo donde tenemos bloqueadas 1 palabra en este
caso simplemente anexamos keyword al final del comando anterior.
vyatta@Central:# set service
local-block keyword porno

webproxy

url-filtering

squidguard

vyatta@Central:#commit
vyatta@Central:#save
Listo con esto ya tenemos funcional nuestro servidor proxy...

A la libertad, por la universidad

Pgina 46

Universidad Nacional Autnoma de Nicaragua UNAN- Len

6.4 Prctica # 04
Configuracin VLAN implementados con Switch Cisco Catalyst 3560
Para lograr hacer funcional nuestro servidor Vyatta en la implementacin de VLAN
necesitamos contar de algn equipo que pueda hacer la redistribucin de puertos, por tal
razn en este caso lo haremos con un Switch capa3 Catalyst 3560.

Ac solamente vamos a explicar cmo es que funcionan las VLAN cuando lo


configuramos en un equipo que tenga Vyatta instalado, el equipo debe tener al menos 2
interfaz de red.

Sin perder ms tiempo iniciamos por configurar las interfaz en nuestro caso usaremos el
mismo esquema de la prctica anterior pero ahora sobrecargando la interfaz eth1 para la
configuracin de VLAN como se muestra en la siguiente figura.

A la libertad, por la universidad

Pgina 47

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Figura3. Configuracin VLAN con Switch Catalyst 3560

A la libertad, por la universidad

Pgina 48

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Ya se mencionaba que este escenario es el mismo que se utiliz en la practica 1 y 2 por tal
razn no vamos a volver a configurar las interfaz de nuestro servidor VYATTA. Simplemente
nos enfocaremos en la parte de creacin de VLAN y realizaremos algunas pruebas para
verificar que todo es correcto.

a) Primero nos creamos la interfaz de VLAN y asignamos una direccin de red.


vyatta@Central:#
vyatta@Central:#
vyatta@Central:#
vyatta@Central:#

set interfaces Ethernet eth1 vif 20 address 10.20.0.254/16


set interfaces Ethernet eth1 vif 30 address 10.30.0.254/16
commit
save

Podemos verificar que las VLAN se crearon correctamente con el comando show
interfaces

b) Es necesario crear unos pool con dhcp para que cundo se asignen las vlan a un puerto
predeterminado no se est escribiendo direcciones estticas en las PC.
vyatta@Central:# set service
start 10.20.0.50 stop 10.20.0.60
vyatta@Central:# set service
default-router 10.20.0.254
vyatta@Central:# set service
dns-server 192.136.45.66
vyatta@Central:# set service
dns-server 200.85.160.4
vyatta@Central:# set service
lease 86400

dhcp-server shared-network-name Vlan20 network 10.20.0.0/16


dhcp-server shared-network-name Vlan20 network 10.20.0.0/16
dhcp-server shared-network-name Vlan20 network 10.20.0.0/16
dhcp-server shared-network-name Vlan20 network 10.20.0.0/16
dhcp-server shared-network-name Vlan20 network 10.20.0.0/16

A la libertad, por la universidad

Pgina 49

Universidad Nacional Autnoma de Nicaragua UNAN- Len


vyatta@Central:# set service
start 10.30.0.50 stop 10.30.0.60
vyatta@Central:# set service
default-router 10.30.0.254
vyatta@Central:# set service
dns-server 192.136.45.66
vyatta@Central:# set service
dns-server 200.85.160.4
vyatta@Central:# set service
lease 86400
vyatta@Central:# commit
vyatta@Central:# save

dhcp-server shared-network-name Vlan30 network 10.30.0.0/16


dhcp-server shared-network-name Vlan30 network 10.30.0.0/16
dhcp-server shared-network-name Vlan30 network 10.30.0.0/16
dhcp-server shared-network-name Vlan30 network 10.30.0.0/16
dhcp-server shared-network-name Vlan30 network 10.30.0.0/16

Ahora ya tenemos asignacin dinmica para las VLAN que creamos anteriormente.
NOTA:
Ya que tenemos creadas nuestras vlan no necesitamos hacer en el puerto eth1 ningn
mode trunk en la parte de Vyatta como se hace con Cisco.

c) Configurar el Switch Catalyst 3560 para distribuir las vlan que creamos en Vyatta.

Lo primero que haremos ser configurar un puerto para recibir las vlan que se crearon en
Vyatta. En nuestro caso configuramos FasEthernet0/2 pero puedes configurar el que t
gustes.
cisco(config)# interface FastEthernet0/2
cisco(config-if)# switchport trunk encapsulation dot1q
cisco(config-if)# switchport mode trunk
cisco(config-if)# do wr
Ahora configuramos el resto de puertos para distribuir las Vlan en este caso los puertos
del 3-4 pertenecern a la Vlan20 y los puertos 5-7 a la Vlan30.
cisco(config)# interface range FastEthernet0/3-4
cisco(config-if)# switchport mode trunk
cisco(config-if)# switchport access vlan20

A la libertad, por la universidad

Pgina 50

Universidad Nacional Autnoma de Nicaragua UNAN- Len


cisco(config)# interface range FastEthernet0/5-7
cisco(config-if)# switchport mode trunk
cisco(config-if)# switchport access vlan30
cisco(config-if)# do wr
Podemos verificar que la configuracin del Switcher es correcta con el comando show
running

d) Ahora

A la libertad, por la universidad

Pgina 51

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Podemos observar que en la configuracin del Router no hay nada ms configurado que las
contraseas para acceder de forma remota y las interfaces con la que tiene el Router.

e) Conecta una PC al puerto 3 o 4 y verifica que direccin IP asigna.

Primeramente lo conectamos al puerto 3 y al verificar la interfaz de red nos retorna lo


siguiente.

A la libertad, por la universidad

Pgina 52

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Podemos observar que nos asign 10.20.0.50/16 y ahora verificamos nuestro Gateway y
veremos que nos retorna 10.20.0.254.

f) Conecta una PC al puerto 5, 6 o 7 y verifica que direccin IP asigna.

Conectamos al puerto 5 y al verificar la interfaz de red nos retorna lo siguiente.

A la libertad, por la universidad

Pgina 53

Universidad Nacional Autnoma de Nicaragua UNAN- Len


g) Realiza un ping desde cualquiera de las Vlan conectadas y verifica que navegas a internet
sin ningn problema.

Excelente todo funciona muy bien!!!

6.5 Prctica # 05
Configuracin de Protocolos de Encaminamiento BGP-RIP-OSPF
1. Escenario de red utilizando RIP, OSPF y BGP
En esta prctica se pretende hacer una simulacin de mltiples ISPs usando distintos
protocolos de encaminamientos para lograr comunicacin entre cada uno de estos
implementando exportacin e importacin de sus tablas de enrutamiento.

Se desea para crear un escenario de red como el que se muestra en la figura 4. En esta
figura hay cuatro AS (Sistemas Autnomos): AS10, AS20, AS30 y AS40. Se ha configurado
OSPF y BGP dentro de AS10, BGP y RIP dentro de AS20 y AS30 y por ultimo RIP dentro de
AS40 y se desea configurar estos protocolos para conectar los 4 sistemas autnomos.

A la libertad, por la universidad

Pgina 54

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Figura4. Implementacin
Protocolos Enrutamiento
BGP-OSPF-RIP
A la libertad, por la universidad

Pgina 55

Universidad Nacional Autnoma de Nicaragua UNAN- Len


1.1 Configuracin de los Router de AS10.
a) Como primer paso debemos asignarle una direccin IP a cada uno de los Router junto
con su mscara y el Loopback al que pertenece.
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#

set
set
set
set

interfaces
interfaces
interfaces
interfaces

Ethernet
Ethernet
Ethernet
Loopback

eth0 address 10.0.30.254/24


eth1 address 10.0.20.254/24
eth2 address 10.0.100.254/24
lo address 10.0.0.1/32

vyatta@R2:# set interfaces Ethernet eth0 address 10.0.20.253/24


vyatta@R2:# set interfaces Ethernet eth1 address 10.0.40.254/24
vyatta@R2:# set interfaces Loopback lo address 10.0.0.2/32
vyatta@R3:# set interfaces Ethernet eth0 address 10.0.30.253/24
vyatta@R3:# set interfaces Ethernet eth1 address 10.0.50.254/24
vyatta@R3:# set interfaces Loopback lo address 10.0.0.3/32
b) Configurar R1 para usar el protocolo OSPF pero adems que este pueda redistribuir todo
paquete que llegue hacia l.
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#
vyatta@R1:#

set protocols
set protocols
set protocols
set protocols
set protocols
set protocols
set protocols
commit
save

ospf
ospf
ospf
ospf
ospf
ospf
ospf

area 0.0.0.11 network 10.0.20.0/24


area 0.0.0.11 network 10.0.30.0/24
area 0.0.0.11 network 10.0.100.0/24
area 0.0.0.11 network 10.0.0.1/32
parameters abr-type cisco
parameters router-id 10.0.0.1
redistribute connected metric-type 2

c) Configurar R2 para usar el protocolo OSPF pero adems que este pueda redistribuir todo
paquete que llegue hacia l a travs del protocolo BGP.
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#

set protocols
set protocols
set protocols
set protocols
set protocols
set protocols
commit
save

ospf
ospf
ospf
ospf
ospf
ospf

area 0.0.0.11 network 10.0.20.0/24


area 0.0.0.11 network 10.0.0.2/32
parameters abr-type cisco
parameters router-id 10.0.0.2
redistribute connected
redistribute bgp

A la libertad, por la universidad

Pgina 56

Universidad Nacional Autnoma de Nicaragua UNAN- Len


d) Configuramos R3 para encaminar por OSPF y adems hacer que este redistribuya su
tabla de enrutamiento a travs de BGP.
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#

set protocols
set protocols
set protocols
set protocols
set protocols
set protocols
commit
save

ospf
ospf
ospf
ospf
ospf
ospf

area 0.0.0.11 network 10.0.30.0/24


area 0.0.0.11 network 10.0.0.3/32
parameters abr-type cisco
parameters router-id 10.0.0.3
redistribute connected
redistribute bgp

e) Configurar R2 para encaminar paquetes a travs del protocolo BGP y tambin hacer que
este redistribuya su tabla de enrutamiento a travs de OSPF y BGP.

Para resolver este el inciso anterior primero debemos crear algunas listas de acceso que nos
permitirn comunicar un protocolo con otro para finalmente lograr que puedan llegar paquetes
de una red hacia otra sin importar el protocolo que tenga en su extremo configurado cada
enrutador.
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
100
vyatta@R2:#

set policy access-list 100 rule 10 action permit


set policy access-list 100 rule 10 destination any
set policy access-list 100 rule 10 source any
set policy access-list 150 rule 10 action permit
set policy access-list 150 rule 10 destination any
set policy access-list 150 rule 10 source inverse-mask 0.0.0.255
set policy access-list 150 rule 10 source network 10.0.20.0
set policy route-map SET-MED rule 10 action permit
set policy route-map SET-MED rule 10 match ip address access-list 150
set policy route-map SET-MED rule 10 set metric 1000
set policy route-map SET-MED rule 20 action permit
set policy route-map SET-MED rule 20 match ip address access-list 100
set policy route-map SET-LOCAL-PREF rule 10 action permit
set policy route-map SET-LOCAL-PREF rule 10 match ip address access-list
set policy route-map SET-LOCAL-PREF rule 10 set local-preference 333

Ahora que ya tenemos nuestras polticas de acceso podemos configurar BGP para importar y
exportar las tablas de enrutamiento de OSPF configurado en R2.

A la libertad, por la universidad

Pgina 57

Universidad Nacional Autnoma de Nicaragua UNAN- Len


vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#
vyatta@R2:#

f)

set
set
set
set
set
set
set
set

protocols
protocols
protocols
protocols
protocols
protocols
protocols
protocols

bgp 10
bgp 10
bgp 10
bgp 10
bgp 10
bgp 10
bgp 10
bgp 10

neighbor 10.0.30.253 remote-as 10


neighbor 10.0.30.253 route-map import SET-LOCAL-PREF
neighbor 10.0.40.253 nexthop-self
neighbor 10.0.40.253 remote-as 20
neighbor 10.0.40.253 route-map export SET -MED
parameters router-id 10.0.0.2
redistribute connected
redistribute ospf

Configuramos R3 para encaminar paquetes a travs del protocolo BGP y tambin hacer

que este redistribuya su tabla de enrutamiento a travs de OSPF y BGP.

Igual que el apartado anterior debemos crear algunas listas de acceso que nos permitirn
comunicar un protocolo con otro para finalmente lograr que puedan llegar paquetes de una
red hacia otra sin importar el protocolo que tenga en su extremo configurado cada enrutador.
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#

set policy access-list 100 rule 10 action permit


set policy access-list 100 rule 10 destination any
set policy access-list 100 rule 10 source any
set policy access-list 150 rule 10 action permit
set policy access-list 150 rule 10 destination any
set policy access-list 150 rule 10 source inverse-mask 0.0.0.255
set policy access-list 150 rule 10 source network 10.0.30.0
set policy route-map SET-MED rule 10 action permit
set policy route-map SET-MED rule 10 match ip address access-list 150
set policy route-map SET-MED rule 10 set metric 2000
set policy route-map SET-MED rule 20 action permit
set policy route-map SET-MED rule 20 match ip address access-list 100
set policy route-map SET-LOCAL-PREF rule 10 action permit
set policy route-map SET-LOCAL-PREF rule 10 match ip address access-list100
set policy route-map SET-LOCAL-PREF rule 10 set local-preference 222

Ahora que ya tenemos nuestras polticas de acceso podemos configurar BGP para importar y
exportar las tablas de enrutamiento de OSPF configurado en R3.
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#
vyatta@R3:#

set
set
set
set
set

protocols
protocols
protocols
protocols
protocols

bgp
bgp
bgp
bgp
bgp

10
10
10
10
10

neighbor
neighbor
neighbor
neighbor
neighbor

10.0.20.253
10.0.20.253
10.0.50.253
10.0.50.253
10.0.50.253

remote-as 10
route-map import SET-LOCAL-PREF
nexthop-self
remote-as 30
route-map export SET -MED

A la libertad, por la universidad

Pgina 58

Universidad Nacional Autnoma de Nicaragua UNAN- Len


vyatta@R3:# set protocols bgp 10 parameters router-id 10.0.0.3
vyatta@R3:# set protocols bgp 10 redistribute connected
vyatta@R3:# set protocols bgp 10 redistribute ospf

g) Verificar las interfaz de red de R1 - R2 - R3 con el comando show interfaces.

R1

R2

A la libertad, por la universidad

Pgina 59

Universidad Nacional Autnoma de Nicaragua UNAN- Len

R3

h) Usa el comando show protocols en R1 y explica su contenido.

Con el comando show protocols podemos observar el protocolo que tiene configurado R1,
vemos que es OSPF y este nos muestra las redes que este conoce adems nos muestra el
identificado asignado y por ultimo pues la redistribucin de rutas que este tiene que aplicar.

A la libertad, por la universidad

Pgina 60

Universidad Nacional Autnoma de Nicaragua UNAN- Len


i)

Usa el comando show protocols bgp en R2 y explica su contenido.

Podemos observar que este tiene configurado el protocolo BGP y nos muestra algunas rutas
que este importa o exporta de otra red. Adems vemos cuales son las redes vecinas que tiene
configurado y tambin el sistema autnomo al que pertenece y por ultimo vemos que se hace
una redistribucin de BGP a OSPF.

A la libertad, por la universidad

Pgina 61

Universidad Nacional Autnoma de Nicaragua UNAN- Len


j)

Usa el comando show protocols ospf en R2 y explica su contenido.

Cabe mencionar que R2 tambin tiene configurado el protocolo OSPF este para poder
comunicarse con R1, ac se muestra las redes que este conoce, el identificador que tiene y
una redistribucin de protocolos entre OSPF y BGP esto para poder exportar e importar las
tablas de enrutamiento de cada Router.
k) Usa el comando show protocols bgp en R3 y explica su contenido.

Podemos observar que este tiene configurado el protocolo BGP y nos muestra algunas rutas
que este importa o exporta de otra red. Adems vemos cuales son las redes vecinas que tiene
configurado y tambin el sistema autnomo al que pertenece y por ultimo vemos que se hace
una redistribucin de BGP a OSPF.

A la libertad, por la universidad

Pgina 62

Universidad Nacional Autnoma de Nicaragua UNAN- Len

l)

Usa el comando show protocols ospf en R3 y explica su contenido

A la libertad, por la universidad

Pgina 63

Universidad Nacional Autnoma de Nicaragua UNAN- Len

Observamos que est configurado el protocolo OSPF este para poder comunicarse con R1,
ac se muestra las redes que este conoce, el identificador que tiene y una redistribucin de
protocolos entre OSPF y BGP esto para poder exportar e importar las tablas de enrutamiento
de cada Router.

m) Verifica la tabla de enrutamiento de R1 y explica su contenido.


Usando el comando show ip route podemos ver las rutas que se guardan en la tabla de
enrutamiento de R1, ac nos muestra que rutas aprendi mediante el protocolo OSPF y nos
dice hasta la interfaz por la cual aprendi esa ruta.

A la libertad, por la universidad

Pgina 64

Universidad Nacional Autnoma de Nicaragua UNAN- Len

n) Verifica la tabla de enrutamiento de R2 y explica su contenido.


Usando el comando show ip route podemos saber cul es la tabla de enrutamiento que
tiene R3, esta nos mostrara cuales son las rutas que estn directamente conectadas haca
el, adems muestra que aprendi rutas mediante BGP y OSPF a travs de alguna de las
interfaces que tiene R3.

o) Verifica la tabla de enrutamiento de R3 y explica su contenido.

R3 aprende rutas mediante OSPF

y muestra por cual interfaz esta aprendi esta ruta.

Tambin este tiene guardada rutas a travs del protocolo BGP, es ac donde tiene mucha
importancia la parte de exportar rutas y por eso mismo fue que se crearon algunas listas de
acceso para la configuracin de BGP en R2 y R3.

A la libertad, por la universidad

Pgina 65

Universidad Nacional Autnoma de Nicaragua UNAN- Len

1.2 Configuracin de los Router de AS20.


a) Primero debemos asignarle una direccin IP a cada uno de los Router junto con su
mscara y el Loopback al que pertenece.
vyatta@R4:# set interfaces Ethernet eth0 address 10.0.40.253/24
vyatta@R4:# set interfaces Ethernet eth1 address 10.0.60.254/24
vyatta@R4:# set interfaces Loopback lo address 10.0.0.4/32
b) Ahora configuramos R4 para encaminar paquetes a travs del protocolo BGP para
redistribuir todo paquete que llegue hacia l y que venga tanto as AS10 como de AS30 o
AS40.

Primero comenzamos configurando BGP y hacemos redistribucin de paquetes de RIP ya que


este es el otro protocolo que tendremos configurado en este Router.

A la libertad, por la universidad

Pgina 66

Universidad Nacional Autnoma de Nicaragua UNAN- Len


vyatta@R4:#
vyatta@R4:#
vyatta@R4:#
vyatta@R4:#

set
set
set
set

protocols
protocols
protocols
protocols

bgp
bgp
bgp
bgp

20
20
20
20

neighbor 10.0.40.254 remote-as 10


parameters router-id 10.0.0.4
redistribute connected
redistribute rip

Ahora configuramos RIP en R4 y hacemos redistribucin de paquetes que vengan a travs de


BGP
vyatta@R4:#
vyatta@R4:#
vyatta@R4:#
vyatta@R4:#

set
set
set
set

protocols
protocols
protocols
protocols

rip
rip
rip
rip

network 10.0.60.0/24
network 10.0.0.4/32
redistribute connected
redistribute bgp

c) Usa el comando show protocols en R4 y explica su contenido

Ac vemos que simplemente estn configurado RIP y BGP pero no hay ninguna lista de
acceso para poder comunicar RIP y BGP como se hizo en el apartado anterior, esto se debe a

A la libertad, por la universidad

Pgina 67

Universidad Nacional Autnoma de Nicaragua UNAN- Len


que RIP es un protocolo ms vulnerable. Tambin observamos las redes vecina que tiene R4
que en este caso ser R2 y R6.

d) Verifica la tabla de enrutamiento de R4 y explica su contenido.

Usando el comando show ip route en R4 podemos observar cuales son las rutas que estn en
la tabla de enrutamiento, vemos que este guarda rutas aprendida mediante el protocolo RIP y
BGP adems nos dice hasta la interfaz por la cual aprendi esa ruta el enrutador.

e) Verifica haciendo ping entre R1 y R4 para saber si todo funciona correctamente en el


enrutamiento de protocolos.

A la libertad, por la universidad

Pgina 68

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Cabe mencionar que todo funciona correctamente vemos que los tiempos de llegada son muy
buenos y no hay ninguna prdida de paquetes de R1 a R4.
1.3 Configuracin de los Router de AS30.
a) Primero debemos asignarle una direccin IP a cada uno de los Router junto con su
mscara y el Loopback al que pertenece.
vyatta@R5:# set interfaces Ethernet eth0 address 10.0.50.253/24
vyatta@R5:# set interfaces Ethernet eth1 address 10.0.70.254/24
vyatta@R5:# set interfaces Loopback lo address 10.0.0.5/32
b) Configurar R5 para encaminar paquetes a travs del protocolo BGP para redistribuir todo
paquete que llegue hacia l y que venga tanto as AS10 como de AS30 o AS40.

Primero comenzamos configurando BGP y hacemos redistribucin de paquetes de RIP ya que


este es el otro protocolo que tendremos configurado en este Router.
vyatta@R5:#
vyatta@R5:#
vyatta@R5:#
vyatta@R5:#

set
set
set
set

protocols
protocols
protocols
protocols

bgp
bgp
bgp
bgp

30
30
30
30

neighbor 10.0.50.254 remote-as 10


parameters router-id 10.0.0.5
redistribute connected
redistribute rip

Ahora configuramos RIP en R5 y hacemos redistribucin de paquetes que vengan a travs de


BGP
vyatta@R5:#
vyatta@R5:#
vyatta@R5:#
vyatta@R5:#

set
set
set
set

protocols
protocols
protocols
protocols

rip
rip
rip
rip

network 10.0.70.0/24
network 10.0.0.5/32
redistribute connected
redistribute bgp

c) Usa el comando show protocols en R5 y explica su contenido.

Pues podemos observar que R5 tiene configurado BGP y RIP pero ac la configuracin se
hizo sin hacer uso de ninguna lista de acceso debido a que al hacer exportacin de red de
BGP a RIP y viceversa debido a que RIP es un protocolo de encaminamiento ms vulnerable
no es necesario hacer ninguna lista, es suficiente con que se conozcan cules sern los
vecinos de R5 y hacer la redistribucin de protocolos.
A la libertad, por la universidad

Pgina 69

Universidad Nacional Autnoma de Nicaragua UNAN- Len

d) Verifica la tabla de enrutamiento de R5 y explica su contenido.


Usando el comando show ip route en R5 podemos ver la tabla de enrutamiento de este
Router, ac nos muestra que hay rutas aprendidas mediante RIP y BGP, tambin podemos
observar cuales son las redes conectadas directamente hacia l y por cual interfaz aprendi
este estas rutas.

A la libertad, por la universidad

Pgina 70

Universidad Nacional Autnoma de Nicaragua UNAN- Len

e) Verifica haciendo ping R1 a R5 para saber si la exportacin de tablas de enrutamiento es


correcto.

Cabe mencionar que todo funciona correctamente vemos que los tiempos de llegada son muy
buenos y no hay ninguna prdida de paquetes de R1 a R5.

A la libertad, por la universidad

Pgina 71

Universidad Nacional Autnoma de Nicaragua UNAN- Len


1.4 Configuracin de los Router de AS40.
a) Primero debemos asignarle una direccin IP a cada uno de los Router junto con su
mscara y el Loopback al que pertenece.
vyatta@R6:# set interfaces Ethernet eth0 address 10.0.60.253/24
vyatta@R6:# set interfaces Ethernet eth1 address 10.0.70.253/24
vyatta@R6:# set interfaces Loopback lo address 10.0.0.6/32
b) Ahora configuramos R6 para encaminar paquetes a travs del protocolo RIP y hacemos
que redistribuya paquetes del mismo.
vyatta@R6:#
vyatta@R6:#
vyatta@R6:#
vyatta@R6:#
vyatta@R6:#

set
set
set
set
set

protocols
protocols
protocols
protocols
protocols

rip
rip
rip
rip
rip

network 10.0.60.0/24
network 10.0.70.0/24
network 10.0.0.6/32
redistribute connected
redistribute bgp

c) Usa el comando show protocols en R6 y explica su contenido.

Vemos que RIP es el protocolo ms vulnerable y sencillo de configurar, pues solamente


pasamos las redes vecinas y le decimos que cualquier paquete que pase por ac lo
redistribuya con BGP esto para poder llegar hasta R1 de ser posible.

A la libertad, por la universidad

Pgina 72

Universidad Nacional Autnoma de Nicaragua UNAN- Len


d) Verifica la tabla de enrutamiento de R6 y explica su contenido.

Como podemos observar R6 conoce todas las rutas que estn distribuidas, tambin vemos
que estas rutas son aprendidas mediante el protocolo RIP y a travs de que interfaz de
aprendieron,

e) Verifica haciendo ping R6 a R1 para saber si los paquetes llegan correctamente.

A la libertad, por la universidad

Pgina 73

Universidad Nacional Autnoma de Nicaragua UNAN- Len


Podemos observar que todo funciona correctamente vemos que los tiempos de llegada son
muy buenos y no hay ninguna prdida de paquetes de R6 a R1 y de igual forma funciona de
R1 a R6 como se muestra en la siguiente figura.

A la libertad, por la universidad

Pgina 74

Universidad Nacional Autnoma de Nicaragua UNAN- Len

VII Conclusiones y Futuros Trabajos


Una vez finalizada y probado el sistema se ha llegado a la siguiente conclusin:
1) Se analiz y comparo detenidamente las distintas herramientas de Open Source
Routing y la seleccin fue Vyatta por las funciones ya descritas.

2) El sistema Vyatta es una potente herramienta de Open Source Routing ya que facilita
todo los aspectos relacionados, tanto en la parte de Switching, Enrutamiento,
Aplicaciones, as como seguridad de la red.
3) Tambin decir que las pruebas realizadas en el proyecto son a un nivel de laboratorio,
por lo que los resultados no se pueden comparar con los que resultaran en una gran
empresa en dnde un router tiene que manejar millones de paquetes.
4) Despus de haber realizado las prcticas de laboratorio de Redes, se puede
comprobar que a travs del sistema Vyatta es posible realizar todas las configuraciones
que antes se hacan en Cisco, y por lo tanto realizar los mismos escenarios.
LNEAS DE TRABAJO FUTUROS.
Al finalizar este trabajo se proponen las siguientes lneas de trabajo:
1) A partir de las implementaciones bsicas que se realizaron, se pueden plantear
prcticas de laboratorios ms complejas.

2) Actualizar las prcticas de laboratorios ya realizadas con las nuevas versiones de


VYATTA.
3) Montar escenarios complejos combinando VYATTA con otras tecnologas tales como:
CISCO, DELL, Pfsense, Zeroshell, etc.

A la libertad, por la universidad

Pgina 75

Universidad Nacional Autnoma de Nicaragua UNAN- Len

VIII Bibliograf a.
http://opensourcerouting.org/
http://www.nongnu.org/quagga/
http://www.vyatta.com/
http://sw-libre.blogspot.com/2010/11/netgui-un-simulador-de-redes-libre-con.html
http://www.xorp.org/
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_RoutingPolicies_R6
.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_RIP_R6.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_BGP_R6.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_OSPF_R6.3_v01.p
df
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_Firewall_R6.3_v01.
pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_Security_R6.3_v01.
pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_VPN_R6.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_QoS_R6.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_RemoteAccessAPI
2.0_R6.3_v01.pdf
http://www.vyatta.com/downloads/documentation/VC6.4/Vyatta_WANInterfaces_R6
.3_v01.pdf

A la libertad, por la universidad

Pgina 76