You are on page 1of 15

R23(config)#do sh run

Building configuration...
Current configuration : 2549 bytes
!
! Last configuration change at 18:49:47 CET Wed Sep 2 2015
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
ip name-server 192.168.1.200
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!

!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.23.23.23 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Ethernet2/0
no ip address
shutdown
!
interface Ethernet2/1
no ip address
shutdown
!
interface Ethernet2/2
no ip address
shutdown
!
interface Ethernet2/3
no ip address

shutdown
!
interface Ethernet3/0
no ip address
shutdown
!
interface Ethernet3/1
no ip address
shutdown
!
interface Ethernet3/2
no ip address
shutdown
!
interface Ethernet3/3
no ip address
shutdown
!
interface Serial4/0
ip address 134.56.78.10 255.255.255.252
ip nat outside
ip virtual-reassembly in
encapsulation ppp
serial restart-delay 0
!
interface Serial4/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 3
network 192.23.23.23 0.0.0.0 area 3
network 192.168.1.1 0.0.0.0 area 3
default-information originate always
!
router bgp 65103
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 134.56.78.9 remote-as 12345
!
address-family ipv4
redistribute ospf 3
neighbor 134.56.78.9 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server

no ip http secure-server
ip dns server
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static tcp 134.56.78.10 23 192.168.1.1 8080 extendable
ip route 0.0.0.0 0.0.0.0 134.56.78.9
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
transport input none
!
!
end
R23(config)# wr
^
% Invalid input detected at '^' marker.
R23(config)#do wr
Building configuration...
[OK]
R23(config)#do sh run
Building configuration...
Current configuration : 2549 bytes
!
! Last configuration change at 18:49:47 CET Wed Sep 2 2015
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60

no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
ip name-server 192.168.1.200
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.23.23.23 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address

shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Ethernet2/0
no ip address
shutdown
!
interface Ethernet2/1
no ip address
shutdown
!
interface Ethernet2/2
no ip address
shutdown
!
interface Ethernet2/3
no ip address
shutdown
!
interface Ethernet3/0
no ip address
shutdown
!
interface Ethernet3/1
no ip address
shutdown
!
interface Ethernet3/2
no ip address
shutdown
!
interface Ethernet3/3
no ip address
shutdown
!
interface Serial4/0
ip address 134.56.78.10 255.255.255.252
ip nat outside
ip virtual-reassembly in
encapsulation ppp

serial restart-delay 0
!
interface Serial4/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 3
network 192.23.23.23 0.0.0.0 area 3
network 192.168.1.1 0.0.0.0 area 3
default-information originate always
!
router bgp 65103
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 134.56.78.9 remote-as 12345
!
address-family ipv4
redistribute ospf 3
neighbor 134.56.78.9 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip dns server
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static tcp 134.56.78.10 23 192.168.1.1 8080 extendable
ip route 0.0.0.0 0.0.0.0 134.56.78.9
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4

login
transport input none
!
!
end
R7#sh run
Building configuration...
Current configuration : 4243 bytes
!
! Last configuration change at 17:29:36 CET Wed Sep 2 2015
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
ip dhcp excluded-address 172.16.100.1 172.16.100.199
ip dhcp excluded-address 172.16.100.201 172.16.100.254
!
ip dhcp pool VLAN100
network 172.16.100.0 255.255.255.0
domain-name VLAN100.com
default-router 172.16.100.1
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!

!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
crypto isakmp policy 10
encr 3des
authentication pre-share
crypto isakmp key cisco address 0.0.0.0
!
!
crypto ipsec transform-set 3dessha esp-3des esp-sha-hmac
mode transport
!
crypto ipsec profile CCIE
set transform-set 3dessha
!
!
!
!
!
!
!
interface Loopback0
ip address 172.7.7.7 255.255.255.255
!
interface Loopback1
ip address 172.247.1.1 255.255.255.255
!
interface Tunnel10
bandwidth 1000
ip address 172.247.247.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp map 172.247.247.2 192.168.1.2
ip nhrp map multicast 192.168.1.2
ip nhrp network-id 200
ip nhrp holdtime 300
ip nhrp nhs 172.247.247.2
ip nhrp registration timeout 60
ip tcp adjust-mss 1360
ip ospf network broadcast
tunnel source Ethernet0/0.123
tunnel mode gre multipoint
tunnel key 200
tunnel protection ipsec profile CCIE
!
interface Ethernet0/0

no ip address
!
interface Ethernet0/0.123
encapsulation dot1Q 123
ip address 123.45.67.22 255.255.255.252
!
interface Ethernet0/0.124
encapsulation dot1Q 124
ip address 124.45.67.22 255.255.255.252
!
interface Ethernet0/0.125
encapsulation dot1Q 125
ip address 125.45.67.22 255.255.255.252
!
interface Ethernet0/1
ip address 172.16.1.1 255.255.255.252
ip access-group 10 in
!
interface Ethernet0/2
ip address 172.16.0.5 255.255.255.252
!
interface Ethernet0/3
ip address 172.16.1.9 255.255.255.252
!
interface Ethernet1/0
no ip address
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Ethernet2/0
no ip address
shutdown
!
interface Ethernet2/1
no ip address
shutdown
!
interface Ethernet2/2
no ip address
shutdown
!
interface Ethernet2/3
no ip address
shutdown
!
interface Ethernet3/0
no ip address
shutdown
!

interface Ethernet3/1
no ip address
shutdown
!
interface Ethernet3/2
no ip address
shutdown
!
interface Ethernet3/3
no ip address
shutdown
!
router ospf 4
router-id 172.7.7.7
network 123.45.67.22 0.0.0.0 area 0
network 172.7.7.7 0.0.0.0 area 0
network 172.16.0.5 0.0.0.0 area 0
network 172.16.1.1 0.0.0.0 area 0
network 172.16.1.9 0.0.0.0 area 0
network 172.247.1.1 0.0.0.0 area 0
network 172.247.247.1 0.0.0.0 area 0
default-information originate always
!
router bgp 65100
bgp router-id 172.7.7.7
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 123.45.67.21 remote-as 12345
neighbor 124.45.67.21 remote-as 12345
neighbor 125.45.67.21 remote-as 12345
!
address-family ipv4
network 172.7.7.7 mask 255.255.255.255
redistribute connected
redistribute static
neighbor 123.45.67.21 activate
neighbor 123.45.67.21 default-originate
neighbor 124.45.67.21 activate
neighbor 125.45.67.21 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list DMVPN interface Ethernet0/0.123 overload
ip nat inside source static esp 123.45.67.21 interface Ethernet0/0.123
ip nat inside source static udp 123.45.67.21 500 interface Ethernet0/0.123 500
ip nat inside source static udp 123.45.67.21 4500 interface Ethernet0/0.123 4500
ip route 172.16.100.0 255.255.255.0 172.16.1.10
ip route 172.16.200.0 255.255.255.0 172.16.1.2
!
ip access-list extended DMVPN
permit ip 123.45.67.20 0.0.0.3 any
!
!
!
access-list 10 permit any

!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
transport input none
!
!
end
R21#sh run
Building configuration...
Current configuration : 2599 bytes
!
! Last configuration change at 15:13:32 CET Wed Sep 2 2015
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!

!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 134.21.21.21 255.255.255.255
!
interface Ethernet0/0
ip address 134.56.78.38 255.255.255.252
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
ip address 134.56.78.5 255.255.255.252
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!

interface Ethernet1/3
no ip address
shutdown
!
interface Ethernet2/0
ip address 134.56.78.50 255.255.255.252
!
interface Ethernet2/1
no ip address
shutdown
!
interface Ethernet2/2
no ip address
shutdown
!
interface Ethernet2/3
no ip address
shutdown
!
interface Ethernet3/0
no ip address
shutdown
!
interface Ethernet3/1
no ip address
shutdown
!
interface Ethernet3/2
no ip address
shutdown
!
interface Ethernet3/3
no ip address
shutdown
!
interface Serial4/0
ip address 134.56.78.9 255.255.255.252
encapsulation ppp
serial restart-delay 0
!
interface Serial4/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial4/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 2
network 134.21.21.21 0.0.0.0 area 1
network 134.56.78.38 0.0.0.0 area 1
network 134.56.78.50 0.0.0.0 area 1

!
router bgp 12345
bgp router-id 134.21.21.21
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 123.3.3.3 remote-as 12345
neighbor 123.3.3.3 update-source Loopback0
neighbor 134.56.78.6 remote-as 65535
neighbor 134.56.78.10 remote-as 65103
!
address-family ipv4
network 134.21.21.21 mask 255.255.255.255
neighbor 123.3.3.3 activate
neighbor 123.3.3.3 next-hop-self
neighbor 134.56.78.6 activate
neighbor 134.56.78.10 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 192.168.1.0 255.255.255.0 134.56.78.10
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
transport input none
!
!
end