You are on page 1of 30

Notions fondamentales sur les rseaux

Chapitre 7 : Les VLANs

Slide 1

Les LANs virtuels (VLANs)


Gnal VALET
Version 1.2 Jan 2011

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 2

Sommaire

Dans ce chapitre, nous aborderons :


Quest-ce quun VLAN ?

Prsentation, dfinition, intrt des VLANs


Les diffrents types de VLAN
Le VLAN de niveau 1, 2 et 3
Ltiquetage des trames avec 802.1q (dot1q)
La mise en place dun VLAN avec CISCO
Les liens TRUNK
Le pruning
Le routage entre les VLANs

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 3

Rappels sur les LAN traditionnels

LAN : Local Area Network


Rseau dont lchelle se situe autour dun ou plusieurs btiments
Il est souvent segment en sous-rseaux interconnects les uns
aux autres par des routeurs

Les LANs sont trs souvent commuts


Les commutateurs relient les machines entre elles
Ils sont relis entre eux pour former un maillage
Ils voluent dans un mme domaine de broadcast
Sauf en cas de prsence de routeurs

La mise en place de routeurs permet :


De diminuer la taille du domaine de broadcast
Pour un cot lev : celui dun routeur et dun ou plusieurs
commutateurs
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 4

Exemple de LAN traditionnel

Exemple : LAN segment avec routeur

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 5

La problmatique du LAN traditionnel

Ds quun changement est effectu


Une modification du cblage est ncessaire
La configuration des machines doit tre modifie
Ds quun poste est ajout
Il faut un port libre sur le switch correspondant son sous-rseau
dappartenance

Une forte croissance du LAN induit :


Un domaine de broadcast plus grand
Lajout dun sous-rseau supplmentaire implique que :
Une nouvelle interface doit tre ajoute sur le routeur
Le cblage et les tables de routage soient revus afin dintgrer le
nouveau sous-rseau
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 6

La problmatique du LAN traditionnel (suite)

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 7

La solution VLAN

Consiste crer des rseaux logiques indpendants dans un


rseau physique existant
Aucune modification du cblage nest ncessaire
La prise en charge seffectue au niveau des switchs
Les machines appartenant un mme VLAN se comportent
comme si elles taient connectes au mme rseau physique
Mme si elles sont physiquement raccordes un autre segment
du rseau
Ces machines peuvent changer de lieu gographique mais rester
dans le mme VLAN

Aucune modification matrielle nest ncessaire

Ltanchit parfaite est assure entre les VLANs


Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 8

Les avantages du VLAN

Ladministrateur organise son rseau de manire logique et non


physique
Les VLANs permettent aux administrateurs de :
Ajouter ou dplacer facilement les stations de travail
Aucune modification matrielle nest ncessaire
Modifier facilement la configuration du LAN
Ladministrateur peut associer nimporte quel port du commutateur un
VLAN sans toucher au cblage
Contrler facilement le trafic rseau
Le trafic de broadcast est limit au VLAN correspondant
Amliorer la scurit
Toutes les stations utilisent la mme bande passante de commutation
mais les VLANs restent tanches
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 9

Les types de VLANs

Comment lappartenance un VLAN est-elle dfinie ?


Par le port du switch auquel la machine est connecte
VLAN de niveau 1
Les ports dun switch peuvent tre associs des Vlans diffrents
Par ladresse MAC de la machine
VLAN de niveau 2
Le switch lit ladresse MAC de la machine et lassocie son VLAN
dappartenance
Par ladresse IP de la machine
VLAN de niveau 3
Le switch lit ladresse IP de la machine et lassocie son VLAN
dappartenance
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 10

VLAN de niveau 1

Les ports des switchs sont associs des VLANs


Ports 1,2 et 3 appartiennent au VLAN 1
Ports 4,5 et 6 au VLAN 2
Ports 7 et 8 au VLAN 3

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 11

VLAN de niveau 1 (suite)

Un exemple base de 2 switchs

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 12

VLAN de niveau 2

Ladresse MAC est associe un VLAN quelque soit le port utilis


Ncessit de maintenir jour la base de donnes des adresses
MAC
Lappartenance un VLAN ne dpend plus de lemplacement de
la machine

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 13

VLAN de niveau 3

Bas sur le protocole ou ladresse IP


Lappartenance un VLAN est dfini par ladresse IP de la
machine
Les VLANs sont dfinis par sous rseau
Cela exclue la possibilit dutiliser DHCP
Ce type de VLAN nest plus utilis aujourdhui
Lappartenance un VLAN est dfini par le protocole utilis par la
machine
Il devient possible de sparer en VLANs les machines utilisant
TCP/IP et IPX (Netware)
Pas vraiment utilis aujourdhui

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 14

Bilan sur les types de VLAN


Types de VLANs

Description

Bas sur le port

Configuration la plus courante


Ports affects individuellement un ou plusieurs VLANs
Facile mettre en place
Coupl DHCP, les VLAN par ports offrent une bonne
flexibilit
Les interfaces de gestion des switchs permettent une
configuration facile

Bas sur ladresse


MAC

Rarement utilis
Ladresse MAC dtermine lappartenance un VLAN
Les switchs schangent leurs tables dadresses MAC ce qui
peut ralentir les performances
Difficile administrer, dpanner et grer

Bas sur le protocole

Pas utilis aujourdhui cause de la prsence de DHCP


Ladresse IP (sous-rseau) dtermine lappartenance un
VLAN

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 15

Principe de ltiquetage des trames

Frame tagging
Ltiquetage consiste marquer toutes les trames sortantes du
commutateur avec le n du VLAN dappartenance
Le commutateur suivant peut alors reprer les trames et les
diriger vers le VLAN correspondant

1) Envoi dune
trame de broadcast
Greta industriel des technologies avances

2) Etiquetage de la
trame sortante du
commutareur

3) Rception
sur le VLAN 1
uniquement
G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 16

La trame Ethernet (Rappel)

Voici la composition dune trame Ethernet classique

Adresse MAC
destination
De la trame (48 bits)

Adresse MAC source


de la trame
(48 bits)

Greta industriel des technologies avances

Type de trame (16 bits)


0x0806 pour ARP
0x0800 pour IPv4
0x08100 pour 802.1q

Frame Check
Sequence
(32 bits)
Squence de contrle
permettant de vrifier
la cohrence avec les
valeurs des champs
prcdents

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 17

La trame Ethernet 802.1q

Ltiquetage se fait grce la norme 802.1q (dot 1q)


Les trames ont un champ supplmentaire

EtherType aura la valeur


0x8100

Dfinit 8 niveaux de
priorit dun VLAN par
rapport un autre. Ne pas
confondre avec le champ
priorit du paquet IP

Canonical Format Identifier


Permet de distinguer les
trames Ethernet des trames
Token ring ( Valeur 0 du bit
pour Ethernet)

Greta industriel des technologies avances

Identifiant de VLAN (VLAN


ID) sur 12 bits. Il est possible
de coder 212-2 = 4094 Vlans
avec ce champ

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 18

Administration des Vlans

La mise en place de VLANs ncessite de disposer dquipements


administrables
Commutateurs manageable
La base de donnes des Vlans est la mme sur tout le LAN
Soit configure manuellement sur chaque commutateur
La maintenance peut tre assez lourde si on souhaite faire voluer le
LAN
Soit configure automatiquement via un protocole propritaire qui
dpend de la marque de lquipement
Cas du Vlan Trunking Protocol (VTP) de la marque CISCO (Voir plus
loin)
Le protocole se charge de distribuer sur lensemble du LAN les
informations sur les VLANs
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 19

Le routage entre VLANs

Le trafic entre les Vlans est assur par un quipement de niveau 3


Un routeur
Un commutateur de niveau 3
Lien trunk vhiculant le
trafic des Vlans 1 et 2

Lien trunk vhiculant le


trafic des Vlans 1 et 2

Le trafic entre le
VLAN 1 et 2
passe dans tous
les cas par le
routeur (mme si
les machines
sont connects
au mme
commutateur)

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 20

Conditions runir pour un routage entre VLANs

Attribuer chaque VLAN des plages dadresses IP nappartenant


pas au mme rseau

Configurer un routeur capable de comprendre ltiquetage


802.1q
Crer un lien spcial entre le switch et le routeur avec des trames
tiquetes 802.1q
CISCO : Lien trunk
NETGEAR, DLINK : Tagged ou Untagged port
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 21

Le VLAN selon CISCO

Les VLANs sont mis en uvre via 2 normes


802.1q (Etiquetage de trames)
ISL (Encapsulation de trames)
Technologie propritaire CISCO qui tend disparatre

Les commandes de lIOS (Internetworking Operating System)


permettent de:
Crer un lien Trunk qui vhicule le trafic de plusieurs Vlans
Associer un port un ou plusieurs Vlans
Choisir les Vlans vhiculer avec le pruning
Comment les commutateurs changent-il des informations sur
les VLANs ?
Grce au protocole VTP : Vlan Trunking Protocol
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 22

Le VLAN natif

Le VLAN 1 est appel le VLAN natif


Destin la gestion distante des quipements
Les trames VTP circulent sur le VLAN natif
Les trames destines au Vlan natif ne sont pas tiquetes
On peut communiquer avec les quipements via le Vlan natif

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 23

Lien Trunk

Le lien Trunk vhicule le trafic venant de plusieurs VLANS


Les trames sont donc tiquetes lorsquelle sont envoyes par un
lien Trunk

Un lien trunk est dfini au niveau dun commutateur


Soit vers un routeur
Soit vers un autre commutateur

Greta industriel des technologies avances

Lien trunk
Lien trunk

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 24

Dfinir un lien TRUNK

Grce la commande switchport


Switch# configure terminal
Enter configuration commands, one per line.
CNTL/Z.
Switch(config)# interface fastEthernet 0/20
Switch(config-if)# switchport mode trunk

End with

Prciser le type dencapsulation sur les anciens modles de switch


Switch# configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
Switch(config)# interface fastEthernet 0/20
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 25

Associer le port dun switch un VLAN

Toujours avec la commande switchport


En prcisant le n de VLAN
Switch# configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
Switch(config)# interface fastEthernet 0/2
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10

Agir sur plusieurs ports la fois


Version rcente dIOS : 12.0 ou 12.1 T)
Exemple : Toutes les interfaces de 1 15
Switch(config)# interface range fastEthernet 0/1 - 15
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 100
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 26

Afficher les VLANS

La commande show permet dafficher les affectations des


ports aux Vlans
Switch# show vlan brief

Ports configurs sur le


VLAN1

VLAN Name
Status
Ports
---- -------------------------------- --------- ------------------------------1
default
active
Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
Gi0/9, Gi0/12, Gi0/13, Gi0/15, Gi0/16, Gi0/17
Gi0/19, Gi0/22, Gi0/24, Gi0/25, Gi0/26, Gi0/27
Gi0/28
3
NEWPEDA
active
Port 10 configur sur le VLAN 100
100 VLAN0100
active
Gi0/10
102 VLAN0102
active
103 EDPI
active
104 VLAN0104
active
Gi0/18
Port 18 configur sur le VLAN 104
105 VLAN0105
active
106 VLAN0106
active
108 VLAN0108
active
Gi0/14
Port 14 configur sur le VLAN 108
109 VLAN0109
active
110 VLAN0110
active
111 VLAN0111
active
112 IRIS
active
114 VLAN0114
active
115 VLAN0115
active
116 VLAN0116
active

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 27

Configurer le routage InterVlan sur le routeur

Etape 1 : Crer une sous interface par VLAN


ROUTEUR # configure terminal
ROUTEUR(config)# interface fastEthernet 0/0.100
ROUTEUR(config-subif)#

100 est une sousinterface de


FastEthernet 0/0

Etape 2 : Dclarer linterface du routeur comme un lien Trunk


802.1q
ROUTEUR(config-subif)# encapsulation dot1Q 100

Sous interface
affecte au VLAN
100

Etape 3 : Affecter une adresse IP dans le rseau du VLAN


correspondant chaque sous interface
ROUTEUR(config-subif)#ip address 192.168.100.254 255.255.255.0

Etape 4 : Dfinir un lien trunk entre switch et routeur (Sur switch)


SWITCH(config) # interface FastEthernet 0/12
SWITCH(config-if)# switchport mode trunk

Greta industriel des technologies avances

FastEthernet 0/12 est le lien


avec le routeur
G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 28

VTP : Vlan Trunking Protocol

Protocole de diffusion des informations concernant les VLAN


Les diffrents quipements changent leurs informations de
VLAN

Les domaines VTP permettent dinclure tout ou partie des


quipements dun rseau dans un ensemble
Lquipement peut se situer dans plusieurs modes VTP
Mode serveur
Mode client
Mode transparent
Les mises jour VTP se font en multicast une adresse spciale
01-00-0C-CC-CC-CC
Greta industriel des technologies avances

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 29

Les modes VTP


Utilis lorsque le switch
introduit de nouveaux
VLANs destins tre
publis vers les autres
switchs

Illustration des diffrents modes VTP


Mode Server
Cration, modification et suppression de VLAN
Publie le domaine VTP
Sauvegarde des infos de VLAN en NVRAM

Utilis lorsque le switch


nintroduit pas de
nouveau VLAN. Le
nombre de
configurations
manuelles se rduit

Mode Client
Pas de cration, modification et suppression de VLAN
Pas de sauvegarde des infos de VLAN en NVRAM
Sert limiter le nombre de points de configuration

Mode Transparent
Cration, modification et suppression de VLAN manuelle
Sauvegarde des infos de VLAN en NVRAM
Pas de publication des ses infos vers les autres switchs

Greta industriel des technologies avances

Permet de configurer
manuellement les VLAN
sans les publier vers les
autres switch. Permet
quand mme de relayer
les messages VTP des
autres switchs

G. Valet genael.valet@gita.fr

Notions fondamentales sur les rseaux


Chapitre 7 : Les VLANs

Slide 30

Configuration de VTP

Dfinir le mode, le domaine et un ventuel mot de passe


Switch# configure terminal
Enter configuration commands, one per line.
CNTL/Z.
Switch(config)# vtp server
Switch(config)# vtp domain diderot.org
Switch(config)# vtp password toto

End with

Montrer la configuration VTP


Switch# show vtp status
Switch# show vtp counters

Greta industriel des technologies avances

G. Valet genael.valet@gita.fr