Teknik Block Situs Facebook Menggunakan Layer 7 Mikrotik

Teknik Block situs facebook menggunakan layer 7 Mikrotik

filed in Jaringan on Aug.26, 2009 Block situs Facebook menggunakan layer 7 mikrotik 1. PENDAHULUAN Situs jejaring social Facebook akhir-akhir ini sangat cukup terkenal dan sangat digemari oleh banyak orang bahkan anak kecil yang masih Sekolah Dasar pun sudah tau apa itu facebook. Dengan banyaknya digemari oleh banyak orang tak terkecuali para staff atau para pegawai yang sehari harinya mengakses internet disamping sebagai sarana social, facebook ternyata membawa dampak negative dalam dunia kerja, contoh ringan kurang efektifnya kinerja para karyawan karena setiap detik, menit, jam tidak terlepas dari situs jejaring ini. Untuk itu para pimpinan mulai resah atas perilaku kinerja karyawan yang kurang efektif, terjadilah dialog antara pimipinan dan admin jaringan untuk mencari solusi yang terbaik. Munculah suatu kebijakan untuk menutup akses facebook dari pukul 08.00-15.00 Wib dengan memberikan kesempatan karyawan untuk mengakses situs jejaring selama 1 jam sebelum pulang kerja. 2. LATAR BELAKANG menggunakan layer 7 Mikrotik Pada awal mulanya penutupan situs jejaring facebook dilakukan dengan memblok ip satu persatu menggunakan ip firewall filter, tetapi ini berlangsung hanya sekitar 2 bulan saja, selebihnya banyak karyawan yang sudah bisa mengaksesnya kembali, saya coba mengikuti list ip facebook.com satu persatu tetapi ko yo banyak sekali, tadinya berniat untuk block ip perblok tetapi ini tidak efektif karena takut ada ip lain yang terkena block, ahirnya mencobalah block menggunakan layer 7 ini. 3. LANGKAH KONFIGURASI a. Mengakses core router (maingw) b. Membuat Address List Exception Ini untuk pengecualian, fungsinya apabila ada request pimipinan atau pejabat yang ingin mengakses facebook pada jam kerja. Untuk mengakses Address List : IP>FIREWALL>ADDRESS LIST Untuk menambahkan rules klik tanda + sebelah kiri atas, kemudian lakukan seperti gambar dibawah ini :

Klik OK c. Setting layer 7 untuk facebook.com IP > FIREWALL>Layer 7 Protocols Tampilannya akan seperti gambar dibawah ini

d. Kemudian untuk mendaftarkan satu persatu klik tanda plus berwarna merah kemudia akan muncul layar Firewall L7 Protocol kemudian isi Name dan Regexp seperti gambar dibawah ini.

e. Setting Mangle Mangle disini adalah untuk mengkelompokan, bahwa setiap akses yang menuju ke www.facebook.com akan dimasukan ke illegal-url-connection. Untuk mengakses Mangle : IP>FIREWALL>MANGLE Untuk menambahkan klik tanda + warna merah, kemudian lakukan seperti gambar dibawah ini.

Kemudian klik Advance dan isi seperti gambar dibawah ini

Kemudian klik Action dan isi seperti gambar dibawah ini :

Klik ok Kemudian klik tanda + kembali isi seperti gambar dibawah ini

Kemduian klik tab Action kemudian isi seperti gambar dibawah ini :

Setelah itu klik Ok Kemudian akan muncul list seperti gambar dibawah ini

f. Setting Filter Rule Setelah pengelompokan menggunakan Mangle, saatnya sekarang pengaturan filter. Untuk mengakses Filter Rules : IP>FIREWALL>FILTER RULES Kemudian untuk menambahkan aturan klik tanda + disebelah kiri atas, untuk filter rules ada beberapa tahapan, yaitu : Tahapan Pertama : Mengalihkan setiap koneksi yg mengakses illegal-url-connection Lakukan step-step dibawah ini : Klik tab General kemudian isi seperti gambar dibawah ini

Klik tab Actions, kemudian isi seperti gambar dibawa ini

Kemudian klik Ok Tahapan Kedua : Menyimpan log setiap koneksi yang mengakses illegal-url-connection Klik + untuk menambahkan rule, kemudian lakukan seperti gambar dibawah ini :

Kemudian klik Action kemudian lakukan seperti gambar dibawah ini :

Setela itu klik Ok. Tahapan Ketiga : Melist address illegal-url-connection (disini akan terliat list ip facebook yg terkena blok) Klik tanda + untuk menambakan rules, kemudian lakukan seperti gambar dibawah ini :

Kemudian klik Action, lakukan seperti gambar dibawa ini :

Klik ok Tahap Ke Empat : Melakukan drop koneksi yg menuju ke illegal-url-connection Untuk menambah rule baru klik tanda +, kemudian lakukan seperti gambar dibawah ini :

Kemudian klik tab Advanced, kemudian lakukan seperti gambar dibawah ini :

Pada gambar diatas adalah peri tah untuk tidak melakukan drop akses untuk group ip yang masuk ke group exception. Kemudian klik Action, lakukan seperti gambar dibawah ini :

Kemudian klik comment dan isi seperti gambar dibawah ini (ini berfungsi untuk pengaturan waktu di scheduler)

Kemudian klik Ok. g. Pengaturan waktu (cron job) Disini untuk mengatur waktu block atau allow user untuk mengakses situs facebook, pada tulisan sebelumnya dijelaskan waktu untuk mengakses facebook dari pukul 08.00 -15.00 Wib, berikut langkah-langkahnya : Tahap pertama : membuat script untuk mengallow dan memblock * Scri untuk all w

Untuk mengakses script : klik System>Script

Script ini berjalan dengan mendisable filter rules yang memiliki comment facebook, berikut contohnya :

Klik Ok *Script untuk memblock Script ini berjalan dengan meng enable filter rules yang memiliki comment facebook, , berikut contohnya :

Tahap kedua : mengatur waktu pemblokan dan allow. Untuk mengakses Scheduler : klik System>Scheduler *Script untuk allow

*Script untuk memblock

Kemudian klik ok Untuk melihat ip facebook yg berhasil di block anda IP>FIREWALL>ADDRESS LIST, seperti gambar dibawah ini : bisa melihat di

Untuk saat ini sudah sekitar 424 IP Facebook yang berhasil di block, bayangkan apabila anda harus memblock satu persatu ipnya , Selamat mencoba..

Ngelimit vidio di youtube
Code:

/ip firewall layer7 -protocol add name=http -video regexp="http/(0 \.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][09][\x09-\x0d -~]*(content -type: video)" Mangle Mark Packet http-video nya
Code:

/ip frewall mangle add action=mark -packet chain=prerouting comment="http -video mark -packet" \ disabled=no layer7 -protocol=http -video new-packet-mark=http -video \ passthrough=no Queue Simple http-video nya
Code:

/queue simple add max-limit=0/64000 name=http -video packet -marks=http -video Saat buka YouTube ..... kenceng, tapi saat Play Video langsung ke limit 64kbps Selamat mencoba

Ato:

Code:

/ip firewall layer7 -protocol add comment="" name=http -video regexp="http/(0 \\.9|1\\.0|1\\.1)[\\x09-\\x0d ][\ 1-5][0-9][0-9][\\x09-\\x0d -~]*(content -type: video)"

Code:

/ip fi ma add action=mark -packet chain=prerouting comment="Mark Packet HTTP Video" disabled=no in -interface=ether1 layer7 -protocol=http -video \ new-packet-mark=http-video-up passthrough=no add action=mark -connection chain=forward comment="" disabled=no \ layer7-protocol=http -video new-connection -mark=video -stream passthrough= \ yes

\

add action=mark -packet chain=forward comment="" connection -mark=video stream \ disabled=no in -interface=ether2 layer7 -protocol=http -video \ new-packet-mark=http-video-down passthrough=no

Code:

/que typ add kind=pcq name=http -video-up pcq-classifier=src -address pcq -limit=50 \ pcq-rate=0 pcq -total-limit=2000 add kind=pcq name=http -video-down pcq-classifier=dst -address pcq -limit=50 \ pcq-rate=0 pcq -total-limit=2000

Code:

/que sim add burst -limit=0/0 burst -threshold=0/0 burst -time=0s/0s comment="" \ direction=both disabled=no dst -address=0.0.0.0/0 interface=all limit at=\ 64k/128k max -limit=64k/128k name="7. HTTP Video Traffict" packet marks=\ http-video-up,http-video-down parent=none priority=8 queue= \ http-video-up/http-video-down total -queue=default -small add burst -limit=0/0 burst -threshold=0/0 burst -time=0s/0s comment="" \ direction=both disabled=no dst -address=0.0.0.0/0 interface=all limit at=\ 0/0 max-limit=16k/96k name="Queue HTTP Video" packet -marks=\ http-video-up,http-video-down parent="7. HTTP Video Traffict" priority=8 \ queue=http -video-up/http-video-down target -addresses=0.0.0.0/0 \ total-queue=default -small

ada gak cara buat limit youtube, aku liat traffic youtube kalo gak dibatasi bisa menyedot bw aku nih Langkah 1 Kita masukan rule di firewall untuk mendapatkan IP dari download server dan memasukan IP tersebut ke dalam address list « /ip firewall filter add chain=forward \ src-address=192.168.10.0/24 protocol=tcp content=.flv \ action=add-dst-to-address-list address-list=downloads \ address-list-timeout=01:00:00 nb: src-address=client network (lan) Rule diatas akan menangkap semua traffic dengan content .flv yang berasal dari blok IP LAN dan memasukannya ke addres list downloads selama 1 jam. Variable diatas dapat dirubah sesuai dengan topology dan kebutuhan anda sendiri. Langkah 2 Kita lakukan mangle untuk marking paket yang berasal dari address list yang telah kita dapat dari Langkah 1 /ip firewall mangle add chain=forward \ protocol=tcp src-address-list=downloads \ action=mark-packet new-packet-mark=download-paket

Mangle ini kita perlukan untuk melabeli paket sehingga simple queue dapat menangkap traffic dari IP yang telah terdapat pada address list ³downloads´ Langkah 3 Langkah terakhir kita masukkan simple queue dari paket mark yang telah kita dapet dari langkah 2 /queue simple add name=download-files \ max-limit=64000/64000 packet-marks=download-paket Letakan queue di urutan paling atas supaya dibaca dulu oleh MikroTIK That¶s it .. Kita sudah berhasil mengalokasikan bandwidth untuk traffic download file2 yang kita inginkan, dan browsing tetap lancar .. meskipun browsing ke server yang sudah pada address list menjadi lambat karena ikut ke limit ;-) at least for the next 1 hour ...

Sign up to vote on this title
UsefulNot useful