You are on page 1of 8

Linguagens de Programao I

2a Lista de Exerccios
Assunto: Tomada de deciso
OBS: Onde et programa, leia-se algoritmo

Exerccios de Fixao
1. Faa um programa que leia um nmero e imprima uma mensagem dizendo se par ou impar.
Algoritmo
inteiro n
leia (n)
se (n MOD 2 == 0)
ento
imprima (Par)
seno
imprima (Par)
fim_se
fim

2. Faa um programa que leia 2 nmeros e imprima uma mensagem dizendo se so iguais ou
diferentes.
Algoritmo
inteiro n1, n2
leia (n1, n2)
se (n1 == n2)
ento
imprima (Iguais)
seno
imprima (Diferentes)
fim_se
fim

3. Faa um programa que leia 2 nmeros e imprima uma mensagem dizendo o maior deles.
Suponha que os nmeros sero diferentes.
Algoritmo
inteiro n1, n2
leia (n1, n2)
se (n1 > n2)
ento
imprima (Maior e o n1 = , n1)
seno
OBS: Agradecimentos ao prof. Cludio Miguel (Unidade Ipanema) pela concesso deste material

imprima (Maior e o n2 = , n2)


fim_se
fim

4. Faa um programa que leia 2 nmeros e imprima uma mensagem dizendo o maior deles. Detalhe:
se os nmeros forem iguais, imprima uma mensagem avisando ao usurio.
Algoritmo
inteiro n1, n2
leia (n1, n2)
se (n1 > n2)
ento
imprima (Maior e o n1 = , n1)
seno
se (n2 > n1)
ento
imprima (Maior e o n2 = , n2)
seno
imprima (Iguais = , n1)
fim_se
fim_se
fim

5. Faa um programa que leia da entrada padro um nmero e imprima o seu valor absoluto (sem o
sinal).
Algoritmo
real n
leia (n)
se (n < 0)
ento
imprima (-n)
seno
imprima (n)
fim_se
fim

6. Faa um programa que leia 3 nmeros e imprima o menor deles.


Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n1 < n2) e (n1 < n3)
ento
imprima (n1)
2/8

seno
se (n2 < n3)
ento
imprima (n2)
seno
imprima (n3)
fim_se
fim_se
fim

7. Faa um programa que leia 3 nmeros e os imprima em ordem crescente.


Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n1 <= n2) e (n2 <= n3)
ento
imprima (n1, n2, n3)
seno
se (n1 <= n3) e (n3 <= n2)
ento
imprima (n1, n3, n2)
seno
se (n2 <= n1) e (n1 <= n3)
ento
imprima (n2, n1, n3)
seno
se (n2 <= n3) e (n3 <= n1)
ento
imprima (n2, n3, n1)
seno
se (n3 <= n2) e (n2 <= n1)
ento
imprima (n3, n2, n1)
seno
imprima (n3, n1, n2)
fim_se
fim_se
fim_se
fim_se
fim

Outra forma:
Algoritmo
real n1, n2, n3, maior, meio, menor, restante1, restante2
leia (n1, n2, n3)

3/8

se (n1 < n2) e (n1 < n3)


ento
menor = n1
restante1 = n2
restante2 = n3
seno
se (n2 < n3)
ento
menor = n2
restante1 = n1
restante2 = n3
seno
menor = n3
restante1 = n1
restante2 = n2
fim_se
fim_se
se (restante1<restante2)
ento
meio = restante1
maior = restante2
seno
meio = restante2
maior = restante1
fim_se
imprima (menor, meio, maior)
fim

8. Faa um programa que leia 3 nmeros e os imprima em ordem decrescente.

Similar ao anterior (s muda a ordem)

9. Faa um programa que leia 3 nmeros e imprima o valor intermedirio, entre o menor e o maior
nmero. Suponha que os nmeros sero diferentes.
Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n2 < n1) e (n1 < n3) ou (n3 < n1) e (n1 < n2)
ento
imprima (n1)
seno
se (n1 < n2) e (n2 < n3) ou (n3 < n2) e (n2 < n1)
ento
imprima (n2)
4/8

seno
imprima (n3)
fim_se
fim_se
fim

10. Faa um programa que leia 3 nmeros e imprima uma das seguintes mensagens:

todos os nmeros so iguais;

todos os nmeros so diferentes; ou

apenas dois nmeros so iguais.

Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n1 == n2) e (n2 == n3)
ento
imprima (todos os nmeros so iguais)
seno
se (n1 == n2) ou (n1 == n3) ou (n2 == n3)
ento
imprima (apenas dois so iguais)
seno
imprima (todos os nmeros so diferentes)
fim_se
fim_se
fim
11. Faa um programa que leia trs notas de um aluno, calcule sua mdia aritmtica e imprima uma
mensagem dizendo se o aluno foi aprovado, reprovado ou dever fazer prova final. O critrio de
aprovao o seguinte:

aprovado (mdia 7);

reprovado (mdia < 3) e

prova final ( 3 mdia < 7).

Algoritmo
real n1, n2, n3, media
leia (n1, n2, n3)
media = (n1+n2+n3)/3
se (media >= 7)
ento
imprima (Aprovado)
seno
se (media < 3)
ento

5/8

imprima (Reprovado)
seno
imprima (Prova final)
fim_se
fim_se
fim
12. Faa um programa que leia a idade de uma pessoa e informe sua classe eleitoral:

no eleitor (abaixo de 16 anos);

eleitor obrigatrio (entre 18 e 65 anos) e

eleitor facultativo (entre 16 e 18 anos e acima dos 65 anos).

Algoritmo
inteiro idade
leia (idade)
se (idade < 16)
ento
imprima (No eleitor)
seno
se (idade >=18 e idade < 65)
ento
imprima (Eleitor obrigatorio)
seno
imprima (Eleitor facultativo)
fim_se
fim_se
fim

13. Faa um programa que calcula a rea de determinadas figuras geomtricas. O programa dever
apresentar um menu com as seguintes opes:

quadrado ( lado 2 )

retngulo (comprimento * largura)

crculo (3,14 * raio2 )

trapzio ((base maior + base menor) * altura / 2)

De acordo com a opo, o programa deve pedir os valores necessrios para realizar o clculo.
Algoritmo
real lado, comprimento, largura, raio, baseMaior, baseMenor, altura
inteiro opcao
imprima ([1] Quadrado)
imprima ([2] Retngulo)
imprima ([3] Crculo)
imprima ([4] Trapzio)
imprima (Digite sua opo: )
6/8

leia (opcao)
se (opcao == 1)
ento
imprima (Entre com o lado: )
leia (lado)
imprima (Area = , lado*lado)
seno
se (opcao == 2)
ento
imprima (Entre com o comprimento: )
leia(comprimento)
imprima (Entre com a largura: )
leia(largura)
imprima (Area = , comprimento * largura)
seno
se (opcao == 3)
ento
imprima (Entre com o raio: )
leia(raio)
imprima (Area = , 3,14*raio*raio)
seno
se (opcao == 4)
ento
imprima (Entre com a base maior: )
leia(baseMaior)
imprima (Entre com a base menor: )
leia(baseMenor)
imprima (Entre com a altura: )
leia(altura)
imprima (Area = , (baseMaior+baseMenor)*altura/2)
fim_se
fim_se
fim_se
fim_se
fim
14. Em uma eleio presidencial, existem quatro candidatos. Os votos so informados atravs de
cdigo. Os dados utilizados para a escrutinagem obedecem seguinte codificao:

1, 2, 3, 4 = voto para os respectivos candidatos;

5 = voto nulo;

6 = voto em branco;

Elabore um programa que calcule e imprima:


a) total de votos para cada candidato;
b) total de votos nulos;
c) total de votos em branco;
d) percentual dos votos em branco e nulos sobre o total;
e) situao do candidato vencedor sobre os outros dois, no caso, se ele obteve ou no mais
7/8

votos que os outros dois somados.


Como finalizador do conjunto de votos, tem-se o valor 0.

15. Uma equipe de vlei paga aos seus jogadores, alm do salrio, um valor adicional ao salrio
mensal (bicho) que funo da produtividade de cada um.
Essa produtividade paga de acordo com a tabela a seguir:
classe

nvel

valor adicional

excelente

+100%

bom

+80%

mdio

+50%

regular

+30%

precisa treinar mais

+10%

te cuida

+5%

passe no Departamento Pessoal

0%

Faa um programa que, dados o salrio e o cdigo da classe de um jogador, calcule e imprima o
seu salrio final e o nome da sua classe (nvel).
16. Faa um programa que implemente uma mquina de calcular com operaes +, -, *, / e %,
atravs da leitura de dois operandos numricos inteiros e do operador (tipo caracter), no formato:
operando1 operador operando2. Verifique casos de operaes que no podem ser realizadas (antes
de oper-las).
17. Faa um programa que leia um horrio no sistema de 24 horas e imprima este horrio no sistema
de 12 horas.
Exemplo: 22:32 10:32 pm
Obs.:

0:00 12:00 am

6:00 6:00 am

8/8

12:00 12:00 pm