You are on page 1of 14

ESTRUCTURA DE UN PROGRAMA EN C

++
El objetivo de la presente sesión es:
 Conocer las herramientas para el manejo de las estructuras
selectivas (Carta N-S, Diagrama de flujo y Pseudocodigo)
 Codificar en C++ el algoritmo planteado en estas herramientas.
 Conocer las sentencia if/else del C++

 Conocer las sentencias if/else if/ else.
 Resolver en cada caso ejemplos

ING. FÉLIX HUARI

1

[else sentencia2(s). FÉLIX HUARI 2 . a) Sentencia if() Sintaxis if (<condicion>) sentencia1(s). donde mediante esta podemos alterar el flujo del control secuencial.] ING. en el orden en el que se escribieron. pero es posible escribir que el programador indique las instrucciones que se debe ejecutar Para ello se utiliza las estructuras de selección.ESTRUCTURA SELECTIVA DE CONTROL EN C++ Las sentencias se ejecutan una tras otra.

es decir la sentencia que esta después de la cláusula else. FÉLIX HUARI 3 .ESTRUCTURA SELECTIVA DE CONTROL EN C++ Si la condición es verdadero. REPRESENTACION EN PSEUDOCODIGO Si (<condicion>) entonces sentencia(s) Sino sentencia(s) Fin Si ING. en caso contrario se ejecuta la sentencia2(s). se ejecuta la sentencia1(s).

ESTRUCTURA SELECTIVA DE CONTROL EN C++ Representación en carta N-S y diagrama de flujo.F. Condición Verdad Si Falso Condición Sentencia(s) Sentencia(s) No Sentencia2 Sentencia1 ING. FÉLIX HUARI 4 . N-S D.

ESTRUCTURA SELECTIVA DE CONTROL EN C++ Diagrama de flujo Diagrama carta N-S Condición No Condición Si Verdad Falso Sentencia(s) Sentencia1 ING. FÉLIX HUARI 5 .

[else if(<condicion2>) sentencia2(s). FÉLIX HUARI 6 .] ING... else if(<condicion3>) sentencia3(s). else sentencia(s).. .ESTRUCTURA SELECTIVA DE CONTROL EN C++ b) Setencia if() en Bloque Sintaxis if (<condicion1>) sentencia1(s).

ESTRUCTURA SELECTIVA DE CONTROL EN C++ Representacion en Pseudocodigo Si (<condicion1>) entonces Sentencia1(s) Sino Si(<Condicion2>) entonces Sentencia2(s) Sino Si(<Condicion3>) entonces Sentencia3(s) …………… Sino Sentencia(s) Fin Si ING. FÉLIX HUARI 7 .

F. FÉLIX HUARI 8 .ESTRUCTURA SELECTIVA DE CONTROL EN C++ Representación en carta N-S y diagrama de flujo (D.). Condición1 F V Si Condición2 F Sentencia1 No Si Sentencia3(s) Sentencia2(s) Sentencia1(s) V Condición 1 Condición2 Sentencia2 No Sentencia3 ING.

se ejecuta la sentencia1(s). Si ninguna de las condiciones se cumple. en caso contrario prueba la condicion2.ESTRUCTURA SELECTIVA DE CONTROL EN C++ Si la condición1 es verdadero. Nota: En una instrucción if/else. y así sucesivamente se va probando el resto de las condiciones. for. no es necesario delimitar con llaves. Si existe una instrucción se llama sentencia simple. ING. si es verdadero se procesa la sentencia2(s). while. es sentencia compuesta por lo tanto debe delimitarse con llaves ({ }). do while. En cambio si existe mas de una instrucción. entonces se ejecuta la sentencia que viene después de la cláusula else. FÉLIX HUARI 9 .

b) Si(b<>0) entonces restoa-a/b*b Si(resto=0) entonces Escribir(a. Luego codificar en C ++ ING. en cada caso escribir un mensaje adecuado.b) FinSi Sino Escribir(“Error. “No es divisible entre “.ESTRUCTURA SELECTIVA DE CONTROL EN C++ Inicio Declarar variables a. “es divisible entre “.b. Denominador es 0”) FinSi Fin Dado 2 números enteros.b) Sino Escribir(a. FÉLIX HUARI 10 . se pide diseñar un algoritmo en pseudocodigo que permita verificar si es divisible el primer numero con el segundo.resto como enteros Escribir(“Ingrese 2 numeros enteros:”) Leer(a.

cout<<"Ingrese primer numero:".cin>>a. cout<<endl. //Programa principal int main() { int a.cin>>b. ING. if(b!=0) { resto= a-a/b*b. cout<<"Ingrese segundo numero:". FÉLIX HUARI 11 .ESTRUCTURA SELECTIVA DE CONTROL EN C++ //Codificacion en C++ #include <iostream> using namespace std. resto. b.

denominador debe ser diferente de cero\n". } ING..ESTRUCTURA SELECTIVA DE CONTROL EN C++ if(resto==0) cout<<a<<" es divisible entre "<<b<<endl. FÉLIX HUARI 12 . system("pause").. } else cout<<"Error. cout<<endl. else cout<<a<<" no es divisible entre "<<b<<endl..

} else cout<<"Error en ingreso de datos\n". cout<<"Ingrese primer numero:". } ING. if(n>=100 && n<1000) { m=n/10. system("pause"). cin>>n.d.ESTRUCTURA SELECTIVA DE CONTROL EN C++ #include <iostream> using namespace std. FÉLIX HUARI 13 . d=m-m/10*10. cout<<endl. cout<<"El digito central es "<<d<<endl. //Programa principal int main() { int n.m.

celsius. } ING. cout<<"o una C si la temperatura esta en grados Celsius: ". } else cout<<"Equivale a "<<(9. if(tipo=='F') { celsius=5.ESTRUCTURA SELECTIVA DE CONTROL EN C++ Ejemplo #include <iostream> using namespace std. FÉLIX HUARI 14 .0/9*(temp-32. cout<<"Temperatura a convertir:". cout<<"Digite F si la temperatyura esta en grados Fahrenheit"<<endl. de temperaturas int main() { char tipo. cin>>temp. float temp.0/5*temp+32. cin>>tipo. // Programa de conv.0). cout<<"Equivale a "<<celsius<<" grados celsius"<<endl.0)<<" grados Fahrenheit"<<endl.