You are on page 1of 32

Esquema básico para administración de una red

Natalia Sandoval Cárdenas


Williams Andrés Maldonado Vela
Meyleth Suarez Tous
(Martes 07:00 am)

CORPORACIÓN UNIFICADA NACIONAL DE EDUCACIÓN SUPERIOR CUN


FACULTAD DE INGENIERÍA
ÁREA DE SISTEMAS
BOGOTA
2010
Esquema básico para la administración de una red

Natalia Sandoval Cárdenas


Williams Andrés Maldonado Vela
Meyleth Suarez Tous
(Martes 07:00 am)

TRABAJO PRESENTADO EN LA ASIGNATURA DE ADMINISTRACION Y


GESTION EN REDES, COMO INVESTIGACIÓN AL INGENIERO Alejandro
Pérez

CORPORACIÓN UNIFICADA NACIONAL DE EDUCACIÓN SUPERIOR CUN


FACULTAD DE INGENIERÍA
ÁREA DE SISTEMAS
BOGOTA
2010
TABLA DE CONTENIDO

Introducción
1. objetivos
1.1 objetivos generar
1.2 objetivos específicos
2. Qué es un Router
2.1Características Esenciales
2.2Partes de un Router
2.2.1Memoria RAM / DRAM (dinámica)
2.2.2 Memoria N V RAM
2.2.3 Memoria FLASH
2.2.4 Memoria ROM (bootstrap)
2.2.5Interfaces
2.2.6Conectores: DB-60, SMART-SERIAL, V-3R
2.2.7Conectores: RJ-45, AVI-15, DB-15
2.3 Pasos al encender un Router
2.4 Como acceder al Router ya teniendo el cable ROLLOVER conectado
2.5 En el Router existen varios modos de trabajo, estos son
2.5.1 Comandos para el cambio de distintos Modos de trabajo
2.6 Algunos comandos Necesarios para la buena configuración del Router
3. Como configurar el Computador para que acepte estos cambios en la
topología ?
3.1 Cargar el protocolo (RIP)
4. Tipos de rutas, y como utilizarlas
4.1 Las Dinámicas
4.2 La Estática.
4.2.1 Configuración de Rutas Estáticas
4.2.2 Ejemplo de Configuración de Rutas Estáticas
4.2.3 Comprobación de Rutas Estáticas
4.2.4 Ejemplo
5. Colocar una contraseña en las interfaces del Router
5.1 Máscara de Windcard
6. ACL Lista Control de Acceso
6.1 ¿Cómo configurarla?
6.2 ¿Cómo cárgala a la interface?
6.3 ¿Cómo eliminar la lista de control de acceso?
6.4 ¿Cómo configurarla?
7. Comandos para configurar un Switch Cisco
7.1 Rip (Routing Information Protocol)
7.2 Switch
7.3Interface web
7.4 Asignar una Mac estatica
8. OSPF (Open Shortest Path First) La ruta abierta más corta
8.2 Aumentar la prioridad para elegir un router DR
8.2 EIGRP
9. Configuración del Puerto que se desconecte cuando se produce una
violación de seguridad.
9.1 Poner Ip a la Vlan1
9.2 Archivos de configuración
9.3 Configuración de la velocidad
9.4 Crear el trunk Del switch
9.5 Trunk en el router
9.6 Quitar un Puerto de una VLAN
9.7 Eliminar una vlan
9.8 Configuración de VTP
9.10 Copiar el IOS a un server tftp
9.11Copiar IOS desde un Server tftp
10. Recuperar el acceso al Switch
11. Actualizar el firmware
12. Extraer la nueva versión del IOS
12.1 Cambiar prioridad
12.2 Configurar VLAN
12.3 Configurar puertos en las VLAN
12.4 Eliminar el Puerto de la vlan
12.5 Para eliminar un Puerto de la vlan
12.6 Eliminar un vlan
12.7 Enlace troncal ISL
12.8 Vtp, servidor y cliente
12.9 Ruteo entre VLAN
13. Asignación de dirección IP
13.1 En un switch 2950
14. Seguridad de los Puertos
15. Conclusion

INTRODUCCION
Este documento describe de forma resumida los principales comandos de
configuración de los encaminadores (Routers), configuración de switch, seguridad de
los puertos entre otros además este esquema de redes nos dará puntos claros a
seguir para la buena configuración de los nombrados anteriormente.

Se recomienda tener instalado en todos los Ordenadores del laboratorio para


obtener un resultado óptimo a la hora de hacer todos los procedimientos a seguir
como la configuración de una red.

1. OBJETIVOS

1.1 OBJETIVOS GENERAR


Realizar un Esquema básico de configuraciones de una red para tener donde poder
consultar alguna duda.

1.2 OBJETIVOS ESPECIFICOS

Describir la función de cada de router, switch

Describir como se administran las rutas conectadas directamente en la tabla


de enrutamiento y seguridad de los puertos

Verificación de la configuración de conectividad con los comandos


correspondientes.

Describir de que manera la tabla de enrutamiento puede conectar y utilizar


rutas estáticas o dinámicas

2. Qué es un Router
Un Router es un enrutador, elemento que marca el camino más adecuado para la
transmisión de mensajes en una red completa, por ejemplo Internet tiene miles de
estos Router. Este toma como por decirlo el mejor camino para enviar los datos
dependiendo del tipo de protocolo que este cargado.
El Router casi es un computador, claro que no tiene Mouse ni Monitor, pero si tiene
procesador. El Router que va hacer de DCE es el que como por decirlo el que
administra, es el más robusto, tiene más procesadores y mucha más capacidad en
sus respectivas memorias.
OSPF: se basa en la métrica. (Principal)
-Velocidad.
-Seguridad.
-Ancho de banda.
RIP (principal)
-Menos saltos, pasar por menos Routers así estén ocupados.
-IBRP (otros)
-EIGRP (otros)
-BGP V4 (otros)

2.1Características Esenciales

• Es un dispositivo Inteligente
• Procesa y toma decisiones
• Genera tabla de enrutamiento (conoce si sus Routers vecinos están en
funcionamiento).
• Siempre toma una dirección Lógica.
• Tiene varias interfaces (sirven para interconectarse con las redes LAN u otros
Routers).
• Reconoce las redes que tiene directamente conectadas
• Mantiene una actualización constante de la topología (depende del protocolo).
• LOAD 1/255 entre menor sea el numerador esta mas ocupado.
• RALY 255/255 entre mayor sea el numerador es más confiable y seguro.

2.2Partes de un Router
2.2.1Memoria RAM / DRAM (dinámica)

• Es volátil, temporal (si se apaga el Router se pierde la información).


• Carga la IOS (sistema operativo).
• Carga la tabla de enrutamiento antigua y la actualiza.
• Carga la memoria cache de conmutación.
• Almacena la cola de espera de paquetes.
• Ejecuta el archivo de configuración.
2.2.2 Memoria N V RAM
• RAM permanente, allí se almacena el archivo de configuración.
2.2.3 Memoria FLASH
• Aquí se almacena el IOS y es re-programable, maneja varias versiones.
2.2.4 Memoria ROM (bootstrap)
• Proceso de arranque, checa y busca el sistema operativo.
2.2.5Interfaces
• Serial (conecta el Router a otro Router)
2.2.6Conectores: DB-60, SMART-SERIAL, V-3R
• ETHERNET, FAST ETHERNET, AR ETHERNET (conecta el Router con varias
redes como LAN, MAN. Etc.)
2.2.7Conectores: RJ-45, AVI-15, DB-15
• MODEM (conecta el PC con el Router)
Conectores: RJ-16 (teléfono)
• Conexión de configuración
El más usado es utilizando el cable ROLLOVER o mal llamado "cable azul" para
configurar el Router, aunque la conexión vía MODEM también se utiliza para esto.
Conectores: RJ-45 desde el PC al DV 9 hembra del Router.

2.3 Pasos al encender un Router


ROM-bootstrap:
carga el sistema operativo desde la Memoria FLASH.
TFTP (ROM).
carga el IOS.
carga el archivo de configuración.
N V RAM----
TFTP --Carga el archivo de configuración.
CONSOLA—
2.4 Como acceder al Router ya teniendo el cable ROLLOVER conectado
1. Ingresar por HYPERTERMINAL (inicio, programas, accesorios,
comunicaciones, HYPERTERMINAL.
2. También se puede instalar desde panel de control, agregar y quitar programas,
instalación de Windows, comunicaciones, chulear Hyperterminal y Aceptar.
3. selecciona el icono que desees y el nombre a tu gusto.
4. escoger cualquiera de los COM, por ejemplo COM1.
5. En la siguiente opción: vel ( velocidad Router por ejemplo, vel 9600 bits).
6. Paridad: ninguno.
7. Control de Flujo: ninguno.
Del paso 1
2.5 En el Router existen varios modos de trabajo, estos son
(>) Modo Usuario: Desde aquí se puede hacer muy poco trabajo.
(#) Modo Privilegiado: Desde aquí se pueden trabajar todos los comandos show,
(config#) Modo Global: Desde aquí se trabaja las listas de acceso.
(config-if) Modo Int: Desde aquí se trabaja la configuración de las interfaces, se
cargan las listas de acceso, y el clock rate.
(config-Router)# Modo Router: Desde aquí se trabaja la subida del protocolo y su
respectiva configuración.
2.5.1 Comandos para el cambio de distintos Modos de trabajo
• De Modo Usuario a Privilegiado.
(Enable).
• De Modo Privilegiado a Global.
(Configure terminal).
• De Modo Global a Int.
(Interface serial 0) "serial 0" depende de la interface en la que se este trabajando.
• De Modo Global a Router.
(Router rip).
• Estando en cualquiera de los Modos y desea bajar un Modo se utiliza el comando
(Exit).
• Estando en cualquiera de los Modos y se desea pasar a modo Privilegiado se
utiliza el comando (ctrl.+Z).
2.6 Algunos comandos Necesarios para la buena configuración del Router
Los comandos show y otros que se ejecutan desde el Modo Privilegiado.
Show running: Muestra la versión del sistema operativo.
Muestra el nombre del Router.
Muestra la IP de todas las interfaces y su respectiva descripción.
Muestra si esta cargado el clock rate.
Muestra las IDS de las redes y sub-redes conectadas directamente al Router.
Muestra las listas de acceso.
Muestra la manera de la que fue configurado el respectivo protocolo.
Show versión: Muestra la información del Router, como
Capacidades de memoria.
Sistema operativo.
IOS.
Archivo de registro.
• Show Start: este comando hace lo mismo que Show running.
• Show Interface (numero de interface): muestra la información de la respectiva
interfast (ejemplo show interface 1ß ).
• Write: guarda los cambios efectuados en el archivo de Configuración.
• Show ip Inter brief: este comando muestra las conexiones existentes y si
están funcionales o no lo están.
• Show ip route: muestra que redes y cuantas sub-redes están conectadas, si
son funcionales o no, cuantas redes a aprendido, que tipo de protocolo esta
• Cargado, y que interfaces están conectadas.
• Show access-list: muestra las listas de acceso.
• En general estos son los comandos más usados en la configuración de un
Router.
2.7 Pasos a seguir para la configuración de un Router
(Teniendo toda la parte de hardware lista)
1. estando dentro del Router, vamos a darle un nombre a nuestro Router
entonces:
Estando en Modo Global: (config#) hostname "nombre".
Como por ejemplo (config#) hostname Bogotá. Al dar Enter debe de salir el siguiente
renglón en blanco.
2. como necesitamos conectar las demás redes al Router, tendremos que darles una
dirección IP, pero antes de proceder, una pequeña aclaración.
"Las mascara para las dos direcciones es de 30"

1. 172.83.24.2
Las conexiones de un dispositivo a otro deben de tener la misma redy sub.-red, solo
cambiara el nodo, de este modo será lo mismo con las demás conexiones.
Es muy recomendable utilizar una sola mascara para las conexiones entre Routers
(CABLE SERIAL), personalmente utilizo mascara 30 para no tener que desperdiciar
IP.
Continuando, para dar una IP a una interface seguimos los siguientes pasos.
1. ingresamos al Modo Int completo.
2. Ejemplo: (config-if) interface serial 0
En la parte de "serial" cambia si se va a configurar otra interface.
Ejemplo: (config-if) interface Ethernet 0

3. ingresamos a la interface con el paso anteriormente nombrado.


El comando es (config-if)# ip address la dirección y mascara.
Ejemplo (config-if)# ip address 172.83.24.1 255.255.255.252
4. ya habiendo puesto esto, en la siguiente linea escribimos el comando para dar
la IP
La descripción debe de llevar el nombre del Router al que va conectado y a
cual interface, en general solo son estas dos cosas.
(config-if)# description conecta al Router Manizales a la interface serial 2/0

5. después de esto en la siguiente línea damos su descripción de la siguiente


manera.
6. ya para terminal en la siguiente línea escribimos el comando para cargar lo
hecho a la interface.
(Config-if)# No shutdown.

Después de escribir no shutdown, damos ctrl.+Z (aparecerá como Z) para pasar a


modo privilegiado, y escribimos write (wr) para que cargue lo hecho al archivo de
configuración.

Ahora vamos a configurar una Fast Ethernet.


MAPA
1. en esencia es lo mismo:
2. Ingresamos al modo INT y damos el comando "interface FastEthernet 0/0.
3. estando allí damos el siguiente comando "ip address (dirección y mascara)
192.16.24.1 255.255.255.0"
4. a continuación damos la descripción "description este Router conecta con el
SW 0 a la interface 4/0.
5. luego la cargamos a la interface "no shutdown"
6. a continuación damos ctrl.+Z.
7. estando en Modo privilegiado escribimos Write.
Listo, ya sabes poner direcciones IP a las interfaces, estos mismos pasos sirven
para todas.
3. Como configurar el Computador para que acepte estos cambios en la
topología?
Las direcciones IP de los Computadores deben de tener la misma red y sub.-red de
la interface fastEthernet o Ethernet que distes.
Ejemplo: 192.16.24.1 para la interface del Router. (255.255.255.0 es la mascara).
192.16.24.2 para uno de los Computadores
192.16.24.3 para otro Computador etc.
Configurando el Computador debes de entrar al MS-DOS o SIMBOLO DEL
SISTEMA, para Computadores Windows 2000 y XP.
Comandos: winipcfg.
Allí pondrás la dirección IP del Computador, la mascara de sub.-red y la puerta de
enlace (Gateway)
La puerta de enlace es por donde entra y sale la información, allí ponemos la IP de
la interface del Router, que está conectada al SWITHS y luego al Router.

3.1 Cargar el protocolo (RIP)


Ahora vamos a cargar un protocolo (RIP), este protocolo ya lo hemos visto en
explicaciones pasadas, y es muy fácil trabájalo.
Pasamos a Modo Router.
Ejemplo: Network 192.168.192.192 (Enter)
200.192.224.224 (Enter)
10.192.0.0 (Enter) etc.
escribimos el comando Network y procedemos a colocar las ID de todas las
redes que se encuentren directamente conectadas al Router.
al terminar de hacer esto pasamos a Modo Privilegiado y guardamos los
cambios hechos (ctrl.+Z).
lo mismo es con todos los Routers.
4. Tipos de rutas, y como utilizarlas
4.1 Las Dinámicas
Al momento de configurar un Router surgen las rutas Dinámicas, estas son las
automáticas, el protocolo lo define configuración de rutas dinámicas con el protocolo
de enrutamiento RIP,(Routing Information Server). Como ya sabemos pertenece a la
familia de protocolos IGP, (Interior Gateway Protocol) y presenta las siguientes
características:
Pertenece a la familia de protocolos de vector distancia los cuales buscan el
camino más corto determinando la dirección y la distancia a cualquier enlace.
Estos algoritmos de enrutamiento basados en vectores, pasan copias
periódicas de una tabla de enrutamiento de un router a otro y acumulan
vectores distancia.
La métrica empleada es el número de saltos que hay entre el router origen y
destino. Una red directamente conectada tendrá un coste igual a 1.
Para el intercambio de información emplean datagramas UDP.
El Puerto reservado para este protocolo es el 520.
Las rutas tienen un tiempo de vida de 180 segundos. Si pasado este tiempo,
no se han recibido mensajes que confirmen que esa ruta está activa, se borra.
Estos 180 segundos, corresponden a 6 intercambios de información.
RIP no es capaz de detectar rutas circulares, por lo que necesita limitar el
tamaño de la red a 15 saltos. Cuando la métrica de un destino alcanza el
valor de 16, se considera como infinito y el destino es eliminado de la tabla
(inalcanzable).
Pasada esta pequeña introducción pasemos al ejemplo completo.
La estructura del ejemplo es la de siempre:

La configuración de los diferentes dispositivos sería la siguiente:


Configuración de los switch A:
>enable
#configure
Enter configuration commands, one per line. End with CNTL/Z
(config)#ip addres 192.168.1.253 255.255.255.0
(config)#enable secret cisco
(config)#exit
#
Configuración de los switch B:
>enable
#configure
Enter configuration commands, one per line. End with CNTL/Z
(config)#ip addres 192.168.2.253 255.255.255.0
(config)#enable secret cisco
(config)#exit
#
Configuración del Router A:
// Entramos en el modo configuración:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z
//Pasamos a configurar el interfaz fastethernet.
Router(config)#interface f0/1
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown
14:39:15 %LINK-3-UPDOWN: Interface Fastethernet0/1, changed state to up
14:39:15 %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/1,
changed state to up
Router(config-if)#exit
//Pasamos a configurar el interfaz Serial. Cambia un poco la configuración entrando
en juego varios parámetros nuevos. Por un lado “clock rate” y por otro Bandwidth”.
Hay que resaltar que estos parámetros solo se deben configurar en el router que
haga de DCE.
Router(config)#interface s0/0
Router(config-if)#no shutdown
14:39:33 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
<14:39:33 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed
state to up
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#clock rate 9600
Router(config-if)#bandwidth 56000
Router(config-if)#exit
//Guardamos la configuración.
Router#copy running-config startup-config
Building configuration…
[OK]
Router#La configuración del router B es igual que la del A pero cambiando las IPs
correspondientes. Con esto tendríamos configurados todos los equipos pero nos
quedaría configurar las rutas dinámicas para ello deberemos usar los siguiente
comandos:
# configure terminal
(config)# router rip //Entramos en el modo configuración de protocolo dinámico.
(config-router)#? (algunos de los comandos)
Router configuration commands:
auto-summary Para restaurar la conducta por default de sumarización automática
de rutas de subredes en rutas a nivel de red, usamos el comandos de configuración
de enrutamiento auto-summary. Para deshabilitar esta función debemos utilizar el
prefijo no a este comando.
default-information Control distribution of default information
default-metric Cambia la métrica de las rutas.
distance Define la distancia administrativa.
distribute-list Filter networks in routing updates
exit Sale del modo de configuración.
neighbor Especifica los routers vecinos.
network Defina las redes directamente conectadas.
output-delay Interpacket delay for RIP updates
passive-interface Impedir actualizaciones.
timers Ajustar el tiempo de actualización.
version Selecciona la versión de protocolo.
Para poder concluir nuestro ejemplo deberemos añadir las siguientes líneas a la
configuración:
Router A:
(config)#router rip
(config-router)# version 2
(config-router)# network 192.168.1.0
(config-router)# network 10.0.0.0
Router B:
(config)#router rip
(config-router)# version 2
(config-router)# network 192.168.2.0
(config-router)# network 10.0.0.0
Para comprobar que todo va bien, podemos usar “show ip route” y por supuesto el
comando ping. Por lo tanto para configurar este protocolo de enrutamiento bastará
con anunciar las redes a las que estamos directamente conectados.
Pero existe otro tipo de ruta,
4.2 La Estática.
La configuración de rutas estáticas, si bien es un tema bastante simple, siempre trae
complicaciones a la hora de implementarlo, sobre todo cuando hay más de 2 routers
en la topología.
Las rutas estáticas, a diferencia de las rutas dinámicas que son aprendidas por los
routers mediante protocolos de enrutamiento, son asignadas manualmente en el
router por el admin para que se produzca el enrutamiento de paquetes a una red
destino.
El uso de rutas estáticas es recomendable solo en redes de pequeña envergadura
debido a que normalmente los cambios de topología son mínimos y fáciles de
administrar. No es recomendable utilizar rutas estáticas en redes medianas o
grandes, solo para servicios específicos junto a protocolos de enrutamiento, ya que
al no ser escalable un cambio en la topología implicaría modificar manualmente una
gran cantidad de rutas estáticas en las tablas de enrutamiento de los dispositivos.
Hasta acá la teoría básica sobre enrutamiento estático. Vayamos a lo práctico.
4.2.1 Configuración de Rutas Estáticas
Las rutas estáticas se configuran mediante el comando ip route, en el modo
configuración global, utilizando la siguiente sintaxis:

Router(config)# ip route « IP destino + máscara de red destino ó subred destino » «


IP del siguiente salto ó interfaz de salida » « distancia administrativa »

IP destino + máscara de red o subred destino: La IP específica la red o host que se


quiere alcanzar junto con la máscara de red o subred correspondiente.

IP del siguiente salto: Es la IP de la interfaz del router conectado directamente al


router donde se está configurando la ruta estática.

Interfaz de salida: Es la interfaz serial del router donde se está configurando la ruta
estática. Se utiliza en el caso de desconocer la IP del siguiente salto.

Distancia administrativa: Si no se especifica distancia administrativa, esta tomará el


valor por defecto de 1 en la tabla de enrutamiento. El valor puede ser de 1-255,
siendo 1 el valor que da más importancia a la ruta.

4.2.2 Ejemplo de Configuración de Rutas Estáticas


Supongamos que tenemos la siguiente topología y se nos pide que mediante rutas
estáticas se produzca el enrutamiento de paquetes entre las redes 192.168.1.0,
192.168.2.0 y 192.168.3.0.
Comencemos por el RouterA. Para que los paquetes origen de la red 192.168.1.0
sean enrutados hacia la red 192.168.2.0 y 192.168.3.0 tenemos que configurar 2
rutas estáticas hacia esas redes y asignar la IP del siguiente salto. En este caso, la
IP del siguiente salto para las 2 rutas estáticas es la misma.
RouterA(config)# ip route 192.168.2.0 255.255.255.0 10.0.0.1
RouterA(config)# ip route 192.168.3.0 255.255.255.0 10.0.0.1
En el caso del RouterB, para que los paquetes de la red 192.168.2.0 sean enrutados
hacia la red 192.168.1.0 y 192.168.3.0, también hay que configurar 2 rutas estáticas
pero esta vez la IP del siguiente salto va a ser diferente ya que el enrutamiento se
realiza por diferentes interfaces.
RouterB(config)# ip route 192.168.1.0 255.255.255.0 10.0.0.2
RouterB(config)# ip route 192.168.3.0 255.255.255.0 11.0.0.2
La configuracián del RouterC es muy similar a la del RouterA, hay que configurar las
2 rutas estáticas para acceder a la red 192.168.1.0 y 192.168.2.0 utilizando la misma
IP del siguiente salto.
RouterC(config)# ip route 192.168.2.0 255.255.255.0 11.0.0.1
RouterC(config)# ip route 192.168.1.0 255.255.255.0 11.0.0.1
Si solo tenemos como información las IP de las redes que tenemos que alcanzar y
no tenemos la IP del siguiente salto, utilizamos la interfaz de salida del router local
para nuestra configuración.
RouterA(config)# ip route 192.168.2.0 255.255.255.0 s0/0
RouterA(config)#ip route 192.168.3.0 255.255.255.0 s0/0
RouterB(config)# ip route 192.168.1.0 255.255.255.0 s0/0
RouterB(config)# ip route 192.168.3.0 255.255.255.0 s0/1
RouterC(config)# ip route 192.168.2.0 255.255.255.0 s0/1
RouterC(config)# ip route 192.168.1.0 255.255.255.0 s0/

4.2.3 Comprobación de Rutas Estáticas:


Podemos comprobar la configuración y el funcionamiento de las rutas estáticas
mediante el comando ping. Para comprobar la configuración en caso de fallas usar
el comando show ip route para ver las tablas de enrutamiento. Las marcadas con "C"
son las redes directamente conectadas y las marcadas con "S" son las rutas
estáticas.
RouterA#show ip route
C 10.0.0.0/8 is directly connected, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S 192.168.2.0/24 [1/0] via 10.0.0.1
S 192.168.3.0/24 [1/0] via 10.0.0.1
RouterB#show ip route
C 10.0.0.0/8 is directly connected, Serial0/0
C 11.0.0.0/8 is directly connected, Serial0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
S 192.168.1.0/24 [1/0] via 10.0.0.2
S 192.168.3.0/24 [1/0] via 11.0.0.2
RouterC#show ip route
C 11.0.0.0/8 is directly connected, Serial0/1
C 192.168.3.0/24 is directly connected, FastEthernet0/0
S 192.168.1.0/24 [1/0] via 11.0.0.1
4.2.4 Ejemplo:
Vemos que con las dinámicas no existe ningún problema, pero las estáticas se
pueden utilizar para desviar la información. Aquí diremos como hacerlo.
Rojo: Estática Negro: Dinámica

La información sale desde Manizales hasta Medellín.


Estando en el Router de origen (en este caso Manizales) configuramos utilizando lo
siguiente.
Pasamos a Modo global
(Config#)# IP Router – ID de red – dirección del la interface del Router.
5. Colocar una contraseña en las interfaces del Router
Claro que como Administrador de red, solo yo puedo Administrar la red o personas
con privilegios.
No podemos permitir que cualquier desconocido entre al Router a hacer cualquier
maldad, por eso es bueno instaurar una contraseña para cada interface del Router.
Los pasos son los siguientes:
vamos al modo Global (config#).
Ejemplo: line con 0 ← (Enter).
escribimos line (Modo que deseemos).
Ejemplo: password Bogotá.
password (contraseña que deseemos).
login (la palabra que desees).
Ejemplo: login Cisco.
Cárgalo al Router
en Modo Global (config#) enable password Cisco.
Quitar la contraseña
estando en Modo Privilegiado # escribimos no enable (login)
Ejemplo: # no enable Cisco.
5.1 Máscara de Windcard
Las mascaras de Windcard son muy importantes para lo que viene. Es el inverso de
la máscara de sub.-red y nos ayudan a permitir o denegar partes de la dirección IP.
Ejemplo: que deniegue el acceso a los nodos 172.16.64.0, los Bits de la red y sub.-
red van en 0 pero los de nodos todos los Bits van en 1.
172.16.64.0 0.0.191.255 denegaría los nodos 191.255 o sea todos.
172.16.64.0 es la ID de la red y sub.-red.
172.16.64.1 es la IP de un nodo.
172.16.65.2 es la IP de otro nodo.
172.16.64.0 es la mascara de Windcard para que verifique los nodos.
0.0.0.0 es la máscara de Windcard para que no verifique nada.
255.255.255.255 es la máscara que verifica todo.
0= verifica.
1= no verifica.
In= permite la entrada al Router.
Out= permite la salida del Router.
6. ACL Lista Control de Acceso
Las listas de control de acceso funcionan como un filtro, nos ayudan a denegar o
permitir el acceso de una red a otra red. Pero esta lista casi no se utiliza ya que crea
mucho tráfico en la red, más que deniega los paquetes al finalizar su recorrido.
Existen dos clases de listas de acceso.
Estándar
• Estas listas se configuran lo más cerca al destino.
• Llevan la dirección IP del origen.
• Se toma desde los números del 1 al 99.
• La gran mayoría son con Out.
6.1 ¿Cómo configurarla?
Estando en Modo global escribimos access list (numero 1 a 99) (permit / deny) ID de
red o sub.-red o host origen mascara de windcard.
Ejemplo: (config#) access list 55 deny 192.168.100.1 0.0.0.0
6.2 ¿Cómo cárgala a la interface?
Se ubica en la interface del modo anteriormente explicado.
Ejemplo: modo global interface fastEthernet 1/0 (enter)
IP access-group 55 out (enter)
6.3 ¿Como eliminar la lista de control de acceso?
Estando en modo global damos: no access-list 55 (enter)
Y listo, ya no tenemos lista de acceso 55.
Extendidas
• Se configuran lo mas cerca al origen.
• Lleva la IP de origen.
• Lleva la IP del destino.
• Lleva el protocolo de capa 4. (Modelo OSI)
• Numero de Puerto.
• Lleva un número de 100 a 199.
• Siempre lleva tres sentencias, primero decepciones después sentencia general.
• La gran mayoría son con In.
It = menor que.
Gt = mayor que.
Eq = igual a.
Neg = distinto que.
6.4 ¿Cómo configurarla?
1. Algunos puertos.
FTP = 21
TELNET = 23
Http = 80
SMTP = 25
SHHP = 161
NETBIOS = 137
Ejemplo: (config#) access-list 100 permit tcp host 128.25.247.1 host
193.84.26.8 eq 137
2. Estando en modo global escribimos, access-list (numero de 100 a 199) permit
tcp host (dirección ip Computador origen) host (dirección ip Computador
destino) eq (numero de puerto).
Ejemplo: access-list 100 deny ip 128.25.247.0 (/24) 0.0.0.255 193.84.26.0 (/26)
0.0.0.63
(La letra con rojo no es validad, solamente está allí para que usted conozca la
máscara de sub.-red en el ejercicio pasado).
3. En Modo global: (config#) access-list (numero de lista "debe de ser el mismo
número de la primera sentencia") deny ID de red y sub.-red origen mascara
windcard ID de red y sub.-red de destino mascara windcard.
4. en la nueva línea en blanco escribes la sentencia general así: en modo global
access-list (numero de lista) permit ip any any.
Pasamos a modo Int escribimos: interface (la más cercana, la gran mayoría son
Ethernet o FastEthernet) (enter).
5. para finalizar solo hay que cárgala a la interface más cercana del destino.
6. en esta nueva línea escribimos: ip access-group (numero de lista) (in-entrada
out-salida).
Ejemplo paso 3: (config#) access-list 100 permit IP any any (enter)
Ejemplo paso 4: interface FastEthernet 0/0 (enter)
Ip access-group 100 in (enter)
Ejemplo paso 5: ip access-group 100 In (enter).

7. Comandos para configurar un Switch Cisco


Etiquetas:
El siguiente es un pequeño resumen sobre comandos para configurar un switch
cisco y algunos de router.

7.1 Rip (Routing Information Protocol)


NewYork(config)#interface fastethernet0/0
NewYork(config-if)#ip address 192.168.50.129 255.255.255.192
NewYork(config-if)#ip rip send version 1
NewYork(config-if)#ip rip receive version 1
NewYork(config)#interface fastethernet0/1
NewYork(config-if)#ip address 172.25.150.193 255.255.255.240
NewYork(config-if)#ip rip send version 1 2

Show ip protocols
show interface interface
show ip interface interface
show running-config
Show ip rip database
7.2 Switch
Switch# dir flash:
Switch#show flash
Switch#show vlan

Switch#vlan database
Switch(vlan)#vlan vlan_number
Switch(vlan)#exit
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number
Switch#vlan database
Switch(vlan)#no vlan 300
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number

Sw1#delete flash:vlan.dat
Sw1#erase startup-config
Sw1#reload

7.3Interface web
Sw1(config)#ip http port 80

Ver la tabla MAC:


Switch#show mac-address-table (? Mas opciones)
Switch#clear mac-address-table

7.4 Asignar una mac estatica


•Switch(config)#mac-address-table static interface FastEthernet vlan
•Switch(config)#no mac-address-table static interface FastEthernet vlan
Seguridad de Puerto

Sw1(config)#interface fastEtehernet 0/2


Sw1(config-if)#switchport port-security ?(sale las opciones)

Limitar la cantidad de host por puerto


1900:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#port secure mas-mac-count 1

2950:
Sw1(config)#interface fastEtehernet 0/2
Sw1(config-if)#switchport port-security maximum 1.

8. OSPF (Open Shortest Path First) La ruta abierta más corta

Router(config)#router ospf process-id


Router(config-router)#network address wildcard-mask area area-id

Router(config)#interface lookback 0
Router(config-if)#ip address 192.168.3.33 255.255.255.255

Rtr(config-if)# bandwidth 64
Rtr(config-if)# ip ospf cost 1562

Autenticación sin md5


Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area-number authentication
Autenticación con md5
Router(config-if)#ip ospf message-digest-key key-id encryption-type md5 key
Router(config-router)#area area-id authentication message-digest

Router(config-if)#ip ospf hello-interval seconds


Router(config-if)#ip ospf dead-interval seconds
debug ip ospf events

8.1 Aumentar la prioridad para elegir un router DR


sw(config)#interface fasethernet 0/0
sw(config-if)#ip osfp priority 50
sw(config-if)#end

8.2 EIGRP
Router(config)#router eigrp as-id
Router(config-router)#network 192.168.3.0
Router(config-router)#end
Router# show ip eigrp topology
eigrp log-neighbor-changes
resumen de rutas: router(config-router)#no auto-summary

9. Configuración del Puerto que se desconecte cuando se produce una


violación de seguridad.

Sw(config-if)#switchport port-security violation shutdown


2900xl:
Sw(config-if)#port security action shutdown

9.1Poner Ip a la Vlan1
Catalyst 2950
Sw(config)#interface Vlan1
Sw(config-if)#ip address 192.168.1.2 255.255.255.0
Sw(config-if)#no shutdown
Sw(config)# ip default-gateway 192.168.1.1

Catalyst 1900
Sw(config)#ip address 192.168.1.2 255.255.255.0
Sw(config)# ip default-gateway 192.168.1.1

9.2 Archivos de configuración


Sw# copy running-config startup-config
1900:
Sw#copy nvram tftp://tftp server ip add/destination_filename

9.3 Configuración de la velocidad


Switch(config)#interface fastethernet 0/9
Switch(config-if)#duplex full
Switch(config-if)#speed 100

9.4 Crear el trunk del switch


Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#end}

2900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

1900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

9.5 Trunk en el router


Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1q vlan-number
Router(config-subif)#ip address…….
router1#copy running-config tftp

9.6 Quitar un Puerto de una VLAN


Switch(config)#interface fasethernet 0/9
Switch(config-if)#no switchport access vlan 300

9.7 Eliminar una vlan


Switch#vlan database
Switch(vlan)#no vlan 300
Spanning tree
show spanning-tree

9.8 Configuración de VTP


switch#vlan database
switch#vtp v2-mode
switch(vlan)#vtp domain password
switch#vtp {client | server | transparent}

9.10 Copiar el IOS a un server tftp


Sw#copy flash tftp
2900: sw#copy flash:nombre_del_archivo tftp

9.11 Copiar IOS desde un Server tftp


Sw#copy TFTP flash
Sw# copy Start tftp

1900: sw#copy nvram tftp://numero-ip/name


Sw#copy tftp startup-config

1900: sw#copy tftp://numero-ip/name nvram

10. Recuperar el acceso al Switch

10.1 Apagar el switch, Vuelva a encenderlo mientras presiona el botón


MODE en la parte delantera del switch. Deje de presionar el botón MODE una
vez que se apague el led de STAT
10.2 introducir los siguientes comandos:
flash_init
load_helper
dir flash:
10.3 rename flash:config.text flash:config.old
10.4 reiniciar el sistema original:
10.4.1 despues de entrar al switch hacer: rename flash:config.old
flash:config.text
10.4.2 sw#copy flash:config.text system:running-config
10.4.3 Cambiar los password

11. Actualizar el firmware


Sw#show boot (muestra el archive de boteo)

Cambiar el nombre del archivo de la ios,con el commando #rename flash:nombre


flash:Nuevo_nombre
Sw(config)#no ip http Server
Sw# delete flash:html/*

12. Extraer la nueva versión del IOS


Sw#archive tar /x tftp://192.168.1.3/nombre_del_archivo.tar flash:
Sw(config)#ip http Server
Sw(config)#boot system flash: nombre.bin
Spanning-Tree
#show spanning-tree brief

12.1 Cambiar prioridad:


ios 12.0 sw(config)#spanning-tree priority 1
sw(config)#exit
ios 12.1 sw(config)#spanning-tree vlan 1 priority 4096
sw(config)#exit
12.2 Configurar VLAN
Sw#vlan database
Sw(vlan)#vlan 2 name Logistica
Sw(vlan)#vlan 3 name Licitaciones
Sw(vlan)#end

1900:
Sw#config terminal
Sw(config)#vlan 2 name VLAN2
Sw(config)#vlan 3 name VLAN3

12.3 Configurar puertos en las VLAN


Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan2
Sw(config-if)#end

12.4 Eliminar el Puerto de la vlan


Sw(config-if)#no switchport access vlan2
Sw(config-if)#end

1900:
Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#vlan static 2

12.5 Para eliminar un Puerto de la vlan


Sw(config-if)#no vlan-membership 2
Sw#show vlan
Sw#show vlan id 2

1900: Show vlan-membership


Show vlan 2

12.6 Eliminar un vlan


Sw#valn database
Sw(vlan)#no vlan 3
Sw(vlan)# exit
1900: sw(confgi)# interface ethernet 0/7
sw(confgi)#no vlan 3

12.7 Enlace troncal ISL


sw(Config.)#interaface fastethernet 0/1
sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation isl
sw(Config-if)#end
enlace troncal 802.1q

2950: por defecto dotiq


sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk

2900:sw(Config.)#interafce fastethernet 0/1


sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation dot1q

12.8 Vtp, servidor y cliente


Sw# Vlan database
Sw(vlan)# vtp server
Sw(vlan)# vtp domain group1
Sw(vlan)# exit
Sw# Vlan database
Sw(vlan)# vtp client
Sw(vlan)# vtp domain group1
Sw(vlan)# exit

12.9 Ruteo entre VLAN


Poner el encapsulamiento en las subinterfaces del router
(config-if)#interface fastethernet 0/0.1
(config-subif)#encapsulation dot1q 1 (1 es la vlan a la que esta)
Para la configuración inicial del Switch se utiliza el puerto de consola conectado a un
cable transpuesto o de consola y un adaptador RJ-45 a DB-9 para conectarse al
puerto COM1 del ordenador. Este debe tener instalado un software de emulación
de terminal, como el HyperTerminal.

Los parámetros de configuración son los siguientes:


• El puerto COM adecuado
• 9600 baudios
• 8 bits de datos

• Sin paridad

• 1 bit de parada

• Sin control de flujo Asignación de nombre y contraseñas

La asignación de un nombre exclusivo al Switch y las contraseñas correspondientes


se realiza en el modo de configuración global, mediante los siguientes comandos:
Switch>enable
Switch#configureterminal
Switch(config)#hostnameSW_MADRID
SW_MADRID(config)#enable password [nombre de la enable pass]
SW_MADRID(config)#enable secret [nombre de la enable secret]
SW_MADRID(config)#lineconsole0
SW_MADRID(config-line)#login
SW_MADRID(config-line)#password [nombre de la pass de consola]
SW_MADRID(config)#line vty 0 4
SW_MADRID(config-line)#login
SW_MADRID(config-line)#password [nombre de la pass de telnet]

13. Asignación de dirección IP

Para configurar la dirección IP a un switch se debe hacer sobre una interfaz de vlan.
Por defecto la VLAN 1 es vlan nativa del switch, al asignar un direccionamiento a la
interfaz vlan 1 se podrá administrar el dispositivo vía telnet. Si se configura otra
interfaz de vlan automáticamente queda anulada la anterior configuración pues solo
admite una sola interfaz de vlan.

13.1 En un switch 2950:

SW_2950(config)#interface vlan 1
SW_2950(config-vlan)#ip address [direccion ip + mascara]
SW_2950(config-vlan)#no shutdown
Si el switch necesita enviar información a una red diferente a la de administración se
debe configurar un gateway:

SW_2950(config)#ip default-gateway[IP de gateway]


Eliminación de la configuración de la NVRAM:

Switch#erase startup-config

Erasing the nvram filesystem will remove all files! Continue? [confirm]

Erase of nvram: complete


A pesar de eliminar la configuración de la NVRAM las VLANS no se eliminan debido
a que se guardan en un archivo en la memoriua flash llamado VLAN.dat.
En un switch 1900:

SW_1900(config)#ip address [direccion ip + mascara]


SW_1900(config)#ip default-gateway[IP de gateway]
Eliminacion de la configuracion de la NVRAM:

Switch#delete nvram
El switch 1900 no admite sesión de telnet.

Configuración de puertos:

Switch(config)#interface FastEthernet 0/1


Switch(config-if)#speed [10 | 100 | auto]
Switch(config-if)#duplex [full | half | auto]

14. Seguridad de los Puertos


El comando switchport port-security permite asociar la primera dirección MAC a
dicho puerto:

Switch (config)#interface FastEthernet 0/1


Switch(config-if)#switchport port-security

La cantidad posibles de direcciones MAC asociadas al puerto tiene un valor


comprendido entre 1 y 132, el comando switchport port-security maximun permite
establecer la cantidad máxima permitida.

El ejemplo ilustra la configuración de un puerto con 10 direcciones MAC máximas


posibles.

Switch (config)#interface FastEthernet 0/1


Switch(config-if)#switchport port-security maximum 10

En el caso de que se detecte algún intento de violación del puerto se puede ejecutar
el siguiente comando, haciendo que el puerto quede automáticamente cerrado:

Switch (config-if)#switchport port-security violation


[protect|restrict|shutdown]
15. Conclusión

Al Realizar este Esquema básico de configuraciones de una red, hemos llegado a la


conclusión que para poder desarrollar cualquier red siempre tenemos que tener
bases solidas y un buen guía para poder consultar cualquier cosa que nos falla a la
hora de estar montando nuestra red.

En esta manual Describimos la función de cada de router, switch como se


administran las rutas conectadas directamente en la tabla de enrutamiento y
seguridad de los puertos

Además es una ayuda para la Verificación de la configuración de conectividad con


los comandos correspondientes.

Y Describir de qué manera la tabla de enrutamiento puede conectar y utilizar rutas


estáticas o dinámicas