You are on page 1of 2

Universidad del Norte

Departamento de Ingeniera de Sistemas


Algoritmia y Programacin I
Parcial II
1. (2 Puntos)La Alcalda de Barranquilla est interesada en que disee un algoritmo para el recaudo anual
del Impuesto de los predios con que cuenta la ciudad, de acuerdo con las siguientes especificaciones:
La ciudad tiene dos tipos de predios (1= Residencial, 2= Comercial)
Cada predio se identifica por un cdigo y tiene un valor a pagar que se debe leer.
Hay tres posibles fechas de pago (1= paga en la primera fecha y se le concede un descuento del
15% del valor a pagar, 2= Paga en la segunda fecha y se le concede un descuento del 5% del valor a
pagar y 3= No hay descuento)
El algoritmo debe tener un control de fin de recaudos.
El algoritmo debe poder responder las siguientes preguntas:
a) Cuantos predios tipo residencial obtuvieron descuento del 15%
b) Cunto dinero se recogi por los pagos realizados.
c) Cual fue el total de dinero que se descont a los predios de tipo comercial.
d) Cual fue el cdigo del predio que pago mayor dinero por impuestos. Suponga que solo hubo uno
que cumpli con esta condicin.
2.
a. (0.5 puntos) Completar el siguiente algoritmo para que permita mostrar cada trmino y calcular la
suma de la siguiente serie:
3
8
15
24
35
=
+

+
2! 0! 4! 2! 6! 4! 8! 6! 10! 8!
El proceso terminar cuando el k-esimo termino tenga un valor inferior a 10^(-20)

b. (1.0 punto) Escriba el pseudocdigo que implementa la siguiente operacin:

! !
3. (1.5 puntos)En el siguiente algoritmo, llene la tabla con los datos que se muestran en la Instruccin
Escribir ubicada dentro del ciclo Hacer Hasta (Repetir Hasta), si a=5 y b=4?.
Cuando se terminen los ciclos anidados, escriba que valor queda almacenado en la variable sum.

Inicio
definir c,sum, sum1,a,b,d como enteros;
sum1 0;
sum 0;
c 0;
Leer a;
Leer b;
Repetir
d 0;
Repetir
Si
(d+c)%4=0 Entonces
sum1 sum1+1;
Escribir "valores :",c," y ",d, "mostrados ",sum1;

Inicio
enteros i, f, j
real num, sum, term
sum 0
i 1
num 0
term 2
Mientras (_________________________) Hacer
f 1
Para j 1 Hasta ________________ Con Paso 1 Hacer
f f*j
Fin Para
f f* (2*i-1) * 2*i - f
num __________________________
term __________________________
sum __________________________
i i+1
Fin Mientras
Escribir "resultado de la serie: ", sum
Fin

Sino
sum sum+1;
FinSi
d d+1;
Hasta Que (d > b)
c c+1;
Hasta Que (c > a)
Escribir sum;
Fin

Valor final de sum =

Escribir valores:
c
d

mostrados
Sum1

b. (1.0 punto) Escriba el pseudocdigo que implementa la siguiente operacin:

Universidad del Norte


Departamento de Ingeniera de Sistemas
Algoritmia y Programacin I

Parcial II
"

1. (2 Puntos) Tu Taquilla Barranquilla, est programando realizar un concierto, para la cual se le solicita realizar
un algoritmo que lo ayude en las ventas de la boletera. Teniendo en cuenta las siguientes consideraciones:
Habrn tres tipos de boletas: Palco, VIP, Gradera
Inicialmente, se dispone de una cantidad de boletas para los tres tipos de ubicaciones, que usted debe de
leer.
Cada boleta de palco tiene un costo de $6000.000=, la de VIP $250.000=, y la de Gradera $135.000=.
Para cada persona que compra se debe leer su nmero de cedula y la cantidad de boletas a comprar.
Cada persona puede comprar solo de un tipo de boleta y si se le venden si hay existencias suficientes.
Si no hay existencias suficientes, a esa persona no se le vende y se escribe un mensaje No hay suficientes
boletas
El algoritmo termina cuando se acaben todas la boletas de los tres tipos el dueo del evento decida no
vender ms.
Responda a las siguientes preguntas:
a) Cuantas boletas para Palco se vendieron y cuantas quedaron sin vender.
b) Cunto dinero se recopilo por las boletas VIP
c) Cuantas boletas para Gradera, se dejaron de vender por no haber existencias suficientes.
d) Total de dinero recopilado.

4. (1.5 puntos)En el siguiente algoritmo, llene la tabla con los datos que se muestran en la Instruccin
Escribir ubicada dentro del ciclo Hacer Hasta (Repetir Hasta), si a=5 y b=4?.
Cuando se terminen los ciclos anidados, escriba que valor queda almacenado en la variable sum.

Inicio
definir c,sum, sum1,a,b,d como enteros;
sum1 0;
sum 0;
c 0;
Leer a;
Leer b;
Repetir
c 0;
Repetir
Si
(d+c)%4=0 Entonces
sum1 sum1+1;
Escribir "valores :",c," y ",d, "mostrados ",sum1;

a. (0.5 puntos) Completar el siguiente algoritmo para que permita mostrar cada trmino y calcular la
suma de la siguiente serie:
3
8
15
24
35
=
+

+
2! 0! 4! 2! 6! 4! 8! 6! 10! 8!
El proceso terminar cuando el k-esimo termino tenga un valor inferior a 10^(-20)

Inicio

Sino
enteros i, f, j
real num, sum, term
sum 0, i 1, num 0, term 2
Mientras (_________________________) Hacer
f 1
Para j 1 Hasta ________________ Con Paso 1 Hacer
f f*j
Fin Para
F f*(2*i+1)*2*i-f
num __________________________
term __________________________
sum __________________________
i i+1
Fin Mientras
Escribir "resultado de la serie: ", sum

Fin

!+ !

sum sum+1;
FinSi
c c+1;
Hasta Que (c > a)
d d+1;
Hasta Que (d > b)
Escribir sum;
Fin

Valor final de sum =

Escribir valores:
c
d

mostrados
Sum1