You are on page 1of 11

ALGORTMICA

ESTRUCTURAS CONDICIONALES
Y SELECTIVA
Docente: Alejandro Ricaldi Rosas

Concepto
Las estructuras condicionales permiten evaluar una
expresin o expresiones lgicas y segn el resultado de
la evaluacin se procesan un grupo de instrucciones y/o
sentencias.

Condicional Simple
Se emplea para evaluar una expresin o expresiones
lgicas. Si el resultado de esta evaluacin es un valor
lgico verdadero, entonces se procesarn un bloque
de instrucciones y/o sentencias.

Condicional Simple
Sintaxis:

Resulta verdad

SI (Expresion(es) Lgicas) ENTONCES


Instrucciones
y/o
Sentencias

FIN SI

Ejemplo 1: Ingrese 2 nmeros enteros y visualice el


mayor de dichos nmeros ingresados.
ALGORITMO Ejemplo1
VARIABLES
ENTERO: A, B, Mayor
INICIO
LEER ( A, B)
Mayor A
SI ( B > A ) ENTONCES
Mayor B
FIN SI
ESCRIBIR ( Mayor )
FIN

Condicional Doble
Evala una expresin o expresiones lgicas, si el
resultado de esta evaluacin es un valor lgico
verdadero, entonces se procesarn un grupo de
sentencias; caso contrario (si el resultado es falso) se
procesar otro grupo de sentencias.
Sintaxis :
verdad
SI (Expresion(es) Lgicas) ENTONCES
Instrucciones y/o Sentencias

SINO
Otras instrucciones

FIN SI

Ejemplo 2: Calcular el mayor valor de 2 nmeros


enteros ingresados y visualizarlo.
ALGORITMO Ejemplo2
VARIABLES
ENTERO: A, B, Mayor
INICIO
LEER (A, B)
SI ( A > B ) ENTONCES
Mayor A
SINO
Mayor B
FIN SI
ESCRIBIR (Mayor)
FIN

Ejemplo 3: Ingrese un nmero entero y luego visualice si


dicho nmero es PAR o IMPAR.
ALGORITMO Ejemplo3
VARIABLES
ENTERO: N
INICIO
LEER ( N )
Resto N MOD 2
SI ( Resto = 0 ) ENTONCES
ESCRIBIR (ES PAR)
SINO
ESCRIBIR (ES IMPAR)
FIN SI
FIN

Condicional Mltiple
Si la primera expresin lgica a evaluar resulta falso, se
vuelven a evaluar otras expresiones lgicas y as
sucesivamente hasta culminar con el SINO.
Sintaxis :

verdad

SI (Expresion(es) Lgicas) ENTONCES


Instrucciones A

verdad

SINO SI (Expresion(es) Lgicas) ENTONCES


Instrucciones B

SINO
Otras Instrucciones

FIN SI

Ejemplo 4: Calcular el mayor valor de 3 nmeros enteros


ingresados y visualizarlo.
ALGORITMICA Ejemplo4
VARIABLES
ENTERO: N1, N2, N3, MAYOR
INICIO
LEER (N1, N2, N3)
SI (N1 > N2) Y (N1 > N3) ENTONCES
MAYOR N1
SINO SI (N2 > N1) Y (N2 > N3) ENTONCES
MAYOR N2
SINO
MAYOR N3
FIN SI
ESCRIBIR (MAYOR)
FIN

Estructura Selectiva
Se utiliza para evaluar una variable de tipo numrico
entero o carcter, con una lista de valores posibles, para
luego procesar un grupo de instrucciones y/o sentencias.
Sintaxis :
SEGUN (Variable) SEA
CASO valorA : Instrucciones X
CASO valorB : Instrucciones Y
CASO valorC : Instrucciones Z

DE OTRO MODO : Instrucciones n


FIN SEGUN

Ejemplo 5: Ingrese el nmero del da de la semana (1 al 7) y


visualice el nombre del da.
ALGORITMO Ejemplo5
VARIABLES
ENTERO numeroDia
CADENA nombreDia
INICIO
LEER (numeroDia)
SEGN (numeroDia) SEA
CASO 1 : nombreDia Lunes
CASO 2 : nombreDia Martes
CASO 3 : nombreDia Mircoles
CASO 4 : nombreDia Jueves
CASO 5 : nombreDia Viernes
CASO 6 : nombreDia Sbado
CASO 7 : nombreDia Domingo
DE OTRO MODO : nombreDia No existe
FIN SEGN
ESCRIBIR (nombreDia)
FIN