You are on page 1of 8

!

S0
conf t
hostname S0
no ip domain-lookup
line con 0
logging synchronous
!password cisco
login
line vty 0 4
logging synchronous
!password cisco
login
end
conf t
!enable secret cisco
service password-encryption
ip default-gateway 192.168.99.1
end
conf t
int vlan 99
ip address 192.168.99.10 255.255.255.0
no shut
end
conf t
vlan 100
valn 50
int range fa0/1 - 2
switchport mode access
switchport access vlan 100
spanning-tree portfast
spanning-tree bpduguard enable
no shut
int range fa0/5 - 6
switchport mode access
switchport access vlan 50
spanning-tree portfast
spanning-tree bpduguard enable
no shut
end
wr

////////
!S2
conf t
hostname S2
no ip domain-lookup
line con 0
logging synchronous
!password cisco
login
line vty 0 4
logging synchronous
!password cisco

login
end
conf t
!enable secret cisco
service password-encryption
ip default-gateway 192.168.99.1
end
conf t
int vlan 99
ip address 192.168.99.12 255.255.255.0
no shut
end
conf t
vlan 100
valn 50
int range fa0/1 - 2
switchport mode access
switchport access vlan 100
spanning-tree portfast
spanning-tree bpduguard enable
no shut
int range fa0/5 - 6
switchport mode access
switchport access vlan 50
spanning-tree portfast
spanning-tree bpduguard enable
no shut
end
conf t
spanning-tree vlan 100 root primary
spanning-tree vlan 50 root secondary
end
wr
////////////
S1
conf t
hostname S1
no ip domain-lookup
line con 0
logging synchronous
!password cisco
login
line vty 0 4
logging synchronous
!password cisco
login
end
conf t
!enable secret cisco
service password-encryption
ip default-gateway 192.168.99.1
end
conf t
int vlan 99
ip address 192.168.99.11 255.255.255.0

no shut
end
conf t
vlan 100
valn 50
int range fa0/1 - 2
switchport mode access
switchport access vlan 100
spanning-tree portfast
spanning-tree bpduguard enable
no shut
int range fa0/5 - 6
switchport mode access
switchport access vlan 50
spanning-tree portfast
spanning-tree bpduguard enable
no shut
end
conf t
spanning-tree vlan 100 root primary
spanning-tree vlan 50 root secondary
end
wr
/////////////////////////////////
conf t
hostname S3
no ip domain-lookup
line con 0
logging synchronous
!password cisco
login
line vty 0 4
logging synchronous
!password cisco
login
end
conf t
!enable secret cisco
service password-encryption
ip default-gateway 192.168.99.1
end
conf t
int vlan 99
ip address 192.168.99.13 255.255.255.0
no shut
end
conf t
vlan 100
valn 50
int range fa0/1 - 2
switchport mode access
switchport access vlan 100
spanning-tree portfast

spanning-tree bpduguard enable


no shut
int range fa0/5 - 6
switchport mode access
switchport access vlan 50
spanning-tree portfast
spanning-tree bpduguard enable
no shut
end
conf t
spanning-tree vlan 100 root primary
spanning-tree vlan 50 root secondary
end
wr

R1
conf t
hostname R1
no ip domain-lookup
line con 0
logging synchronous
password cisco
login
line vty 0 4
logging synchronous
password cisco
login
end
conf t

enable secret cisco


service password-encryption
end
wr

conf t
vlan 10
name Docentes
vlan 20
name Estudiantes
int range fa0/1 - 3
switchport mode access
switchport access vlan 10
no shut
int range fa0/6 - 8
switchport mode access
switchport access vlan 20
no shut
int range fa0/23 - 24
switchport mode trunk
no shut
int range fa0/4 - 5
shutdown
int range fa0/9 - 22
shutdown
int range gi0/1 - 2
shutdown
end
wr

!R1
conf t
hostname R1
no ip domain-lookup
line con 0
logging synchronous
end
conf t
int g0/0
ip address 192.168.20.1 255.255.255.0
no shut
int s0/0/0

ip address 192.168.30.110 255.255.255.252


bandwidth 4000
no shut
int s0/0/1
ip address 192.168.30.34 255.255.255.252
bandwidth 4000
no shut
exit
router ospf 1
router-id 1.1.1.1
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.110 0.0.0.3 area 0
network 192.168.30.32 0.0.0.3 area 0
passive-interface gi0/0
end
wr

!R2
conf t
hostname R2
no ip domain-lookup
line con 0
logging synchronous
int g0/0
ip address 192.168.10.1 255.255.255.0
no shut
int g0/1
ip address 192.168.30.49 255.255.255.252
no shut
int s0/0/1
ip address 192.168.30.17 255.255.255.252
bandwidth 4000
no shut
router ospf 1
router-id 2.2.2.2
network 192.168.10.0 0.0.0.255 area 0
network 192.168.30.48 0.0.0.3 area 0
network 192.168.30.16 0.0.0.3 area 0
end
wr
!R3
conf t
hostname R3
no ip domain-lookup
line con 0
logging synchronous
end
conf t
ip route 0.0.0.0 0.0.0.0 200.191.72.2

int s0/0/0
ip address 200.191.72.1 255.255.255.0
bandwidth 4000
no shut
int g0/1
ip address 192.168.30.50 255.255.255.252
no shut
int s0/0/1
ip address 192.168.30.33 255.255.255.252
bandwidth 4000
no shut
router ospf 1
router-id 3.3.3.3
network 200.191.72.0 0.0.0.255 area 0
network 192.168.30.48 0.0.0.3 area 0
network 192.168.30.32 0.0.0.3 area 0
passive-interface s0/0/0
end
wr
!R4
conf t
hostname R4
no ip domain-lookup
line con 0
logging synchronous
int s0/0/0
ip address 192.168.30.109 255.255.255.252
bandwidth 4000
no shut
int s0/0/1
ip address 192.168.30.18 255.255.255.252
bandwidth 4000
no shut
router ospf 1
router-id 4.4.4.4
network 192.168.30.108 0.0.0.3 area 0
network 192.168.30.16 0.0.0.3 area 0
end
wr

conf t
int range fa0/21-24
sw mode trunk
no shut
end
wr
s3
conf t
int range g0/1

sw mode trunk
no shut
end
wr
conf t
host name R1
int g0/1
int g0/1.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
int g0/1.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0
int g0/1.99
encapsulation dot1Q 99
ip address 192.168.99.1 255.255.255.0

router ospf10
router-id 1.1.1.1
network 192.168.20.0
network 192.168.40.0
network 192.168.60.0
network 172.16.50.0
network 192.168.99.0
exit
interface fa0/23
no switchport
ip address 172.16.50.2 255.255.255.240
no shutdown
exit

You might also like