You are on page 1of 5

CCNA Routing and Switching Essentials

Christopher Maskell

Reflection Sheet
Name of Activity: Chapter 8 Skills Integration Challenge
Background:
In this Skills Integration Challenge, your focus is OSPFv2 and OSPFv3 configurations. You will
configure IP addressing for all devices. Then you will configure OSPFv2 routing for the IPv4
portion of the network and OSPFv3 routing for the IPv6 portion of the network. One router will
be configured with both IPv4 and IPv6 configurations. Finally, you will verify your configurations
and test connectivity between end devices.

Below is the physical topology of the lab exercise.

What I did:
The first thing I did was I configured IPv4 addressing on router RA, and then I
configured OSPFv2 on router RA as well as the process ID of 1, and a router ID of
1.1.1.1, and set the LAN ID to passive. I then went over to Router RB and configured
OSPFv2 and v3 with IPv4 and IPv6 addresses according to the table, with the G0/0 link
local address being FE80::1. It was also configured with a process ID of 1, and a router
ID of 2.2.2.2, and the LAN interface set to passive. I did the same with OSPFv3, and I
enabled IPv6 and configuring it according to the routing table. Finally, I configured just
OSPFv3 on router RC and I set the link local address on g0/0 to FE80::3. I then entered
the command to allow IPv6 routing. Along with the process ID 1 and the router ID
3.3.3.3. Then I configured the proper IP/IPv6 addresses on PC-A,B and C.

CCNA Routing and Switching Essentials

Christopher Maskell

Problems:
One problem that I had was I didn't remember that in OSPFv3 that you have to enable it
on every interface instead of using the network statement like you do in OSPFv2.

Tests and results:

What I learned:
What I learned and what the focus of this lab, was on OSPFv2 and OSPFv3
configurations. I felt like I learned a lot about the configurations of these two protocols
and how to set them up with IPv4 and IPv6. It also helped strengthen my knowledge of
the configurations that go along with this lab.

CCNA Routing and Switching Essentials


Configurations:
RA#show run
Building configuration...
Current configuration : 1190 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RA
!
ip cef
no ipv6 cef
license udi pid CISCO2911/K9 sn FTX1524VC8D
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.31.0.1 255.255.254.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.31.4.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1

Christopher Maskell
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 172.31.0.0 0.0.1.255 area 0
network 172.31.4.0 0.0.0.3 area 0
!
ip classless
ip flow-export version 9
!
line con 0
history size 100
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
end
RB#show run
Building configuration...
Current configuration : 1363 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RB
!
ip cef
ipv6 unicast-routing
no ipv6 cef
license udi pid CISCO2911/K9 sn FTX1524VLXS
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.31.2.1 255.255.254.0
duplex auto
speed auto

CCNA Routing and Switching Essentials


ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:1::1/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.31.4.2 255.255.255.252
!
interface Serial0/0/1
no ip address
ipv6 address 2001:DB8:2::1/64
ipv6 ospf 1 area 0
clock rate 2000000
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 172.31.4.0 0.0.0.3 area 0
network 172.31.2.0 0.0.1.255 area 0
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
ip classless
ip flow-export version 9

Christopher Maskell
!
line con 0
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
end
RC#show run
Building configuration...
Current configuration : 1021 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RC
!
ip cef
ipv6 unicast-routing
no ipv6 cef
license udi pid CISCO2911/K9 sn FTX15248GJT
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:3::1/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address

CCNA Routing and Switching Essentials


ipv6 address 2001:DB8:2::2/64
ipv6 ospf 1 area 0
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
ip classless
ip flow-export version 9
!
line con 0
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
end

Christopher Maskell