You are on page 1of 5

Basic configuration for 4-PON port OLT

Port
Port information
show interfaces brief
Port configuration
Gigabit Etherent or EPON ports
config
interface gigaEthernet 0/[x] - [x] - gigaEthernet port number
or
interface EPON 0/[x] - [x] - EPON port number
no shutdown - turn current interface on
shutdown - turn current interface off
For ONU setup the speed of ONU
config
interface EPON 0/[x]:[y] - [x] - Epon port number, [y] - ONU number
epon sla upstream pir 1000000 cir 10240
epon sla downstream pir 1000000 cir 10240
For ONU port
config
interface epON 0/[x]:[y] - [x] Epon port number, [y] - ONU number
epon onu port [z] ctc [no] shutdown -[z] ONU port number
Changing GigabitEthernet port speed
config
interface gigaEthernet 0/[x] - [x] gigaEthernet port number
speed [value] ,Where [value] is as follows:
# 10 -- Force 10 Mbps operation
# 100 -- Force 100 Mbps operation
# 1000 -- Force 1000 Mbps operation
# auto -- Enable AUTO speed configuration
Changing Onu ports speed
configure
interface epON 0/[x]:[y] - [x] - Epon port number, [y] - ONU number
epon onu port [z] speed - [z] ONU port number an speed is as follows:
# 10 -- Force 10 Mbps operation
# 100 -- Force 100 Mbps operation
# auto -- Enable AUTO speed configuration

Eurolan Ltd.- Sofia, bul. Tzarigradsko shoes, 7km, building 3, floor 5 phone +3592 9714455, mobile:+359888563583

Cable test
All ONUs
show epon optical-transceiver-diagnosis
A specific ONU
show epon interface epon 0/[x]:[y] onu ctc optical-transceiver-diagnosis
#[x] - Epon port number, [y] - ONU number
Port statistics
show interfaces [type] 0/[x] - [x] port number [type] is gigaEthernet or Epon
show epon interface epon 0/[x]:[y] onu port 1 ctc [function]
[x] Epon port number, [y] - ONU number [function] is as follows:
# auto-negotiation Show ONU interface auto negotiation
# flow-control Show ONU interface flow control
# mcst Multicast
# qos Show ONU interface qos
# ratelimit-ingress Show ONU interface ingress rate limit
# vlan VLAN
clear l2 counters interface [type] 0/[x] - [x] - port number and type is gigaEthernet or Epon
Binding an ONU on the EPON port
interface EPON 0/[x] - [x] - port number
epon bind-onu mac xxxx.xxxx.xxxx [#] - [#] Number to bind to ONU, [xxxx.xxxx.xxxx] - mac address of
the ONU
Turn on 2 MAC address limitation on the ONU
interface epON 0/[x]:[y] - [x] - Epon port number, [y] - ONU number
switchport port-security dynamic maximum 2
switchport port-security mode dynamic
show mac address-table interface epON 0/[x]:[y] - [x] - Epon port number, [y]- ONU number
show mac address-table interface gigaEthernet 0/[x] - [x] port number

Eurolan Ltd.- Sofia, bul. Tzarigradsko shoes, 7km, building 3, floor 5 phone +3592 9714455, mobile:+359888563583

VLAN
show vlan
Create a VLAN
config
vlan [] - []- VLAN number
name [name] - [name]- VLAN number
dd/remove VLAN to the GigaEthernet port
config
interface GigaEthernet 0/[x] - [x] - port number
switchport trunk vlan-allowed add [] - [] - VLAN number
switchport trunk vlan-allowed remove[] - [] - VLAN number
Add/remove VLAN to the Epon port
config
interface Epon 0/[x] - [x] - port number
switchport trunk vlan-allowed add [] - [] - VLAN number
switchport trunk vlan-allowed remove[] - [] - VLAN number
Add/remove VLAN to ONU
config
interface epON 0/[x]:[y] - [x] - Epon port number, [y] - ONU number
epon onu port [z] ctc vlan mode tag [] - [z] ONU port number, [] - VLAN number
Port mode for GigaEthernet
config
interface GigaEthernet 0/[x] - [x] port number
switchport mode trunk - always in TRUNK mode
switchport trunk vlan-untagged none - Do not forward in-tagged traffic
switchport pvid [m] - [m] Management VLAN number
Port mode for Epon port
config
interface Epon 0/[x] - [x] - port number
switchport mode trunk - always in TRUNK mode up-link for ONU
switchport trunk vlan-untagged none - Do not forward in-tagged traffic
switchport pvid [m] - [m] Management VLAN number

Eurolan Ltd.- Sofia, bul. Tzarigradsko shoes, 7km, building 3, floor 5 phone +3592 9714455, mobile:+359888563583

DHCP Snooping
Overall statistics
show ip dhcp-relay snooping statistics
MAC address binding
show ip dhcp-relay snooping binding all
Globally
config
ip dhcp-relay snooping
ip dhcp-relay snooping vlan [] - [] - VLAN number
For the GigaEthernet Port (up-link)
config
interface GigaEthernet 0/[x] - [x] port number
dhcp snooping trust

Security
Turn on/off for mac address binding for the VLAN and the ONU ONU
config
[no]mac address-table static xxxx.xxxx.xxxx vlan [] interface epon 0/[x]:[y]
[x] - Epon port number, [y] - ONU number
Turn on/off for mac address binding for the ONU
config
interface EPON 0/[x]:[y] #[x] - Epon port number , [y] - ONU number
[no]epon onu port 1 mac-bind enable
Turn on/off for the EPON port
config
interface EPON 0/[x] #[x] - Epon port number
[no]filter dhcp
[no]filter icmp
Turn on/off globally
config
[no] ip verify source vlan [vlan list] - Enabling Source IP Address Monitoring in a VLAN

Ip arp inspection
Turn on/off globally
config
[no] ip arp inspection vlan [vlan list]
Turn on/off the arp filter on the EPON port
config
interface EPON 0/[x] - [x] - Epon port number
[no]filter arp

Eurolan Ltd.- Sofia, bul. Tzarigradsko shoes, 7km, building 3, floor 5 phone +3592 9714455, mobile:+359888563583

Loopdetection
Turning on/off the pbdu filtration function on the EPON port
config
interface EPON 0/[x] - [x] - Epon port number
[no]filter bpdu
Globally - Loopgurard
config
spanning-tree mode rstp
spanning-tree loopguard default

IPTV Multicast
Add IPTV Multicast globally
config
ip mcst enable
ip mcst mrouter interface GigaEthernet0/[x] - [x] -UPLINK port number
ip mcst mc-vlan 33 range 239.0.1.1 - 239.0.1.253
On the ONU port
config
interface epON 0/[x]:[y] - [x] - Epon port number, [y] - ONU number
epon onu port [z] ctc mcst tag-stripe enable - [z] - ONU port number
epon onu port [z] ctc mcst mc-vlan add [] - [z] ONU port number, [] - VLAN number
The Multicast VLAN must be on all up-links

Eurolan Ltd.- Sofia, bul. Tzarigradsko shoes, 7km, building 3, floor 5 phone +3592 9714455, mobile:+359888563583