You are on page 1of 18

ANALISIS QUALITY OF SERVICE (QOS) PADA

JARINGAN SESSION DESCRIPTION PROTOCOL


(SDP) MENGGUNAKAN GNS3

Disusun Oleh :
ANDREAN DICKY KURNIAWAN
13101043
S1 TEKNIK TELEKOMUNIKASI B 2013

SEKOLAH TINGGI TEKNOLOGI TELEMATIKA TELKOM


JL. DI. PANJAITAN 128 PURWOKERTO

ABSTRAK- Session Description Protocol (SDP) adalah seperangkat aturan yang


mendefinisikan bagaimana session multimedia dapat diatur untuk memungkinkan
semua end user untuk berpartisipasi secara efektif dalam suatu session. SDP
adalah format untuk menggambarkan parameter inisialisasi media streaming. Pada
penelitian ini layanan Video Streaming dan Voice over IP (VoIP) pada jaringan
lokal SIP menggunakan Graphical Network Simulator (GNS3) dianalisis dengan
mengamati Quality of Service (QoS) yaitu nilai delay, jitter, packet loss dan
throughput dengan Wireshark. Terdapat 3 model/arsitektur jaringan dengan
perbedaan pada jumlah simulasi router Cisco c7200 dan jenis link/kabel
penghubung jaringan komunikasi. Dari hasil pengujian yang dilakukan, diperoleh
bahwa Nilai QoS pada model 1 jaringan lokal SIP menggunakan GNS3 yang dicapture dengan perangkat lunak GNS3 hasilnya sangat baik dan sesuai standar
ITU G.114. Pada model 2 dan 3, layanan video streaming dari komputer 3 ke 2
tidak memenuhi standar karena jalur komunikasinya panjang, melewati 3 router
dan link serta adanya bottleneck pada model 3. Hasil capture QoS perangkat lunak
Wireshark pada simulasi tugas akhir ini terutama nilai delay berbeda dengan
pengamatan langsung karena perangkat keras yang digunakan kurang handal
untuk menggantikan tugas Router dalam menghubungkan berbagai komponen
komunikasi.
Kata Kunci : SDP, VoIP, GNS3, QoS, Wireshark

BAB I
PENDAHULUAN
1.1 Latar Belakang Masalah
Internet telah menjadi kebutuhan yang sangat penting bagi masyarakat yang
menginginkan informasi yang cepat, akurat dan mendukung berbagai jenis
layanan komunikasi. Seiring dengan kebutuhan tersebut, maka dikembangkanlah
suatu protokol jaringan komunikasi yang disebut Session Description Protocol
(SDP). SDP dimaksudkan untuk menggambarkan session komunikasi multimedia
untuk tujuan pengumuman session, undangan session, dan parameter negosiasi.
SDP tidak mengirimkan media itu sendiri tetapi digunakan untuk melaksanakan
negosiasi antar end user dari jenis media, format, dan semua properti terkait.
Himpunan sifat dan parameter sering disebut profil session. SDP dirancang untuk
diperluas untuk mendukung jenis dan format media baru. Selain itu, SDP adalah
seperangkat aturan yang mendefinisikan bagaimana session multimedia dapat
diatur untuk memungkinkan semua end user untuk berpartisipasi secara efektif
dalam suatu session. SDP adalah format untuk menggambarkan parameter
inisialisasi media streaming.
Jaringan VoIP dengan menggunakan Voice VLAN (Voice Virtual Local Area
Network) dapat memisahkan data non-voice dengan voice dalam satu kabel atau
biasa disebut mini-trunk. Hal ini dapat meningkatkan pembagian jalur untuk
VLAN untuk jalur voice dan non-voice. Jaringan Voice memerlukan prioritas
dalam jaringan komputer yang mana dilalui oleh berbagai macam jenis data
(Converged Network). Oleh karena itu, diperlukan QoS (Quality of Service) yang
mampu membagi prioritas serta limitasi bandwidth pada masing-masing jalur.
Jaringan VoIP akan sangat berkembang seiring dengan ketersediaan jaringan
internet yang berbasis IP (Internet Protocol) diharapkan dengan adanya
infrastruktur jaringan internet dan kemajuan teknologi VoIP dapat mengurangi
biaya telepon dan juga fleksibilitas. Kemajuan Teknologi Informasi di bidang
device seperti smartphone yang telah mendukung aplikasi VoIP dan jaringan
wireless, serta IP Phone yang merupakan telepon berbasis IP juga menambah
tingkat penggunaan jaringan voice sebagai media untuk berkomunikasi.
Penelitian sebelumnya tentang berbagai layanan berbasis SDP antara lain
analisis kinerja layanan Voice over Internet Protocol (VoIP) menggunakan

Asterisk sebagai Session Initiation Protocol (SIP) server.. Telah dilakukan juga
Analisis Quality of Service (QoS) Video Streaming pada jaringan IPv4 murni,
IPv6 murni dan tunneling 6to4. Selain itu, terdapat juga penelitian tentang
perbandingan QoS jaringan VoIP menggunakan protocol SDP dan H.323
berdasarkan parameter pendukungnya.
Berdasarkan penelitian - penelitian di atas, dalam tugas akhir ini dibuat
analisis QoS layanan Video Streaming dan VoIP pada 3 model/arsitektur jaringan
lokal SDP menggunakan Graphical Network Simulator (GNS3) sebagai
pengembangan dari tugas akhir yang telah ada. Jaringan lokal SIP adalah sebuah
jaringan komunikasi yang memiliki sebuah sesi inisiasi dalam tugas akhir ini
dilakukan oleh sebuah server VoIP dan tidak tersambung ke jaringan internet
global sehingga disebut jaringan lokal SDP.
Analisis QoS/kinerja layanan dilakukan dengan mengamati dan menganalisis
nilai delay (waktu tunda), jitter (variasi waktu tunda), packet loss (paket/data yang
hilang) dan troughput (bandwith/kecepatan pengiriman data nyata) menggunakan
Wireshark.
1.2 Rumusan Masalah
Berdasarkan latar belakang yang telah disimpulkan diatas, permasalahan yang
muncul pada yang akan di analisis antara lain :
1. Bagaimana hasil analisis Quality of Service (QOS) pada jaringan Session
Description Protocol (SDP) menggunakan GNS3.
2. Bagaimana Quality of Service (QOS) dapat meningkatkan kualitas traffic
suara yang dikirimkan melalui sebuah jaringan dengan parameter packet
loss, jitter, delay, dan throughput.
1.3 Tujuan
1. Mengetahui kualitas traffic suara yang dihasilkan dari layanan VoIP yang
menerapkan Voice VLAN di dalam sebuah jaringan berdasarkan parameter
packet loss, jitter, delay dan Throughput
2. Menganalisis secara menyeluruh mengenai QoS dalam meningkatkan
performa jaringan Voice Over Internet Protocol (VoIP) berdasarkan traffic
suara yang melalui jaringan menggunakan parameter packet loss, jitter,
delay dan throughput
1.4 Kegunaan

Pada hasil analisis Quality of Service (QOS) pada jaringan Session


Description Protocol (SDP) diharapkan memiliki manfaat :
1. Mengetahui kualitas traffic suara yang dihasilkan dari layanan VoIP yang
menerapkan Voice VLAN di dalam sebuah jaringan berdasarkan parameter
packet loss, jitter, delay dan Throughput.
2. Mengetahui Kelemahan layanan VoIP dalam sebuah Jaringan Berdasarkan
traffic suara.

BAB II
TINJAUAN PUSTAKA
Pada bab kajian pustaka ini, diuraikan tentang analisa Quality of Service
(QOS) pada jaringan Session Description Protocol (SDP) menggunakan GNS3.
Beberapa teori yang ada di dalam sub bab telah dibatasi agar pembahasan tidak
terlalu melebar dan supaya terfokus pada teori yang yang dibutuhkan untuk

penyelesaian permasalahan pada tugas akhir ini. Maka berikut ini di uraikan teori
teori yang menjelaskan sub sistem pada telekomunikasi.
2.1 Perancangan Sistem
Pada Tugas Akhir ini dibuat dan dianalisis Quality of Service (Qos) pada
layanan Video Streaming dan VoIP pada 3 model jaringan lokal SIP menggunakan
GNS3. Topologi protokol jaringan SDP terdapat pada Gambar 1.

Gambar 1. Topologi Protokol Jaringan SDP


Secara default, SDP menggunakan protokol UDP tetapi dapat juga menggunakan
TCP sebagai protokol transport. Protokol yang mendukung SDP antara lain :
1. Real-time Transport Protocol (RTP)
Menyediakan transfer media secara terus-menerus pada jaringan paket. Protokol
RTP menggunakan protokol UDP dan header RTP mengandung informasi kode bit
yang spesifik pada tiap paket yang dikirimkan dimana hal ini membantu penerima
untuk melakukan antisipasi jika terjadi paket yang hilang/packet loss.

2. Real-time Control Transport Protocol (RTCP)


Merupakan protokol yang mengendalikan transfer media. Protokol ini bekerja
sama dengan protokol RTP dalam proses transfer media yang terjadi. Dalam sesi
komunikasi, protokol RTP mengirimkan paket RTCP secara periodik untuk
memperoleh informasi transfer media dalam perbaikan kualitas layanan.
3. Session Initiation Protocol (SIP)

SIP

merupakan

sebuah

application-layer

protocol

untuk

membentuk,

memodifikasi, dan menterminasi sebuah sesi multimedia. Seperti layaknya HTTP,


SIP merupakan client-server protocol yang menggunakan model transaksi re&uest
dan response. Sesi multimedia adalah pertukaran data antar pengguna yangbisa
meliputi suara, video dan text. SIP tidak menyediakan layanan secara langsung
tetapi menyediakan pondasi yangdapat digunakan oleh protokol aplikasi lainnya
untuk memberikan layanan yang lebih lengkap bagi pengguna misalnya dengan
RTP (Real Time Transport Protocol) untuk transfer data secara real-time, dengan
SDP (Session Description Protocol) untuk mendiskripsikan sesi multimedia,
dengan MEGACO (Media Gateway Control Protocol) untuk komunikasi dengan
PSTN (Public Switch Telephone Network).
2.2 Quality of Service (QoS) Pada Jaringan Lokal SDP
Merupakan kemampuan suatu jaringan untuk menyediakan layanan yang baik
dengan menyediakan kapasitas jaringan, mengatasi jitter dan delay (waktu tunda).
QoS dirancang untuk membantu pengguna menjadi lebih produktif dengan
memastikan bahwa pengguna mendapatkan kinerja yang handal dari aplikasi aplikasi berbasis jaringan. QoS mengacu pada kemampuan jaringan untuk
menyediakan layanan yang lebih baik pada trafik jaringan tertentu melalui
teknologi yang berbeda- beda. QoS merupakan suatu tantangan yang besar dalam
jaringan berbasis IP dan internet secara keseluruhan. Terdapat banyak hal bisa
terjadi pada paket ketika melakukan perjalanan dari asal ke tujuan, yang
mengakibatkan masalah-masalah dan sering disebut sebagai parameter-parameter
QoS, antara lain:
2.2.1

Delay (Waktu tunda)


Merupakan akumulasi berbagai waktu tunda dari ujung ke ujung pada

jaringan Internet. Delay mempengaruhi kualitas layanan (QoS) karena waktu


tunda menyebabkan suatu paket lebih lama mencapai tujuan. ITU-T G.114
merekomendasikan Delay tidak lebih besar dari 150 ms untuk berbagai aplikasi,
dengan batas 400 ms untuk komunikasi multimedia yang masih dapat diterima.
Sementara itu untuk aplikasi Voice seperti VoIP, batasan delay maksimal adalah
300 ms. Rekomendasi tersebut ditunjukkan Tabel 1.

Tabel 1. Standar Delay Berdasarkan ITU G.114


Sementara itu, delay end-to-end ditunjukkan pada Gambar 2 yang terdiri atas
waktu tunda pengkodean (codec delay), waktu tunda paketisasi (packetization
delay), waktu tunda serialisasi (serialization delay), waktu tunda propagasi
(propagation delay), dan waktu tunda akibat jitter buffer (dejitter buffer delay).

Gambar 2. Delay Pada Jaringan Komunikasi

2.2.2

Jitter (Variasi Waktu Tunda)


Merupakan perbedaan selang waktu kedatangan antar paket di terminal

tujuan. jitter dapat disebabkan oleh terjadinya kongesti, kurangnya kapasitas


jaringan, variasi ukuran paket, serta ketidakurutan paket. Tabel 2 di bawah ini
menunjukkan standar nilai jitter yang mempengaruhi kualitas layanan multimedia.

Tabel 2. Standar Nilai Jitter Berdasarkan ITU G.114


2.2.3

Packet Loss
Merupakan penyebab utama pelemahan video streaming dan VoIP. Packet

loss dapat disebabkan oleh pembuangan paket di jaringan (network loss) atau
pembuangan paket di gateway/terminal sampai kedatangan terakhir (late loss).
Network loss secara normal disebabkan kemacetan (router buffer overflow),
perubahan rute secara seketika, kegagalan link dan lossy link seperti saluran
nirkabel. Kemacetan atau kongesti pada jaringan merupakan penyebab utama dari
packet loss. Tabel 3 menunjukkan standar nilai packet loss yang mempengaruhi
kualitas layanan (QoS).

2.2.4

Tabel 3. Standar Packet loss Berdasarkan ITU G.114


Throughput
Merupakan rate (kecepatan) transfer data efektif, yang diukur dalam bit per

second (bps). Throughput merupakan jumlah total kedatangan paket yang sukses
yang diamati pada sisi klien/tujuan selama selang waktu tertentu dibagi oleh
durasi selang waktu tersebut.
2.3 Komponen Perangkat Keras

1. Laptop Lenovo G480 untuk menjalankan GNS3, Router Cisco c7200, dan
Virtual Box dengan Sistem Operasi Windows XP SP 2 sebanyak 2 buah
dan Trixbox sebagai server VoIP.
2. Laptop Lenovo untuk menjadi broadcaster video streaming dan klien
VoIP.
3. Kabel Local Area Network (LAN) dengan crimping jenis cross.
4. Headphone untuk melakukan percakapan VoIP.
2.3.1

Komponen Perangkat Lunak


1. GNS3 sebagai perangkat lunak utama yang berfungsi sebagai
emulator/berfungsi selayaknya Router Cisco c7200 dan sebagai inti jaringan
lokal SIP yang menyediakan layanan Video Streaming dan VoIP.
2. Asterisk Trixbox v2.8.0.4 yang di-install di ubuntu sebagai server VoIP
dan mempunyai keunggulan dapat melakukan pengaturan server dengan
GUI sederhana.
3. VLC Media Player v2.0.6 Twoflower untuk mengirim dan menjalankan
video streaming.
4. X-Lite v3.0 sebagai softphone VoIP dan di-install pada 3 klien VoIP.
5. Mozilla Firefox v17.0.1 untuk setting GUI pada server VoIP PBX.
6. Wireshark v1.6.8 sebagai penganalisa protokol jaringan/network protocol
analyzer.

2.4 Instalasi dan Konfigurasi GNS3


GNS3 dapat dijalankan di berbagai sistem operasi, seperti Windows, Linux,
atau Mac OS. Prinsip kerja GNS3 adalah mengemulasi Cisco Internetworking
Operating System (IOS) pada komputer, sehingga PC dapat berfungsi layaknya
sebuah atau beberapa router dan switch dengan cara mengaktifkan fungsi dari
Ethernet Switch Card. Perangkat lunak GNS3 dapat diunduh dari www.gns3.net
lalu dilakukan proses Instalasi. Setelah itu, GNS3 dapat digunakan dan proses
konfigurasi untuk membuat layanan Video Streaming, Audio Streaming, VoIP dan
Conference Call dapat dimulai. Konfigurasi dan proses pembuatannya dibagi
menjadi beberapa tahap, yaitu:
2.4.1

Menambahkan IOS Image Pada GNS3


Merupakan sistem operasi yang digunakan pada router Cisco. GNS3

membutuhkan image IOS untuk dapat mensimulasikan dan mengemulasi

perangkat Cisco. Seperti sistem operasi lain, Cisco IOS memiliki antarmuka
pengguna sendiri dan dapat mengeksekusi perintah konfigurasi. Setiap perubahan
yang dimasukkan oleh administrator jaringan disimpan pada konfigurasi
berjalan/running-config dan segera dilaksanakan. Pada Tugas Akhir ini,
menggunakan IOS yang dapat mengemulasi sistem operasi Router Cisco c7200.
2.4.2

Membuat Topologi Jaringan


Pada Tugas Akhir ini menggunakan Router Cisco c7200, virtual box guess,

cloud dan link. Router c7200 dipilih karena merupakan Router Cisco yang paling
stabil performa IOS-nya. Selanjutnya diatur juga penggunaan slot port pada router
dan LAN Card yang akan digunakan pada setiap host yang akan di sambungkan.
Selain itu, digunakan juga VirtualBox untuk koneksi ke komputer dengan jaringan
yang berbeda. Untuk koneksi ini digunakan kabel GigaEthernet yang terdapat
pada GNS3 dan dihubungkan ke semua bagian dari model jaringan lokal SIP.
Ethernet adalah protokol LAN yang dikembangkan oleh Xerox Corporation yang
bekerjasama dengan DEC dan Intel pada tahun 1976. Layanan Video Streaming
dan VoIP pada jaringan lokal SIP ini menggunakan 3 model/arsitektur jaringan
pada GNS3 yang terintegrasi/terhubung dengan berbagai perangkat lunak
pendukung layanan tersebut. Topologi jaringan lokal SIP secara umum yang
digunakan adalah topologi star yang berpusat di router R1 dengan masing
masing klien PC dan Server VoIP berbeda jaringan.
2.4.3

Konfigurasi Router R1 Pada GNS3


Router adalah perangkat jaringan yang dapat menghubungkan beberapa

jaringan yang berbeda. Konfigurasi Router R1 model 1 jaringan lokal SDP pada
GNS3 sebagai berikut :
Router>en
Router#conf t
Enter configuration commands, one per line. End
with CNTL/Z. Router(config)#hostname R1
R1(config)#interface GigabitEthernet 1/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)# interface GigabitEthernet2/0

R1(config-if)# ip address 192.168.3.1 255.255.255.0


R1(config-if)# no shutdown
R1(config)#interface GigabitEthernet 3/0
R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface GigabitEthernet 4/0
R1(config-if)# ip address 192.168.4.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#router ospf 10
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.2.0 0.0.0.255 area 0
R1(config-router)#network 192.168.3.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#^Z
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R1#

Pada model 2 jaringan lokal SDP menggunakan GNS3 yang terdiri dari 3
router, konfigurasi Router R1 sama seperti pengaturan R1 pada model 1.
Sedangkan pengaturan router R2 sebagai berikut
R2#config terminal
R2(config)#interface GigaEthernet 1/0
R2(config-if)# ip address 182.182.182.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)# interface GigaEthernet 2/0
R2(config-if)# ip address 10.128.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-router)#exit
R2(config)#exit
R2#copy run start
R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Sementara pengaturan router R3 sebagai berikut :


R3#config terminal

R3(config)#interface GigaEthernet 1/0


R3(config-if)# ip address 10.128.1.2 255.255.255.0
R3(config-if)#no shutdown
R3(config)# interface FastEthernet 2/0
R3(config-if)# ip address 192.168.4.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-router)#exit
R3(config)#exit
R3#copy run start
R3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Pada model 3 jaringan lokal SDP menggunakan GNS3 yang terdiri dari 3
router, konfigurasi Router R1 dan R3 sama seperti pengaturan pada model 2.
Sedangkan pengaturan router R2 sebagai berikut:
R2#config terminal
R2(config)#interface GigaEthernet 1/0
R2(config-if)# ip address 182.182.182.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)# interface Serial 2/0
R2(config-if)# ip address 10.128.1.2 255.255.255.0
R2(config-if)# clock rate 152000
R2(config-if)# no shutdown
R2(config-router)#exit
R2(config)#exit
R2#copy run start
R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Setelah itu, menyiapkan VirtualBox yang sudah di-install OS Windows XP,


memberi IP address 192.168.1.3 dan 192.168.4.3 pada network OS Windows XP
yang lain di VirtualBox. Selain itu, mengatur IP OS Windows 7 pada laptop
Lenovo dengan IP address 192.168.2.3. Hasil akhir dari pengaturan pengaturan
di atas akan membentuk 3 model jaringan lokal SDP pada GNS3 yang telah
terintegrasi dengan berbagai perangkat lunak yang telah diinstall pada VirtualBox

dan sistem operasi Windows sehingga dapat menyediakan layanan video


streaming dan VoIP pada jaringan lokal SIP.

2.5 Kerangka Pemikiran


Untuk itulah pada Tugas Akhir ini akan dilakukan analisa Quality of Service
(QOS) pada jaringan Session Description Protocol (SDP) menggunakan GNS3
Sehingga proses menganalisa tidak lagi membutuhkan banyak alat, hanya
membutuhkan laptop, smartphone, dan software-software. Dengan demikian
analisa bisa dilakukan dengan waktu yang agak lama serta tidak kesulitan ketika
menggunakan suatu layanan VoIP dan kualitasnya agar lebih bermanfaat dan tidak
ada kesalahan-kesalahan lagi pada melakukan suatu layanan QoS.
2.6 Hipotesis
Analisis Quality of Service (QOS) pada jaringan Session Description Protocol
(SDP) menggunakan GNS3 untukk memudahkan bagi pengguna agar bisa
menggunakan layanannya dengan baik dan dibutuhkan waktu agak lama untuk
menganalisa karena banyak software-software yang harus di install dan
menggunakan ubuntu untuk layanan VoIP, tetapi tidak mengeluarkan biaya
apapun.

BAB III
METODE PENELITIAN
Bab metode penelitian menjelaskan beberapa hal pokok yaitu obyek
penelitian, metode dan disain penelitian, operasionalisasi variabel, langkahlangkah dalam pengumpulan data dan alat pengumpulan data, pengolahan data
serta analisis data yang dipakai. Semuanya dijelaskan secara cermat dan jelas.
3.1 Objek Penelitian
Ada beberapa parameter atau objek penelitian yang akan digunakan dalam
penelitian perancangan perangkat lunak drive test ini. Parameter tersebut antara
lain :
1.
2.
3.
4.

Delay
Jitter
Packet Loss
Throughput

3.2 Metode dan Desain Penelitian


Tahap pertama yang dilakukan pada menganalisa Quality of Service (QOS)
pada jaringan Session description Protocol (SDP) adalah menginstall GNS3,
Asterisk, dan Wireshark untuk mengetahui kelebihan dan kelemahan pada
jaringan SDP. Setelah mengetahui kelebihan dan kelemahan pada jaringan
tersebut yang dilakukan adalah memperbaiki kelemahan-kelemahan jaringan
tersebut agar bisa lebih baik saat digunakan.
3.2.1 Use Case Diagram
Use case merupakan gambaran skenario dari interaksi antara user
dengansistem. Sebuah diagram use case menggambarkan hubungan antara aktor
(pengguna) dan kegiatan yang dapat dilakukannya terhadap aplikasi. Berikut ini

adalah use case diagram yang memperlihatkan peranan aktor dalam interaksinya
dengan sistem.

Gambar 3.2.1 Use Case Diagram


3.2.2 Activity Diagram
Jalur kerja dari aplikasi drive test akan dijelaskan pada Activity Diagram
dibawah ini :

Gambar 3.2.2 Activity Diagram


3.3 Operasionalisasi Variabel

Pengambilan data dilakukan dengan proses pengukuran beberapa


parameter yang telah di sebutkan pada subbab 3.1 pengambilan data ini
dibandingkan dengan pengambilan data QoS menggunakan metode yang sudah
ada, hal ini bertujuan untuk mengetahui kualitas hasil analisis. Berikut ini rincian
untuk melakukan proses pengambilan data.
1. Melakukan Pengiriman Paket antar user
2. Mengambil data menggunakan wireshark
3. Menganalisa hasil pengiriman dan hasil pada wireshark
3.3.1 Diagram Alur Penelitian

Mulai

Menginstal GNS3, Wireshark


dan Asterisk

Membuat Topologi Jaringan

Konfigurasi topologi Jaringan

Mengambil data
menggunakan Wireshark

Menganalisa hasil percobaan

Selesai

3.4 Sumber Data dan Alat Pengumpulan Data


Dalam penelitian ini yang dimaksud dengan pengumpulan data ada dua
pengertian, yaitu :
a. Data untuk kebutuhan percobaan
Data yang dimaksud adalah data referensi pendukung berupa jurnal
ilmiah, buku pustaka, laporan skripsi, datasheet dari setiap komponen atau
modul yang akan digunakan.
b. Data untuk hasil penelitian
Data yang dimaksud adalah data yang diperoleh pada saat pengujian
alat apakah alat telah bekerja sesuai dengan yang diharapkan atau belum.
Sehingga dapat diketahui kekurangan pada alat tersebut apabila terjadi
kesalahan pada saat alat tersebut bekerja

3.5 Teknik Pengolahan Data


Dalam penelitian ini metode yang digunakan untuk mengolah data adalah
metode komparasi dan deskriptif. Metode komparasi yaitu dengan cara
membandingkan nilai percobaan dengan pengukuran yang dihasilkan antara
menggunakan Asterisk pada ubuntu dengan Software GNS3 pada windows yang
dibuat. Sedangkan metode deskriptif yaitu penjelasan tentang kelebihan dan
kekurangan dari sistem yang akan dibuat.