You are on page 1of 22

Oficina Nacional de Gobierno

Electrnico e Informtica

Interconexin de Redes

Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Que se necesita para interconectar Redes?


Primero debemos saber si las redes son locales o remotas.
Si las redes son locales, debemos tener todas maquinas en una misma
red.
Si las redes son remotas debemos tambin tener equipos con capacidad
de encaminar la informacin de una red hacia la otra red.
El nivel de seguridad que requieren las redes.

Peru_e_Gobierno

GobiernoElectronicoONGEI

Interconexin de Red Local

Oficina Nacional de Gobierno


Electrnico e Informtica

Las maquinas que desean comunicarse deben estar dentro de


la misma red (ejemplo 192.168.1.0/24)
Se requiere de un equipo que conmute la informacin entre las
diferentes maquinas.
.1

.2

.253

Peru_e_Gobierno

.254

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Interconexin de Redes Remotas

Se requiere tambin de un equipo que encamine la


informacin entre las diferentes redes.
Se requiere de una puerta de enlace o una puerta por defecto.
.2

.2

192.168.1.0/24

.1
192.168.3.0/24

.254

Peru_e_Gobierno

.1

.254

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Nivel de seguridad

Se requiere conocer como funcionan los servicios, entender las


Capas OSI para realizar filtros por polticas y listas de accesos.

.2

.2

192.168.3.0/24

192.168.1.0/24

.254

Peru_e_Gobierno

.1

.1

.254

GobiernoElectronicoONGEI

Redes Locales

Oficina Nacional de Gobierno


Electrnico e Informtica

Se debe saber el tamao de la Red, esto se refleja por la


mascara de la red.
x.y.z.0/24 (256 Ips 254 equipos, mascara 255.255.255.0)
x.y.0.0/16 (65536 Ips 65534 equipos, mascara 255.255.0.0)
x.0.0.0/8 (16777216 Ips 16777214 equipos, mascara 255.0.0.0)
Hay 2 ips que no se usan:
Ip de red y la Ip de Broadcast
Peru_e_Gobierno

GobiernoElectronicoONGEI

Redes Locales

Oficina Nacional de Gobierno


Electrnico e Informtica

Dentro de una red local los equipos que se encuentren dentro


del rango de una misma red pueden comunicarse.
Ejemplo la 192.168.1.0/24, tiene la siguiente distribucin:
192.168.1.0 (ip que representa a la red)
192.168.1.1 hasta 192.168.1.254 (ips que pueden asignarse a
equipos)
192.168.1.255 (ip de broadcast, enva paquetes a los equipos con
ips desde la 192.168.1.1 hasta la ip 192.168.1.254)
Peru_e_Gobierno

GobiernoElectronicoONGEI

Redes Remotas

Oficina Nacional de Gobierno


Electrnico e Informtica

Las maquinas requieren de una ip que les sirva como puerta de


salida para su informacin.
Ip 192.168.1.2
Mascara = 255.255.255.0
GW 192.168.1.1

192.168.1.0/24
.1

Ip 192.168.1.254
Mascara 255.255.255.0
GW 192.168.1.1

Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Redes Remotas

Para redes remotas bsicas solo se requiere de un Default


Gateway.

192.168.2.0/24

Ip 192.168.1.1
Ip 192.168.2.1
Mascara = 255.255.255.0 Mascara = 255.255.255.0

Ip 192.168.1.254
Mascara = 255.255.255.0
GW 192.168.1.1

Ip 192.168.1.2
Mascara = 255.255.255.0
GW 192.168.1.1
192.168.1.0/24

Ip 192.168.2.2
Mascara = 255.255.255.0
GW 192.168.2.1

Ip 192.168.2.254
Mascara = 255.255.255.0
GW 192.168.2.1
Peru_e_Gobierno

GobiernoElectronicoONGEI

Redes Remotas

Oficina Nacional de Gobierno


Electrnico e Informtica

Para redes remotas complejas tambin se requiere ensearle a


los routers las rutas de la red destino.
Existen 2 formas de ensearle rutas:
Rutas estticas, que son rutas manuales
Rutas dinmicas, que son rutas que se forman de manera
dinmica segn el mejor camino a usar.
Nota: Las rutas dinmicas mas usadas son Rip, Eigrp, Ospf, Isis,
Bgp
Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Redes Remotas Estticas

Se deben inscribir las rutas con las redes destino de manera


manual en un router, ejemplo:
.2

ip route 192.168.3.0 255.255.255.0 192.168.2.2

192.168.1.0/24

.254

.2

192.168.2.0/24

.1
192.168.3.0/24

.1

.1

.2

.254

ip route 192.168.1.0 255.255.255.0 192.168.2.1

Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Redes Remotas Dinmicas

Se deben inscribir las redes origen en un router, las rutas se


generan de manera dinmica ejemplo:
route rip
network 192.168.1.0
network 192.168.2.0

.2

192.168.1.0/24

.254

.2

192.168.2.0/24

.1
192.168.3.0/24

.1

.1

.2

.254

route rip
network 192.168.2.0
network 192.168.3.0
Peru_e_Gobierno

GobiernoElectronicoONGEI

Seguridad en las redes

Oficina Nacional de Gobierno


Electrnico e Informtica

La seguridad se brinda en las diferentes capas de modelo OSI y


TCP/IP

Peru_e_Gobierno

GobiernoElectronicoONGEI

Seguridad en Capa 2
Red Local

Oficina Nacional de Gobierno


Electrnico e Informtica

Puertos no usados cados


No usar la Vlan 1
Definir si es acceso o troncal
Usar Port-Security
.1

.1

.253

Peru_e_Gobierno

.254

GobiernoElectronicoONGEI

Seguridad en capa 2

Oficina Nacional de Gobierno


Electrnico e Informtica

Puertos en shutdown
interface range fa 0/3 24 (Configura los puertos por bloques)
shutdown (deshabilita los puertos)
Puertos como acceso
interface range fa 0/3 24 (Configura los puertos por bloques)
switch mode access (los puertos son de acceso)
switch access vlan 2 (los puertos estn en la vlan 2)
Peru_e_Gobierno

GobiernoElectronicoONGEI

Seguridad en capa 2

Oficina Nacional de Gobierno


Electrnico e Informtica

Port-Security
Int fast 0/3 (ingresa al puerto fa 0/3)
Switchport port-security (habilita port-security)
Switchport port-security mac-address sticky (guarda la direccin
mac de la maquina que esta comunicandose en el puerto fa 0/3)

Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Seguridad en Capa 3 y Capa 4

Si no se cuenta con firewall se puede usar un router con


funciones bsicas de un firewall (ACL)
Listas de Acceso por IP (Capa 3)
Lista de Acceso por Puerto (Capa 4)
.2

.2

192.168.1.0/24

.1
192.168.3.0/24

.254
Peru_e_Gobierno

.1

.254
HTTP
GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Wildcard

La Wildcard es el resultado de la resta del valor


255.255.255.255 de la mascara de una red, ejemplo:
255.255.255.255
255.255.255.0
0.0.0.255

Valor Total
Mascara de red
Wildcard

Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Seguridad en Capa 3

Los access-list desde 1 hasta 99 son usados para aplicar filtros


por IP (capa de red).
access-list 50 permit 192.168.1.0 0.0.0.255
int fast 0/0
ip access-group 50 out
.2
FTP

.2

192.168.1.0/24

.1
192.168.3.0/24

.254
Peru_e_Gobierno

.1

.254
HTTP
GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Seguridad en Capa 4

Los access-list desde 100 hasta 199 y desde 2000 hasta 2699
son usados para aplicar filtros por capa de transporte y red.

access-list 150 permit tcp 192.168.1.0 0.0.0.255 host 192.168.3.254 eq www


int fast 0/0
ip access-group 150 out
.2
FTP

.2

192.168.1.0/24

.1
192.168.3.0/24

.254
Peru_e_Gobierno

.1

.254
HTTP
GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Subnetting

/ 255.255.255.X Cant. de Ips Subredes


0
256
1
/24
128
128
2
/25
192
64
4
/26
224
32
8
/27
240
16
16
/28
248
8
32
/29
252
4
64
/30
254
2
/31
255
1
/32
Peru_e_Gobierno

GobiernoElectronicoONGEI

Oficina Nacional de Gobierno


Electrnico e Informtica

Gracias

Peru_e_Gobierno

GobiernoElectronicoONGEI