//1.

- Elaborar un algoritmo que valide que solo se ingresen los meses del año,
lo contrario muestre un mensaje.
Algoritmo Ejercicio1
Definir Mes Como Entero;

Escribir "Ingrese el numero de Mes";
Leer mes;

Si Mes>= 1 y Mes<=12 Entonces;
Mostrar "El numero correspondonde a un mes";
Sino
Mostrar "Error en dato ingresado"
Fin si
FinAlgoritmo

//2.- Diseñe un algoritmo que permita encontrar el entero positivo más
pequeño (num) para el cuál la suma 1+2+3+...+num
//es menor o igual que el límite osea, hasta que la suma sea mayor que el
límite. Muestre num y la suma.

Algoritmo Ejercicio2
Definir Limite, Suma,Num Como Entero
Num=0
Suma=0

Escribir "Ingrese un Limite";
Leer Limite;

Repetir
Num=Num+1
Suma=Suma+Num

mostrar Suma;
Hasta Que Suma>Limite;

Imprimir "El Numero entero Positivo es: ", Suma;

FinAlgoritmo

//3.- Una compañía de seguros está abriendo un departamento de finanzas y
estableció un programa para captar clientes,
//que consiste en lo siguiente: si el monto por el que se efectúa el prestamo es
menor de 500.000 bs
//la cuota a pagar será por el 3% del monto y, si el monto es mayor de 500.000
bs la cuota a pagar será el 25 del monto .
//La compañía desea determinar cual será la cuota que debe pagar un cliente.

Algoritmo Ejercicio3
Definir Monto, Cuota, Porcentaje Como Real;

Escribir "Ingrese el Monto";
Leer Monto;

Si Monto<= 500 Entonces
Cuota= Monto*0.03;
Sino
Cuota= Monto*0.25;
Finsi

Mostrar Cuota;
FinAlgoritmo
// Se tiene un conjunto de 1.000 tarjetas cada una contiene la información del
censo para una persona

//1.- Número de censo,
//2,- Sexo
//3.- Edad
//4.- Estado Civil (a.- Soltero, b.- Casado, c.- Viudo, d.- Divorciado)
//Diseñe un pseudocódigo estructurado que lea todos estos datos, e imprima el
número de censo
//de todas las jóvenes solteras que estén entre 16 y 21 años.

Algoritmo Ejercicio4
Definir Nro, age, i, f Como Entero
Definir sexo, civil Como Caracter

Escribir "CENSO";
f<-0;

Para i<-0 hasta 10 con paso 1 Hacer
Escribir "Numero de Censo";

Repetir
Escribir Sin Saltar "Genero (F/M): ";
leer sexo;
Si sexo <> 'F' y sexo <> 'M' Entonces
Escribir "Opcion incorrecta introduzca F=Femenino,
M=Masculino";
FinSi
Hasta Que sexo='F' o sexo = 'M'

Escribir Sin Saltar "Edad: "
Leer age;

Repetir
Escribir Sin Saltar "Estado Cvil (S/C/V/D): ";
leer civil;
Si civil <> 'S' y civil <> 'C' y civil <> 'V' y civil <> 'D'
Entonces
Escribir "Opcion incorrecta introduzca S=Soltero,
C=Casado, V=Vuido, D=Divorciado";
FinSi
Hasta Que civil='S' o civil = 'C' o civil = 'V' o civil = 'D'

Si (age >= 16) y (age<=21) y (sexo = 'F' y civil = 'S') Entonces
f=f+1
FinSi
Borrar Pantalla
FinPara
Escribir "La Cantidad de Jóvenes Solteras Censadas que se encuentran
entre 16 y 21 años son: ", f;
FinAlgoritmo

//5.- En una empresa se requiere calcular el salario semanal de cada uno de los
empleados que laboran en ella
//el salario se obtiene de la siguiente forma:
//-Sí el obrero trabaja 40 horas o menos se le paga 2.085 bs por hora
//-Sí trabaja más de 40 horas se le paga 2.085 por cada una de las
//primeras 40 horas y 2.600 por cada hora extra.

Algoritmo Ejercicio5
Definir HorasT, HorasE Como Entero;
Definir Salario Como Real;

Escribir "Ingrese Numero de Horas Trabajadas";

Leer HorasT;

Si HorasT <= 40 Entonces
Salario= HorasT*2085;
Sino
HorasE= HorasT-40;
Salario= (40*2085)+(HorasE*2600);
Finsi

Mostrar Salario;
FinAlgoritmo

//6.- Un estudiante desea saber cual será su promedio general en llas tres
materias más fáciles que cursa
//y cual será el promedio que obtendrá en cada una de ellas. Estas materias se
evalúan como se muestra a continuación:

//La calificación de Lógica se obtendrá de la siguiente manera:
//

Prueba 90%

//

Promedio de trabajos 10%

//

en esta materia se pidió un total de tres trabajos*/

//La calificación de programación se obtiene de la siguiente manera:
//

Prueba 80%

//

Promedio de trabajos 20%

//

en esta materia se pidió un total de dos trabajos*/

//La calificación de Introducción a la Arquitectura del Computador se obtiene de
la siguiente manera:
//

Prueba 85%

//

Promedio de trabajos 15%

//

en esta materia se pidió un total de tres trabajos*/

//La calificación de Física se obtiene de la siguiente manera:
//Primer parcial 15%
//

Trabajo 5%

//

Segundo parcial 15%

//

Trabajo 5%

//

Tercer parcial 20%

//

Trabajo 10%

//

Prueba final 20%

//

Trabajo 10%

Algoritmo Ejercicio6
Definir
NotaLogPrue,NotaLogTrab1,NotaLogTrab2,NotaLogTrab3,NotaProgPrue,NotaProg
Trab1,NotaProgTrab2 como real;
Definir
NotaArqPrue,NotaArqTrab1,NotaArqTrab2,NotaArqTrab3,NotaFisParc1,NotaFisTra
b1,NotaFisParc2 como real;
Definir
NotaFisTrab2,NotaFisParc3,NotaFisTrab3,NotaFisParc4,NotaFisTrab4,PromLog,Pro
mProg,PromFis,PromGeneral como real;

Repetir
Escribir "Ingrese Nota de la Prueba de Logica";
Leer NotaLogPrue;
Hasta Que NotaLogPrue>=0 y NotaLogPrue<=20;

Repetir
Escribir "Ingrese Nota del 1er Trabajo de Logica";
Leer NotaLogTrab1;
Hasta Que NotaLogTrab1>=0 y NotaLogTrab1<=20;

Repetir
Escribir "Ingrese Nota del 2do Trabajo de Logica";
Leer NotaLogTrab2;
Hasta Que NotaLogTrab2>=0 y NotaLogTrab2<=20;

Repetir
Escribir "Ingrese Nota del 3er Trabajo de Logica";
Leer NotaLogTrab3;
Hasta Que NotaLogTrab3>=0 y NotaLogTrab3<=20;

NotaLogPrue=(NotaLogPrue*0.01)*90;
NotaPromLogTrab
=((((NotaLogTrab1+NotaLogTrab2+NotaLogTrab3)/3)*0.01)*10);

Repetir
Escribir "Ingrese Nota de la Prueba de Programacion";
Leer NotaProgPrue;
Hasta Que NotaProgPrue>=0 y NotaProgPrue<=20;

Repetir
Escribir "Ingrese Nota del 1er Trabajo de Programacion";
Leer NotaProgTrab1;
Hasta Que NotaProgTrab1>=0 y NotaProgTrab1<=20;

Repetir
Escribir "Ingrese Nota del 2do Trabajo de Programacion";
Leer NotaProgTrab2;
Hasta Que NotaProgTrab2>=0 y NotaProgTrab2<=20;

NotaProgPrue

=(NotaProgPrue*0.01)*80;

NotaPromProgTrab=((((NotaProgTrab1+NotaProgTrab2)/2)*0.01)*20);

Repetir
Escribir "Ingrese Nota de la Prueba de Arquitectura";
Leer NotaArqPrue;
Hasta Que NotaArqPrue>=0 y NotaArqPrue<=20;

Repetir
Escribir "Ingrese Nota del 1er Trabajo de Arquitectura";
Leer NotaArqTrab1;
Hasta Que NotaArqTrab1>=0 y NotaArqTrab1<=20;

Repetir
Escribir "Ingrese Nota del 2do Trabajo de Arquitectura";
Leer NotaArqTrab2;
Hasta Que NotaArqTrab2>=0 y NotaArqTrab2<=20;

Repetir
Escribir "Ingrese Nota del 3er Trabajo de Arquitectura";
Leer NotaArqTrab3;
Hasta Que NotaArqTrab3>=0 y NotaArqTrab3<=20;

NotaArqPrue =(NotaArqPrue*0.01)*85;
NotaPromArqTrab
=((((NotaArqTrab1+NotaArqTrab2+NotaArqTrab3)/3)*0.01)*15);

Repetir
Escribir "Ingrese Nota del 1er Parcial de Fisica";

Leer NotaFisParc1;
Hasta Que NotaFisParc1>=0 y NotaFisParc1<=20;

Repetir
Escribir "Ingrese Nota del 1er Trabajo de Fisica";
Leer NotaFisTrab1;
Hasta Que NotaFisTrab1>=0 y NotaFisTrab1<=20;

Repetir
Escribir "Ingrese Nota del 2do Parcial de Fisica";
Leer NotaFisParc2;
Hasta Que NotaFisParc2>=0 y NotaFisParc2<=20;

Repetir
Escribir "Ingrese Nota del 2do Trabajo de Fisica";
Leer NotaFisTrab2;
Hasta Que NotaFisTrab2>=0 y NotaFisTrab2<=20;

Repetir
Escribir "Ingrese Nota del 3er Parcial de Fisica";
Leer NotaFisParc3;
Hasta Que NotaFisParc3>=0 y NotaFisParc3<=20;

Repetir
Escribir "Ingrese Nota del 3er Trabajo de Fisica";
Leer NotaFisTrab3;
Hasta Que NotaFisTrab3>=0 y NotaFisTrab3<=20;

Repetir
Escribir "Ingrese Nota del 4to Parcial de Fisica";

Leer NotaFisParc4;
Hasta Que NotaFisParc4>=0 y NotaFisParc4<=20;

Repetir
Escribir "Ingrese Nota del 4to Trabajo de Fisica";
Leer NotaFisTrab4;
Hasta Que NotaFisTrab4>=0 y NotaFisTrab4<=20;

NotaFisParc1=(NotaFisParc1*0.01)*15;
NotaFisTrab1=(NotaFisTrab1*0.01)*5;
NotaFisParc2=(NotaFisParc2*0.01)*15;
NotaFisTrab2=(NotaFisTrab2*0.01)*5;
NotaFisParc3=(NotaFisParc3*0.01)*20;
NotaFisTrab3=(NotaFisTrab3*0.01)*10;
NotaFisParc4=(NotaFisParc4*0.01)*20;
NotaFisTrab4=(NotaFisTrab4*0.01)*10;

PromLog
PromProg

=NotaLogPrue+NotaPromLogTrab;
=NotaProgPrue+NotaPromProgTrab;

PromArq

=NotaArqPrue+NotaPromArqTrab;

PromFis
=NotaFisParc1+NotaFisTrab1+NotaFisParc2+NotaFisTrab2+NotaFisParc3+NotaF
isTrab3+NotaFisParc4+NotaFisTrab4;
PromGeneral

=((PromLog+PromProg+PromArq)/3);

Borrar Pantalla
Imprimir " ";
Imprimir "______________________________________________";
Imprimir "

|";

Imprimir "El Promedio obtenido en Logica es:

| ",PromLog;

Imprimir "_________________________________________|____";
Imprimir "

|";

Imprimir "El Promedio obtenido en Programacion es: | ",PromProg;
Imprimir "_________________________________________|____";
Imprimir "

|";

Imprimir "El Promedio obtenido en Arquitectura es: | ",PromArq;
Imprimir "_________________________________________|____";
Imprimir "

| ";

Imprimir "El Promedio obtenido en Fisica es:

| ",PromFis;

Imprimir "_________________________________________|____";
Imprimir "

|";

Imprimir "El Promedio General de las Materias

|";

Imprimir "Logica, Programacion y Arquitectura es: | ",PromGeneral;
Imprimir "_________________________________________|____";

Imprimir " ";
Imprimir "Fin del Calculo";

Esperar Tecla
FinAlgoritmo

//7.- En un supermercado un cajero captura los precios de los artículos que los
clientes compran
//e indica a cada cliente cual es el monto que deben pagar.
//Al final del día le indica a su supervisor cuanto fue lo que cobró en total a
todos los clientes que pasaron por su caja.

Algoritmo Ejercicio7

Definir Cant,i como Entero;
Definir Precio, AcumPrecio, AcumCaja como Real;
Definir Op como Caracter;

Escribir "Ingrese Cantidad de Articulos";
Leer N;

Para i desde 1 hasta Cant Hacer
Escribir "Ingrese Precio de Articulo";
Leer Precio;
AcumPrecio=Acumprecio+Precio;
Finpara

Mostrar "El Precio Total de la Venta es: ", Acumprecio;
AcumCaja= AcumCaja+AcumPrecio

Escribir "Desea Incluir otra Compra";
Leer Opcion1;

Mientras Opcion1=S Hacer
Escribir "El Monto total de Caja fue: ", AcumCaja;
FinMientras
FinAlgoritmo
//8.- suponga que tiene una tienda y desea registrar sus ventas por medio de
una computadora
//diseñe un algoritmo que lea por cada cliente:
//a. el monto de la venta
//b. calcule e imprima el iva,
//c. calcule e imprima el total a pagar,
//d.lea la cantidad con que paga el cliente,

//e: calcule e imprima el cambio,
//al final del día debe imprimir la cantidad de dinero que debe haber en caja.

Algoritmo Ejercicio8
Definir MontoV, Iva, TotalP, PagoC, Cambio, Caja, Deuda Como Real
Definir Op Como Caracter

Repetir

Escribir "Ingrese Monto de la Venta";
Leer MontoV;

Borrar Pantalla
Iva=MontoV*0.12

Mostrar "Iva: ", Iva;

TotalP=Iva+MontoV

Mostrar "Total a Pagar ", TotalP;

Escribir " ";
Escribir "Presione tecla para continuar";
Esperar Tecla
Borrar Pantalla

Escribir "Ingrese Cantidad con que Paga el Cliente";
Leer PagoC

Cambio=PagoC-TotalP

Escribir "Su cambio es: ", Cambio;
Escribir "Presione tecla para continuar";
Esperar Tecla

Caja=Caja+TotalP

Borrar Pantalla

Escribir "Desea Ingresar otra Venta";
Leer Op

Hasta Que Op='N';

Imprimir "El total de dinero en caja es: ",Caja;
FinAlgoritmo

//Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las
variables A, B y C respectivamente.
//El algoritmo debe imprimir cual es el mayor y cual es el menor.
//Recuerde constatar que los tres valores introducidos por el teclado sean
valores distintos.
//Presente un mensaje de alerta en caso de que se detecte la introducción de
valores iguales.

Algoritmo Ejercicio9

Definir May, Men, A, B, C Como Entero

Repetir
Escribir "Ingrese Primer Valor";
Leer A;
Escribir "Ingrese Segundo Valor";
Leer B;
Escribir "Ingrese Tercer Valor";
Leer C;
Si A=B o A=C o B=C Entonces
Escribir "Dos de los numeros ingresados son Iguales";
FinSi
Esperar Tecla
Borrar Pantalla
Hasta Que A<>B y A<>C y B<>C;

Si A>B y A>C Entonces
May=A
FinSi

Si B>A y B>C Entonces
May=B
FinSi

Si C>A y C>B Entonces
May=C
FinSi

Si A<B y A<C Entonces

Men=A
FinSi

Si B<A y B<C Entonces
Men=B
FinSi

Si C<A y C<B Entonces
Men=C
FinSi

Borrar Pantalla

Imprimir "__________________________";
Imprimir " ";
Imprimir "El Numero Mayor es: | ",May;
Imprimir "__________________________";
Imprimir " ";
Imprimir "El Numero Menor es: | ",Men;
Imprimir "__________________________";
FinAlgoritmo
//10.- De los hombres casados del estado Zulia, se desea saber; cuántos tienen
hijos y cuántos no tienen:
//además se desea tener un promedio del nuevo número de hijos.

Algoritmo Ejercicio10
Definir Registro, CantH, H2, i, j, k Como Entero;
Definir PromH Como Real;
Definir H1 Como Caracter;

Escribir "Ingrese Cantidad de Personas a Registrar"
Leer Registro;

Repetir
Escribir "Indique si tiene Hijos (s) o (n)";
Leer H1;

Si H=s Entonces
i=i+1

Escribir "Ingrese Cantidad de Hijos";
Leer H2;
CantH=CantH+H2;
Sino
j=j+1;
FinSi

Borrar Pantalla

k=i+j

Hasta Que k=Registro

PromH=CantH/i;

Imprimir "La Cantidad de Hombre que no Poseen Hijos es: ", j;
Imprimir " ";
Imprimir "La Cantidad de Hombre que si Poseen Hijos es: ", i;
Imprimir " ";

Imprimir "El Promedio de Nuevos Hijos es: ", PromH;
FinAlgoritmo

//11.- Elaborar un algoritmo para encontrar el promedio de edad de los
estudiantes de una universidad mayores de 21 años
//y el promedio de edad del resto. Por cada estudiante se tiene un registro con
el código y la edad.
Algoritmo Ejercicio11
Definir codigo, edad, edad1, i, g, f, num Como Entero
Definir prom Como Real

Escribir "Ingrese Cantidad de Alumnos a Registrar";
Leer num;

Para i<-1 Hasta num Con Paso 1 Hacer
Escribir "Favor Ingrese Codigo de Estudiante";
Leer codigo;
Escribir "Favor Ingrese Edad de Alumno";
Leer edad;
Borrar Pantalla

Si edad>=21 entonces
g=g+1
Sino
f=f+1;
edad1=edad1+edad;
FinSi

Fin Para

prom=edad1/f

Imprimir "El numero de estudiantes mayor a 21 años es: ", g;
Imprimir " ";
Imprimir "El Promedio de edades de estudiantes menores a 21 años es:
", prom;
Esperar Tecla
FinAlgoritmo

//12.- Elabore un programa que imprima los primeros 50 números múltiplos de
3 anteriores al 301.

Algoritmo Ejercicio12
Definir Mult, Base, Nro Como Entero

Escribir "Los Primeros 50 Numeros multiplos de 3 son: ";

Para Nro<-1 Hasta 50 Con Paso 1 Hacer
Base=3

Mult=Mult+Base;
Mostrar Mult;
Fin Para
FinAlgoritmo

//13.- De los habitantes de Venezuela, se desea saber cuántos no han tenido
enfermedades graves
//y un promedio del número de enfermedades graves de los habitantes que sí
ahn padecido de alguna enfermedad.
//De cada registro se debe leer la cédula y el numero de enfermadades graves.
Haga un algoritmo.

Algoritmo Ejercicio13
Definir Registro, CI, E2, i, j,l Como Entero
Definir Prom Como Real
Definir E1 Como Caracter

Escribir "Ingrese Cantidad de Personas a Registrar"
Leer Registro;

Repetir
Escribir "Ingrese Nro de Cedula";
Leer CI;

Escribir "Indique si a Padesido Enfermedades Graves (s) o (n)";
Leer E1

Si E=s Entonces
i=i+1

Escribir "Ingrese Cantidad de Enfeermedades Graves que a
tenido";
Leer l
E2=E2+l
Sino
j=j+1
FinSi

Borrar Pantalla

k=i+j

Hasta Que k=Registro;

Prom=E2/i;

Imprimir "La Cantidad Habitantes que no han tenido
Enfermedades Graves: ", j;
Imprimir " ";
Imprimir "La Cantidad Habitantes que si han tenido Enfermedades
Graves: ", i;
Imprimir " ";
Imprimir "El Promedio de Enfermedades Graves: ", Prom;
FinAlgoritmo
//14.- Elaborar un algoritmoque permita ingresar el número de partidos
ganados, perdidos y empatados,
//por algún equipo en el Torneo Apertura. Se debe mostrar su puntaje total,
//teniendo en cuenta que por cada partido ganado obtendrá 3 puntos,
empatado 1 punto y perdido 0 puntos.

Algoritmo Ejercicio14

Definir Ganado, Empatado, Perdido,Pganado, Pempatado, Ptotal como
Entero;

Escribir "Ingrese Cantidad de Partidos Ganados";
Leer Ganado;
Escribir "Ingrese Cantidad de Partidos Empatados";
Leer Empatado;
Escribir "Ingrese Cantidad de Partidos Perdidos";
Leer Perdido;

Pganado=Ganado*3
Pempatado=Empatado*1
Ptotal=Pganado+Pempatado

Imprimir "El Puntaje Total Obtenido por el Equipo en el Torneo de
Apertura es: ", Ptotal;
FinAlgoritmo

//15.- Elaborar un algoritmo que permita calcular el número de Cds necesarios
para hacer una copia de seguridad,
//de la información almacenada en un disco duro cuya capacidad se conoce.
Considerar que el disco duro contiene información,
//además expresado en gigabyte. Un CD virgen cuenta con una capacidad de
700 Megabyte y un gigabyte es igual a 1024 megabyte.

Algoritmo Ejercicio15
Definir Cdisco, Trespaldo, TrespaldoM como Real;

Escribir "Ingrese el Total de Gigabyte a Respaldar";
Leer Trespaldo

TrespaldoM=Trespaldo*1024;
Cdisco=TrespaldoM/700;

Mostrar "La cantidad de CDs necesarios para realizar el Respaldo es:
",Cdisco;

FinAlgoritmo

//16.- Elabore un algoritmo que pida la edad de dos hermanos y muestre un
mensaje indicando la edad del hermano mayor y,
//cuantos de diferencia lo distancia con el hermano menor.

Algoritmo Ejercicio16
Definir H1, H2, Dif como Entero;

Escribir "Favor Ingres Edad de Primer Hermano";
Leer H1;
Escribir "Favor Ingres Edad de Primer Hermano";
Leer H2

Si H1<H2 Entonces
Dif=H2-H1
Imprimir "El Hermano Mayor es: ",H2;
Sino
Dif=H1-H2
Imprimir "El Hermano Mayor es: ",H1
FinSi

Imprimir "La diferencia de Edad entre los Hermanos es: ",Dif;
FinAlgoritmo

//17.- Se requiere registrar la producción (unidades) logradas por un trabajador
a lo largo de una semana (lunes a viernes).
//Elabore un algoritmo que muestre si el trabajador recibirá incentivos,
//sabiendo que el promedio de producción mínima es de 100 unidades por
semana.

Algoritmo Ejercicio17
Definir UniPro como Entero;

Escribir "Ingrese la Cantidad de Unidades Producidas a la Semana";
Leer UniPro

Si UniPro<=100 Entonces
Escribir "El trabajador no recibira incentivo ya que no cumplio con
la produccion minima";
Sino
Unipro= Unipro-100
Escribir "El Trabajador Recibira Incentivo ya el Excedente de
Produccion Semanal es de: ",Unipro;
FinSi
FinAlgoritmo
//18.- Realice un algoritmo que registre un monto de venta alcanzado por un
vendedor durante el mes,
//luego de calcular la bonoficación que le corresponde sabiendo:
//___________________________________
//|_____MONTO______|__BONIFICACIÓN__|
//|_ 0 - 1000 _|_

0

_|

//|_ 1000 - 5000 _|_

3

_|

//|_ 5000 - 20000 _|_

5

_|

//|_ 20000 a más _|_

8

_|

Algoritmo Ejercicio18
Definir MontoV, Bonificacion como Real;

Escribir "Ingrese Monto de Venta del Mes";
Leer MontoV;

Si MontoV>= 0 y MontoV<= 1000 entonces;
Bonificacion= MontoV
Finsi
Si MontoV > 1000 y MontoV<= 5000 entonces;
Bonificacion= MontoV*0.03
Finsi
Si MontoV > 5000 y MontoV<= 20000 entonces;
Bonificacion= MontoV*0.05
Finsi
Si MontoV > 20000 entonces
Bonificacion= MontoV*0.08
Finsi
Mostrar "La bonificacion mensual es: ", Bonificacion;
FinAlgoritmo

//19.- Elaborar un algoritmo que muestre 10 números enteros a partir de 1
excepto los pares.

Algoritmo Ejercicio19
Definir Base, Nro Como Entero

Base=1

Escribir "Los Primeros 10 Numeros Enteros a Partir de 1 exceptuando los
Numeros Pares son";

Para Nro<-1 Hasta 10 Con Paso 1 Hacer
Base=Base+2
Mostrar Base;
Fin Para
FinAlgoritmo

//20.- Elaborar un algoritmo utilizando un vector de tipo char de dimensión =
10 que permita ingresar un nombre cualquiera,
//que desglose y muestre los caracteres en forma vertical.

Algoritmo Ejercicio20
Definir i como Entero;
Definir Nombre Como Caracter;
Dimension Nombre(10);
i<-0

Para i<-1 hasta 9 con paso 1 hacer
Escribir "Ingrese Nombre",i;
Leer Nombre(i);
FinPara;

Para i<-1 hasta 9 con paso 1 Hacer
Escribir "El valor guardado en el Vector es: ", Nombre(i);

FinPara

FinAlgoritmo