You are on page 1of 25

Creacin de VLAN Ethernet en switches Catalyst

Contenidos
Introduccin
Requisitos previos
Requisitos
Componentes utilizados
Productos relacionados
Convenciones
Diferencia entre el software del sistema CatOS y Cisco IOS
Configuracin de VLAN en switches Catalyst que ejecutan CatOS
Creacin de VLAN y puertos
Eliminacin de puertos o VLAN
Consejos para la resolucin de problemas
Configuracin de VLAN en switches Catalyst series 2900XL, 3500XL, 2950, 2970 y 2940
Creacin de VLAN y puertos
Eliminacin de puertos o VLAN
Configuracin de un puerto de VLAN mltiple en Catalyst 2900XL/3500XL
Configuracin de VLAN en los switches Catalyst series 3550, 3750, 4500/4000 y 6500/6000 que ejecutan el software Cisco IOS
Creacin de VLAN y puertos
Asignacin de puertos mltiples a una sola VLAN
Eliminacin de VLAN
Cmo aislar la comunicacin entre dos VLAN
Cmo configurar las VLAN de rango extendido en un switch Catalyst serie 6500
Consejos para la resolucin de problemas
Verificacin
Resolucin de problemas
Error del valor TLB incoherente en los switches de IOS
Recuperacin del archivo vlan.dat en los switches de IOS
Informacin relacionada

Introduccin
En este documento se proporciona informacin bsica sobre cmo crear VLAN en los switches Catalyst que ejecutan el software del sistema
Catalyst OS (CatOS) y Cisco IOS. En los comandos de ejemplo de cada seccin se utiliza un switch Catalyst de cada seccin de configuracin.

Requisitos previos
Requisitos

Cisco recomienda tener conocimientos de la informacin de esta seccin.

Las VLAN son un mecanismo que permite a los administradores de red crear dominios de difusin lgicos que puedan expandirse a travs de un
solo switch o de varios, independientemente de la proximidad fsica. Esta funcin resulta til para reducir el tamao de los dominios de difusin o
para permitir que los grupos o usuarios se agrupen de manera lgica sin tener que estar ubicados fsicamente en el mismo lugar.

Para crear VLAN, debe decidir cmo configurar los siguientes elementos:

Qu nombre de dominio de Protocolo de troncal VLAN (VTP) y modo VTP se debe utilizar en este switch

Qu puertos del switch pertenecern a cada VLAN

Si ser necesario que haya comunicacin entre las VLAN o si estarn aisladas

Si necesita establecer comunicacin entre las VLAN, debe usar un dispositivo de enrutamiento de capa 3 como, por ejemplo, un router de
Cisco externo o un mdulo de router interno. A continuacin se muestran algunos ejemplos:

Tarjeta de capa 3 WS-X4232 para switches Catalyst 4500/4000 con Supervisor Engine I y Supervisor Engine II
Mdulo de switch de rutas (RSM) o tarjeta de funcin de switch de rutas (RSFC) para los switches Catalyst 5500/5000

Mdulo de switch multicapa (MSM) o tarjeta de funcin de switch multicapa (MSFC) para los switches Catalyst 6500/6000

Algunos de los switches tienen compatibilidad integrada en el software y el hardware para el enrutamiento InterVLAN. Con este
enrutamiento, no se requieren dispositivos externos, mdulos ni tarjetas secundarias. A continuacin se muestran algunos ejemplos de estos
switches:

Catalyst 3550/3750/6500 con Supervisor Engine 720

Catalyst 4500/4000 with Supervisor Engine II+, Supervisor Engine III y Supervisor Engine IV

Consulte los siguientes documentos si desea obtener ms informacin sobre la configuracin del enrutamiento InterVLAN en MSFC, RSM,
RSFC o un router externo:

Configuring InterVLAN Routing with Catalyst 3750/3560/3550 Series Switches (Configuracin de enrutamiento InterVLAN con switches
Catalyst de las series 3750/3560/3550)

La seccin Configuring InterVLAN Routing on the MSFC (Configuracin de enrutamiento InterVLAN en MSFC) de Configuring
InterVLAN Routing (Configuracin de enrutamiento InterVLAN)

La seccin Configuring InterVLAN Routing on the RSM (Configuracin de enrutamiento InterVLAN en RSM) de Configuring
InterVLAN Routing (Configuracin de enrutamiento InterVLAN)

Configuring InterVLAN Routing on the RSFC (Configuracin de enrutamiento InterVLAN en RSFC)

La seccin Configuring InterVLAN Routing on an External Cisco Router (Configuracin de enrutamiento InterVLAN en un router externo
de Cisco) de Configuring InterVLAN Routing (Configuracin de enrutamiento InterVLAN)

Configuring InterVLAN Routing Using an Internal Router (Layer 3 Cart) on Catalyst 5500/5000 and 6500/6000 Switches That Run CatOS
System Software (Configuracin de enrutamiento InterVLAN mediante un router interno (tarjeta de capa 3) en los switches Catalyst
5500/5000 y 6500/6000 que ejecutan el software del sistema CatOS)

Configuring InterVLAN Routing and ISL/802.1Q Trunking on a Catalyst 2900XL/3500XL/2950 Switch Using An External Router
(Configuracin de enrutamiento InterVLAN y la conexin troncal ISL/802.1Q en un switch Catalyst 2900xl/3500xl mediante un router
externo)

Nota: en este documento se asume que dispone de conectividad bsica con el switch, ya sea mediante la consola o acceso Telnet. Consulte los
siguientes documentos para obtener ms informacin sobre cmo obtener una conectividad bsica con los switches:

Switches Catalyst series 6500/6000: Basic Software Configuration (Configuracin de software bsica)

Switches Catalyst serie 2900 XL: Quick Start Guide (Gua de inicio rpido)

Componentes utilizados

La informacin de este documento se basa en estas versiones de hardware y software:

Switch Catalyst 6009 que ejecuta el software CatOS 5.5(x)

Switch Catalyst 3524XL que ejecuta la versin 12.0(5.x)XU del software Cisco IOS

Switch Catalyst 4507 con Supervisor Engine IV (WS-X4515) que ejecuta la versin 12.1(13)EW1 del software Cisco IOS

La informacin que contiene este documento se cre a partir de los dispositivos en un ambiente de laboratorio especfico. Todos los dispositivos
que se utilizan en este documento se pusieron en funcionamiento con una configuracin despejada (predeterminada). Si la red est en produccin,
asegrese de comprender el impacto que pueda tener cualquier comando.

Productos relacionados

La informacin de este documento tambin puede utilizarse con los siguientes switches:

Switches Catalyst 4500/4000/2948G/2980G/4912G

Switches Catalyst series 5000/2926G


Switches Catalyst series 6500/6000

Switches Catalyst 2900XL/3500XL/2950/3550/3750

Convenciones

Consulte Cisco Technical Tips Conventions (Convenciones sobre consejos tcnicos de Cisco) para obtener ms informacin sobre las
convenciones del documento.

Diferencia entre el software del sistema CatOS y Cisco IOS


CatOS en Supervisor Engine y software Cisco IOS en la MSFC (hbrida): es posible utilizar una imagen de CatOS como software del sistema
para ejecutar Supervisor Engine en switches Catalyst 6500/6000. Si la MSFC opcional est instalada, se utiliza una imagen del software Cisco
IOS distinta para ejecutar la MSFC.

Software Cisco IOS en Supervisor Engine y en la MSFC (nativa): es posible utilizar una nica imagen del software Cisco IOS como software
del sistema para ejecutar tanto Supervisor Engine como la MSFC en switches Catalyst 6500/6000.

Nota: consulte Comparison of the Cisco Catalyst and Cisco IOS Operating Systems for the Cisco Catalyst 6500 Series Switch (Comparacin
entre los sistemas operativos Cisco Catalyst y Cisco IOS para switches de la serie Catalyst 6500) para obtener ms informacin.

Configuracin de VLAN en switches Catalyst que ejecutan CatOS


Creacin de VLAN y puertos

Complete los pasos de esta seccin para crear una VLAN.

Antes de que pueda crearla, el switch debe estar en modo de servidor VTP o en modo transparente VTP. Si el switch es un servidor VTP, debe
definir un nombre de dominio VTP antes de agregar cualquier VLAN.

1. Defina un nombre de dominio VTP.

Debe definir el nombre de dominio VTP independientemente de:

El nmero de switches de la red, ya sea uno o varios

Si utiliza VTP para propagar las VLAN a los dems switches de la red

La configuracin VTP predeterminada en el switch es la siguiente:

CatosSwitch> (enable)show vtp domain

Domain Name Domain Index VTP Version Local Mode Password


-------------------------------- ------------ ----------- ----------- ----------
1 2 server -

Vlan-count Max-vlan-storage Config Revision Notifications


---------- ---------------- --------------- -------------
5 1023 0 disabled

Last Updater V2 Mode Pruning PruneEligible on Vlans


--------------- -------- -------- -------------------------
0.0.0.0 disabled disabled 2-1000

Ejecute el comando set vtp para establecer el modo y el nombre del dominio.

CatosSwitch> (enable)set vtp domain ?

<name> Domain name

CatosSwitch> (enable)set vtp domain cisco ?

mode Set VTP mode


passwd Set VTP password
pruning Set VTP pruning
v2 Set VTP version 2

CatosSwitch> (enable)set vtp domain cisco mode ?

client VTP client mode


server VTP server mode
transparent VTP transparent mode

CatosSwitch> (enable)set vtp domain cisco mode server

VTP domain cisco modified

Nota: consulte Understanding and Configuring VLAN Trunk Protocol (VTP) (Introduccin y configuracin del protocolo de troncal
VLAN) para obtener ms informacin sobre VTP.

2. Ejecute el comando show vtp domain para verificar la configuracin VTP.

CatosSwitch> (enable)show vtp domain

Domain Name Domain Index VTP Version Local Mode Password


-------------------------------- ------------ ----------- ----------- ----------
cisco 1 2 server -

Vlan-count Max-vlan-storage Config Revision Notifications


---------- ---------------- --------------- -------------
5 1023 1 disabled

Last Updater V2 Mode Pruning PruneEligible on Vlans


--------------- -------- -------- -------------------------
0.0.0.0 disabled disabled 2-1000

Nota: si tiene el resultado de un comando show vtp domain de su dispositivo Cisco, puede utilizar la herramienta intrprete de resultados
( slo para clientes registrados) (OIT) para que se muestren los problemas potenciales y sus soluciones.

3. Despus de configurar y verificar el dominio VTP, puede empezar a crear las VLAN en el switch.

De forma predeterminada, hay slo una VLAN para todos los puertos. Esta VLAN se denomina default. No es posible eliminar ni
cambiar el nombre de VLAN 1.

Puede usar el comando show vlan para visualizar los parmetros de todas las VLAN configuradas en el dominio administrativo.

CatosSwitch> (enable)show vlan

VLAN Name Status IfIndex Mod/Ports, Vlans


---- -------------------------------- --------- ------- ------------------------
1 default active 5 1/1-2

3/1-48

4/1-16
1002 fddi-default active 6
1003 token-ring-default active 9
1004 fddinet-default active 7
1005 trnet-default active 8

VLAN Type SAID MTU Parent RingNo BrdgNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 trcrf 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - - - 0 0
1005 trbrf 101005 1500 - - - ibm - 0 0

VLAN DynCreated RSPAN


---- ---------- --------
1 static disabled
1002 static disabled
1003 static disabled
1004 static disabled
1005 static disabled

VLAN AREHops STEHops Backup CRF 1q VLAN


---- ------- ------- ---------- -------
1003 7 7 off

a. Ejecute el comando set vlan para crear las VLAN.

CatosSwitch> (enable)set vlan


Usage: set vlan <vlan> <mod/port>
(An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
[pvlan-type <pvlan_type>]
[said <said>] [mtu <mtu>]
[ring <hex_ring_number>]
[decring <decimal_ring_number>]
[bridge <bridge_number>] [parent <vlan_num>]
[mode <bridge_mode>] [stp <stp_type>]
[translation <vlan_num>] [backupcrf <off|on>]
[aremaxhop <hopcount>] [stemaxhop <hopcount>]
[rspan]
(name = 1..32 characters, state = (active, suspend)
type = (ethernet, fddi, fddinet, trcrf, trbrf)
said = 1..4294967294, mtu = 576..18190
pvlan-type = (primary,isolated,community,none)
hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
stp = (ieee, IBM, auto), translation = 1..1005
hopcount = 1..13)
Set vlan commands:
----------------------------------------------------------------------------
set vlan Set vlan information
set vlan mapping Map an 802.1q vlan to an Ethernet vlan

CatosSwitch> (enable)set vlan 2 name cisco_vlan_2

Vlan 2 configuration successful

b. Ejecute el comando show vlan para verificar la configuracin VLAN.

CatosSwitch> (enable)show vlan

VLAN Name Status IfIndex Mod/Ports, Vlans


---- -------------------------------- --------- ------- --------------------
1 default active 5 1/1-2
3/1-48
4/1-16
2 cisco_vlan_2 active 75
1002 fddi-default active 6
1003 token-ring-default active 9
1004 fddinet-default active 7
1005 trnet-default active 8

VLAN Type SAID MTU Parent RingNo BrdgNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 trcrf 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - - - 0 0
1005 trbrf 101005 1500 - - - IBM - 0 0

!--- Resultado suprimido.

c. Si desea agregar puertos a la VLAN, ejecute el comando set vlan vlan_number mod/ports .

CatosSwitch> (enable)set vlan 2 3/1-12

VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 3/1-12
15/1

Nota: tambin puede crear la VLAN y agregarle los puertos con toda la informacin en un solo comando.

Por ejemplo, si desea crear una tercera VLAN y, a continuacin, asignarle los puertos 3/13 a 3/15, ejecute este comando:

CatosSwitch> (enable)set vlan 3 3/13-15

Vlan 3 configuration successful


VLAN 3 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
3 3/13-15
15/1

4. Ejecute el comando show vlan para verificar la configuracin VLAN.

CatosSwitch> (enable)show vlan

VLAN Name Status IfIndex Mod/Ports, Vlans


---- -------------------------------- --------- ------- ------------------------
1 default active 5 1/1-2
3/16-48
4/1-16
2 cisco_vlan_2 active 75 3/1-12
3 VLAN0003 active 76 3/13-15
1002 fddi-default active 6
1003 token-ring-default active 9
1004 fddinet-default active 7
1005 trnet-default active 8

VLAN Type SAID MTU Parent RingNo BrdgNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
3 enet 100003 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 trcrf 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - - - 0 0
1005 trbrf 101005 1500 - - - IBM - 0 0

!--- Resultado suprimido.

Eliminacin de puertos o VLAN

Para eliminar puertos de una VLAN, ejecute el comando set vlan vlan_number mod/ports y site los puertos en una VLAN distinta. Esta
eliminacin es lo que sucede cuando un puerto se asigna a cualquier VLAN, ya que todos los puertos pertenecen inicialmente a VLAN 1.

Ejecute el comando clear vlan para eliminar una VLAN. Los puertos se desactivan porque continan siendo parte de esa VLAN y sta ya no
existe. El switch muestra una advertencia y ofrece la posibilidad de cancelar la solicitud actual.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3


in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name Status IfIndex Mod/Ports, Vlans


---- -------------------------------- --------- ------- ------------------------
1 default active 5 1/1-2
3/16-48
4/1-16
2 cisco_vlan_2 active 75 3/1-12
1002 fddi-default active 6
1003 token-ring-default active 9
1004 fddinet-default active 7
1005 trnet-default active 8

VLAN Type SAID MTU Parent RingNo BrdgNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 trcrf 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - - - 0 0
1005 trbrf 101005 1500 - - - IBM - 0 0

!--- Resultado suprimido.


Nota: los puertos 3/13 a 3/15 no se muestran en el resultado del comando show vlan, ya que se desactivan con la eliminacin de VLAN 3. Los
puertos no se muestran hasta que se agregan de nuevo a otra VLAN.

Consejos para la resolucin de problemas

En esta seccin se proporcionan algunos consejos para resolver problemas comunes que pueden aparecer al crear redes VLAN en switches
Catalyst que ejecutan CatOS:

Si crea una VLAN cuando no hay ningn nombre de dominio VTP definido, aparecer este mensaje de error:

Cannot add/modify VLANs on a VTP server without a domain name.

Para corregir este problema, cree un nombre de dominio VTP en el switch. En la seccin Creacin de VLAN y puertos se muestra el
procedimiento a seguir.

Si crea una VLAN en un switch que est en modo de cliente VTP, se indicar el siguiente mensaje de error:

Cannot add/modify VLANs on a VTP client.

Nota: un switch slo puede crear VLAN si est en modo de servidor VTP o modo transparente VTP. Consulte Understanding and
Configuring VLAN Trunk Protocol (VTP) (Introduccin y configuracin del protocolo de troncal VLAN) para obtener ms informacin
sobre VTP.

Los puertos estn en estado inactive en el resultado del comando show port mod/port . Este estado significa que la VLAN a la que
pertenecan los puertos en un principio se elimin, generalmente debido a VTP. Puede volver a crear esa VLAN o corregir la configuracin
VTP para que se restablezca la VLAN en el dominio VTP. Este el resultado del comando de ejemplo show port mod/port :

CatosSwitch> (enable)show port 3/1

Port Name Status Vlan Duplex Speed Type


----- ------------------ ---------- ---------- ------ ----- ------------
3/1 inactive 2 auto auto 10/100BaseTX

Port AuxiliaryVlan AuxVlan-Status InlinePowered PowerAllocated


Admin Oper Detected mWatt mA @42V
----- ------------- -------------- ----- ------ -------- ----- --------
3/1 none none - - - - -

!--- Resultado suprimido.

Si tiene el resultado de un comando show-tech support de su dispositivo Cisco, puede utilizar la herramienta intrprete de resultados (
slo para clientes registrados) (OIT) para que se muestren los problemas potenciales y sus soluciones.

CatosSwitch> (enable)show vlan 2

VLAN Name Status IfIndex Mod/Ports, Vlans


---- -------------------------------- --------- ------- ------------------------
Unable to access VTP Vlan 2 information.

VLAN Type SAID MTU Parent RingNo BrdgNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
Unable to access VTP Vlan 2 information.

VLAN DynCreated RSPAN


---- ---------- --------
Unable to access VTP Vlan 2 information.

VLAN AREHops STEHops Backup CRF 1q VLAN


---- ------- ------- ---------- -------

Las interfaces VLAN creadas en los mdulos de enrutamiento (RSM, RSFC, MSM o MSFC) slo aparecen cuando la VLAN
correspondiente est disponible en el switch. Para que la interfaz VLAN se active por completo, lo que supone que administrativamente
est activa y que el protocolo de lnea est activado, asegrese de disponer al menos de un puerto como miembro de esa VLAN, con un
dispositivo activo conectado a l. Consulte la seccin Requisitos de este documento para obtener informacin sobre las pautas de
configuracin.

Configuracin de VLAN en switches Catalyst series 2900XL, 3500XL, 2950, 2970 y 2940
Creacin de VLAN y puertos

Nota: el resultado que visualice puede ser diferente de algunos resultados de comandos que se muestran en esta seccin. La diferencia depende
del modelo de switch.

Siga estos pasos para crear una VLAN.

1. Decida si utilizar VTP en su red.

Con VTP, puede realizar cambios en la configuracin de manera central en un solo switch y puede comunicar automticamente estos
cambios a los dems switches de la red. El modo VTP predeterminado de los switches Catalyst 2900XL, 3500XL, 2950, 2970 y 2940 es el
modo de servidor. Consulte Understanding and Configuring VLAN Trunk Protocol (VTP) (Introduccin y configuracin del protocolo de
troncal VLAN) para obtener ms informacin sobre VTP.

Nota: ejecute el comando show vtp status para verificar el estado de VTP de los switches de la serie XL.

3524XL#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally: 254
Number of existing VLANs : 5
VTP Operating Mode : Server

!--- Este es el modo predeterminado.

VTP Domain Name :


VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

2. Despus de configurar y verificar el dominio VTP, puede empezar a crear las VLAN en el switch.

De forma predeterminada, hay slo una VLAN para todos los puertos. Esta VLAN se denomina default. No es posible eliminar ni
cambiar el nombre de VLAN 1.

Ejecute el comando show vlan para comprobar la informacin de VLAN.

3524XL#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4,
Fa0/5, Fa0/6, Fa0/7, Fa0/8,
Fa0/9, Fa0/10, Fa0/11, Fa0/12,
Fa0/13, Fa0/14, Fa0/15, Fa0/16,
Fa0/17, Fa0/18, Fa0/19, Fa0/20,
Fa0/21, Fa0/22, Fa0/23, Fa0/24,
Gi0/1, Gi0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 IBM - 0 0
1005 trnet 101005 1500 - - 1 IBM - 0 0

Ejecute este conjunto de comandos en modo privilegiado para crear otra VLAN:
3524XL#vlan database

!--- Debe entrar en modo de base de datos VLAN para configurar cualquier VLAN.

3524XL(vlan)#vtp server

Device mode already VTP SERVER.

!--- Puede omitir este comando si el switch ya est en modo de servidor y


!--- desea que siga en este modo.

Nota: un switch slo puede crear VLAN si est en modo de servidor VTP o modo transparente VTP. Consulte Understanding and
Configuring VLAN Trunk Protocol (VTP) (Introduccin y configuracin del protocolo de troncal VLAN) para obtener ms informacin
sobre VTP.

524XL(vlan)#vlan ?

<1-1005> ISL VLAN index

3524XL(vlan)#vlan 2 ?

are Maximum number of All Route Explorer hops for this VLAN
backupcrf Backup CRF mode of the VLAN
bridge Bridging characteristics of the VLAN
media Media type of the VLAN
mtu VLAN Maximum Transmission Unit
name Ascii name of the VLAN
parent ID number of the Parent VLAN of FDDI or Token Ring type VLANs
ring Ring number of FDDI or Token Ring type VLANs
said IEEE 802.10 SAID
state Operational state of the VLAN
ste Maximum number of Spanning Tree Explorer hops for this VLAN
stp Spanning tree characteristics of the VLAN
tb-vlan1 ID number of the first translational VLAN for this VLAN (or zero
if none)
tb-vlan2 ID number of the second translational VLAN for this VLAN (or zero
if none)

3524XL(vlan)#vlan 2 name ?

WORD The ASCII name for the VLAN

3524XL(vlan)#vlan 2 name cisco_vlan_2

VLAN 2 added:
Name: cisco_vlan_2

3524XL(vlan)#exit

!--- Debe salir de la base de datos VLAN para que los cambios
!--- se implementen.

APPLY completed.
Exiting....
3524XL#

Nota: el modo VTP puede cambiar de modo de cliente a modo transparente si el switch intenta aprender o transmitir una cantidad mayor
de VLAN de las que admite. Compruebe siempre que los switches que funcionan en modo de cliente admitan la misma cantidad de VLAN
que la que envan los switches en modo de servidor.

3. Ejecute el comando show vlan para comprobar que se crea la VLAN.

3524XL#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4,
Fa0/5, Fa0/6, Fa0/7, Fa0/8,
Fa0/9, Fa0/10, Fa0/11, Fa0/12,
Fa0/13, Fa0/14, Fa0/15, Fa0/16,
Fa0/17, Fa0/18, Fa0/19, Fa0/20,
Fa0/21, Fa0/22, Fa0/23, Fa0/24,
Gi0/1, Gi0/2
2 cisco_vlan_2 active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 IBM - 0 0
1005 trnet 101005 1500 - - 1

4. Puede agregar puertos (interfaces) en las nuevas VLAN creadas.

Debe adoptar el modo de configuracin de interfaz para cada una de las interfaces que desee agregar a la nueva VLAN.

Nota: puede asignar los puertos de un switch Catalyst de capa 2 a varias VLAN, pero el switch slo admite una interfaz VLAN de
administracin activa al mismo tiempo, y las otras interfaces virtuales conmutadas (SVI) no estn activadas debido a la funcionalidad de la
capa 2. Por lo tanto, el switch slo admite una direccin de la capa 3 de administracin activa. En un switch Catalyst de capa 2, puede
ejecutar el comando opcional management en la nueva SVI para cerrar automticamente VLAN 1 y transferir la direccin IP a la nueva
VLAN.

Switch#configure terminal

Switch(config)#interface vlan 2

Switch(config-subif)#management

Switch(config-subif)#^Z

Switch#show ip interface brief


Interface IP-Address OK? Method Status Protocol
VLAN1 10.0.0.2 YES manual up down
VLAN2 20.0.0.2 YES manual up up
FastEthernet0/1 unassigned YES unset up up
FastEthernet0/2 unassigned YES unset up up

!--- Resultado suprimido.

Ejecute este conjunto de comandos en modo privilegiado para agregar una interfaz concreta a la VLAN:

3524XL#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#switchport access ?

vlan Set VLAN when interface is in access mode

3524XL(config-if)#switchport access vlan ?

<1-1001> VLAN ID of the VLAN when this port is in access mode


dynamic When in access mode, this interfaces VLAN is controlled by VMPS

3524XL(config-if)#switchport access vlan 2

!--- Estos comandos asignan la interfaz Fast Ethernet 0/2 a VLAN 2.

3524XL(config-if)#exit

3524XL(config)#interface fastethernet 0/3


3524XL(config-if)#switchport access vlan 2

!--- Estos comandos asignan la interfaz Fast Ethernet 0/3 a VLAN 2.

3524XL(config-if)#end

3524XL#
00:55:26: %SYS-5-CONFIG_I: Configured from console by console

3524XL#write memory

!--- Esto guarda la configuracin.

Building configuration...

5. Ejecute el comando show vlan para verificar la configuracin VLAN.

3524XL#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/4, Fa0/5, Fa0/6,
Fa0/7, Fa0/8, Fa0/9, Fa0/10,
Fa0/11, Fa0/12, Fa0/13, Fa0/14,
Fa0/15, Fa0/16, Fa0/17, Fa0/18,
Fa0/19, Fa0/20, Fa0/21, Fa0/22,
Fa0/23, Fa0/24, Gi0/1, Gi0/2
2 cisco_vlan_2 active Fa0/2, Fa0/3
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 IBM - 0 0
1005 trnet 101005 1500 - - 1 IBM - 0 0

Eliminacin de puertos o VLAN

Para eliminar puertos de la VLAN, ejecute el comando no switchport access vlan vlan_number en modo de configuracin de interfaz. Despus
de eliminar el puerto de una VLAN que no sea VLAN 1 (predeterminada), el puerto se vuelve a agregar automticamente a la predeterminada.

Por ejemplo, si desea eliminar la interfaz Fast Ethernet 0/2 de cisco_vlan_2 (VLAN 2), ejecute el siguiente conjunto de comandos en modo
privilegiado:

3524XL#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- Estos dos comandos eliminan la interfaz Fast Ethernet 0/2 de VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Nota: Fast Ethernet 0/2 se vuelve a agregar a la VLAN predeterminada.

Fa0/6, Fa0/7, Fa0/8, Fa0/9,


Fa0/10, Fa0/11, Fa0/12, Fa0/13,
Fa0/14, Fa0/15, Fa0/16, Fa0/17,
Fa0/18, Fa0/19, Fa0/20, Fa0/21,
Fa0/22, Fa0/23, Fa0/24, Gi0/1,
Gi0/2
2 cisco_vlan_2 active Fa0/3
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 IBM - 0 0
1005 trnet 101005 1500 - - 1 IBM - 0 0

Para borrar la VLAN, ejecute el comando no vlan vlan_number en el modo de base de datos VLAN. Las interfaces de esa VLAN seguirn
siendo parte de ella y se desactivarn, ya que no pertenecen a ninguna otra VLAN.

Por ejemplo, si desea eliminar cisco_vlan_2 del switch, ejecute el siguiente conjunto de comandos en modo privilegiado:

3524XL#vlan database

!--- Este comando hace que acceda al modo de base de datos VLAN.

3524XL(vlan)#no vlan 2

!--- Este comando elimina la VLAN de la base de datos.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/4, Fa0/5,
Fa0/6, Fa0/7, Fa0/8, Fa0/9,
Fa0/10, Fa0/11, Fa0/12, Fa0/13,
Fa0/14, Fa0/15, Fa0/16, Fa0/17,
Fa0/18, Fa0/19, Fa0/20, Fa0/21,
Fa0/22, Fa0/23, Fa0/24, Gi0/1,
Gi0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

!--- Resultado suprimido.

Tenga en cuenta que el puerto Fast Ethernet 0/3 no se muestra en el resultado del comando show vlan. La eliminacin de VLAN 2 desactiva este
puerto. Si no agrega de nuevo el puerto a otra VLAN, ste no se mostrar ni estar disponible.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Resultado suprimido.

Para que la interfaz est disponible, debe asegurarse de que pertenece a alguna VLAN. En el caso de esta seccin del documento, debe agregar la
interfaz Fast Ethernet 0/3 a la VLAN predeterminada (VLAN 1) para que se pueda utilizar.
Si tiene el resultado de un comando show-tech support de su dispositivo Cisco, puede utilizar la herramienta intrprete de resultados ( slo para
clientes registrados) (OIT) para que se muestren los problemas potenciales y sus soluciones.

Nota: en el caso de los switches Catalyst 3550, podr seguir utilizando la interfaz sin tener que agregarla a una VLAN. Sin embargo, debe
convertir la interfaz en una interfaz de capa 3. Consulte la seccin Configuring Layer 3 Interfaces (Configuracin de interfaces de capa 3) de
Configuring Interface Characteristics (Configuracin de las caractersticas de la interfaz) para obtener ms informacin sobre las interfaces de
capa 3 en los switches Catalyst 3550.

Configuracin de un puerto de VLAN mltiple en Catalyst 2900XL/3500XL


La funcin de puerto de VLAN mltiple de los switches Catalyst 2900 XL/3500XL permite la configuracin de un solo puerto en dos o ms
VLAN. Esta caracterstica permite que los usuarios de diferentes VLAN tengan acceso a un servidor o router sin la implementacin de la
capacidad de enrutamiento InterVLAN. Un puerto de VLAN mltiple realiza funciones de conmutacin normales en todas sus VLAN asignadas.
El trfico de VLAN del puerto de VLAN mltiple no se encapsula como en la conexin de troncal.

Nota: existen limitaciones en la implementacin de las funciones del puerto de VLAN mltiple:

No puede configurar un puerto de VLAN mltiple cuando hay una troncal configurada en el switch. No puede conectar el puerto de VLAN
mltiple a un router o servidor. El switch cambia automticamente al modo transparente de VTP cuando se habilita la funcin de puerto de
VLAN mltiple, lo que deshabilita VTP. No se necesita ninguna configuracin VTP.

La funcin de puerto de VLAN mltiple slo la admiten los switches Catalyst series 2900XL/3500XL. Esta caracterstica no es compatible
con los switches Catalyst series 4500/4000, 5500/5000 o 6500/6000 ni en otros switches Catalyst.

1. Determine qu puerto se debe configurar como puerto de VLAN mltiple.

Se han creado tres VLAN en un switch Catalyst 3512XL y un puerto del switch se conecta a un router externo. En este ejemplo se
configura el puerto conectado al router como un puerto de VLAN mltiple.

6-3512xl#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -----------------------------
1 default active Fa0/1, Fa0/3, Fa0/6, Fa0/7,
Fa0/8, Fa0/9, Fa0/10, Fa0/11,
Fa0/12, Gi0/1, Gi0/2
2 VLAN0002 active Fa0/2, Fa0/4
3 VLAN0003 active Fa0/5
4 VLAN0004 active
5 VLAN0005 active
6 VLAN0006 active

En el ejemplo, el puerto Fast Ethernet 0/1 est conectado a un router externo. Para obtener ms informacin sobre cmo crear redes VLAN
y asignarles puertos, consulte la seccin de este documento Configuracin de VLAN en switches Catalyst series 2900XL, 3500XL, 2950,
2970 y 2940.

2. Configure el puerto Fast Ethernet 0/1 en modo de VLAN mltiple y agregue las VLAN asignadas al puerto de VLAN mltiple.

6-3512xl#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

6-3512xl(config)#interface fastethernet 0/1

6-3512xl(config-if)#switchport mode multi

!--- Este comando cambia el modo del puerto Fast Ethernet 0/1 a mltiple.

6-3512xl(config-if)#switchport multi vlan ?

LINE VLAN IDs of VLANs to be used in multi-VLAN mode


add add VLANs to the current list
remove remove VLANs from the current list

6-3512xl(config-if)#switchport multi vlan 1,2,3

!--- Este comando asigna las VLAN 1, 2 y 3 al puerto de VLAN mltiple Fast Ethernet 0/1.

6-3512xl(config-if)#^Z

6-3512xl#
3. Ejecute el comando show interface interface_id switchport y el comando show vlan para comprobar la configuracin.

6-3512xl#show interface fastethernet 0/1 switchport

Name: Fa0/1
Operational Mode: multi

!--- El puerto est en el modo de VLAN mltiple.

Administrative Trunking Encapsulation: isl


Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: NONE
Pruning VLANs Enabled: NONE

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

6-3512xl#show vlan brief

VLAN Name Status Ports


---- -------------------------------- --------- ----------------------------
1 default active Fa0/1, Fa0/3, Fa0/6, Fa0/7,
Fa0/8, Fa0/9, Fa0/10, Fa0/1
Fa0/12, Gi0/1, Gi0/2
2 VLAN0002 active Fa0/1, Fa0/2, Fa0/4

!--- Nota: anteriormente, el puerto Fast Ethernet 0/1 se encontraba nicamente en VLAN 1.
!--- Ahora el puerto se ha asignado a varias VLAN: 1, 2 y 3.

3 VLAN0003 active Fa0/1, Fa0/5


4 VLAN0004 active
5 VLAN0005 active

4. Ejecute el comando ping desde el switch hasta el router para comprobar el funcionamiento de VLAN mltiple.

El comando ping recibe una respuesta del router cada vez que la direccin IP de administracin se asigna a cualquier VLAN, 1, 2 o 3.

6-3512xl#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

6-3512xl(config)#interface vlan 1

6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0

!--- La direccin IP de administracin est asignada a VLAN 1.

6-3512xl(config-if)#^Z

6-3512xl#
23:56:54: %SYS-5-CONFIG_I: Configured from console by console

6-3512xl#ping 192.168.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms

6-3512xl#ping 192.168.1.2

!--- Puede hacer ping al router desde VLAN 1.

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms

6-3512xl#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

6-3512xl(config)#interface vlan 1

6-3512xl(config-if)#no ip address

!--- La direccin IP de administracin se ha eliminado de VLAN 1.

6-3512xl(config-if)#shutdown

6-3512xl(config-if)#exit

6-3512xl(config)#interface vlan 2

6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0

6-3512xl(config-subif)#no shutdown

!--- La direccin IP de administracin est asignada a VLAN 2.

6-3512xl(config-subif)#exit

6-3512xl(config)#exit

6-3512xl#ping 192.168.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms

6-3512xl#ping 192.168.1.2

!--- Puede hacer ping al router desde VLAN 2.

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms

6-3512xl#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

6-3512xl(config)#interface vlan 2

6-3512xl(config-subif)#no ip address

!--- La direccin IP de administracin se ha eliminado de VLAN 2.

6-3512xl(config-subif)#shutdown

6-3512xl(config-subif)#exit

6-3512xl(config)#interface vlan 3

6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0

6-3512xl(config-subif)#no shut

!--- La direccin IP de administracin est asignada a VLAN 3.

6-3512xl(config-subif)#exit

6-3512xl(config)#exit

6-3512xl#ping 192.168.1.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms

6-3512xl#ping 192.168.1.2
!--- Puede hacer ping al router desde VLAN 3.

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Configuracin de VLAN en los switches Catalyst series 3550, 3750, 4500/4000 y 6500/6000
que ejecutan el software Cisco IOS
Creacin de VLAN y puertos
En esta seccin se utiliza el switch Catalyst 4500 para los comandos de configuracin de ejemplo, pero las tareas de configuracin tambin se
aplican a otros switches que ejecutan la capa 3 (o el software Cisco IOS). Entre estos otros se incluyen los switches Catalyst series 3550, 3570 y
6500 que ejecutan el software Cisco IOS. Antes de que pueda crearla, el switch debe estar en modo de servidor VTP o en modo transparente
VTP. Si el switch es un servidor VTP, debe definir un nombre de dominio VTP antes de agregar cualquier VLAN. Debe definir un nombre de
dominio VTP independientemente de:

El nmero de switches de la red, ya sea uno o varios

Si utiliza VTP para propagar las VLAN a los dems switches de la red

Consulte Understanding and Configuring VTP (Introduccin y configuracin de VTP) para obtener ms informacin sobre cmo configurar VTP
en los mdulos de Supervisor Engine basados en el software Cisco IOS en Catalyst 4500/4000. Consulte la gua de configuracin de software de
la plataforma del switch en cuestin para obtener informacin sobre la configuracin VTP en otras plataformas de switches Catalyst. Consulte las
pginas de soporte de productos de LAN para localizar la gua de configuracin de software.

Se pueden crear redes VLAN en modo de base de datos VLAN o en modo de configuracin global. Debe crear VLAN que tengan una
numeracin superior a 1005 en modo de configuracin global. El modo VTP se debe establecer en transparente para poder crear estas VLAN. Las
VLAN que tengan una numeracin superior a 1005 no sern anunciadas por VTP. Adems, las VLAN con numeracin superior a 1005 se
almacenan en el archivo de configuracin del switch y no en el archivo .dat de VLAN. La ubicacin predeterminada del archivo .dat de VLAN en
los switches Catalyst 4000 con Supervisor Engine IV es el directorio cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Nota: un switch Catalyst 6500 que ejecuta el software Cisco IOS permite crear VLAN en modo de servidor sin un nombre de dominio VTP.

El comando show vtp status muestra la informacin de VTP en el switch.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)

1. Ejecute el comando show vlan para comprobar la informacin de VLAN.

Switch#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Gi1/1, Gi1/2, Gi3/1, Gi3/2
Gi3/3, Gi3/4, Gi3/5, Gi3/6
Gi3/7, Gi3/8, Gi3/9, Gi3/10
Gi3/11, Gi3/12, Gi3/13, Gi3/14
Gi3/15, Gi3/16, Gi3/17, Gi3/18

!--- Resultado suprimido.

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Primary Secondary Type Ports


------- --------- ----------------- ------------------------------------------

2. Acceda al modo correcto, ya sea el de base de datos o de configuracin global.

Ejecute el comando vlan database en modo privilegiado para entrar en el modo de base de datos VLAN.

Switch#vlan database

Switch(vlan)#

3. Ejecute el comando vlan vlan_number para configurar una VLAN.

Switch(vlan)#vlan 2

VLAN 2 added:
Name: VLAN0002

Switch(vlan)#apply

APPLY completed.

Nota: para que se aplique la configuracin, puede ejecutar el comando apply o salir del modo de base de datos. La palabra clave end y los
mtodos de salida Ctrl-Z no funcionan en modo de base de datos VLAN. Ejecute el comando exit para salir del modo de base de datos
VLAN.

Ejecute estos comandos para realizar una configuracin de VLAN en modo de configuracin global.

Switch(config)#vlan 3

Switch(config-vlan)#exit

Switch(config)#

4. Ejecute el comando show run para ver las VLAN con numeracin superior a 1005 en la configuracin en ejecucin.

Switch#show running-config

Building configuration...

Current configuration : 2975 bytes


!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
!
vlan 2000
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!

!--- Resultado suprimido.

En el software Cisco IOS, las interfaces estn en estado shutdown de manera predeterminada, a diferencia de los switches basados en CatOS.
En CatOS, el puerto se activa cuando detecta la presencia de un enlace fsico.

De manera predeterminada, las interfaces del software Cisco IOS son de capa 2 en los switches Catalyst series 3550, 3750 y 4500. Las interfaces
son de capa 3 en los switches Catalyst 6500/6000. La interfaz se puede configurar como capa 2 con el comando switchport en modo de
configuracin de interfaz. Debe ejecutar este comando antes de asignar una interfaz a una VLAN, si la interfaz est en modo de capa 3. El
comando para asignar una interfaz a una VLAN es switchport access vlan vlan_number .

Nota: si la interfaz est configurada como una interfaz de capa 3, lo que significa que se configura el comando no switchport, no podr asignarla
a una VLAN.

Para asociar los puertos a las VLAN en el software Cisco IOS se requiere la siguiente configuracin mnima:

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- Se requiere este comando si la interfaz est en modo de capa 3.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Ejecute el comando show interface gigabitethernet module/interface switchport para verificar el estado de la interfaz de capa 2.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Si el puerto est configurado como un puerto troncal, es decir, un puerto que puede transportar varias VLAN, el comando switchport trunk
native vlan puede resultar til. Este comando es til si la VLAN nativa de la interfaz se ha modificado o debe modificar sus valores
predeterminados. La VLAN nativa es la que se utiliza si la interfaz debe convertirse en una interfaz de capa 2. Si no se define una VLAN nativa
de forma explcita, VLAN 1 se convierte en la nativa de forma predeterminada. Tenga en cuenta que no se agrega ningn encabezado IEEE
802.1Q al enviar los datos a la VLAN nativa. Asegrese de que los puertos troncales de ambos dispositivos conectados tengan la misma VLAN
nativa. Si no coinciden, se pueden producir problemas de enrutamiento de InterVLAN, entre otros conflictos.

Este mensaje aparece cuando la VLAN nativa no coincide en los dos switches de Cisco.

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),


with D-R3550-9B GigabitEthernet0/1 (1)

En este mensaje de ejemplo, la VLAN nativa es VLAN 2 en uno de los switches, pero el switch vecino tiene a VLAN 1 como nativa.

Ejecute el comando show interfaces module/interface trunk para ver la informacin de conexin troncal VLAN, encapsulacin y VLAN
nativa.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan


Gi3/1 on 802.1q trunking 1
Port Vlans allowed on trunk
Gi3/1 1-4094
Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Si utiliza la configuracin predeterminada, la VLAN nativa se establece como VLAN 1. Para cambiar la VLAN nativa de la interfaz en conexin
troncal, ejecute el comando switchport trunk native vlan vlan_number .

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Ejecute este comando para verificar:

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan


Gi3/1 on 802.1q trunking 2
Port Vlans allowed on trunk
Gi3/1 1-4094
Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Asignacin de puertos mltiples a una sola VLAN


Es posible asignar las diferentes interfaces de un switch a una sola VLAN. Ejecute los comandos siguientes:

1.
Switch(config)#interface range fastethernet [mod/slot - mod/slot]

2.
Switch(config-if-range)#switchport access vlan vlan_number

3.
Switch(config-if-range)#switchport mode access

4.
Switch(config-if-range)#no shut

Nota: el comando interface range no es compatible con todas las versiones de software. El comando interface range se admite en la versin
12.1(13)EW y posteriores del software Cisco IOS.

Eliminacin de VLAN

Para eliminar una VLAN de la base de datos VLAN, ejecute el comando no vlan vlan_number , ya sea en modo de base de datos VLAN o en
modo de configuracin global. En este ejemplo se utiliza el modo de base de datos para eliminar VLAN 2.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

El modo de configuracin global no registra ningn mensaje de error en la consola que indique la eliminacin de la VLAN. No obstante, puede
ejecutar el comando show vlan para verificar que se ha eliminado.

Cmo aislar la comunicacin entre dos VLAN

En esta seccin no se tratan las VLAN privadas. Este tipo de VLAN proporcionan aislamiento de capa 2 entre puertos de la misma VLAN
privada (VLAN aislada) o entre las VLAN privadas (VLAN comunitarias).

Existen dos escenarios posibles cuando se intenta aislar dos VLAN.

VLAN de capa 2

VLAN de capa 3

Aislamiento entre dos VLAN de capa 2

Una VLAN de capa 2 se crea en el switch y no se configura con el comando interface vlan <vlan_number>. Los hosts de las distintas VLAN
de capa 2 no se pueden comunicar entre s.

Siga estos pasos para crear una VLAN de capa 2 y aislarla de las VLAN antiguas:

1. Cree la nueva VLAN en la base de datos. Cuando salga del modo de base de datos VLAN se aplicarn los cambios de configuracin.

Switch#vlan database

!--- Debe entrar en el modo de base de datos VLAN para


!--- configurar cualquier VLAN.

Switch(vlan)#vlan 5
VLAN 5 added:
Name: VLAN0005
Switch(vlan)#vlan 6
VLAN 6 added:
Name: VLAN0006
Switch(vlan)#exit
APPLY completed.
Exiting....

2. Asegrese de que se haya creado la VLAN en la base de datos VLAN. La nueva VLAN debe aparecer en el resultado del comando show
vlan .

3. No defina ninguna direccin IP en las VLAN recin creadas.

4. Configure las interfaces fsicas que conectan los clientes con la VLAN correspondiente.

Switch(config)#interface fastEthernet 2/1


Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 5
Switch(config-if)#no shut

witch(config)#interface fastEthernet 2/2


Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 6
Switch(config-if)#no shut

5. Asigne a cada host una direccin IP esttica, una mscara de subred y no defina una gateway predeterminada. Esto hace que los hosts de
los puertos fa 2/1 y 2/2 no se comuniquen entre s. Los dispositivos que pertenezcan a una VLAN no llegarn a nada que no sean los
dispositivos dentro de la misma VLAN.

Aislamiento entre dos VLAN de capa 3

Si se crea una VLAN y se asigna una direccin IP con el comando interface vlan <vlan_number>, la VLAN pasa a ser de capa 3. En los
switches de capa 3, los hosts entre dos VLAN se pueden comunicar entre s (si los hosts se configuran con la gateway predeterminada como la
direccin IP de la interfaz VLAN). Las ACL se pueden utilizar para rechazar la comunicacin entre las VLAN.

En esta seccin se muestra un ejemplo de cmo aislar la comunicacin entre una VLAN de capa 3 recin creada y una VLAN antigua.

En el ejemplo, el switch 3750 tiene dos VLAN (VLAN 1 y VLAN 2). La VLAN creada recientemente es VLAN 5. VLAN 1, VLAN 2 y VLAN
5 son VLAN de capa 3. Las ACL se implementan para rechazar el trfico de modo que VLAN 1 y VLAN 2 no se puedan comunicar con VLAN
5, y que VLAN 5 no se comunique con VLAN 1 ni con VLAN 2.

VLAN 1 - 10.10.10.0 /24

VLAN 2 - 172.16.1.0 /24

VLAN 5 - 192.168.1.0 /24

1. Cree la nueva VLAN en la base de datos. En este caso, la nueva VLAN es VLAN 5. Cuando salga del modo de base de datos VLAN se
aplicarn los cambios de configuracin.

Switch#vlan database

!--- Debe entrar en modo de base de datos VLAN


!--- para poder configurar cualquier VLAN.

Switch(vlan)#vlan 5
VLAN 5 added:
Name: VLAN0005
Switch(vlan)#exit
APPLY completed.
Exiting....

2. Asegrese de que se haya creado la VLAN en la base de datos VLAN. Compruebe el resultado del comando show vlan.

3. Defina una direccin IP para la VLAN recin creada.

Switch(config)#interface vlan 5
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config)#no shut

4. Configure las interfaces fsicas que conectan los clientes con la VLAN correspondiente.

Switch(config)#interface fastEthernet 2/1


Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 5
Switch(config-if)#no shut

Es necesario configurar tres listas de acceso, una para cada VLAN.

Esta lista de acceso rechaza el trfico procedente de VLAN 1 hasta VLAN 5.

!--- Algunos comandos de este resultado se ajustan en


!--- una segunda lnea debido a limitaciones de espacio.

Switch#configure terminal
Switch(config)#access-list 101 deny
ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any

Esta lista de acceso rechaza el trfico procedente de VLAN 2 hacia VLAN 5.

Switch#configure terminal
Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any

Esta lista de acceso rechaza el trfico procedente de VLAN 5 hacia VLAN 1 y VLAN 2.

Switch#configure terminal
Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any

Una vez configuradas, aplique estas listas de acceso a la interfaz VLAN 1, VLAN 2 y VLAN 5.

Switch#configure terminal
Switch(config)#interface vlan 1
Switch(config-if)#ip access-group 101 in
Switch(config-if)#exit

Switch#configure terminal
Switch(config)#interface vlan 2
Switch(config-if)#ip access-group 102 in
Switch(config-if)#exit

Switch#configure terminal
Switch(config)#interface vlan 5
Switch(config-if)#ip access-group 105 in
Switch(config-if)#end

Cmo configurar las VLAN de rango extendido en un switch Catalyst serie 6500

Para llevar a cabo esta operacin en los switches de este tipo que ejecutan Cisco IOS, debe ejecutar el comando spanning-tree extend system-id.
La VLAN extendida se debe crear en modo de configuracin y no desde el modo de base de datos VLAN.

Complete estos pasos para crear VLAN extendidas en los switches Catalyst serie 6500 que ejecutan IOS:

1. Acceda a la consola del switch:

Switch>enable
Switch#

2. Indique el modo de configuracin:

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#

3. Ejecute el comando spanning-tree extend system-id en modo de configuracin:

Switch(config)#spanning-tree extended system-id

4. Ejecute el comando vtp mode transparent en modo de configuracin:

Switch(config)#vtp mode transparent

5. Cree la VLAN en modo de configuracin:


Switch(config)#vlan 1311

Notice
Switch(config-vlan)#exit

6. Salga del modo de configuracin:

Switch(config)#exit

7. Ejecute el comando show vlan para comprobar la informacin de VLAN.

Switch#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
101 VLAN0101 active Gi4/8, Gi4/10
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
1311 VLAN1311 active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
101 enet 100101 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
1311 enet 101311 1500 - - - - - 0 0

Consejos para la resolucin de problemas

En esta seccin se proporciona informacin para resolver problemas comunes que pueden aparecer durante la creacin de VLAN en los switches
Catalyst que ejecutan el software Cisco IOS.

En los switches con Cisco IOS, puede usar el propio switch para el enrutamiento InterVLAN, en lugar de un router externo. Cuando se crea una
SVI, no se crea automticamente una VLAN en la base de datos de la capa 2. Para que aparezca una SVI, se debe crear una VLAN en modo de
base de datos o (en versiones posteriores del software Cisco IOS) en modo de configuracin global. Para que la SVI se active por completo, lo
que supone que administrativamente est activa y que el protocolo de lnea est activado, asegrese de disponer al menos de un puerto como
miembro de esa VLAN, con un dispositivo activo conectado a l.

Lo mismo sucede al copiar configuraciones de un switch diferente o restablecer configuraciones con VLAN creadas en modo de base de datos
VLAN. Tambin debe reemplazar el archivo de la base de datos VLAN (vlan.dat) o volver a crear las VLAN, siguiendo el procedimiento descrito
en la seccin de este documento Creacin de VLAN y puertos. Si copia la configuracin de otro switch, la base de datos VLAN no se copiar.

Si no se ha creado la VLAN de la capa 2 en el switch, las interfaces SVI se muestran como UP/DOWN en el resultado del comando show ip
interface brief al aplicar la configuracin al switch. Asegrese de que todas las VLAN anteriores creadas en modo de base de datos VLAN o en
modo de configuracin global siguen existiendo una vez que la configuracin se haya copiado en el switch.

Verificacin
Actualmente, no hay un procedimiento de verificacin disponible para esta configuracin.

Resolucin de problemas
Error del valor TLB incoherente en los switches de IOS

El error del valor de puente con traduccin (TLB) incoherente puede suceder cuando un usuario crea una VLAN en un switch de IOS, que
recientemente recibi una actualizacin de VTP desde un switch de CatOS o que se convirti desde CatOS. Esto se debe a que CatOS e IOS
tienen valores predeterminados distintos para la VLAN de puente con traduccin. Las VLAN con traduccin traducen la interfaz de datos
distribuidos por fibra (FDDI) o Token Ring a Ethernet. Las VLAN de puente con traduccin (tb) para VLAN 1, 1002 y 1003 son diferentes en
CatOS y tienen el valor '0' de forma predeterminada. Las VLAN de puente de traduccin predeterminado de fbrica en los switches de IOS son:

Vlan ID tb1 tb2


-------- ----- -----
1 1002 1003
1002 1 1003
1003 1 1002

Un switch de IOS, que recientemente recibi una actualizacin de VTP desde un switch de CatOS o que se convirti desde CatOS, sobrescribe
sus valores tb predeterminados. Si se intenta crea una VLAN tras ello, se genera el siguiente mensaje de error:

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Como solucin al problema, cambie los valores predeterminados tb del switch de IOS para VLAN 1, 1002 y 1003 para que coincidan con los
valores de CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Recuperacin del archivo vlan.dat en los switches de IOS

Para los switches Catalyst de Cisco que ejecutan el software Cisco IOS, la informacin de VLAN se encuentra en un archivo independiente
denominado vlan.dat. Si este archivo se elimina de forma accidental y el switch vuelve a cargarse, se perdern todas las VLAN que estaban
disponibles en el switch. Hasta que el switch vuelva a cargarse, la informacin de VLAN est presente en l.

Realice los siguientes pasos para recuperar el archivo vlan.dat:

1. Ejecute el comando show vlan para confirmar la disponibilidad de la informacin de VLAN.

Switch#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/10, Fa0/11, Fa0/12, Gi0/1
Gi0/2
10 VLAN0010 active
11 VLAN0011 active
20 VLAN0020 active
21 VLAN0021 active
30 VLAN0030 active
31 VLAN0031 active
40 VLAN0040 active
41 VLAN0041 active
50 Vlan50 active
100 100thVLAN active

2. Si el switch est en modo transparente o de servidor VTP, realice todas las modificaciones en la base de datos VLAN.

Estas modificaciones pueden ser las siguientes:

Cree cualquier VLAN.

Elimine cualquier VLAN.

Modifique las propiedades de cualquier VLAN existente.

Si el switch est en modo de cliente VTP, realice las modificaciones en la base de datos VLAN en cualquier servidor VTP del mismo
dominio.

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 50

Switch(config-vlan)#name 50thVLAN

Switch(config-vlan)#end
Switch#
Una vez que se realice cualquier cambio en la base de datos VLAN, el switch crear de forma automtica el archivo vlan.dat.

3. Ejecute el comando show flash: para comprobar la creacin del archivo vlan.dat.

Switch#show flash:

Directory of flash:/

2 -rwx 5 Mar 01 1993 00:04:47 private-config.text


3 -rwx 2980487 Mar 02 1993 06:08:14 c2950-i6q4l2-mz.121-19.EA1a.bin
4 -rwx 1156 Mar 01 1993 01:51:27 vlan.dat
16 -rwx 1014 Mar 01 1993 00:04:47 config.text
6 drwx 4096 Mar 02 1993 03:49:26 html
7 -rwx 3121383 Mar 02 1993 03:47:52 c2950-i6q4l2-mz.121-22.EA9.bin

7741440 bytes total (65536 bytes free)

1992-2014 Cisco Systems Inc. Todos los Derechos Reservados.

Fecha de Generacin del PDF: 23 Junio 2008

http://www.cisco.com/cisco/web/support/LA/7/73/73461_3.html