You are on page 1of 48

Henrique Souza

Translate

Selecione o idioma

tera-feira, 31 de dezembro de 2013

LEVANTAMENTO ARQUITETNICO

Levantamento arquitetnico nada mais do que fazer as medies do


ambiente manualmente em um papel e logo converte-lo em um projeto, e
para um levantamento arquitetnico necessrio papel, trena, rgua,
caneta e ajuda de alguns companheiros.

Abaixo est uma pequena demonstrao:

PLANTA BAIXA

VISTA 1
VISTA 2
VISTA 3
VISTA 4
Logo s passar para o projeto.

Obs: em vistas no se coloca cotas na vertical.

PLANTA BAIXA
VISTA 1
VISTA 2

VISTA 3
VISTA 4

Obs: nessa vista eu errei no rodap, 0.30 x 0.08

Postado por Henrique de Amorim s 16:40 Nenhum comentrio:


Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no
FacebookCompartilhar com o Pinterest

quinta-feira, 26 de dezembro de 2013

rea no mapa

Qual a rea de uma chcara que tem forma retangular e aparece em um


mapa de escala 1: 600 com 6 cm de base ?

Resoluo:

At = E^2 . Ad

At = rea do terreno (m^2)


E = escala
Ad = rea do desenho (cm^2)

Ad= 6.4 = 24 cm^2

At = 6000^2 . 24 cm^2
At = 36000000 / 10000
At = 86.4000

Postado por Henrique de Amorim s 20:47 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

domingo, 22 de dezembro de 2013

Camisa Engenharia Civil

Modelo de camisa da Engenharia Civil


Postado por Henrique de Amorim s 12:47 3 comentrios:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

sbado, 21 de dezembro de 2013

GEOMETRIA ANALTICA

EXERCICIOS DE VETORES

1) Determinar a, de modo que o ngulo A do triangulo ABC, seja 60. Dados


A(1,0,2) B(3,1,3) e C(a+1,-2,3)

Resoluo:

AB= B-A= (2,1,1)


AC= C-A= (A,-2,1)

< AB, AC> = (2,1,1) . (a,-2,1) = 2a, -2, +1


< AB, AC> = 2a-1
2) Sejam os vetores a= (1,-m,-3) b= (m+3,4-m,1) e c= m,-2,7) determine
m para que a.b= (a+b) . c

Resoluo:

a= (1,m,-3)

b= (m+3,4-m,1)

c= (m,-2,7)

a.b= (a+b).c

= (1,-m,-3).(m+3,4-m,1)

a.b= //

a+b = (1,-m,-3)+(m+3,4-m,1)
a+b.c= (m+4,4-2m,-2) . (m-2,7)

= m^2 +4m-8+4m-14

= -3m+m^2 = m^2 + 8m-22

= -3m - 8m = -22

= -11m = -22

m = -11 / -11

m= 2 //

6) O vetor U= (-1,-1,-2) e V= (2,-3,4) calcular:

a) A rea do paralelogramo determinado por U e V

b) A altura do paralelogramo relativa base definida pelo vetor U

Resoluo:

A= |U x V| = i j k

1 -1 1 Determinante= -i -2j - k

2 -3 4

b)

A= b . h

A= raiz de 6

b= raiz de 3

h= ?
10) Determine a altura do tetraedro ABCD, onde A= (1,3,1) B=(0,-2,4) C=
(2,1,-3) e D= (0,-6,0).

Resoluo:

AB= B-A= (-1,-5,3)

AC= C-A= (1-2,-4)

AD= D-A= (-1,-9,-1)

-1 -5 3

1 -2 -4

-1 -9 -1

Determinante = -24 = 24

Volume = Ab . h / 2

V = (1/6) . 24

V= 4u

h= ?

v= 4

Ab= raiz de 726


Postado por Henrique de Amorim s 01:31 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

quinta-feira, 19 de dezembro de 2013

Geometria analtica

Volume do paraleleppedo

Volume do tetraedro

Determine o volume do paraleleppedo que tem 3 arestras MN, MP, MQ


sendo m(-1, 1, 2) n (-2, 1, 1) e q (1,3,2)
mn= n-p (3,0,-1)

mp= p-n (-1,0,-1)

mq= q-m (2,2,0)

30 -1

-1 0 -1 D= 8u

2 2 0

Determine o volume do tetraedro ABCD cujos vrtices so A= (1,1,-1) B=


(2,2,-1) C= (3,1,-1) e D= (2,3,1)

Soluo:

<U> AB = B-A (1,1,0)

<V> AC = C-A (3,1,-1)

<W> AD = D-A (2,3,1)

[U,V,W] = 1/6 . |1 1 0|

|2 0 0| D= -4

|1 2 2|
[U,V,W] =

8) Um tetraedro ABCD tem volume 3 u.v sendo A = (4,3,1) B = (6,4,2) e C


= (1,51) determine o vrtice D E OX.

Soluo:

D E OX = D (x,0,0) sempre que se referir em D E OX est se referindo


em x, y, z

por exemplo:

x = (x,0,0)

y = (0,y,0)

z = (0,0,z)

logo:

AB = B-A = (2,1,1)

AC = C-A = (-3,2,0)

AD = D-A = (x-4,-3,-1)

Determinante = - 2x +10

Vt = 1/6 . Vp

3 = 1/6 . |-2x + 10| fazendo a funo modular fica:


3.6 = 2x -10

18+10 = 2x

x = 28 / 2

x = 14

ou

3.6= |-2x +10|

18= -2x +10

18-10 = -2x

8 = -2x

8 / -2 = x

-4 = x como no existe volume negativo x = 4

Postado por Henrique de Amorim s 23:29 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

RUMOS E AZIMUTES

PROPRIEDADES DE RUMOS E AZIMUTES


Para aprender a calcular RUMOS e AZIMUTES segue abaixo um bom
exemplo:

1 Voc deve conhecer o grfico do quadrante:

2 Praticando uns exerccios de aprendizagem

Transforme os azimutes e rumos e os rumos em azimutes.

Obs: para calcular tanto rumo para azimute voc deve seguir as
propriedades e saber o que significa aqueles pontos.

= graus
' = minutos

" = segundos

Resoluo Azimute:

Como o azimute est no primeiro, no precisa fazer calculo ento 1Q = 30


30" 20"

2Q = Como 283 est no 4Q logo

3Q = Como 231 est no 3Q logo

4Q = Como 101 est no 2Q logo

Ento a concluso ser:

IQ = 30 30' 30" NE

IIQ = 76 34' 20" NW


IIIQ = 51 15' 15" SW

IV = 78 29' 45"

Resoluo o rumo -> azimute

IQ = Como 50 NW est no IVQ logo:

IIQ = Como 65 NE est no IQ no precisa fazer calculo

IIIQ = Como 89 SE est no IIQ logo:

IQ = Como 35 SW est no IIIQ logo:

Ento:

IQ = 309 44' 35"


IIQ = 65 20' 20"
IIIQ = 90 39" 35"
IVQ = 215 30' 40"
Postado por Henrique de Amorim s 00:23 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

quarta-feira, 18 de dezembro de 2013

GEOMETRIA ANALTICA / ngulo entre vetores

1) Determine o ngulo entre a diagonal de um cubo e uma de suas arestas


conforme a figura.

Soluo:

U= (1,0,0)

V=(1,1,1)

<U,V> = (1.1 + 0.1+ 0.1)


<U,V) = 1

U= =1

V=

arc cos

2) Dado o tetraedro de arestas OA, OB e OC, conforme a figura abaixo,


sabemos que: OA = (x, 3,4) OB= (0,4,2) e OC= (1,3,2). calcule o valor de x
para que o volume desse tetraedro seja igual a 6 u.v

sabemos que o volume Vt do tetraedro dado por:

Vt = 1/6 ||<OA X OB, OC>||

Soluo:

Vt = 1/6 ||<OA X OB, OC>||

|x 3 4|

Vt = 1/6 . |0 4 2| D= 2x - 10

|1 3 2|

Vt = 1/6 <2x - 10>

6 = 1/2 + (2x - 10)

12 = 2x - 10
12 + 10 = 2x

x = 22 / 2

x = 11

Postado por Henrique de Amorim s 11:20 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

sexta-feira, 13 de dezembro de 2013

Geometria Analtica

Volume do paraleleppedo
Determine o volume do paraleleppedo de arestas AB, AC e AD, sendo A=
(2,1,3) , B= (3,2,3) e

D= (1,2,3)

Soluo:

U = AB = (0,6,1)

V = AC = (1,1,0)

W= AD = (-1,-3,0) fazendo seu determinante

Volume= [ U,V,W ] | 0 6 1|

| 1 1 0|

|-1 -3 0|

Volume = 2 u.v

Postado por Henrique de Amorim s 23:21 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Matrizes

Escreva a matriz A= (aij) nos seguintes casos:

a) A e uma matriz do tipo 3 x 4 com:

aij = -1 para i = 2j
aij = a para i 2j

b) A uma matriz quadrada de 4 ordem com:

aij = 0 para i + j = 4
aij = -1 para i + j 4

Resoluo:
a)
Na letra a aij = -1 para i = 2j para fazer o dobro, ento :

a11 a12 a13 a14 |a -1 a a


a21 a22 a23 a24 = |a a a -1
a31 a32 a33 a34 |a a a a
Resoluo da letra b
b)

a11 a12 a13 a14


a21 a22 a23 a24
a31 a32 a33 a34 =
a41 a42 a43 a44

-1 -1 0 -1
-1 0 -1 -1
0 -1 -1 -1
-1 -1 -1 -1

Postado por Henrique de Amorim s 00:46 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

quinta-feira, 12 de dezembro de 2013

FUNCO E POTENCIA // Algoritmo e programao

algoritmo "38"
// Faa um algoritmo que leia 2 valores inteiros e positivos: X e Y.
// O algoritmo deve calcular e escrever a funo potncia XY.
var
x,y: inteiro
expoente: real
inicio
expoente <-0
escreval("Informe o valor X (onde X a base)")
leia(x)
escreval("Informe o valor Y (onde Y o expoente)")
leia(y)
se y=0 entao
escreval("Esta funo tem o valor de: (1)")
senao
se y=1 entao
escreval("A funo de f(",x," ) =", x)
senao
expoente <-x^y
escreval("A funo de F(",x," ) =", expoente)
fimse
fimse

fimalgoritmo

Postado por Henrique de Amorim s 00:01 Nenhum comentrio:


Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no
FacebookCompartilhar com o Pinterest

MATRICULA DE ALUNOS // Algoritmo e programao

algoritmo "Matricula de Aluno (a)"


// Faca um algoritmo que: Le os seguintes dados de 10 Aluno (a)s de uma
turma de Algoritmo e Programacao
//matricula, nome e a nota de cada um dos dois bimestres (nota bimestral);
// Calcula a media semestral de cada Aluno (a);
// Mostra na tela a lista de Aluno (a)s (matricula, nome e media)
//que foram aprovados sem exame e a respectiva media semestral (um
Aluno (a) e aprovado se sua media semestral for maior ou igual a 7);

// Mostra na tela a lista de Aluno (a)s (matricula, nome e media) que foram
reprovados sem direito a fazer o exame final
//(caso media semestral seja menor que 4);
//Solicita a nota do exame de cada Aluno (a) que precisou fazer o exame.
// Entao calcula a media final destes Aluno (a)s. Apresenta ao final, a
matricula, nome, media e situacao final
//(aprovado, se media maior ou igual a 6 e reprovado, caso contrario)
var
m1: inteiro
a1: caractere
n1, n2, media, mediafinal, notaexame : real

inicio
para m1 de 1 ate 10 faca
escreval
escreval ("MATRCULA SOMENTE NMEROS:")
leia (m1)
escreval ("Nome do Aluno (a):")
leia (a1)
escreval ("Nota do [1] bimestre / nota do [2] bimestre:")
leia (n1,n2)
media <- (n1+n2)/2
se (media >=7) entao
limpatela
escreval ("Aluno (a) (a): [",a1, "] Matricula: [",m1, "] mdia obtida
[",media, "] est aprovado (a)")
fimse
se (media <4) entao
escreval ("Aluno (a): (a) [",a1, "] Matricula: [",m1, "] mdia obtida
[",media, "] est reprovado (a)")

fimse
se (media >=4) e (media <=6.99) entao
limpatela
escreval ("Exame final")
escreval ("Digite a nota do exame final")
leia (notaexame)
mediafinal <- (notaexame + media)/2
se (mediafinal >=6) entao
limpatela
escreval ("Aluno (a): [",a1, "] Matricula= [",m1, "] Mdia final=
[",mediafinal, "] Aprovado no exame no final:")
senao
escreval ("Aluno (a): [",a1, "] Matricula= [",m1, "] Mdia final=
[",mediafinal, "] Reprovado no exame final")
fimse
fimse
fimpara

fimalgoritmo

Postado por Henrique de Amorim s 00:00 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

quarta-feira, 11 de dezembro de 2013

IPTU // Algoritmo e programao

algoritmo "22"
// Em certo municipio, 30 proprietarios de imoveis estao em atraso com o
pagamento do IPTU.
// - Escreva um algoritmo que calcule e escreva o valor da multa a ser paga
por estes proprietarios,
//- considerando que:
//-Os dados de cada imovel
//- (identificacao,
//- valor do imposto
// e numero de meses em atraso)
//- deverao ser lidos do usuario.
//- As multas devem ser calculadas no valor de 1% por mes de atraso.
//- O algoritmo deve exibir: a identificacao de imovel,
//- valor do imposto,
//- a multa a ser paga e o total devido pelo proprietario (imposto + multa).
var
atraso: inteiro
multa, iptu, total: real
prop, imovel, ident: caractere

inicio
para atraso de 1 ate 30 faca
escreval ("NOME DO PROPRIETRIO (a)")
leia (prop)
escreval ("Dados do imvel:")
leia (imovel)
escreval ("Nmero de [Identificao]")
leia (ident)
escreval ("Valor do IPTU")
leia (iptu)
escreval ("Meses em atraso")
leia (atraso)
multa <- (0.01 * atraso)
total <- (iptu + multa)
limpatela
escreval ("Imvel: ",ident, " multa a ser paga ",multa, " R$")
escreval ("Total a ser pago pelo proprietrio (a): ",prop, " de: ",total, " R$")
escreval
fimpara

Postado por Henrique de Amorim s 23:58 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

HIPOTENUSA // Algoritmo e programao

Faa um algoritmo que calcule a hipotenusa de um triangulo

algoritmo "Hipotenusa"
// Funo :
// Autor :
// Data : 11/12/2013
// Seo de Declaraes
var oposto, adjacente, hipotenusa: real

inicio
escreval ("digite o cateto oposto")
leia (oposto)
escreval ("digite o cateto adjacente")
leia (adjacente)
hipotenusa <- raizq (oposto^2 + adjacente^2)
escreval ("Hipotenusa gerada : ",hipotenusa)

// Seo de Comandos
fimalgoritmo

Postado por Henrique de Amorim s 23:54 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

MOD de 2 e 3 // Algoritmo e programao

algoritmo "43"
// Funo :
// Autor :
// Data : 28/11/2013
// Seo de Declaraes
var
A, B, C, D:inteiro
inicio

escreval ("Digite [4] nmeros")


leia (A,B,C,D)

se (A mod 2= 0)entao
escreval(A," divisvel por [2] ")
senao
se (A mod 3 = 0) entao
escreval(A," divisivel por [3] ")
fimse
fimse

se (B mod 2 = 0) entao
escreval(B," divisvel por [2] ")
senao
se (B mod 3 = 0) entao
escreval(B," divisivel por [3] ")
fimse
fimse

se (C mod 2 = 0) entao
escreval(C," divisvel por [2] ")
senao
se (C mod 3 = 0) entao
escreval(C," divisivel por [3] ")
fimse
fimse

se (D mod 2= 0) entao
escreval(D," divisvel por [2] ")
senao
se (D mod 3 = 0) entao
escreval(D," divisivel por [3] ")
fimse
fimse

fimalgoritmo

Postado por Henrique de Amorim s 23:52 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

FATORIAL DE UM NMERO // Algoritmo e programao

algoritmo "40"
//Elabore um algoritmo que leia um nmero qualquer digitado pelo usurio
// e calcule seu Fatorial. (Exemplo: 5! = 5 x 4 x 3 x 2 x 1)
// Autor :
// Data : 13/11/2013
// Seo de Declaraes
var

n, i, fatorial: inteiro

inicio
// Seo de Comandos

escreva("Digite um numero: ")


leia(n)
fatorial<-1

para i de 1 ate n faca

fatorial<-fatorial*i

fimpara

escreval("O fatorial de ",n," : ",fatorial)

fimalgoritmo

Postado por Henrique de Amorim s 23:50 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Numero positivo e negativo // Algoritmo e programao

algoritmo "37l"
// Escreva um programa que leia um nmero inteiro. Se o nmero lido for
positivo,
// escreva uma mensagem indicando se ele par ou mpar.
// Se o nmero for negativo, escreva a seguinte mensagem
//Este nmero no positivo.
var
num,resto : inteiro
inicio
escreval("Digite um nmero")
leia(num)
resto <- num mod 2
se ( resto = 0) entao
escreva("O numero ",NUM, " par e ")
senao
escreva("O numero ",num," mpar e ")
fimse
se ( num >= 0) entao
escreval(" positivo.")
senao
escreval(" no positivo.")
fimse

fimalgoritmo

Postado por Henrique de Amorim s 23:49 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

VOLUME // Algoritmo e programao

algoritmo "32 "


// Faa um algoritmo que determine o volume de uma caixa dgua
cilndrica,
// sendo que o raio e a altura devem ser fornecidos (lidos pelo teclado).
//Formula: V = PI * Raio^2 * Altura
var
raio,altura,volume:real
inicio
escreval("Digite valor do raio:")
leia(raio)
escreval("Digite valor da altura:")
leia(altura)
volume<- PI * raio^2 * altura
escreva("Volume do cilindro :",volume, " Metros cbicos")
fimalgoritmo

Postado por Henrique de Amorim s 23:48 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Horas trabalhadas // Algoritmo e programao

algoritmo "semnome"
// Funo :
// Autor :
// Data : 13/11/2013
// Seo de Declaraes

Escrever um algoritmo que l o nome de um funcionrio, o nmero de horas


trabalhadas, o valor que recebe por hora e o nmero de filhos. Com estas
informaes, calcular o salrio deste funcionrio, sabendo que para cada
filho, o funcionrio recebe 3% a mais, calculado sobre o salrio bruto.

var
nome: caractere
horas, filhos: inteiro
vhora, sal, salbruto: real
inicio
escreva ("Digite o nome do funcionrio: ")
leia (nome)
escreva ("Digite o nmero de horas trabalhadas: ")
leia (horas)
escreva ("Digite o valor que ele recebe por hora: ")
leia (vhora)
escreva ("Digite o nmero de filhos que o funcionrio tem: ")
leia (filhos)

salbruto <- vhora * horas


sal <- (filhos * 0.03 * salbruto) + salbruto

escreval

escreva ("Salrio do funcionrio ", nome, " de: R$", sal," reais")
fimalgoritmo

Postado por Henrique de Amorim s 23:47 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

SALRIO X FINANCIAMENTO // Algoritmo e programao

algoritmo "salario x financiamento"


//Faa um algoritmo que receba o valor do salrio de uma pessoa e o valor
//de um financiamento pretendido. Caso o financiamento seja menor ou
igual a 5
// vezes o salrio da pessoa, o algoritmo dever escrever "Financiamento
Concedido";
// seno, ele dever escrever "Financiamento Negado".
//Independente de conceder ou no o financiamento, o algoritmo escrever
depois a frase "Obrigado por nos consultar.

var
salario,finan:real
inicio
Escreval("Digite o seu salario.")
leia(salario)
Escreval("Digite o valor do seu financiamento.")
leia(finan)
salario <-salario*5
se (salario >= finan) entao
Escreval("Financiamento Concedido!")
senao
Escreval("Financiamento Negado!")
fimse
Escreval("Obrigado por nos consultar.")
fimalgoritmo

Postado por Henrique de Amorim s 23:46 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

100 VALORES // Algoritmo e programao

Faa um algoritmo que leia 100 valores e os escreva na ordem contrria


que foram digitados.

algoritmo "semnome"
// Funo :
// Autor :
// Data : 13/11/2013
// Seo de Declaraes
var
num:vetor[1..100]de inteiro
i:inteiro
inicio
para i de 1 ate 100 faca
escreval("Informe um nmero:")
leia(num[i])
fimpara
para i de 100 ate 1 passo -1 faca
escreval(num[i])
fimpara
fimalgoritmo

Postado por Henrique de Amorim s 23:45 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

NOTAS DE ALUNOS E TURMA // Algoritmo e programao

Elabore um algoritmo que permita ler 6 notas de alunos de uma turma e os


respectivos nomes, identifique qual a nota mxima e a mnima e mostre
quais os respectivos nomes dos alunos que as obtiveram.

algoritmo "20"
var
nota: vetor[1..6] de real
nome: vetor[1..6] de caractere
max,min: real
i: inteiro
inicio
max <- 0
min <- 10
Para i de 1 ate 6 faca
Escreval("Digite o nome do(a) aluno(a) ",i, ".")
Leia(nome[i])
Escreval("Digite a nota do(a) ", nome[i], ".")
Leia(nota[i])
se (nota[i]>max) entao
max <- nota[i]
fimse
se (nota[i]<min) entao
min <- nota[i]
fimse
fimpara
limpatela
Escreva("Nota mxima: ", max)
para i de 1 ate 6 faca
se (nota[i]=max) entao
Escreval(". Aluno (a): ", nome[i])
fimse
fimpara
Escreva("Nota mnima: ", min)
para i de 1 ate 6 faca
se (nota[i]=min) entao
Escreval(". Aluno (a): ", nome[i])
fimse
fimpara
fimalgoritmo

Postado por Henrique de Amorim s 23:44 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

LEITURA DE 20 NMEROS // Algoritmo e programao

Faa um algoritmo para ler 20 nmeros e armazenar em um vetor. Aps a


leitura total dos 20 nmeros, o algoritmo deve escrever esses 20 nmeros
lidos na ordem inversa.

algoritmo "17"
// Funo :
// Autor :
// Data : 10/11/2013
// Seo de Declaraes
var
indice: inteiro
p20: vetor [1..20] de inteiro

inicio
para indice de 1 ate 20 faca
p20 [indice] <- (indice)
fimpara
para indice de 20 ate 1 passo -1 faca
escreval (p20 [indice])
fimpara

// Seo de Comandos
fimalgoritmo

Postado por Henrique de Amorim s 23:42 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

CONCESSIONRIA CARANGO VELHO // Algoritmo e programao

A concessionria de veculos CARANGO VELHO est vendendo os seus


veculos com desconto. Faa um algoritmo que calcule e exiba o valor do
desconto e o valor a ser pago pelo cliente de vrios carros. O desconto
dever ser calculado de acordo com o ano do veculo. At 2008 - 12% e
acima de 2008 - 7%. O sistema dever perguntar se deseja continuar
calculando desconto at que a resposta seja: (N) No . Informar total de
carros com ano at 2008 e total geral.
algoritmo "Carango velho"
// Funo :
// Autor : Henrique de Amorim
// Data : 28/11/2013
// Seo de Declaraes
var
programa, opc: caractere
ano, total, total2000: inteiro
valor, valorFinal, desconto: real

inicio
// Seo de Comandos
programa <- "S"
enquanto programa <> "N" faca
limpatela
escreva("Digite o valor do carro: ")
leia(valor)
escreva("Digite o ano do carro: ")
leia(ano)
se ano <= 2000 entao
desconto <- 0.12
total2000 <- total2000 + 1
total <- total + 1
senao
desconto <- 0.07
total <- total + 1
fimse
desconto <- desconto * valor
valorFinal <- valor - desconto
escreval("O valor do carro com desconto de: ",valorFinal)
escreval("")
escreva("Deseja continuar calculando? (S) Sim - (N) No - ")
leia(opc)
escolha opc
caso "S"
programa <- "S"
caso "N"
programa <- "N"
outrocaso
programa <- "S"
limpatela
escreval("As opes disponveis so apenas S ou N!!!")
leia(opc)
fimescolha
fimenquanto
escreval("Foram calculados",total2000," carro(s) com ano at 2000")
escreval("Total geral: ",total)

fimalgoritmo

Postado por Henrique de Amorim s 23:40 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest
FIBONACCI // Algoritmo e programao

algoritmo "sucesso de Fibonacci"


//Um matemtico italiano conseguiu modelar o ritmo de crescimento da
populao
//de coelhos atravs de uma sequncia de nmeros naturais que passou a
ser
//conhecida como sequncia de Fibonacci. O n-simo nmero da sequncia
de
//Fibonacci dado por:
//F1 = 1
//F2 = 1
//Fi = Fi - 1 + Fi - 2, para i > 2.
//Por exemplo, os sete primeiros elementos so: 1, 1, 2, 3, 5, 8, 13.
//Desenvolva um algoritmo que l N e mostra o N-simo elemento da srie.

var f1,f2,f3,f5,f8,f13,f21,f34,f89: inteiro

inicio
f1<-1+0
f2<-1+0
f3<-f1+f2
f5<- f2+f3
f8<- f3+f5
f13<-f5+f8
f21<-f8+f13
f34<-f13+f21
f89<-f21+f34
escreval (f1,f2,f3,f5,f8,f13,f21,f34,f89)
escreval ("O ltimo termo ",f89)

fimalgoritmo

Postado por Henrique de Amorim s 23:37 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Algoritmo e programao

algoritmo "11"
// Data : 26/11/2013
// Seo de Declaraes
//A prefeitura de uma cidade fez uma pesquisa entre seus habitantes,
coletando dados sobre o salrio e nmero de filhos. A prefeitura deseja
saber:
// a) mdia do salrio da populao;
// b) mdia do nmero de filhos;
// c) maior salrio;
// d) percentual de pessoas com salrio at R$250,00.

var
salario, filhos, mediasalario, mediafilhos, totalsalario, maiorsalario : real
quantidade250, totalfamilia, totalfilhos, percentual :real

inicio
mediasalario <-0
mediafilhos <-0
maiorsalario <-0
quantidade250 <-0
totalfamilia <-0

escreval ("Digite a quantidade de filhos")


leia (filhos)
escreval ("Digite o salrio da familia")
leia (salario)
enquanto (salario >0) faca

totalsalario <- totalsalario + salario


totalfilhos <- totalfilhos + filhos
totalfamilia <- totalfamilia + 1
se (salario > maiorsalario) entao
maiorsalario <- salario
fimse

se (salario <= 250) entao


quantidade250 <- +1
fimse
limpatela

escreval ("PARA SAIR DIGITE A QUANTIDADE DE FILHOS E O SALRIO COM O


VALOR [0]")
escreval ("Digite a quantidade de filhos")
leia (filhos)
escreval ("Digite o salrio da familia")
leia (salario)

mediasalario <-totalsalario / totalfamilia


mediafilhos <- totalfilhos / totalfamilia
percentual <- quantidade250 * 100 / totalfamilia
escreval ("A mdia de salrio da populao de R$ ",mediasalario)
escreval ("A mdia de filhos por familia de : ", mediafilhos)
escreval ("O maior salrio encontrado foi de R$ : ",maiorsalario)
escreval ("O percentual de familias com salrio de at R$ 250,00 reais
de :",percentual)
fimenquanto
fimalgoritmo

Postado por Henrique de Amorim s 23:36 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Algoritmo e programao

algoritmo "semnome"
// Escreva um algoritmo que leia 3 nmeros inteiros e mostre o maior deles.
var
a,b,c: inteiro

inicio
escreval ("Digite 3 nmeros")
leia (a,b,c)
se (a > b) e (b>c) entao
escreval ("Maior nmero: ",a)
fimse
se (b>a) e (a>c) entao
escreval ("Maior nmero: ",b)
fimse
se (c>b) e (b>a) entao
escreval ("Maior nmero: ",c)
fimse
se (a>c) e (c>b) entao
escreval ("Maior nmero: ",a)
fimse
se (c>a) e (a>b) entao
escreval ("Maior nmero: ",c)
fimse
se (b>c) e (c>a) entao
escreval ("Maior nmero: ",b)
fimse
// Seo de Comandos
fimalgoritmo

Postado por Henrique de Amorim s 23:34 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Escalonamento de Sistema Lineares

Considerando o sistema
x +y +z =7
2x + y - z = 9
x - 2y + 2z = 2

O valor da incgnita de Z :

Resoluo:
Multiplique a primeira equao por (-2) e adicionamos a segunda x - y - z =
7 (-2)
-2x -2 y - 2z = -14
2x + y - z = 9

-y - 3z = -5

Multiplique a primeira por (-1) soma com a terceira


x - y + z = 7 (-1)
-x - y - z = -7
x - 2y + 2z = 2

-3 y + z = -5

Do sistema inicial montamos um sistema equivalente

-y - 3z = -5
-3y + z = -5

Como precisamos de z vamos cancelar y assim multiplicamos a primeira


equao por (-3) e somamos com a segunda:

-y - 3z = - 5 (-3)

3y + 9 z = 15
-3y + z = -5

10z = 10
z = 10 / 10
z=1

CONSIDERANDO O SEGUINTE SISTEMA DE EQUAO LINEAR CALCULE O


PRODUTO DE X Y Z T

x + y + z = 11
x - y - z - t = -9
- x + y - z - t = -7
-x - y + z - t = -5

Resoluo:

x + y + z + t = 11
-x + y - z - t = - 9

2x=2
x=2/2
x=1

Agora somando a equao 3 com a 4

-x + y - z -t = -7
-x - y + z - t = -5

2x - 2t = -12

x = 1 logo :

-2 . 1 - 2t = -12
-2t = -12 + 2
-2t = -10
t = -10 / 2
t=5

Agora a equao 2 somada com a 3

x - y - z - t = -9
-z + y - z - t = -7

-2z - 2t = -16

t = 5 assim temos que

-2 z - 2 . 5 = -16
-2z = -16 + 10
-2z = -6
z=3

ento X, Y , Z e T ser

X=1
Y=2
T=5
Z=3 = 30

Postado por Henrique de Amorim s 23:21 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Sistema Linear

Quaisquer que que sejam os numeros reais a, b e c o determinante da


matriz

1 1 1 1
1 1+a 1 1
1 1 1+b 1
1 1 1 x+c dado por:

Resoluo:

1 1 1 1
1 1+a 1 1
1 1 1+b 1
1 1 1 x+c

Utilizando o teorema de Jacobi, para encontrar o determinante atravs do


teorema de Laplace (-1) . L4 = L4

1 1 1 1
1 1+a 1 1
1 1 1+b 1
0 0 0 c

para encontrar o determinante dessa matriz, atravs de Laplace escolha a


linha 4 e encontre o cofator do elemento a44 e multiplique por este
elemento

det = a44 . A44

det = c . (-1) ^4+4

1 1 1 1| 1 1
1 1+a 1 1| 1 1+a
1 1 1+b 1| 1 1

det = c . 1 (1+a) . (1+b) + 2 - 1 - a - 1 -1 - b


det = c . 1 (1+b + ab + a - 1 -b)
det = c (ab)
det = abc

Postado por Henrique de Amorim s 13:53 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Sistema Linear

Para qual valor de m o sistema admite infinitas solues?

|mx - 2y - z = 0
|x - my - 2z = 0
| 3x - 2y = 0

Resoluo: multiplique a primeira por (-2) e some com a segunda

-2mx + 4y + 2z = 0
x - my - 2z = 0

(-2m + 1) x + (4 - m) y = 0
3x - 2y = 0

Agora para termos um SPI , precisamos que na soma das duas equaes os
coeficiente zerem. No coeficiente x temos o valor 3 na segunda equao,
dessa forma, o coeficiente de x da primeira equao deve ser -3

-2m + 1 = -3
-2m = - 4
m=-4/-2
m=2

E no coeficiente de y da primeira equao devemos ter o valor 2:

4-m=2
m=4-2
m=2

Postado por Henrique de Amorim s 02:16 Nenhum comentrio:


Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no
FacebookCompartilhar com o Pinterest

Discusso de Sistema Linear

O sistema linear
|x + ay - 2z = 0
|x + y + z = 1
|x - y - z = 3 no admite soluo se a for igual a:

a) 0
b) 1
c) -1
d) 2
e) -2

Resoluo:
Somando a segunda com a terceira

2x = 4
x =2

Agora, somamos a primeira com o dobro da segunda

{ x + az - 2z = 0
{ 2x + 2y + 2z = 2
3x + ay + 2y = 2

como x = 2, ento :
6 + (a+2) y = 2
(a + 2) y = 2 - 6
(a+ 2) y = -4

Para ser SI, basta que a a + 2 seja igual a zero, logo:

a=-4+2
a = -2

Resposta letra E

Postado por Henrique de Amorim s 02:00 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

DISCUSSO DE SISTEMAS LINEARES

Discuta o sistema abaixo em relao aos parmetros a e b:

[ 3x + 2 by = 1
[ 12x + 8y = a

Resoluo:
Multiplica a primeira equao por (-4) e soma com a segunda, assim:

{ - 12x - 8by = -4
{ 12x + 8y = a

-12x - 12x -8by + 8y = -4 + a


-8by + 8y = -4 + a
(-8b + 8) y = -4 + a

Logo: preciso que o coeficiente de y seja diferente de zero

- 8b + 8 0
- 8b - 8
b1

Precisamos de 0y = 0, ou seja que o coeficiente de y seja igual a zero e que


o valor apos a igualdade seja igual a zero tambm, dessa forma:

- 8b + 8 = 0
-8b = - 8
b=1

-4+a0
a4

Resposta: {SPD para b 1; SPI para a = 4 e b = 1; e SI para a 4 e b = 1}

Postado por Henrique de Amorim s 01:51 Nenhum comentrio:

Enviar por e-mailBlogThis!Compartilhar no TwitterCompartilhar no


FacebookCompartilhar com o Pinterest

Postagens mais recentes Postagens mais antigas Pgina inicial

Assinar: Postagens (Atom)

Arquivo do blog

2016 (31)

Dezembro (1)

Setembro (7)

Agosto (1)

Julho (6)

Junho (2)

Maio (9)
Abril (3)

Maro (1)

Fevereiro (1)

2015 (79)

Dezembro (1)

Novembro (7)

Outubro (4)

Setembro (1)

Agosto (13)

Julho (29)

Junho (10)

Maio (5)

Abril (4)

Maro (2)

Fevereiro (1)

Janeiro (2)

2014 (38)

Dezembro (6)

Novembro (1)

Outubro (7)

Setembro (5)

Agosto (3)

Julho (6)

Junho (4)

Maio (1)

Abril (1)

Maro (1)

Fevereiro (1)

Janeiro (2)

2013 (61)

Dezembro (44)
LEVANTAMENTO ARQUITETNICO

rea no mapa

Camisa Engenharia Civil

GEOMETRIA ANALTICA

Geometria analtica

RUMOS E AZIMUTES

GEOMETRIA ANALTICA / ngulo entre vetores

Geometria Analtica

Matrizes

FUNCO E POTENCIA // Algoritmo e programao

MATRICULA DE ALUNOS // Algoritmo e programao

IPTU // Algoritmo e programao

HIPOTENUSA // Algoritmo e programao

MOD de 2 e 3 // Algoritmo e programao

FATORIAL DE UM NMERO // Algoritmo e programa...

Numero positivo e negativo // Algoritmo e programa...

VOLUME // Algoritmo e programao

Horas trabalhadas // Algoritmo e programao

SALRIO X FINANCIAMENTO // Algoritmo e programa...

100 VALORES // Algoritmo e programao

NOTAS DE ALUNOS E TURMA // Algoritmo e programa...

LEITURA DE 20 NMEROS // Algoritmo e programao

CONCESSIONRIA CARANGO VELHO // Algoritmo e progr...

FIBONACCI // Algoritmo e programao

Algoritmo e programao

Algoritmo e programao

Escalonamento de Sistema Lineares

Sistema Linear

Sistema Linear

Discusso de Sistema Linear

DISCUSSO DE SISTEMAS LINEARES


ACERVO TCNICO

CERTIDO DE REGISTRO DE ATESTADO

ATESTADO DE CAPACIDADE TCNICA

Anotao de responsabilidade tcnica

EQUAO DE MATRIZES

OPERAES COM MATRIZES

Operaes com matrizes

Leitura de Matriz 3X4 algoritmo "matriz 3 x 4" //...

Soma Entre Vetores algoritmo "soma de vetores" //...

Matriz 2: Gerar matriz com cubo dos elementos de o...

Gerar matriz transpostaalgoritmo "semnome"// Autor...

Matriz: Pesquisa de elemento por linha e coluna ...

INTRODUO AO ESTUDO DOS SOLOS Os solos so um do...

Novembro (4)

Outubro (8)

Setembro (1)

Agosto (2)

Maro (1)

Fevereiro (1)

2012 (1)

Dezembro (1)

Colaboradores

Henrique de Amorim

Henrique de Amorim

Seguidores

Pginas

Incio

Acessos
Total de visualizaes de pgina

237108

Modelo Espetacular Ltda.. Tecnologia do Blogger.

Texto original

Sugerir uma traduo melhor