You are on page 1of 3

ALGORITMO JUEGO

Pseudocódigo
Definir n1,n2,n3,n4,n5,m como real
Escribir "Introduce un número del 1 al 100"
Leer n1
borrar pantalla
Escribir "Intenta adivinar el número"
Leer m
Si m=n1 Entonces
Escribir "Has acertado!"
Sino
Si m<n1 Entonces
Escribir "Es menor"
Sino
Escribir "Es mayor"
FinSi
Escribir "Introduce el segundo intento"
Leer n2
Si m=n2 Entonces
Escribir "Has acertado!"
Sino
Si m<n2 Entonces
Escribir "Es menor"
Sino
Escribir "Es mayor"
FinSi
Escribir "Introduce el tercer intento"
Leer n3
Si n3=m Entonces
Escribir "Has acertado!"
Sino
Si m<n3 Entonces
Escribir "Es menor"
Sino
Escribir "Es mayor"
FinSi
Escribir "Introduce el cuarto inetnto"
Leer n4
Si m=n4 Entonces
Escribir "Has acertado!"
Sino
Si m<n4 Entonces
Escribir "Es menor"
Sino
Escribir "Es mayor"
FinSi
Escribir "Introduce el último intento"
Leer n5
Si m=n5 Entonces
Escribir "Has acertado!"
Sino
Escribir "lo sentimos, te has quedado sin
oportunidades"
FinSi
FinSi
FinSi
FinSi
FinSi
FinAlgoritmo

Explicación:
En primer lugar definimos las variables necesarias para realizar el algoritmo, en esta caso 6:
n1,n2,n3,n4,n5 y m como reales. Con las variables ya definidas, le pedimos al jugador 1 que introduzca
un número entre el 1 y 100, el que se quiera. Este número será definido como “m”. A continuación le
especificamos al programa que borre el número que acaba de ser introducido para que no se vea en la
pantalla. Ahora empieza el proceso de adivinar el número. Para ello necesitamos a otro jugador que
intentará adivinar el número (“m”) que ha introducido jugador 1, para ello solo dispondrá de 5 intentos.
Cada intento que falle se le indicará si el número “m” es mayor o menor que el que él ha introducido.
Esto se realiza mediante una secuencia enlazada. El jugador 2 introduce su primer intento (n1), si
coincide con m, habrá logrado acertarlo y ganará el juego. Si no coincide, el programa le indica si el
número introducido por el jugador 1 es mayor o menor que el suyo. Después se le da otra oportunidad,
si acierta habrá ganado y si falla se le indica de nuevo si es mayor o menor y así hasta 5 veces. Si en
los 5 intentos no lo logra adivinar, el jugador 2 habrá perdido el juego.