Τάξη : Γ’ Λυκείου

Ενότητα : Μονοδιάστατοι Πίνακες
Βαθµός ∆υσκολίας :

Πλανήτες

ΕΚΦΩΝΗΣΗ
Ένας ερασιτέχνης αστρονόµος αποφάσισε να γράψει ένα πρόγραµµα για να
απαντήσει µόνος του σε ορισµένα βασικά ερωτήµατα που αφορούν τους πλανήτες
του ηλιακού µας συστήµατος.
Πιο συγκεκριµένα θέλει το πρόγραµµα :

Να καταχωρεί σε πίνακα τα ονόµατα των εννέα πλανητών,

Να διαβάζει για κάθε πλανήτη την µέση θερµοκρασία του και την διάµετρο του
και θα τα αποθηκεύει σε πίνακες,

Να υπολογίζει ποιος είναι ο µεγαλύτερος πλανήτης,

Να υπολογίζει ποιος είναι ο πιο θερµός πλανήτης και

Να εµφανίζει ποιοι πλανήτες έχουν θερµοκρασία µεγαλύτερη από την µέση
θερµοκρασία όλων των πλανητών.

ΜΕΘΟ∆ΟΛΟΓΙΑ
Στο παράδειγµα αυτό δεν µας ζητείται να διαβάσουµε τα στοιχεία ενός πίνακα αλλά
να καταχωρήσουµε συγκεκριµένες τιµές σε αυτά (τα ονόµατα των εννέα πλανητών).
Συνεπώς θα πρέπει να χρησιµοποιήσουµε µία εντολή εκχώρησης για κάθε στοιχείο
του πίνακα. Κατόπιν πρέπει να υπολογίσουµε το µέγιστο στοιχείο δύο διαφορετικών
πινάκων (µεγαλύτερος και θερµότερος πλανήτης).
Τέλος θα πρέπει να εµφανίσουµε τα στοιχεία που έχουν τιµή µεγαλύτερη από την
µέση τιµή. Όµως η µέση τιµή δεν είναι γνωστή πριν την εκτέλεση του προγράµµατος.

Ασκήσεις Α.Ε.Π.Π.

Σε αυτές τις περιπτώσεις χρειάζεται ιδιαίτερη προσοχή αφού για να πετύχουµε το
ζητούµενο πρέπει να δουλέψουµε σε δύο βήµατα:

πρώτα υπολογίζουµε την τιµή που µας ζητείται (στην περίπτωση µας είναι η µέση
τιµή αλλά θα µπορούσε να είναι η µέγιστη τιµή, η ελάχιστη τιµή ή µία
οποιαδήποτε υπολογιζόµενη τιµή) και µετά

εµφανίζουµε τις τιµές που ικανοποιούν την συνθήκη που θέτει η άσκηση (στην
περίπτωση µας όλα τα στοιχεία του πίνακα που έχουν τιµή µεγαλύτερη από την
µέση τιµή).

ΛΥΣΗ
ΠΡΟΓΡΑΜΜΑ Πλανήτες
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι, ΜΕΓ_ΠΛΑΝΗΤΗΣ, ΘΕΡΜ_ΠΛΑΝΗΤΗΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΘΕΡΜ[9], ∆ΙΑΜ[9], ΜΕΓ_∆ΙΑΜ, ΜΕΓ_ΘΕΡΜ, ΣΥΝ_ΘΕΡΜ, ΜΟ_ΘΕΡΜ
ΧΑΡΑΚΤΗΡΕΣ: ΠΛΑΝΗΤΗΣ[9]
ΑΡΧΗ
ΠΛΑΝΗΤΗΣ[1]  "ΕΡΜΗΣ"
ΠΛΑΝΗΤΗΣ[2]  "ΑΦΡΟ∆ΙΤΗ"
ΠΛΑΝΗΤΗΣ[3]  "ΓΗ"
ΠΛΑΝΗΤΗΣ[4]  "ΑΡΗΣ"
ΠΛΑΝΗΤΗΣ[5]  "∆ΙΑΣ"
ΠΛΑΝΗΤΗΣ[6]  "ΚΡΟΝΟΣ"
ΠΛΑΝΗΤΗΣ[7]  "ΟΥΡΑΝΟΣ"
ΠΛΑΝΗΤΗΣ[8]  "ΠΟΣΕΙ∆ΩΝΑΣ"
ΠΛΑΝΗΤΗΣ[9]  "ΠΛΟΥΤΩΝΑΣ"

Καταχωρούµε τα ονόµατα
των εννέα πλανητών στον
πίνακα ΠΛΑΝΗΤΗΣ.

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
ΓΡΑΨΕ "Ποια είναι η µέση θερµοκρασία του πλανήτη ", ΠΛΑΝΗΤΗΣ[Ι], "; "
∆ΙΑΒΑΣΕ ΘΕΡΜ[Ι]
ΓΡΑΨΕ "Ποια είναι η διάµετρος του πλανήτη ", ΠΛΑΝΗΤΗΣ[Ι], "; "
∆ΙΑΒΑΣΕ ∆ΙΑΜ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΕΓ_∆ΙΑΜ  ∆ΙΑΜ[1]
ΜΕΓ_ΠΛΑΝΗΤΗΣ  1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 9
ΑΝ ΜΕΓ_∆ΙΑΜ < ∆ΙΑΜ[Ι] ΤΟΤΕ

Υπολογίζουµε τον µεγαλύτερο
πλανήτη (δηλαδή ΜΕΓΙΣΤΟ και
ΘΕΣΗ ΜΕΓΙΣΤΟΥ ΣΕ ΠΙΝΑΚΑ).

ΜΕΓ_∆ΙΑΜ  ∆ΙΑΜ[Ι]
Αφού βρήκαµε την θέση του µεγαλύτερου
ΜΕΓ_ΠΛΑΝΗΤΗΣ  Ι
πλανήτη (στον πίνακα ∆ΙΑΜ) πάµε στην
αντίστοιχη θέση του πίνακα που κρατάει τα
ΤΕΛΟΣ_ΑΝ
ονόµατα και εµφανίζουµε το όνοµα του.
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ""
ΓΡΑΨΕ "Μεγαλύτερος είναι ο πλανήτης ", ΠΛΑΝΗΤΗΣ[ΜΕΓ_ΠΛΑΝΗΤΗΣ]

Σαρηµπαλίδης Ιωάννης

Σελίδα 2

Ασκήσεις Α.Ε.Π.Π.

ΜΕΓ_ΘΕΡΜ  ΘΕΡΜ[1]
ΘΕΡΜ_ΠΛΑΝΗΤΗΣ  1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 9
ΑΝ ΜΕΓ_ΘΕΡΜ < ΘΕΡΜ[Ι] ΤΟΤΕ

Υπολογίζουµε τον θερµότερο
πλανήτη (δηλαδή ΜΕΓΙΣΤΟ και
ΘΕΣΗ ΜΕΓΙΣΤΟΥ ΣΕ ΠΙΝΑΚΑ).

ΜΕΓ_ΘΕΡΜ  ΘΕΡΜ[Ι]
ΘΕΡΜ_ΠΛΑΝΗΤΗΣ  Ι
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ""
ΓΡΑΨΕ "Θερµότερος είναι ο πλανήτης ", ΠΛΑΝΗΤΗΣ[ΘΕΡΜ_ΠΛΑΝΗΤΗΣ]
ΣΥΝ_ΘΕΡΜ  0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
ΣΥΝ_ΘΕΡΜ  ΣΥΝ_ΘΕΡΜ + ΘΕΡΜ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Υπολογίζουµε την µέση θερµοκρασία
των πλανητών (δηλαδή υπολογίζουµε
αρχικά ΑΘΡΟΙΣΜΑ ΠΙΝΑΚΑ και
κατόπιν διαιρούµε µε 9 για να
υπολογίσουµε τον µέσο όρο).

ΜΟ_ΘΕΡΜ  ΣΥΝ_ΘΕΡΜ/ 9
ΓΡΑΨΕ "Μέση θερµοκρασία : ", ΜΟ_ΘΕΡΜ, " βαθµούς Κελσίου."
ΓΡΑΨΕ "Θερµότεροι πλανήτες από µέση θερµοκρασία :"
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
ΑΝ ΘΕΡΜ[Ι] > ΜΟ_ΘΕΡΜ ΤΟΤΕ
ΓΡΑΨΕ ΠΛΑΝΗΤΗΣ[Ι]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Εµφανίζουµε τα ονόµατα των
πλανητών µε θερµοκρασία µεγαλύτερη
από την µέση θερµοκρασία.
Παρατηρείστε ότι πρέπει πρώτα να
υπολογίσουµε την µέση θερµοκρασία.

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πλανήτες

ΕΚΤΕΛΕΣΗ ΚΩ∆ΙΚΑ
Ποια είναι η µέση θερµοκρασία του πλανήτη ΕΡΜΗΣ; 167
Ποια είναι η διάµετρος του πλανήτη ΕΡΜΗΣ; 4879

Ποια είναι η µέση θερµοκρασία του πλανήτη ΠΛΟΥΤΩΝΑΣ; -225
Ποια είναι η διάµετρος του πλανήτη ΠΛΟΥΤΩΝΑΣ; 2390
Μεγαλύτερος είναι ο πλανήτης ∆ΙΑΣ
Θερµότερος είναι ο πλανήτης ΑΦΡΟ∆ΙΤΗ
Μέση θερµοκρασία : -32.11 βαθµούς Κελσίου.
Θερµότεροι πλανήτες από µέση θερµοκρασία:
ΕΡΜΗΣ
ΑΦΡΟ∆ΙΤΗ
ΓΗ

Σαρηµπαλίδης Ιωάννης

Σελίδα 3