You are on page 1of 2

Algoritmo nueve

definir n,l como real


Escribir "introducir el dni"
Leer n
Si n<10000000 o n>99999999 Entonces
Escribir "error"
Sino
l = n MOD 23
Segun l Hacer
0:
Escribir "la letra es:,T "
1:
Escribir "la letra es:,R "
2:
Escribir "la letra es:,W "
3:
Escribir "la letra es:,A "
4:
Escribir "la letra es:,G "
5:
Escribir "la letra es:,M "
6:
Escribir "la letra es:,Y "
7:
Escribir "la letra es:,F "
8:
Escribir "la letra es:,F "
9:
Escribir "la letra es:,D "
10:
Escribir "la letra es:,X "
11:
Escribir "la letra es:,B "
12:
Escribir "la letra es:,N "
13:
Escribir "la letra es:,J "
14:
Escribir "la letra es:,Z "
15:
Escribir "la letra es:,S "
16:
Escribir "la letra es:,Q "
17:
Escribir "la letra es:,V "
18:
Escribir "la letra es:,H "
19:
Escribir "la letra es:,L "
20:
Escribir "la letra es:,C "
21:
Escribir "la letra es:,K "
22:
Escribir "la letra es:,E "
FinSegun
FinSi
FinAlgoritmo
ExPLICACIN:
1. Se definen las variables "n" y "l" como numeros enteros. La letra "n" ser el
numero del DNI que ha de introducirse y "l" el resto de la divisin de "n"
entre el numero 23 ya que as se calcula la letra del DNI.
2. Poner en nuestra pantalla "introducir el DNI" e indicar que este nmero ser
la letra "n" (n del DNI).
3. Prximamente hay que decir que la variable "n" ha de ser una cifra de ocho
dgitos como mximo. Por lo tanto, decimos que "n" debe de ser mayor que 1000000
0
y menos que 999999999. Si el nmero no cumple estas condiciones el algoritmo
finalizr poniendo en la pantalla ERROR.
4. Suponiendo que la condicin s se cumple, definimos la segunda variable "l" que
ser el resto de la divisin de "n" entre 23. l=n MOD 23.
5. Para conclur, segn el valor que tenga "l" se le asignar una letra que es la
que aparecer en pantalla como resultado final.