You are on page 1of 79

Interconnexion de Rseaux

Grande chelle

Optimisation des Routes

L. Steffenel 2008 1
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 2
Optimisation des Routes

L'objectif est de contrler


le moment o les routeurs changent les mises jour
les routes qui seront incluses dans ces mises jour
Nous pouvons aussi contrler le sens des flux de donnes
Outils disponibles :
contrle des mises jour
politiques de routage
redistribution de routes

L. Steffenel 2008 3
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 4
Interfaces Passives

La commande passive-interface a des rsultats diffrents selon le


protocole de routage utilis :
RIP/IGRP:
l'interface reoit les MAJ mais ne les envoie pas
OSPF:
les informations de routage ne sont ni reues ni envoyes par
l'interface
le rseau de l'interface passive est indiqu comme un rseau
stubbed
EIGRP:
Le routeur n'envoit pas des hello travers les interfaces
passives
Comme rsultat, EIGRP ne peut pas former un voisinage
travers cette interface, ni envoyer/recevoir des mises jour
L. Steffenel 2008 5
Interfaces Passives

RTA(config)#router rip
RTA(config-router)#network 10.0.0.0
Updates RIP

Par dfaut :
les updates RIP sont envoyes sur toutes les interfaces
appartenant au rseau 10.0.0.0
Tout sous-rseau directement connect et appartenant au
rseau 10.0.0.0 sera inclus dans les MAJ RIP, aussi que toute
route apprise dynamiquement
L. Steffenel 2008 6
Interfaces Passives

RTA(config)#router rip
RTA(config-router)#network 10.0.0.0

Inclut les sous-


10.1.1.0 /24 rseaux 10.0.0.0 dans
10.3.3.0 /24 les updates
10.4.4.0 /24
10.2.2.0 /24 10.1.1.0 /24 10.1.1.0 /24
10.3.3.0 /24 10.2.2.0 /24 10.2.2.0 /24
10.4.4.0 /24 10.3.4.0 /24 10.4.4.0 /24

L. Steffenel 2008 7
Interfaces Passives

RTA(config)#router rip
RTA(config-router)#network 10.0.0.0

Ce comportement n'est pas optimis :


L'interface E0 n'a pas besoin des updates RIP
les updates RIP obligent de garder la liaison ISDN active

L. Steffenel 2008 8
Interfaces Passives

RTA(config)#router rip Les interfaces passives


RTA(config-router)#network 10.0.0.0 reoivent les MAJ mais
RTA(config-router)#passive-interface e0
ne les transmettent pas
RTA(config-router)#passive-interface bri0

Passive interface

passive-interface [default] {interface-type number}


Le mot cl default change toutes les interfaces en passive par dfaut
L. Steffenel 2008 9
Interfaces Passives et le protocole RIP

Les interfaces passives


reoivent les MAJ mais ne
les retransmettent pas

L. Steffenel 2008 10
Interfaces Passives et OSPF/EIGRP

Le rseau de l'interface passive


apparat comme un rseau stun
dans le domaine OSPF
- attention au masque dans la
commande network

Un routeur EIGRP ne peut pas


tablir un lien de voisinage ni
envoyer/recevoir des updates

L. Steffenel 2008 11
Interfaces Passives et les DDR

Les interfaces passives peuvent tre


utilises pour les WANs afin de ne pas
envoyer des updates aux partenaires
Si la connexion est un ISDN (rseau
commut) l'envoi rgulire de updates
RIP oblige la ligne rester active

L. Steffenel 2008 12
Interfaces Passives

Cet exemple met toutes les interfaces en


mode passif et aprs active l'interface E0

RTA
router rip
passive-interface default
no passive-interface ethernet0
network 10.0.0.0

L. Steffenel 2008 13
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 14
Filtrage de Routes

Configurer une interface passive empche totalement l'envoi de


MAJ, mais parfois on a besoin de supprimer seulement certaines
routes
La commande distribute-list permet le choix des routes qui seront
annonces
La commande distribute-list fait rfrence une access-list, qui
dfinit un filtre de routage
Filtre de routage ensemble de rgles pour contrler les
routes qui seront envoyes dans un update
L. Steffenel 2008 15
Filtrage de Routes

Le filtrage de routes peut tre associ des politiques


dtermines par des facteurs extrieurs, tels que :
le cot des liens
la juridiction administrative
raisons de scurit
diminution de la surcharge - empche les access routers de
recevoir la totalit des tables de routage des core routers

L. Steffenel 2008 16
Filtrage de Routes Routes Entrantes et Sortantes

Exemple de filtrage sortant

L. Steffenel 2008 17
Filtrage de Routes - Entre

Filtrage l'entre des interfaces


Pour configurer le filtrage l'entre d'une interface, utiliser la
commande suivante :

Router(config-router)#distribute-list access-list-number in
[interface-name]

Note : Ceci n'empche pas/autorise l'entre de paquets sur le routeur,


seulement indique les routes qui seront reues/envoyes lors des
updates
L. Steffenel 2008 18
Filtrage de Routes - Entre

s0

S'applique toutes les interface, s0 incluse e0

RTZ

L. Steffenel 2008 19
Filtrage de Routes Interface d'Entre

s0

S'applique uniquement sur s0 e0


RTZ(config)#router rip
RTZ(config-router)#network 10.0.0.0
RTZ(config-router)#distribute-list 16 in s0
RTZ(config)#access-list 16 deny 10.1.1.0 0.0.0.255
RTZ(config)#access-list 16 permit any

L. Steffenel 2008 20
Filtrage de Routes - Sortie

Interfaces de sortie :
Lorsqu'il s'agit des updates sortants, la syntaxe peut
tre plus complexe :

Router(config-router)#distribute-list access-list-number out


[interface-name | routing-process | as-number]

L. Steffenel 2008 21
Filtrage de Routes Sortie Globale

S'applique toutes les interfaces

L. Steffenel 2008 22
Filtrage de Routes Interfaces de Sortie

S'applique uniquement S2

RTA(config)#router rip
RTA(config-router)#network 10.0.0.0
RTA(config-router)#distribute-list 24 out s2
RTA(config)#access-list 24 deny 10.1.1.0 0.0.0.255
RTA(config)#access-list 24 permit any

L. Steffenel 2008 23
Filtrage de Routes

Pour chaque interface et processus de routage, L'IOS Cisco


permet :
une distribute-list d'entre globale
une distribute-list de sortie globale
une distribute-list d'entre par interface
une distribute-list de sortie par interface
RTZ(config)#router rip
RTZ(config-router)#distribute-list 1 in
RTZ(config-router)#distribute-list 2 out
RTZ(config-router)#distribute-list 3 in e0
RTZ(config-router)#distribute-list 4 out e0

L. Steffenel 2008 24
Filtrage de Routes - Vrification

RTZ(config)#router rip
RTZ(config-router)#distribute-list 1 in
RTZ(config-router)#distribute-list 2 out
RTZ(config-router)#distribute-list 3 in e0
RTZ(config-router)#distribute-list 4 out e0

RTZ#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 25 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is 2
Ethernet0 filtered by 4
Incoming update filter list for all interfaces is 1
Ethernet0 filtered by 3

L. Steffenel 2008 25
Filtrage des Routes et les protocoles d'tat des Liens

Les protocoles d'tat des Liens dterminent leurs tables de


routage partir des informations sur les tats des liens, et non
partir des notifications des voisins
Le filtrage de routes a un effet diffrent pour les
notifications et la base de donnes des tats des liens
une rgle de base d'un protocole de routage tat des liens est
que tous les routeurs d'une zone doivent avoir une base de
donnes des tats des liens identique

L. Steffenel 2008 26
Filtrage des Routes et les protocoles d'tat des Liens

Les routes OSPF ne peuvent pas tre filtres (empches)


La commande distribute-list in
empche que des routes entrent dans la table de routage,
n'empche pas les paquets link-state d'tre propags
La commande distribute-list out ne fonctionne que sur les routes
distribues la frontire des systmes autonomes (routeurs
ASBRs)
Le filtrage peut s'appliquer des routes extrieurs de type1 ou 2,
mais pas des routes internes ou inter-zone.

L. Steffenel 2008 27
Interfaces Passives EIGRP

Une interface passive ne peut pas envoyer des EIGRP hellos, ce


qui empche la cration d'un voisinage
Un administrateur peut crer une pseudo interface passive EIGRP
avec un filtre de routage qui supprime toutes les routes des update

RTA(config)#router eigrp 364


RTA(config-router)#network 10.0.0.0
RTA(config-router)#distribute-list 5 out s0
RTA(config-router)#exit
RTA(config)#access-list 5 deny any

L. Steffenel 2008 28
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 29
Politiques de Routage

Routes statiques : La commande ip route peut indiquer le


chemin utiliser pour le routage, selon une adresse de destination
Avec des politiques de routage, nous pouvons programmer
manuellement le choix d'une route selon la destination et la source

Certains facteurs obligent les administrateurs definir des


politiques, ou rgles qu'un routeur doit suivre telles que :
le cot ($$$)
rpartition des tches entre les administrateurs
problmes de scurit
Si les routeurs sont laisss avec les configurations standards,
certains choix de routage peuvent entrer en conflit avec ces
politiques
Les politiques de routage ne sont rien de plus que des
routes statiques sophistiques

L. Steffenel 2008 30
Politiques de
Routage

ISP2

Les politiques de routage sont utilises pour :


Remplacer des dcisions issues du routage dynamique
Avoir un contrle prcis de la gestion du trafic des routeurs
Les politiques de routage peuvent tre utilises en interne d'un AS,
mais typiquement sont utilises pour contrler le routage entre
ASs
Extensivent utilises pour les protocoles extrieurs comme BGP

L. Steffenel 2008 31
Politiques de
Routage

Routing Table

Routing Policy
ISP2

La commande route-map est utilise pour configurer une politique


de routage, ce qui est souvent une tche complexe

Les politiques de routage sont des techniques pour que


l'administrateur puisse indiquer au routeur de transmettre
des paquets selon une rgle configure au lieu d'utiliser
l'adresse de destination et la table de routage. Alex Zinin
L. Steffenel 2008 32
Politiques de
Routage

Routing Table

Routing Policy
ISP2

Un route map est dfini avec la syntaxe suivante


Router(config)# route-map map-tag [permit | deny] [sequence-number]
Router(config-map-route)#

Par dfaut les routes sont acceptes (permit)


Deny est plus utilis pour la redistribution de routes (plus tard)
L'option sequence-number permet d'indiquer la position de la nouvelle
rgle dans la liste de rgles dj configures avec le mme nom
Si on ne donne pas un numro, la premire rgle aura le numro 10
L. Steffenel 2008 33
Politiques de
Routage

Une fois entre la commande route-map, nous pouvons dfinir des


situations set et match dans le mode route-map
Chaque route-map a une liste de commandes match et set
associes
Les commandes match spcifient des match criteria les
conditions qui doivent tre valides pour effectuer une action
Les commandes set spcifient les set actions - les actions
effectuer
L. Steffenel 2008 34
Exemple de Politique de Routage

ISP2

L. Steffenel 2008 35
Exemple de Politique de Routage

ISP2

La politique que nous voulons implmenter est la suivante :


Le trafic Internet issu de 192.168.1.0/24 doit tre rout vers ISP1
Le trafic Internet issu de 172.16.1.0/24 doit tre rout vers ISP2

L. Steffenel 2008 36
Exemple de Politique de Routage

Access Lists
D'abord nous configurons deux
listes d'accs

ISP2

RTA(config)#access-list 1 permit 192.168.1.0 0.0.0.255


RTA(config)#access-list 2 permit 172.16.1.0 0.0.0.255

L. Steffenel 2008 37
Niveau Global : route-maps
Ensuite nous configurons deux
politiques de routage comme
suit
La politique ISP1
correspond la liste
d'accs 1, et le trafic est
dirig travers S0 en
direction de ISP1
La politique ISP2 correspond
ISP2 la liste d'accs 2, et le trafic
est dirig travers E1 en
direction de ISP2

RTA(config)#access-list 1 permit 192.168.1.0 0.0.0.255


RTA(config)#access-list 2 permit 172.16.1.0 0.0.0.255
RTA(config)#route-map ISP1 permit 10
RTA(config-route-map)#match ip address 1
RTA(config-route-map)#set interface s0
RTA(config)#route-map ISP2 permit 10
RTA(config-route-map)#match ip address 2
RTA(config-route-map)#set interface s1
L. Steffenel 2008 38
Politiques par interface
L'tape finale est d'appliquer les
politiques aux interfaces
appropries en utilisant la
commande

ip policy route-map map-tag

ISP2

RTA(config)#interface e0
RTA(config-if)#ip policy route-map ISP1
RTA(config)#interface e1
RTA(config-if)#ip policy route-map ISP2
RTA(config)#access-list 1 permit 192.168.1.0 0.0.0.255
RTA(config)#access-list 2 permit 172.16.1.0 0.0.0.255
RTA(config)#route-map ISP1 permit 10
RTA(config-route-map)#match ip address 1
RTA(config-route-map)#set interface s0
RTA(config)#route-map ISP2 permit 10
RTA(config-route-map)#match ip address 2
RTA(config-route-map)#set interface s1
L. Steffenel 2008 39
ISP2

Attention : Et la liaison entre 172.16.1.0 et 192.168.1.0 ?


Dans ce cas, la communication n'est pas possible
sauf peut-tre s'il y a une route pour ces rseaux connue par ISP1 et
ISP2, alors le trafic sera envoy de RTA ISP1/ISP2 et renvoy RTA
pour l'autre LAN
Solution ? Faire une extension des listes d'accs et rajouter une
politique de routage (prioritaire) pour permettre le trafic entre les
deux LANs
L. Steffenel 2008 40
Exemple de Politiques de Routage

RTA(config)#interface e0
RTA(config-if)#ip policy route-map ToNet172
RTA(config-if)#ip policy route-map ISP1
RTA(config)#interface e1
RTA(config-if)#ip policy route-map ToNet192
RTA(config-if)#ip policy route-map ISP2
RTA(config)#access-list 101 permit 192.168.1.0 0.0.0.255
172.16.1.0 0.0.0.255
RTA(config)#access-list 102 permit 172.16.1.0 0.0.0.255
192.168.1.0 0.0.0.255
RTA(config)#route-map ToNet172 permit 10
RTA(config-route-map)#match ip address 101
RTA(config-route-map)#set interface e1
RTA(config)#route-map ToNet192 permit 10
RTA(config-route-map)#match ip address 102
RTA(config-route-map)#set interface e0

L. Steffenel 2008 41
Rsum

Politiques de routage ne sont rien de plus que des


routes statiques sophistiques
Routes statiques transfrent les paquets selon
l'adresse destination

Politiques de routage transfrent les paquets aussi selon


la source du paquet
Les politiques de routage peuvent tre lies des access lists
tendues pour faire du routage aussi selon le type de protocole
et le numro des ports
Comme dans une route statique, les politiques de routage
n'influencient que le routeur sur lequel elles sont configures

L. Steffenel 2008 42
Exemples d'options de Match

Router(config-route-map)#match length min max


Vrifier la longueur du paquet (couche 3)

Router(config-route-map)# match ip address {access-list-


number | name} [...access-list-number | name]
Vrifie que les adresses source et destinations sont accepts
par une ou plusieurs listes d'accs

Si la commande match n'est pas spcifie, les


politiques s'appliquent sur tous les paquets

L. Steffenel 2008 43
Option Set

Router(config-route-map)#set ip next-hop ip-address [... ip-


address]
Dfinit le prochain saut du paquet (doit tre un routeur adjacent)
Router(config-route-map)#set interface interface-type interface-
number [... type number]
Dfinit l'interface de sortie pour le paquet
Router(config-route-map)#set ip default next-hop ip-address
[...ip-address]
Dfinit le prochain saut s'il n'y a pas une route spcifique
Router(config-route-map)#set default interface interface-type
interface-number [... type ...number]
Dfinit l'interface de sortie par dfaut, s'il n'y a pas une route
pour ce paquet

L. Steffenel 2008 44
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 45
Redistribution de
Routes

Les routeurs Cisco supportent jusqu' 30 processus de routage


dynamique
un routeur peut tourner RIP, OSPF, IGRP, IS-IS, EIGRP, IPX RIP, RTMP
(AppleTalk) et autres protocoles simultanment
La plupart de ces protocoles permet l'excution de plusieurs
processus du mme protocole (RIP est une exception)
Multiples processus OSPF
router ospf 10
router ospf 15
L. Steffenel 2008 46
Multiples Processus de Routage

RTA#show running-config

router ospf 24
network 10.2.0.0 0.0.255.255 area 0
!
router ospf 46
Dconseill !
network 192.168.2.0 0.0.0.255 area 2
!
router eigrp 53
network 172.16.0.0
network 172.17.0.0
! Dconseill !
router eigrp 141
network 10.0.0.0
network 192.168.3.0

L. Steffenel 2008 47
Redistribution de
Routes

Redistribution de Routes C'est le principe d'change


d'informations entre deux protocoles diffrents
Pour grer efficacement plusieurs protocoles de routage dans le
mme rseau, l'information de routage doit tre partage entre les
protocoles
Par exemple, des routes apprises par un processus RIP peuvent
tre importes par un processus EIGRP

L. Steffenel 2008 48
Redistribution de
Routes

Redistribution One-way un protocole reoit les routes d'un


autre
Redistribution Two-way les protocoles changent des routes
Routeurs frontaliers :
Routeurs qui effectuent la redistribution des routes
Ctoient deux ou plus ASs
L. Steffenel 2008 49
Redistribution de
Routes

Pourquoi faire de la redistribution ?


Utiliser EIGRP dans un environnement mixte (non seulement Cisco)
Garder la compatibilit avec des machines UNIX qui supportent RIP,
et au mme temps utiliser des protocoles plus scalables ailleurs
Permettre le passage graduel entre un protocole ancien et un
nouveau protocole (ou pendant des tests)
L. Steffenel 2008 50
Recommandation

Uniquement les routers frontaliers doivent tourner plus


d'une instance d'un mme protocole, et cela uniquement si
ncessaire
Chaque processus de routage requiert des quantits
importantes de mmoire et CPU
Un routeur qui utilise plusieurs protocoles peut apprendre le
mme rseau partir de diffrents sources d'information
La Distance Admnistrative du IOS Cisco permet de choisir
parmi diffrentes sources d'information
Si deux routes ont les mme adresses rseau et masques,
l'IOS toujours choisit la route dont le protocole de routage a la
plus petite distance administrative

L. Steffenel 2008 51
Distance Administrative

L. Steffenel 2008 52
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 53
Distance Administrative

La distance administrative indique le niveau de confiance


sur une source d'informations
0 255
distance administrative petite = plus grande confiance
AD = 0 est rserve pour les interfaces directement connectes,
et sera toujours prfre
AD = 255 la source de l'information ne peut pas tre garantie,
alors toute information sera ignore
L. Steffenel 2008 54
Distance Administrative

Principe :
il est difficile de comparer des pommes et des oranges, mais on
peut forcer le routeur choisir d'abord les oranges

L. Steffenel 2008 55
Distance Administrative

IGRP (100)
est favoris

OSPF a
l'avantage

Si un routeur tourne IGRP et OSPF, il peut recevoir des routes


des deux protocoles
Les distances administratives par dfaut favorisent IGRP
On peut modifier la Distance Administrative pour favoriser OSPF

L. Steffenel 2008 56
Distance Administrative

Router(config-router)#distance weight [source-ip-address source-


mask (access-list-number | name)]

RTZ(config)#router rip
RTZ(config-router)#distance 105 10.4.0.2 255.255.255.0

Dfinit une distance administrative = 105 pour toutes routes RIP reues partir de
10.4.0.2

La commande distance peut aussi indiquer la slection des routes


selon leurs origine
Utiliser la commande distance uniquement lorsque c'est ncessaire
pour tablir une route optimise

L. Steffenel 2008 57
Distance Administrative

RTZ(config)#router rip
RTZ(config-router)#distance 97 10.3.0.1 255.255.255.0 2
RTZ(config-router)#exit
Source

RTZ(config)#access-list 2 permit 192.168.3.0 0.0.0.255

La route aura une distance


administrative = 97

On peut configurer un routeur pour appliquer une distance


administrative = 97 des routes RIP spcifiques
192.168.3.0, reue de 10.3.0.1.

L. Steffenel 2008 58
Distance Administrative

RTZ(config)#router rip S'applique toutes les routes de 10.4.0.2


RTZ(config-router)#distance 105 10.4.0.2 255.255.255.0
RTZ(config-router)#distance 97 10.3.0.1 255.255.255.0 2
RTZ(config)#access-list 2 permit 192.168.3.0 0.0.0.255
s'applique uniquement sur la route 192.168.3.0/24 de 10.3.0.1
RTZ#show ip route
R 192.168.5.0/24 [105/1] via 10.4.0.2, 00:00:02, Serial1
10.0.0.0/16 is subnetted, 5 subnets
R 10.2.0.0 [120/1] via 10.3.0.1, 00:00:02, Serial0
C 10.3.0.0 is directly connected, Serial0
R 10.1.0.0 [120/2] via 10.3.0.1, 00:00:02, Serial0
C 10.4.0.0 is directly connected, Serial1
R 192.168.1.0/24 [120/3] via 10.3.0.1, 00:00:02, Serial0
R 192.168.2.0/24 [120/2] via 10.3.0.1, 00:00:02, Serial0
R 192.168.3.0/24 [97/1] via 10.3.0.1, 00:00:02, Serial0

L. Steffenel 2008 59
Optimisation des Routes

Interfaces Passives
Filtrage des Routes
Listes de Distribution
Politiques de Routage
Plans de Routage
Redistribution de Routes
Plusieurs Protocoles de Routage
Modifier les Distances Administratives
Redistribuer les Routes
Mtriques par Dfaut

L. Steffenel 2008 60
Redistribution de Routes

EIGRP Routes

La commande redistribution
disponible sur tous les protocoles de routage IP
La complexit de la syntaxe dpend du protocole de routage et
des options

L. Steffenel 2008 61
Configuration
Mon meilleur
chemin vers
192.100.10.0 est
par ici Mon meilleur
chemin vers
192.100.10.0 est
par ici

La redistribution peut devenir complexe et prsenter des problmes,


comme suit :
Boucles de Routage Selon les mthodes de redistribution, des
routes peuvent tre apprises par d'autres interfaces
Information de routage incompatible
Chaque protocole utilise des mtriques diffrentes
La traduction des mtrique ne se fait pas de manire exacte
La slection des routes peut tre sous-optimale
Temps de convergence diffrents
La vitesse de convergence diffre entre les protocoles
Peut occasionner la perte temporaire de certains rseaux

L. Steffenel 2008 62
Configuration
Ces problmes potentiellement dangereux ncessitent
toute attention
Il faut tre familiaris avec le rseau
Ne pas superposer des protocoles de routage
il faut garder chaque rseau le plus simple possible
Utiliser des changes one-way si on a plusieurs routeurs
frontaliers
a limite les boucles de routage et les problmes de
convergence
Utiliser des routes dfaut dans les rseaux qui n'apprennent
pas des routes extrieures
Utiliser des changes two-way avec un seul ASBR
Minimise la probabilit de boucles
Une combinaison de routes dfaut, filtrage de routes et
modification de distances administratives peut aussi aider
L. Steffenel 2008 63
La commande Redistribute

Router(config-router)# redistribute protocol [process-id] {level-1 | level-


1-2 | level-2} [metric metric-value] [metric-type type-value] [match
{internal | external 1 | external 2}] [tag tag-value] [route-map map-
tag] [weight weight] [subnets]

Le mot cl static [ip] est utilis pour redistribuer les routes IP statiques.
L'option connected indique les routes tablies lorsqu'une interface est
active
(Optionnel) metric utilise pour annoncer les routes
si aucune valeur est spcifie et aucune valeur a t dfinie avec
default-metric, la valeur dfaut de la mtrique est 0
Exception : OSPF par dfaut est 20
(Optionnel) metric-type, pour OSPF, indique le type associ avec la route
extrieur apprise par une domaine OSPF
1 - route externe Type 1
2 - route externe Type 2

L. Steffenel 2008 64
Distribution One Way

RTB(config)# router rip


RTB(config-router)# net 172.16.0.0
RTB(config)# router eigrp 24
RTB(config-router)# net 172.24.0.0
RTB(config-router)# redistribute rip metric 10000 100 255 1 1500

L'option Metric transforme la mtrique RIP dans les mtriques dbit,


latence, fiabilit et charge utilises par EIGRP
MTU doit tre inclus mais n'est pas utilis
La distribution one way est plus courante avec les protocoles IGP qui
redistribuent des routes compltes ou partielles de BGP

L. Steffenel 2008 65
Distribution Two way

EIGRP Routes

RTB(config)# router rip


RTB(config-router)# net 172.16.0.0
RTB(config-router)# redistribute eigrp 24 metric 2
RTB(config)# router eigrp 24
RTB(config-router)# net 172.24.0.0
RTB(config-router)# redistribute rip metric 10000 100 255 1 1500

La syntaxe et les mtriques dpendent du protocole utilis


Pour RIP, OSPF, IS-IS et BGP, la mtrique n'a qu'une valeur
Pour EIGRP, la mtrique contient cinq valeurs
dbit, latence, fiabilit, charge et MTU
L. Steffenel 2008 66
Distribution Two way

EIGRP Routes

RTB(config)# router rip


RTB(config-router)# net 172.16.0.0
RTB(config-router)# redistribute eigrp 24 metric 2
RTB(config)# router eigrp 24
RTB(config-router)# net 172.24.0.0
RTB(config-router)# redistribute rip metric 10000 100 255 1 1500

Aprs configure la redistribution two-way, RTC et RTA ont seulement 11


routes, alors que le routeur frontalier (RTB) a 12
Quel est le problme ?
Les routes directement connects RTB ne sont pas annonces
172.16.0.0/16 (absent de la table RTA)
172.24.0.0/16 (absent de la table RTC)

L. Steffenel 2008 67
Distribution Two way

EIGRP Routes

RTB(config)# router rip


RTB(config-router)# net 172.16.0.0
RTB(config-router)# redistribute eigrp 24 metric 2
RTB(config-router)# redistribute connected metric 2
RTB(config)# router eigrp 24
RTB(config-router)# net 172.24.0.0
RTB(config-router)# redistribute rip metric 10000 100 255 1 1500
RTB(config-router)# redistribute connected metric 10000 100 255 1 1500

redistribute connected -Les routes directement connectes seront


distribues
L. Steffenel 2008 68
Distribution Two way

EIGRP Routes

RTB(config)# router rip


RTB(config-router)# net 172.16.0.0
RTB(config-router)# redistribute eigrp 24 metric 2
RTB(config-router)# redistribute connected metric 2
RTB(config)# router eigrp 24
RTB(config-router)# net 172.24.0.0
RTB(config-router)# redistribute rip metric 10000 100 255 1 1500
RTB(config-router)# redistribute connected metric 10000 100 255 1 1500
RTB(config-router)# redistribute static metric 10000 100 255 1 1500

Comment redistribuer les routes statiques

RTB(config)#router eigrp 24
RTB(config-router)#redistribute static metric 10000 100 255 1 1500

L. Steffenel 2008 69
Redistribution d'un protocole Classless vers uns
protocole Classful

OSPF IGRP
RIPv1
172.2 172.20.0.0/16
0 .113.
192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24
28
114.48/
172.2
0 . Marge Homer Lisa
172.20.112.0
172.20.115.0
Only the OSPF-learned routes with the 24-bit
mask are successfully redistributed into the
IGRP domain, which is also using a 24-bit mask.
RIPv1

L. Steffenel 2008 70
Redistribution d'un protocole Classless vers uns
protocole Classful
Il faut redoubler l'attention lorsqu'on redistribue des routes
classless dans un domaine classful
Un protocole classful n'envoie pas les masques avec les routes
annonces
chaque route reue par un protocole classful, l'une des deux
situations s'applique :
Le routeur a une ou plusieurs interfaces connectes au mme
rseau dfaut (classful)
le routeur utilise son propre masque pour dterminer le sous-
rseau de destination d'un paquet
Le routeur n'a pas d'interfaces connectes au rseau dfaut
(classful)
Uniquement le rseau dfaut peut tre inclus dans l'annonce car
le routeur n'a pas les moyens pour dterminer le masque
utiliser

L. Steffenel 2008 71
Redistribution d'un protocole Classless vers uns
protocole Classful

OSPF IGRP
RIPv1
172.2 172.20.0.0/16
0.113
. 192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24

8/28
.2 0. 114.4 Marge Homer Lisa
172
172.20.112.0
172.20.115.0
Only the OSPF-learned routes with the 24-bit
mask are successfully redistributed into the
IGRP domain, which is also using a 24-bit mask.
RIPv1

Tables de Routage
Homer : a des routes vers tous les rseaux
Marge : a des routes vers tous les rseaux
Lisa : connate uniquement les sous-rseaux RIP et les rseaux
dtermins par le masque dfaut 172.20.112.0 et 172.20.115.0.

L. Steffenel 2008 72
Configuration

La redistribution est configure en deux tapes :


1. Le protocole qui reoit les routes utilise la commande redistribute
2. Dfinir la mtrique attribuer aux routes. Deux mthodes :
utiliser le mot-cl metric (prioritaire)
utiliser la commande default-metric
L. Steffenel 2008 73
Les commandes Redistribute
connected et default-metric

Attention : La commande redistribute connected n'est pas affecte


par la commande default-metric
possibilit de changer la mtrique avec
redistribute connected metric value
RTB(config-router)# redistribute connected metric 10000 100 255 1 1500

L. Steffenel 2008 74
Configuration

OSPF IGRP
EIGRP
172.2 172.20.0.0/16
0.113
. 192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24
28 E1 E0
0.11 4.48/
172.2
Marge Homer Lisa

Exemple (Homer) :
router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 1500
network 172.20.0.0

Cette configuration redistribue les routes apprises par OSPF 1 dans


EIGRP 1
L'option metric indique une valeur pour les routes
Ces valeurs sont appeles la seed metric
La seed metric est la valeur initiale pour une mtrique apprise
de l'extrieur
L. Steffenel 2008 75
Configuration
OSPF IGRP
EIGRP
172.2 172.20.0.0/16
0.113
. 192/2
6
172.20.115.0/24 172.20.112.0/24 172.20.111.0/24 172.20.110.0/24
28 E1 E0
0.11 4.48/
172.2
Marge Homer Lisa

Exemple (Homer):
router ospf 1
redistribute eigrp 1 metric 30 metric-type 1 subnets
network 172.20.112.2 0.0.0.0 area 0
Cette configuration redistribue les routes apprises par EIGRP 1 dans
OSPF 1
L'option metric attribue un cot OSPF 30 chacune des routes
la mtrique dfault est 0, sauf pour OSPF o elle vaut 20
Cette redistribution fait d'Homer un ASBR
L'option metric-type 1 indique que les routes seront annonces comme
E1 routes, et leur cot interne sera rajout (le dfaut est E2)
l'option subnets redistribue les dtails des sous-rseaux. Sans cette option,
seulement les routes classful seraient distribues
L. Steffenel 2008 76
Redistribution et l'Agrgation de Routes

EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1
68.3. /2 7
6 4/27
192.168.4.4/30 . 160
OSPF 1 S1 S0 EIGRP 1 .168
. 3
192
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
0 /24 168.
68.1. Marge Homer Lisa 2.0/2
192.1 4
192.168.3.0/25
192.168.3.128/25

EIGRP, OSPF et IS-IS peuvent faire l'agrgation de routes


L'agrgation est plus utile si le rseau a t bien conu
dans l'exemple, les sous-rseaux 192.168.3.x dans le domaine OSPF sont
tous couverts par l'adresse agrge 192.168.3.0/25.
192.168.3.0/25
Les sous-rseaux de EIGRP 1, sont aussi couverts par l'adresse agrge
192.168.3.128/25.
192.168.3.128/25
Si le sous-rseau 192.168.3.0/27 tait connect Lisa, il devrait tre
annonc sparment.
L. Steffenel 2008 77
Redistribution et l'Agrgation de Routes
EIGRP 2 EIGRP 2
172.16.1.0/24 192.168.4.72/29

Smithers 172.16.2.20/30 Burns


192.1 7
68.3.
6 4/27
192.168.4.4/30 . 1 60/2
OSPF 1 S1 S0 EIGRP 1 68.
.1
3
192
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
E1 E0 192.
/24 168.
2. 1 68.1.0 Marge Homer Lisa 2.0/2
19 4
192.168.3.128/25 172.16.0.0/16

La commande summary-address indique une adresse agrge et un


masque OSPF 1
Cette commande ne marche que sur les ASBRs l'agrgation au niveau des
ABRs est faite par la commande area range
router ospf 1
summary-address 192.168.3.128 255.255.255.128
summary-address 172.16.0.0 255.255.0.0
redistribute eigrp 1 metric 50 subnets
redistribute eigrp 2 metric 100 subnets
network 192.168.3.33 0.0.0.0 area 0
L. Steffenel 2008 78
Redistribution et l'Agrgation de Routes
EIGRP 2 192.168.3.0/24 EIGRP 2
172.16.1.0/24 192.168.4.72/29
192.168.0.0/16
Smithers 172.16.2.20/30 Burns
192.1
68.3. /2 7
6 4/27
192.168.4.4/30 . 160
OSPF 1 S1 S0 EIGRP 1 .168
. 3
192
192.168.3.96/27 192.168.3.32/27 192.168.3.128/27 192.168.3.192/27
4 E1 E0 192.
68. 1.0/2 168.
2.0/2
192.1 Marge Homer Lisa 4
192.168.3.0/25
172.16.0.0/24
192.168.4.0/24
L'agrgation avec EIGRP est faite sur chaque interface
interface ethernet 0
ip add 192.168.3.129 255.255.255.224
ip summary-address eigrp 1 192.168.3.0 255.255.255.128
ip summary-address eigrp 1 172.16.0.0 255.255.0.0
ip summary-address eigrp 1 192.168.4.0 255.255.255.0
interface serial 0
ip add 192.168.4.5 255.255.255.252
ip summary-address eigrp 2 192.168.3.0 255.255.255.0
interface serial 1
ip add 172.16.2.21 255.255.255.252
ip summary-address eigrp 2 192.168.0.0 255.255.0.0

L. Steffenel 2008 79