You are on page 1of 5

<a id="backtotop" name="backtotop"></a>Crear una referencia externa (vnculo) a un ...

Pgina 1 de 5

Excel > Frmulas > Crear frmulas

Crear una referencia externa (vnculo) a un rango de celdas de otro libro

Ocultar todo

Puede hacer referencia al contenido de las celdas de otro libro mediante una referencia externa. Una referencia
externa (tambin denominada vnculo) es una referencia a una celda o a un rango de celdas de una hoja de clculo
de otro libro de Excel, o una referencia a un nombre definido en otro libro. Puede hacer referencia a rangos de
celdas especficas, a un nombre especfico de los rangos de celdas, o bien definir un nombre para la referencia
externa.

Qu desea hacer?

Obtenga ms informacin sobre referencias externas

Crear una referencia externa entre celdas de libros distintos

Crear una referencia externa a un nombre definido en otro libro

Definir un nombre que contenga una referencia externa a las celdas de otro libro

Obtenga ms informacin sobre referencias externas

Aunque las referencias externas se parecen a las referencias de celdas, existen diferencias importantes. Las
referencias externas se usan al trabajar con cantidades grandes de datos o frmulas complejas que se encuentran
extendidas por varios libros. Se crean de modo distinto y aparecen de manera distinta en una celda o en la barra de
frmulas (barra de frmulas: barra de la parte superior de la ventana de Excel que se utiliza para escribir o editar
valores o frmulas en celdas o grficos. Muestra la frmula o el valor constante almacenado en la celda activa.).

DNDE PUEDEN UTILIZARSE EFICAZMENTE LAS REFERENCIAS EXTERNAS

Las referencias externas son especialmente tiles cuando no resulta prctico mantener juntos en el mismo libro los
modelos de hoja de clculo grandes.

Combinar datos de varios libros Puede vincular libros de varios usuarios o departamentos e integrar los
datos pertinentes en un libro de resumen. De este modo, al cambiar los libros de origen (archivo de origen:
el archivo que contiene informacin que se ha utilizado para crear un objeto vinculado o incrustado. Cuando
se actualiza la informacin en el archivo de origen, tambin es posible actualizar el objeto vinculado en el
archivo de destino.), no ser necesario cambiar manualmente el libro de resumen.

Crear distintas presentaciones de los datos Pueden insertarse todos los datos en uno o ms libros de
origen y, a continuacin, crear un libro de informe que slo contenga las referencias externas a los datos
pertinentes.

ms-help://MS.EXCEL.14.3082/EXCEL/content/HP10342364.htm 21/12/2014
<a id="backtotop" name="backtotop"></a>Crear una referencia externa (vnculo) a un ... Pgina 2 de 5

Simplificar modelos grandes y complejos Al dividir un modelo complicado en una serie de libros
interdependientes, podr trabajar en el modelo sin necesidad de abrir todas las hojas relacionadas con l.
Los libros de menor tamao son ms fciles de modificar, no necesitan mucha memoria y se pueden abrir,
guardar y calcular con ms rapidez.

MTODOS PARA CREAR REFERENCIAS EXTERNAS

Si utiliza una referencia de celda para crear una referencia externa, tambin puede aplicar frmulas a la informacin.
Al cambiar entre los distintos tipos de referencias de celda, puede controlar adems las celdas con las que se
establecen vnculos si mueve la referencia externa. Por ejemplo, si utiliza una referencia relativa, al mover la
referencia externa, la celda o celdas con las que se establece el vnculo cambian para reflejar su nueva posicin en
la hoja de clculo.

Cuando se crea una referencia externa de un libro a otro, debe utilizar un nombre para hacer referencia a las celdas
con las que se establece el vnculo. Puede crear una referencia externa utilizando un nombre que ya se haya
definido, o puede definir el nombre cuando cree la referencia externa. Este nombre permite recordar ms fcilmente
el contenido de las celdas con las que se establece el vnculo. Las referencias externas que utilizan nombres
definidos no cambian cuando se mueven, ya que un nombre hace referencia a una celda o rango de celdas
especfico. Si desea utilizar una referencia externa con un nombre definido que cambie al moverse, puede cambiar
el nombre que se utiliza en la referencia externa o puede cambiar las celdas a las que hace referencia el nombre.

ASPECTO DE UNA REFERENCIA EXTERNA A OTRO LIBRO

Las frmulas con referencias externas a otros libros se muestran de dos maneras, en funcin de si el libro de
origen, el que proporciona datos a la frmula, se encuentra abierto o cerrado en Excel.

Cuando el libro de origen est abierto en Excel, la referencia externa incluye el nombre del libro entre corchetes ([ ]),
seguido del nombre de la hoja de clculo, un signo de exclamacin (!) y las celdas de las que depende la frmula.
Por ejemplo, la siguiente frmula suma las celdas C10:C25 del libro Presupuesto.xls.

Referencia externa

=SUMA([Presupuesto.xlsx]Anual!C10:C25)

Si el libro de origen est cerrado en Excel, la referencia externa incluye toda la ruta de acceso.

Referencia externa

=SUMA('C:\Informes\[Presupuesto.xlsx]Anual'!C10:C25)

NOTA Si el nombre de la otra hoja de clculo o del otro libro contiene caracteres no alfabticos, se deber poner
el nombre (o la ruta de acceso) entre comillas sencillas (').

Las frmulas vinculadas con un nombre (nombre: palabra o cadena de caracteres que representa una celda, rango
de celdas, frmula o valor constante. Utilice nombres fciles de entender, como Productos, para referirse a rangos

ms-help://MS.EXCEL.14.3082/EXCEL/content/HP10342364.htm 21/12/2014
<a id="backtotop" name="backtotop"></a>Crear una referencia externa (vnculo) a un ... Pgina 3 de 5

difciles de entender, como Ventas!C20:C30.) definido en otro libro usan el nombre del libro seguido de un signo de
exclamacin (!) y el nombre. Por ejemplo, la siguiente frmula suma las celdas del rango Ventas del libro
Presupuesto.xlsx.

Referencia externa

=SUMA(Presupuesto.xlsx!Ventas)

VOLVER AL PRINCIPIO

Crear una referencia externa entre celdas de libros distintos

1. Abra el libro que contendr la referencia externa (el libro de destino (archivo de destino: archivo donde se
inserta un objeto vinculado o incrustado. El archivo de origen contiene la informacin que se utiliza para
crear el objeto. Cuando se cambia la informacin de un archivo de destino, no se actualiza en el archivo
de origen.)) y el libro que contiene los datos con los que desea establecer el vnculo (el libro de origen).

2. En el libro de origen, haga clic en Guardar en la barra de herramientas de acceso rpido.

3. Seleccione la celda o las celdas en las que desea crear la referencia externa.

4. Escriba = (signo de igual). Si desea ejecutar clculos o funciones en el valor de la referencia externa,
escriba el operador (operador: signo o smbolo que especifica el tipo de clculo que se debe llevar a
cabo en una expresin. Hay operadores matemticos, comparativos, lgicos y referenciales.) o la funcin
que debe preceder a la referencia externa.

5. Cambie al libro de origen y, a continuacin, haga clic en la hoja de clculo que contiene las celdas con
las que desea establecer el vnculo.

6. Seleccione la celda o las celdas con las que desee establecer el vnculo.

7. Vuelva al libro de destino y observe que Excel agrega la referencia al libro de origen y a las celdas que
seleccion en el paso anterior.

8. Tambin puede modificar o cambiar la frmula en la hoja de clculo de destino.

9. Presione CTRL+MAYS+ENTRAR.

VOLVER AL PRINCIPIO

Crear una referencia externa a un nombre definido en otro libro

1. Abra el libro que contendr la referencia externa (el libro de destino) y el libro que contiene los datos con
los que desea establecer el vnculo (el libro de origen).

2. En el libro de origen, haga clic en Guardar en la barra de herramientas de acceso rpido.

3. Seleccione la celda o las celdas en las que desea crear la referencia externa.

ms-help://MS.EXCEL.14.3082/EXCEL/content/HP10342364.htm 21/12/2014
<a id="backtotop" name="backtotop"></a>Crear una referencia externa (vnculo) a un ... Pgina 4 de 5

4. Escriba = (signo de igual). Si desea ejecutar clculos o funciones en el valor de la referencia externa,
escriba el operador o la funcin que debe preceder a la referencia externa.

5. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y despus
en la hoja de clculo que contiene las celdas con las que desea establecer el vnculo.

6. Presione F3 y, a continuacin, seleccione el nombre con el que desea establecer el vnculo.

VOLVER AL PRINCIPIO

Definir un nombre que contenga una referencia externa a las celdas de otro libro

1. Abra el libro de destino y el libro de origen.

2. En el libro de destino, en la ficha Frmulas, en el grupo Nombres definidos, haga clic en Definir
nombre.

3. En el cuadro de dilogo Nombre nuevo, en el cuadro Nombre, escriba un nombre para el rango.

4. Borre el contenido del cuadro Se refiere a y mantenga el cursor dentro del cuadro.

Si el nombre contiene una frmula, escrbala y, a continuacin, site el cursor en la posicin donde
desee colocar la referencia externa. Por ejemplo, escriba =SUMA() y site el cursor entre los parntesis.

5. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y despus
en la hoja de clculo que contiene las celdas con las que desea establecer el vnculo.

6. Seleccione la celda o el rango de celdas con las que desea establecer el vnculo.

7. En el cuadro de dilogo Nombre nuevo, haga clic en Aceptar.

ms-help://MS.EXCEL.14.3082/EXCEL/content/HP10342364.htm 21/12/2014
<a id="backtotop" name="backtotop"></a>Crear una referencia externa (vnculo) a un ... Pgina 5 de 5

VOLVER AL PRINCIPIO

ms-help://MS.EXCEL.14.3082/EXCEL/content/HP10342364.htm 21/12/2014