You are on page 1of 10

UNIVERSIDAD DE GUAYAQUIL

FACULTAD DE INGENIERA INDUSTRIAL

CARRERA
ING. EN TELEMTICA

MATERIA
PROGRAMACIN ESTRUCTURADA

CURSO
SEGUNDO SEMESTRE C

INTEGRANTES:
AVILS MERA VIVIANA MELINA
CEVALLOS AVILEZ IRMA ZULAY

DOCENTE
ING. GARCA TORRES INGRID ANGLICA

2017 2018
GUAYAQUIL ECUADOR
CONSTRUIR ALGORITMO, DIAGRAMA DE FLUJO Y
PSEUDOCDICO EN EL CUAL SE REALICE LO SIGUIENTE:
EJERCICIO #1. Ingresar el sueldo de un trabajador, aplicar
descuento del 18% si es menor a $400.00 y el 14% si asciende.
ALGORITMO
1. Ingresar sueldo.
2. Definir si es menor a $ 400.
V. Descontar el 18% si es menor.
F. Descontar el 14% si es mayor.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese su sueldo: ";
Leer sueldo;
Si sueldo<400 Entonces
sueldototal=(sueldo*18/100)+sueldo;
Escribir "Su nuevo sueldo es: ";
Escribir sueldototal;
Sino
sueldototal=(sueldo*14/100)+sueldo;
Escribir "Su nuevo sueldo es: ";
Escribir sueldototal;
FinSi
FinProceso

FLUJOGRAMA

EJERCICIO #2. En una gasolinera, los surtidores registran lo que


despachan; el precio est fijado en 55 centavos el litro. Calcule
el total a pagar por cliente.
ALGORITMO
1. Ingresar compra de cantidad de galones.
2. Convertir a litros.
3. Calcular el valor a pagar.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese la cantidad en galones: ";
Leer gl;
total=gl*4*0.55;
Escribir "El valor a pagar es: ";
Escribir total;
FinProceso

FLUJOGRAMA

EJERCICIO #3. Dada la distancia entre dos ciudades en


kilmetros y la velocidad de un vehculo en km/h. Calcular el
tiempo que se demora para llegar de una ciudad a otra en horas
y minutos?
ALGORITMO
1. Ingresar la distancia entre dos ciudades.
2. Ingresar la velocidad del automvil.
3. Calcular el tiempo que toma el traslado.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingresar distancia entre 2 ciudades: ";
Leer distancia;
Escribir "Ingrese en km/h la velocidad de su automvil: ";
Leer velocidad;
tiempo=distancia/velocidad;
Escribir "El tiempo que tardara en llegar en horas y minutos es: ";
Escribir tiempo;
FinProceso
FLUJOGRAMA

EJERCICIO #4. Dada la fecha actual (ao, mes y da) y la fecha


de nacimiento (ao, mes y da). Calcule su edad actual en aos,
meses y das.
ALGORITMO
1. Ingresar fecha actual (ao, mes y da).
2. Ingresar fecha de nacimiento (ao, mes y da).
3. Calcular la edad actual en aos, meses y das.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir Ingrese el ao actual: ;
Leer AO1;
Escribir Ingrese el mes actual: ;
Leer MES1;
Escribir Ingrese el da actual: ;
Leer DIA1;
Escribir Ingrese su ao de nacimiento: ;
Leer AO2;
Escribir Ingrese el mes de nacimiento: ;
Leer MES2;
Escribir Ingrese el da de su nacimiento: ;
Leer DIA2;
AOT<-(AO1-AO2);
Escribir Su edad en aos es: ;
Escribir AOT;
MEST<-MES1-MES2;
Escribir Su edad en meses es: ;
Escribir MEST;
DIAT<-DIA1-DIA2;
Escribir Su edad en das es: ;
Escribir DIAT;
FinProceso

FLUJOGRAMA
EJERCICIO #5. Dados tres nmeros enteros diferentes.
Determinar el nmero mayor.
ALGORITMO
1. Ingresar tres nmeros.
2. Determinar el nmero mayor.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese primer nmero: ";
Leer num1;
Escribir "Ingrese segundo nmero: ";
Leer num2;
Escribir "Ingrese tercer nmero: ";
Leer num3;
Si (num1>num2) & (num1>num3) Entonces
Escribir "El nmero mayor es: ";
Escribir num1;
Sino
Si (num2>num1) & (num2>num3) Entonces
Escribir "El nmero mayor es: ";
Escribir num2;
Sino
Escribir "El nmero mayor es: ";
Escribir num3;
FinSi
FinSi
FinProceso

FLUJOGRAMA
EJERCICIO #6. Indicar si el nmero ingresado es positivo o
negativo.
ALGORITMO
1. Ingresar un nmero.
2. Indicar si es positivo o negativo.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese un nmero: ";
Leer num;
Si num>0 Entonces
Escribir "Su nmero es positivo";
Sino
Escribir "Su nmero es negativo";
FinSi
FinProceso

FLUJOGRAMA

EJERCICIO #7. Dado el peso en libras, convierta a kilogramos.


ALGORITMO
1. Ingresar peso en libras.
2. Convertir peso a kilogramo.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese su peso en libras: ";
Leer pl;
peso=pl/2.2;
Escribir "Su peso en Kilogramos es: ";
Escribir peso;
FinProceso

FLUJOGRAMA
EJERCICO #8. Dado el nombre y la edad en aos. Calcular el
nmero de pulsaciones que debe tener por cada diez segundos
de ejercicio.
ALGORITMO
1. Ingresar nombre y edad.
2. Calcular el nmero de pulsaciones que deber tener por cada diez
segundos.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese su nombre: ";
Leer nombre;
Escribir "Ingrese su edad: ";
Leer edad;
nupulsaciones=(220-edad)/10;
Escribir "Su nmero de pulsaciones es: ";
Escribir nupulsaciones;
FinProceso

FLUJOGRAMA
EJERCICIO #9. Sumar dos nmeros.

ALGORITMO
1. Ingresar dos nmeros.
2. Realizar la sumatoria de ambos nmeros.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir "Ingrese valor uno: ";
Leer n1;
Escribir "Ingrese valor dos: ";
Leer n2;
s=n1+n2;
Escribir "La suma es: ";
Escribir s;
FinProceso

FLUJOGRAMA

EJERCICIO #10. Dados el nombre del producto, precio y


cantidad a comprar. Calcular subtotal, 14% I.V.A. y total a pagar.

ALGORITMO
1. Ingresar nombre, precio y cantidad del producto a comprar.
2. Calcular subtotal, I.V.A., y total a pagar.

PSEUDOCDIGO
Proceso SIN_TITULO
Escribir Ingrese el nombre del producto: ;
Leer PROD;
Escribir Ingrese el precio del producto: ;
Leer PRECIO;
Escribir Ingrese la cantidad del producto: ;
Leer CANT;
SUBTOTAL<-PRECIO*CANT;
IVA<-SUBTOTAL*14/100;
TOTAL<SUBTOTAL+IVA;
Escribir El subtotal es: $", SUBTOTAL;
Escribir El IVA es: $, iva;
Escribir Su total a pagar es: $, total;
FinProceso

FLUJOGRAMA