utilizando repeti��es: ENQUANTO...

FA�A

2)
algoritmo

declare contador inteiro

escreva("N�MEROS INTEIROS NO INTERVALO DE 1 A 50")

contador <- 0

enquanto (contador < 50) fa�a

escreva(contador)

contador <- contador + 1

fim_enquanto

fim_algoritmo

3)
algoritmo

declare contador, inf, sup inteiro

escreva("N�MEROS INTEIROS EM UM INTERVALO FORNECIDO PELO USU�RIO")

escreva("ENTRE COM O VALOR DO INTERVALO INFERIOR: ")
leia(inf)

escreva("ENTRE COMO VALOR DO INTEVALOR SUPERIOR: ")
leia(sup)

contador <- inf

enquanto (contador <= sup) fa�a

escreva(contador)

contador <- contador + 1

fim_enquanto

fim_algoritmo

4)
algoritmo

declare soma, contador, n inteiro

escreva("SOMA DOS NUMEROS INTEIROS DE 1 A N")

escreva("ENTRE COM O VALOR DE N: ")
leia(n)

contador <- 1

sal_atual * 1.sal_atual * 1.0 enquanto (contador <= n) fa�a soma <. tot_atual.soma <.TABAJARAS FC") repita escreva("DIGITE O NOME DO JOGADOR: ") leia(nome) escreva("DIGITE O VALOR DO SAL�RIO DESSE JOGADOR: ") leia(sal_atual) se (sal_atual <= 1000) ent�o sal_reaj <-.0 escreva("REAJUSTE SALARIAL .contador + 1 fim_enquanto escreva("O VALOR DA SOMA �: ".2 sen�o se (sal_atual <= 5000) ent�o sal_reaj <-.1 sen�o sal_reaj <-.05 fim_se fim_se . soma) fim_algoritmo 14) REPITA algoritmo declare nome caractere declare sal_atual.0 cont <-.sal_atual * 1.0 tot_reaj <-. percentual real declare cont inteiro tot_atual <-.contador + 1 contador <. tot_reaj. sal_reaj.

sal_atual * 1. nome) escreva("RECEBIA A QUANTIA DE: ".cont + 1 at� (cont > 22) escreva("O JOGADOR: ".tot_atual + sal_atual tot_reaj <-. tot_reaj. tot_reaj "AP�S OS REAJUSTES SALARIAIS") fim_algoritmo 14) PARA algoritmo declare nome caractere declare sal_atual.0 escreva("C�LCULO DO REAJUSTE SALARIAL DO TIME TABAJARAS FC") para vc de 0 at� 22 fa�a (passo +1) escreva("DIGITE O NOME DO JOGADOR: ") leia(nome) escreva("DIGITE O SALARIO DESTE JOGADOR") leia(sal_atual) se (sal_atual <= 1000) ent�o sal_reaj <-.sal_atual * 1. sal_reaj) escreva("A FOLHA SALARIAL DO TIME TABAJARAS FC ERA DE: ". percentual real declare vc inteiro tot_antes <-.0 vc <-.tot_reaj + sal_reaj cont <-. tot_antes.tot_atual <-. sal_reaj. sal_atual "E VAI PASSAR A RECECER O VALOR DE: ". tot_atual "E PASSOU A SER DE: ".0 tot_reaj <-.2 sen�o se (sal_atual <= 5000) ent�o sal_reaj <-.1 sen�o .

0 tot_reaj <-.tot_reaj + sal_reaj fim_para escreva("O JOGADOR ". sal_reaj <-.TABAJARAS FC") tot_atual <-. tot_reaj) fim_algoritmo 14) ENQUANTO algoritmo declare nome caractere declare sal_atual. tot_reaj. sal_atual "E AGORA VAI PASSAR A RECEBER A QUANTIA DE ". tot_antes "E AGORA SER� DE ".05 fim_se fim_se tot_antes <-.0 cont <-.sal_atual * 1. tot_atual. percentual real declare cont inteiro escreva("REAJUSTE SALARIAL . nome "RECEBIA O VALOR DE ".sal_atual * 1. sal_reaj) escreva("O TIME TABAJARAS FC POSSUIA UMA FOLHA SALARIAL DE ".sal_atual * 1.tot_antes + sal_atual tot_reaj <-.1 . sal_reaj.0 enquanto (cont < 22) fa�a escreva("DIGITE O NOME DO JOGADOR: ") leia(nome) escreva("DIGITE O SAL�RIO DO JOGADOR: ") leia(sal_atual) se (sal_atual <= 1000) ent�o sal_reaj <-.2 sen�o se (sal_atual <= 5000) ent�o sal_reaj <-.

tot_atual + sal_atual tot_reaj <-. sal_atual) escreva("VAI RECEBER: ". nome) escreva("RECEBE: ". tot_atual) escreva("A FOLHA SALARIAL SUBIU PARA: ".cont + 1 fim_enquanto escreva("O JOGADOR: ". sal_reaj) escreva("---------------------------------") escreva("O CLUBE TABAJARAS FC") escreva("POSSUIA UMA FOLHA SALARIAL DE: ".tot_reaj + sal_reaj cont <-.sen�o sal_reaj <-. tot_reaj) fim_algoritmo .sal_atual * 1.05 fim_se fim_se tot_atual <-.