You are on page 1of 5

Configurao de Switch Multi-Layer (Layer-3)

Ol Pessoal.

Nesse experimento o leitor aprender a configurar um Switch Multi-Layer (Layer-3) com algumas
das principais caractersticas que diferenciam esse equipamento dos switches convencionais. Os
switches multi-layer conseguem desempenhar tarefas de conectividade de redes locais que fazem
os tradicionais swiches, alm de serem capazes de realizar o roteamento de trfego inter-redes que
somente roteadores podem fazer.

Alm disso, o desempenho de um switch multi-layer "sempre" melhor do que o de qualquer


roteador tradicional porque esses switches multi-layer tm alto desempenho, realizando todas as
suas tarefas eletronicamente em hardware cuidadosamente projetado para esse fim.

No cenrio apresentado na figura acima possvel observar que existem quatro switches de acesso
conectando suas respectivas mquinas terminais e existem duas VLANs (10 e 20). Os switches de
acesso esto conectados a um Switch Multi-Layer que responsvel pela distribuio da
conectividade entre toda a rede, alm de realizar o roteamento inter-VLAN.

Uma caracterstica interessante desse cenrio que os endereos de todas as mquinas da sub-
rede 192.168.10.0/24 (associada VLAN-10) e 192.168.20.0/24 (associada VLAN-20) so
distribudos automaticamente via DHCP. Via de regra, como o servio de DHCP funciona atravs do
envio de broadcasts na rede para localizar um servidor, teramos que ter um servidor DHCP
exclusivo para cada sub-rede. No entanto, essa seria uma opo cara e invivel num ambiente com
mais VLANs.

Para sanar esse problema o servidor DHCP ser instalado em uma sub-rede administrativa parte
das sub-redes 192.168.10.0/24 e 192.168.20.0/24. Essa sub-rede estar vinculada VLAN-1
(padro) e para permitir que o trfego de broadcast gerado pelas mquinas no momento da
solicitao de endreos chegue at o servidor, necessrio configurar uma funo
denominada relay-agent no switch/roteador para que ele saiba que deve reencaminhar todo trfego
de broadcast at o endereo especfico do servidor DHCP na rede admnistrativa.

Cabe destacar que o servidor DHCP utilizado nesse laboratrio j est devidamente configurado
com os escopos corretos para oferecer endereos s sub-redes. O servidor tambm j possui um IP
192.168.0.1/24 atribudo a ele e seu gateway est configurado como sendo o endereo
192.168.0.254. Ou seja, a interface do switch que est conectada ao servidor ter que ser
configurada para ser uma porta rotevel (layer-3) capaz de receber esse IP.
Isso s pode ser feito em switches multi-layer que tm suporte a diferentes tipos de portas, o que
torna esse equipamento bastante verstil. As portas de um switch multi-layer podem ser:

Porta de Camada 2: Essa a porta convencional que possui as funcionalidades bsicas


de qualquer porta de um switch, por isso ela tambm chamada e switchport. Por
padro, as portas dos switches multi-layer sempre esto nesse modo, exceto em
equipamentos de maior porte utilizados no ncleo de grandes redes;
Porta de Camada 3: Atravs do comando "no switchport" na configurao da
interface possvel transform-la em uma porta de roteador, ou seja, uma porta rotevel
em que podemos configurar um IP. Por isso podemos dizer que um switch multi-layer
um roteador com alta densidade de portas, j que todas as suas portas podem rotear.
Porta Virtual de VLAN: Esse modo interessante porque permite a criao de uma
interface virtual vinculada a uma determinada VLAN, de maneira que essa interface
lgica pode ser configurada com um IP que ser o gateway de todas as mquinas que
so membros dessa VLAN.

Obs.: Para que o leitor possa compreender melhor a aplicao prtica de cada um desses tipos de
portas, nesse laboratrio sero configuradas todas essas opes.

Configurao do Switch Multi-Layer (Layer-3)

A configurao do Switch Multi-Layer no nosso cenrio envolve vrios aspectos e por isso
exemplificarei essa configurao em etapas distintas para que o leitor compreenda melhor qual
tarefa est associada com cada bloco de comandos.

Se observamos o comportamento do STP (Spanning Tree Protocol) depois que os switches j esto
estveis, fcil identificar que o Switch DSW no foi eleito o switch raiz da rede. Com o intuito
decriar uma rede robusta e simtrica com o melhor desempenho possvel, faremos a
configurao manualmente da prioridade do DSW para que ele seja o novo raz da rede (spanning-
tree vlan ID priority 0), conforme pode ser observado no primeiro bloco de comandos.

Apesar de switches multi-layer serem capazes de rotear entre redes, normalmente esse
comportamento no est ativado por padro e utilizaremos o comando "ip routing" para permitir
explicitamente que ele faa roteamento entre as redes presentes em sua tabela de roteamento.
Aproveitaremos essa etapa para j realizar as principais configuraes de hostname, desativao
da resoluo de nomes, definio de um domnio de switches, criao de VLANs que sero
utilizadas, etc. Caso o leitor no tenha conhecimento dessas configuraes
bsicas, recomendoleitura prvia do Lab06 do livro "Laboratrios de Tecnologias Cisco"!

Switch> enable
Switch# configure terminal
Switch(config)# hostname DSW
DSW(config)# no ip domain lookup
DSW(config)# ip routing
DSW(config)# vtp mode server
DSW(config)# vtp domain AULA
DSW(config)# vtp password SENHA
DSW(config)# vlan 10
DSW(config-vlan)# name VLAN-10
DSW(config-vlan)# vlan 20
DSW(config-vlan)# name VLAN-20
DSW(config-vlan)# exit
DSW(config)# spanning-tree vlan 1,10,20 priority 0
DSW(config)#

Depois de realizadas essas configuraes iniciais, na sequncia converteremos a interface f0/10


(conectada ao servidor DHCP) para uma porta rotevel (no switchport) e ento atribuiremos a
ela o endereo 192.168.0.254/24, j que esse foi o endereo de gateway configurado no
servidor.Tambm criaremos duas interfaces lgicas vinculadas a cada uma das VLANs (interface
vlan) do laboratrio e configuraremos em cada uma delas um endereo IP que ser o gateway das
sub-redes associadas a suas respectivas VLANs.

Nas interfaces lgicas tambm utilizaremos o comando "ip helper-address" para redirecionar o
trfego de broadcast gerado nas respectivas VLANs at o endereo do Servidor DHCP.
Finalmente configuraremos as interfaces de f0/1 at f0/5 que interligam os demais switches de
acesso para carregarem informaes de todas s VLANs, em modo trunk.

DSW> enable
DSW# configure terminal
DSW(config)# int f0/10
DSW(config-if)# no switchport
DSW(config-if)# ip address 192.168.0.254 255.255.255.0
DSW(config-if)# int vlan 10
DSW(config-if)# ip address 192.168.10.254 255.255.255.0
DSW(config-if)# ip helper-address 192.168.0.1
DSW(config-if)# int vlan 20
DSW(config-if)# ip address 192.168.20.254 255.255.255.0
DSW(config-if)# ip helper-address 192.168.0.1
DSW(config-if)# int range f0/1 - 5
DSW(config-if-range)# switchport trunk encapsulation dot1q
DSW(config-if-range)# switchport mode trunk

Obs.: A partir desse ponto o leitor pode utilizar o comando "show ip route" para exibir a tabela de
rotas do switch multi-layer e constatar que j existem as sub-redes referentes s interfaces em que
atribumos IPs.

Para finalizar, repare que na interligao entre o DSW e o ASW4 utilizamos dois links
redundantesde propsito para que possamos agora configurar uma agregao dos dois links,
formando uma porta lgica (denominada port-channel) equivalente soma das duas interfaces
fsicas, conforme comandos na sequncia.

Isso interessante para garantir maior largura de banda entre os switches atravs do
balanceamento de carga entre os links fsicos. Como o STP bloqueia uma das portas para evitar a
ocorrncia de loops, ento um dos links fsicas fica ocioso, o que pode ser ruim do ponto de vista de
desempenho na rede.

DSW> enable
DSW# configure terminal
DSW(config)# int range f0/4 - 5
DSW(config-if-range)# channel-group 1 mode on
DSW(config-if-range)# end
DSW#

Obs.: Criaremos a port-channel manualmente e repare que repetiremos esse procedimento


posteriormente nas portas f0/23 e f0/24 do ASW4. Tambm interessante reparar que depois que
criamos a porta lgica agregada, ento o STP no bloqueia mais nenhum dos links individuais, j
que para ele somente existe a porta lgica a partir dessa configurao...

Feitos os procedimentos anteriores, ento nosso switch multi-layer est devidamente configurado.
Na prxima etapa faremos as configuraes dos demais switches de acesso para associar suas
portas s suas respectivas VLANs.

Configurao dos Switches de Acesso Convencionais

A configurao dos demais switches de acesso bastante simples e se resume apenas insero
deles no domnio AULA (VTP) e associao das portas com suas respectivas VLANs.
Especificamente no ASW4 esteremos configurando manualmente a agregao com o DSW. Essas
configuraes so todas trazidas nos blocos abaixo:

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW1
ASW1(config)# no ip domain lookup
ASW1(config)# vtp domain AULA
ASW1(config)# vtp mode client
ASW1(config)# vtp password SENHA
ASW1(config)# interface f0/24
ASW1(config-if)# switchport mode trunk
ASW1(config-if)# interface f0/1
ASW1(config-if)# switchport mode access
ASW1(config-if)# switchport access vlan 10
ASW1(config-if)# interface f0/2
ASW1(config-if)# switchport mode access
ASW1(config-if)# switchport access vlan 20
ASW1(config-if)# end
ASW1#

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW2
ASW2(config)# no ip domain lookup
ASW2(config)# vtp domain AULA
ASW2(config)# vtp mode client
ASW2(config)# vtp password SENHA
ASW2(config)# interface f0/24
ASW2(config-if)# switchport mode trunk
ASW2(config-if)# interface f0/1
ASW2(config-if)# switchport mode access
ASW2(config-if)# switchport access vlan 10
ASW2(config-if)# interface f0/2
ASW2(config-if)# switchport mode access
ASW2(config-if)# switchport access vlan 20
ASW2(config-if)# end
ASW2#

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW3
ASW3(config)# no ip domain lookup
ASW3(config)# vtp domain AULA
ASW3(config)# vtp mode client
ASW3(config)# vtp password SENHA
ASW3(config)# interface f0/24
ASW3(config-if)# switchport mode trunk
ASW3(config-if)# interface f0/1
ASW3(config-if)# switchport mode access
ASW3(config-if)# switchport access vlan 10
ASW3(config-if)# interface f0/2
ASW3(config-if)# switchport mode access
ASW3(config-if)# switchport access vlan 20
ASW3(config-if)# end
ASW3#

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW4
ASW4(config)# no ip domain lookup
ASW4(config)# vtp domain AULA
ASW4(config)# vtp mode client
ASW4(config)# vtp password SENHA
ASW4(config)# interface range f0/23 - 24
ASW4(config-if-range)# switchport mode trunk
ASW4(config-if-range)# channel-group 1 mode on
ASW4(config-if-range)# interface f0/1
ASW4(config-if)# switchport mode access
ASW4(config-if)# switchport access vlan 10
ASW4(config-if)# interface f0/2
ASW4(config-if)# switchport mode access
ASW4(config-if)# switchport access vlan 20
ASW4(config-if-range)# end
ASW4#

timo! Agora que j foram realizados os passos anteriormente descritos nessa atividade de
laboratrio, de se esperar que o leitor tenha uma melhor compreenso dos aspectos prticos que
envolvem a configurao de um Switch Multi-Layer (Layer-3). Os comandos abaixo podem ser
utilizados para verificar o status das configuraes:

Switch# show vlan


Switch# show interface trunk
Switch# show ip interface brief
Switch# show ip route
Switch# show ether-channel summary
Switch# show ether-channel port-channel

Abrao.