You are on page 1of 109

Deploying MPLS Traffic

Engineering
Gregory Johnson, Consulting Systems Engineer
grjohnso@cisco.com
BRKMPL-2100
Cisco Spark
Questions?
Use Cisco Spark to chat with the
speaker after the session

How
1. Find this session in the Cisco Live Mobile App
2. Click Join the Discussion
3. Install Spark or go directly to the space
4. Enter messages/questions in the space

Cisco Spark spaces will be cs.co/ciscolivebot#BRKMPL-2100


available until July 3, 2017.

2017 Cisco and/or its affiliates. All rights reserved. Cisco Public
Agenda
MPLS TE Overview
Bandwidth Optimization
Fast Reroute
Deployment Considerations
Forwarding Traffic Down LSPs
Centralized Tunnel Creation and
Control
Future Direction using SR-TE
Technology
Overview
MPLS TE
Head end Explicit Routing
IP/MPLS Constraint Based Routing
Local Protection
OSPF / IS-IS Extensions for link
attributes
RSVP-TE for Signaling and Label
Distribution
Admission Control
Mid-point Tail end Re-optimization
TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 5
How MPLS TE Works
Head end Link information Distribution*
ISIS-TE
IP/MPLS
OSPF-TE

Path Calculation (CSPF)*


Path Setup (RSVP-TE)
Forwarding Traffic down Tunnel*
Auto-route (announce / destinations)
Static route
PBR
PBTS / CBTS
Mid-point Tail end Forwarding Adjacency
TE LSP Pseudowire Tunnel select

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 6
TE Tunnel Attributes
Head end Unidirectional
IP/MPLS Destination Tail TE RID
Priority / Preemption (Setup and
Hold)
Attributes / Affinity
Bandwidth / Loadshare
Local Protection
Path Options (Explicit / Dynamic)
Mid-point Tail end

TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 7
Basic TE Tunnel Configuration
(Cisco IOS XE) Unnumbered
interface Tunnel1
description FROM-ROUTER-TO-DST1
ip unnumbered Loopback0 Tunnel destination and type
tunnel destination 172.16.255.3
tunnel mode mpls traffic-eng Signaled bandwidth and priority
tunnel mpls traffic-eng priority 0 0
tunnel mpls traffic-eng bandwidth 10000 Consider links with 0x0/0xF as attribute
tunnel mpls traffic-eng affinity 0x0 mask 0xF flags (colors)
tunnel mpls traffic-eng path-option 5 explicit name PATH1
tunnel mpls traffic-eng path-option 10 dynamic Tunnel path options
! (explicit, then dynamic)
ip explicit-path name PATH1 enable
next-address 172.16.0.1
next-address 172.16.8.0 Explicit path
next-address 1.1.1.1
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 8
Basic TE Tunnel Configuration
(Cisco IOS XR)
explicit-path name PATH1 Explicit path
index 1 next-address ipv4 unicast 172.16.0.4
index 2 next-address ipv4 unicast 2.2.2.2
index 3 next-address ipv4 unicast 172.16.4.2 MPLS TE point-to-point tunnel
!
interface tunnel-te1 Unnumbered
description FROM-ROUTER-TO-DST1
ipv4 unnumbered Loopback0 Signaled bandwidth and priority
priority 0 0
signalled-bandwidth 100000 Tunnel destination
destination 172.16.255.2
path-option 10 explicit name PATH1 Tunnel path options (explicit then
path-option 20 dynamic dynamic)
affinity f mask f
Consider links with 0xF/0xF as attribute
!
flags (colors)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 9
Link Information Distribution
Additional link characteristics
Interface address
IP/MPLS
Neighbor address
Maximum reservable bandwidth
Unreserved bandwidth
(at eight priorities)
TE metric (administrative weight)
Attribute Flags

IS-IS or OSPF flood link information


All TE nodes build a TE topology database
(TED)
TE
Not required if using off-line path computation Topology
database

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 10
Configuring MPLS TE and Link Information
Distribution Using IS-IS (Cisco IOS XE)
mpls traffic-eng tunnels
! Enable MPLS TE
interface TenGigabitEthernet0/1/0
ip address 172.16.0.0 255.255.255.254
ip router isis
mpls traffic-eng tunnels
mpls traffic-eng attribute-flags 0xF Enable MPLS TE on this interface, specify
mpls traffic-eng administrative-weight 20
attribute flags (colors), TE metric and max
ip rsvp bandwidth 100000
! reservable bandwidth (RSVP)
router isis
net 49.0001.1720.1625.5001.00
is-type level-2-only
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2 Enable wide metric TLVs and TE
passive-interface Loopback0 extensions (TE Id, router level)
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 11
Configuring MPLS TE and Link Information
Distribution Using OSPF (Cisco IOS XR)
router ospf DEFAULT
area 0
mpls traffic-eng
interface Loopback0 Enable MPLS TE extensions in this area
passive
!
interface TenGigE0/0/0/0
!
mpls traffic-eng router-id Loopback0 MPLS TE router id
!
rsvp Configuration mode for RSVP global and
interface TenGigE0/0/0/0 interface (e.g. maximum reservable
bandwidth 100000
! bandwidth) commands
!
mpls traffic-eng
interface TenGigE0/0/0/0
Configuration mode for MPLS TE global
admin-weight 5 and interface (e.g. TE metric, attribute
attribute-flags 0x8 flags) commands
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 12
Path Calculation
Find shortest TE nodes can perform constraint-
path to R8
with 80 Mbps
based routing
IP/MPLS Tunnel head end generally
R1 responsible for path calculation
150 50 200
100 R8 Constraints and topology database
100 used as input to path computation
80
100
Shortest-path-first algorithm ignores
100 links not meeting constraints
Tunnel can be signaled once a path
TE
Topology is found
database
Not required if using offline path
computation

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 13
TE LSP Signaling
Tunnel signaled with TE extensions to RSVP
Soft state maintained with downstream PATH
Head end IP/MPLS
messages
Soft state maintained with upstream RESV
messages
New RSVP objects L=50
LABEL_REQUEST (PATH) RESV Tail end
LABEL (RESV)
EXPLICIT_ROUTE PATH

RECORD_ROUTE (PATH/RESV)
SESSION_ATTRIBUTE (PATH)
Input Out Label,
LFIB populated using RSVP labels allocated by Label Interface
RESV messages 100 50, 0
TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 14
Forwarding Traffic Down Tunnels
Head end Traffic enters tunnel at head end
Multiple traffic selection options
IP/MPLS
Auto-route (announce / destination)
Static routes
Policy Based Routing
Forward Adjacency
Pseudowire Tunnel Selection
Policy / Class Based Tunnel Selection
PSTS / SPP
Tunnel path computation
independent of routing decision
injecting traffic into tunnel
TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 15
Point-to-Multipoint (P2MP)TE LSP
Unidirectional
Explicitly routed IP/MPLS

One head end, but one or more tail


ends (destinations)
Same characteristics (constraints,
protection, etc.) for all destinations

TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 16
P2MP TE LSP Terminology
Tail end
Head-end/Source: Node where LSP
IP/MPLS
signaling is initiated
Head end
Mid-point: Transit node where LSP
signaling is processed (not a head-
Mid-point and
end, not a tail-end)
branch point
Tail-end/Leaf/destination: node
where LSP signaling ends
IP/MPLS

S2L sub-LSP Branch point: Node where packet


replication is performed
S2L sub-LSP
Source-to-leaf (S2L) sub-LSP:
P2MP TE LSP segment that runs
TE LSP from source to one leaf
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 17
P2MP TE LSP Path Computation
Constrained Shortest Path First (CSPF) used to
compute an adequate tree
IP/MPLS R4
CSPF executed per destination R2

TE topology database and tunnel constraints R1


used as input for path computation
R3 R5
Path constraints may include loose, included,
excluded hops
Same constraints for all destinations (bandwidth, TE
affinities, priorities, etc.) Topology
database

Path computation yields explicit path to each


destination
CSPF
No changes to OSPF/IS-IS TE extensions
Static paths possible with offline path Path to R4: (R1, R2, R4)
computation Path to R5: (R1, R2, R5)
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 18
P2MP TE LSP Signaling
Source sends unique PATH
IP/MPLS
PATH
message per destination
PATH
LFIB populated using
PATH RSVP labels allocated by RESV
PATH
messages
Multicast state built by reusing sub-
LSP labels at branch points
IP/MPLS
L=17
L=16 RESV
RESV

L=16
RESV

L=18
Input RESV
Out Label,
Label Interface
16 17, 0
18, 1

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 19
Configuring P2MP Tunnel at Head End
(Cisco IOS XE)
mpls traffic-eng destination list name P2MP-LIST-DST1
Destination list with one path-
ip 172.16.255.1 path-option 10 explicit name PATH1
option per destination
ip 172.16.255.2 path-option 10 dynamic
ip 172.16.255.3 path-option 10 dynamic
ip 172.16.255.4 path-option 10 dynamic
!
interface Tunnel1
description FROM-ROUTER-TO-LIST-DST1
ip unnumbered Loopback0 P2MP TE Tunnel
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP-LIST-DST1
Destination list
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 1000
Signaled bandwidth and setup / hold
!
priorities

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 20
Configuring P2MP Tunnel at Head End
(Cisco IOS XR)
interface tunnel-mte1
ipv4 unnumbered Loopback0 MPLS TE P2MP tunnel
destination 172.16.255.129
path-option 10 explicit name PATH1 Destination with path-option list
path-option 20 dynamic
!
destination 172.16.255.130
path-option 10 dynamic Destination with single path-option
!
priority 0 0
signalled-bandwidth 100000 Signaled bandwidth and setup / hold priorities
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 21
MPLS TE Use Cases
Point-to-Point SLA Protection

R1 IP/MPLS R1 IP/MPLS

R8 R8
R2 R2

Bandwidth Optimization
Strategic / Planned Tactical / Reactive

R1 IP/MPLS R1 IP/MPLS

R3
R8
R2
R2
R4

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 22
MPLS TE Integration with Network Services
A TE LSP provides transport for different network services

CE CE
IP/MPLS
PE PE
ATM
CE Ethernet CE
CE

PE

CE CE

PE PE
CE Ethernet Ethernet CE

Low-Latency, BW TE LSP with L2VPN IP (VPN)


Protected TE LSP Reserved BW (Pseudowire) Service

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 23
Bandwidth optimization
Strategic / Planned Bandwidth Optimization
Tunnel mesh to
Traffic Matrix Physical Topology satisfy traffic matrix
R1 R2 R3 R4 R5 R6
R1 R6 R1 R6
R1 4 7 1 5 4 5
R2 2 2 4 7 2 3
R3
R4
1
9
2
1
9
4
5
1
5
3
5
1
+ R2 R5
= R2 R5

R5 3 7 9 2 7 7
R6 6 3 5 4 9 12 R3 R3
R4 R4

Optimize utilization of physical infrastructure


On-line (CSPF) or off-line path computation
May result in a significant number of LSPs
Will not affect routing adjacencies

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 25
Traffic Matrix Discovery
Full Mesh Zero BW Tunnels
Polling ifMIB
MPLS LSR MIB
IPFIX / NetFlow v9
BGP policy accounting
Communities
AS path
IP prefix

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 26
Tactical / Reactive Bandwidth Optimization
Bandwidth Optimization
Strategic / Planned Tactical / Reactive

R1 IP/MPLS R1 IP/MPLS
R3
R8
R2 R2
R4

Selective deployment of tunnels when highly-utilized links


are identified
Generally, deployed until capacity upgrade alleviates
congested links
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 27
AutoTunnel Mesh
Mesh group: LSRs to mesh New mesh
automatically group
member
Membership identified by
Matching TE Router ID
against ACL (Cisco IOS and IOS XR) New mesh
group
IGP mesh-group
member
advertisement (Cisco IOS)
Each member automatically creates
tunnel upon detection of a member
Tunnels instantiated from template
Individual tunnels not displayed in
router configuration
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 28
Configuring AutoTunnel Mesh
via Protocol Extension (Cisco IOS XE)
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel mesh Enable Auto-tunnel Mesh
!
interface Auto-Template1
Tunnel template
ip unnumbered Loopback0
tunnel destination mesh-group 10
tunnel mode mpls traffic-eng
Template for mesh group 10
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 10 dynamic
tunnel mpls traffic-eng auto-bw frequency 3600
! Dynamic (CSPF) path and Auto BW
router ospf 16
log-adjacency-changes
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0 Advertise mesh group 10 membership in
mpls traffic-eng mesh-group 10 Loopback0 area 0 area 0
passive-interface Loopback0
network 172.16.0.0 0.0.255.255 area 0
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 29
Configuring AutoTunnel Mesh
via ACL (Cisco IOS XR)
ipv4 unnumbered mpls traffic-eng Loopback 0
! Source interface for backup tunnels
mpls traffic-eng
auto-tunnel mesh
group 10 Mesh group 10 identified by ACL DST-
attribute-set 10 RID-ACL
destination-list DST-RID-ACL
!
tunnel-id min 1000 max 2000 Range for mesh tunnel interfaces
!
attribute-set auto-mesh 10
autoroute announce
path-selection metric te Attribute set for tunnels in mesh group 10
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 30
Auto Bandwidth
Total Bandwidth
bandwidth available to
for all TE other tunnels
Max
tunnels
on a path

Tunnel
Min
resized to
measured rate

Dynamically adjust bandwidth reservation based on measured traffic


Optional minimum and maximum limits
Sampling and resizing timers
Actual resizing can be subject to adjustment threshold and
overflow/underflow detection

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 31
Fast Reroute
Traffic Protection Using MPLS TE Fast Re-Route
(FRR)
Sub-second recovery against
node/link failures
IP/MPLS
R1 Scalable 1:N protection
Greater protection granularity
R8
Bandwidth protection
R2
Topology independent

Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 33
FRR Link Protection Operation
Requires pre-signalled next-hop
(NHOP) backup tunnel
IP/MPLS
Point of Local Repair (PLR) swaps R3
25
label and pushes backup label 22 22

Backup terminates R1 R2 R6 R7

on Merge Point (MP) where traffic re-


joins primary 16 22

Restoration time expected under ~50 ms R5


LFIB update
Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 34
Configuring FRR (Cisco IOS XE)
Primary Tunnel

interface Tunnel1
description FROM-ROUTER-TO-DST1-FRR
ip unnumbered Loopback0
tunnel destination 172.16.255.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng bandwidth 20000
tunnel mpls traffic-eng path-option 10 dynamic Signal desire for local protection
tunnel mpls traffic-eng fast-reroute
!

Backup Tunnel
interface Tunnel1
description NNHOP-BACKUP Explicitly routed
ip unnumbered Loopback0
tunnel destination 172.16.255.2
backup with zero BW
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 10 explicit name PATH1
!
interface TenGigabitEthernet1/0/0 Use Tunnel for backup of
ip address 172.16.192.5 255.255.255.254
mpls traffic-eng tunnels LSPs through
mpls traffic-eng backup-path Tunnel1
ip rsvp bandwidth TenGigabitEthernet 1/0/0
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 35
Configuring FRR (Cisco IOS XR)
Primary Tunnel
interface tunnel-te1
description FROM-ROUTER-TO-DST1-FRR
ipv4 unnumbered Loopback0
signalled-bandwidth 30000
destination 172.16.255.2 Signal desire for local protection
fast-reroute
path-option 10 dynamic
!

Backup Tunnel
interface tunnel-te1 Explicitly routed
description NHOP-BACKUP
ipv4 unnumbered Loopback0
backup with zero BW
destination 172.16.255.130
path-option 10 explicit name PATH1
!
mpls traffic-eng
Use Tunnel for backup of LSPs
interface TenGigE0/0/0/0 through TenGigabitEthernet
backup-path tunnel-te 1 0/0/0/0
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 36
FRR Node Protection Operation
Requires pre-signalled next-next-
hop (NNHOP) backup tunnel
IP/MPLS
R3 Point of Local Repair (PLR) swaps
25
36 36 next-hop label and pushes
R1 R2 R4 R6 R7
backup label
Backup terminates on Merge Point
16 22 36
(MP) where traffic re-joins primary
Restoration time depends on failure
R5
detection time / mechanism
Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 37
Bidirectional Forwarding Detection Trigger for FRR
FRR relies on quick PLR failure
detection IP/MPLS
R1
Some failures may not produce loss
of signal or alarms on a link R8

BFD provides light-weight neighbor R2


connectivity failure detection
Much better than RSVP Hellos

BFD session

Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 38
Bandwidth Protection
Backup tunnel with associated
IP/MPLS bandwidth capacity (1:N protection)
R3
Backup tunnel may or may not
actually signal bandwidth
R1 R2 R4 R6 R7

PLR will decide best backup to


protect primary
nhop/nnhop
backup-bw
R5 class-type
node-protection flag

Primary TE LSP
Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 39
AutoTunnel: Primary Tunnels
Whats the Problem?
FRR can protect TE Traffic
Does NOT protect IP or LDP traffic IP/MPLS
R1
How to leverage FRR for all traffic?
What if protection desired without R8
traffic engineering?
R2

Primary TE LSP

Backup TE LSP
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 40
AutoTunnel: Primary Tunnels
Whats the Solution?
Create protected one-hop tunnels on all
Forward all traffic through a one-hop TE links
protected primary TE tunnel Priority 7/7
Bandwidth 0
IP/MPLS Affinity 0x0/0xFFFF
R1
Auto-BW OFF
Auto-Route ON
R8
Fast-Reroute ON
Forwarding-Adj OFF
R2
Load-Sharing OFF
Tunnel interfaces not shown on router
configuration
Configure desired backup tunnels
Primary TE LSP (manually or automatically)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 41
AutoTunnel: Backup Tunnels
Whats the Problem?
MPLS FRR requires backup tunnels
to be preconfigured
IP/MPLS
Automation of backup tunnels is R1

desirable
R8

R2

Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 42
AutoTunnel: Backup Tunnels
Whats the Solution?
Create backup tunnels automatically Detect if a primary tunnel requires
as needed
protection and is not protected

R1
IP/MPLS Verify that a backup tunnel doesnt
already exist
R8 Compute a backup path to NHOP
and NNHOP excluding the protected
R2
facility
Optionally, consider shared risk link
groups during backup path
computation
Primary TE LSP Signal backup tunnels
Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 43
Configuring AutoTunnel Backup Tunnels
(Cisco IOS)
mpls traffic-eng tunnels Enable auto-tunnel backup (NHOP
mpls traffic-eng auto-tunnel backup nhop-only tunnels only)
mpls traffic-eng auto-tunnel backup tunnel-num min 1900 max 1999 Range for backup
mpls traffic-eng auto-tunnel backup srlg exclude preferred tunnel interfaces
!
Preferably consider
SRLGs

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 44
Configuring AutoTunnel Backup Tunnels
(Cisco IOS XR)
ipv4 unnumbered mpls traffic-eng Loopback 0
! Source interface for backup tunnels
mpls traffic-eng
interface GigabitEthernet0/0/0/0
auto-tunnel backup Protect interface with dynamically
exclude srlg preferred created (next-hop only)
nhop-only backup tunnels. Preferably consider
! SRLGs.
!
auto-tunnel backup
Range for backup tunnel interfaces
tunnel-id min min 1900 max 1999
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 45
Shared Risk Link Group (SRLG)
Layer-3 Topology
Some links may share same physical
IP/MPLS resource (e.g. fiber, conduit)
R2 R4
R1 R5 AutoTunnel Backup can force or
prefer exclusion of SRLG
R3 to guarantee diversely routed backup
tunnels
Layer-3 Plus underlying Optical Topology
IS-IS and OSPF flood SRLG
SRLG 10
R2-R4 R2-R3 membership as an additional
IP/MPLS
R2 R4 SRLG 20 link attribute
R4-R2
R1 R5
R4-R3

SRLG 30
R3-R2
R3 R3-R4

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 46
Configuring SRLG (Cisco IOS XE)
Force SRLG Exclusion
mpls traffic-eng tunnels
during backup path
mpls traffic-eng auto-tunnel backup nhop-only
computation
mpls traffic-eng auto-tunnel backup srlg exclude force
!
interface TenGigabitEthernet0/1/0
ip address 172.16.0.0 255.255.255.254
mpls traffic-eng tunnels
mpls traffic-eng srlg 15 Interface member of
mpls traffic-eng srlg 25 SRLG 15 and 25
ip rsvp bandwidth
!
interface TenGigabitEthernet1/0/0
ip address 172.16.0.2 255.255.255.254
mpls traffic-eng tunnels Interface Member of
mpls traffic-eng srlg 25 SRLG 25
ip rsvp bandwidth
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 47
What About Path Protection?
Primary and standby share head and tail,
but expected to be diversely routed
IP/MPLS
Longer restoration times compared to Link
/ Node Protection
R8
Doubles number of TE LSPs
(1:1 protection) R1

Only option for certain topologies


(e.g. Rings)

Primary TE LSP

Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 48
Configuring Path Protection (Cisco IOS XE)
interface Tunnel1
ip unnumbered Loopback0
Explicit Path Option for
tunnel mode mpls traffic-eng
PATH1
tunnel destination 172.16.255.2
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 10 explicit name PATH1
tunnel mpls traffic-eng path-option protect 10 explicit name ProtectPATH1
!

Protect path to be used


for PATH1

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 49
Configuring Path Protection
(Cisco IOS XR)
interface tunnel-te1
description FROM-ROUTER-TO-DST1
ipv4 unnumbered Loopback0 Signal an acceptable
signalled-bandwidth 100000 (node-link, node, link
destination 172.16.255.2 diverse) standby TE LSP
affinity f mask f based on path option
path-protection sequence
path-option 10 explicit name PATH1
path-option 20 explicit name PATH2
path-option 30 dynamic
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 50
P2MP TE LSP Traffic Protection
No new protocol extensions to
support FRR
IP/MPLS R4
Protection requirement applies to all
destinations R2
R1
P2P LSP as backup tunnel for a sub-
LSP
No changes to label stacking R3 R5
procedure
Only link protection supported
Head-end protection requires path Primary TE LSP
redundancy (live-standby / live-live) Backup TE LSP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 51
General
Deployment
Considerations
Should RSVP-TE and LDP be Used
Simultaneously?
IP/MPLS
Guarantees forwarding of VPN traffic if a TE
LSP fails (Belt and Suspenders)
Often required if full mesh of TE LSPs not in
use (Swap and Push 2)
Increased complexity / additional Control
Plane overhead

RSVP TE and LDP

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 53
How Far should Tunnels Span?
56 TE LSP
PE-to-PE Tunnels
PE PE
More granular control on traffic forwarding
PE PE Larger number of TE LSPs
PE PE P-to-P Tunnels
Requires IP tunnels or LDP over TE
PE PE
tunnels to carry VPN traffic (deeper label
stack)
12 TE LSP Fewer TE LSPs
PE PE May be extended with PE-P tunnels
P P
PE PE

PE PE
P P
PE PE

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 54
Low Latency Routing

Learn Latency via IP SLA


DC
TE metric to reflect latency
30ms
Latency Sensitive Apps / LA
50ms
Customers use low latency
LSPs (i.e. TE metric) 10ms
20ms
Non-Latency Sensitive Apps / 10ms

Customers leverage longer


paths with available BW
(i.e. IGP metric)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 55
TE Metric (Administrative Weight) Configuration
IOS XE
interface Tunnel1
description Low-Latency-TO-LA
ip unnumbered Loopback0
tunnel destination 172.16.255.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 0 0
tunnel mpls traffic-eng bandwidth 10000
tunnel mpls traffic-eng affinity 0x0 mask 0xF
tunnel mpls traffic-eng path-option 10 dynamic
tunnel mpls traffic-eng path-selection metric te
Set Tunnel to use TE metric for path selection
!
(default is metric IGP)
interface GigabitEthernet1/0
ip address 10.10.10.1 255.255.255.252
ip ospf network point-to-point
ip ospf cost 1000
mpls traffic-eng tunnels On Interface set TE Metric Lower than
mpls traffic-eng administrative-weight 50 IGP cost
ip rsvp bandwidth 1000000 1000000

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 56
Forwarding Traffic
Autoroute Announce
Tunnel destination
and downstream
Install B, C, D with tunnel prefixes
as output interface and
shortest path metric.
D
Prefixes installed in RIB with tunnel
Tunnel destination MUST
be along shortest path. as output interface if tunnel
B
destination along shortest path
A
C Binds Next Hop of Tunnel tail to the
Tunnel
Tunnel Tunnel
head end Eth0

Y
Occurs after Tunnel is signaled
Supported for IS-IS and OSPF
Z
RIB
Prefix Next Hop Metric Out Interface TE Tunnel
B B 30 Tunnel
IGP Shortest
C B 40 Tunnel path tree
D B 40 Tunnel
Z Y 20 Ethernet0
: : : :

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 58
Class-Based Tunnel Selection
EXP-based selection between multiple Tunnel1
Tunnel10 Prefix1
Tunnel2
tunnels to same destination
Tunnel3
Local mechanism at head-end (no IGP Tunnel4 Tunnel20 Prefix2
Tunnel5
extensions)
Tunnel master bundles tunnel members Tunnel6
Tunnel30 Prefix3
Tunnel7
Tunnel selection configured on tunnel
master (auto-route, etc.)
FIB Tunnel Bundle
Bundle members configured with EXP Prefix1 Tunnel10
Prefix2 Tunnel20
values to carry
Prefix3 Tunnel30

Master (Tunnel10)

Member (Tunnel1)

Member (Tunnel2)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 59
Configuring CBTS (Cisco IOS XE) Tunnel1 will carry packets
with MPLS EXP 5
interface Tunnel1
ip unnumbered Loopback0
tunnel destination 172.16.255.2
tunnel mode mpls traffic-eng Tunnel2 will carry packets
tunnel mpls traffic-eng bandwidth 50000 class-type 1
tunnel mpls traffic-eng path-option 10 dynamic
with MPLS EXP markings
tunnel mpls traffic-eng exp 5 other than 5
!
interface Tunnel2
ip unnumbered Loopback0
tunnel destination 172.16.255.2 Tunnel0 defined as
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng bandwidth 100000 class-type 0 bundle master with
tunnel mpls traffic-eng path-option 10 dynamic
tunnel mpls traffic-eng exp default Tunnel2 and Tunnel1 as
! members
interface Tunnel10
ip unnumbered Loopback0
tunnel destination 172.16.255.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel1
tunnel mpls traffic-eng exp-bundle member Tunnel2 CBTS performed on prefix
! 192.168.0.0/24 using
ip route 192.168.0.0 255.255.255.0 Tunnel10
! Tunnel0

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 60
Policy Based Tunnel Selection
Mechanism local to Tunnel Head Input policy matches
traffic based on ACL
PBR policy sets forwarding class for and sets forwarding
ingress traffic class
PE1 Tunnel-te1000
Traffic forwarding down Tunnel with Forwarding class 1
matching forwarding class PE2
Tunnel-te2000
Seven distinct forwarding classes support Forwarding class 0
(1-7) (default)

One forwarding class reserved as


default (0)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 61
Configuring PBTS (Cisco IOS XR)
interface tunnel-te1
ipv4 unnumbered Loopback0
tunnel-te1 will carry
autoroute announce
packets with MPLS EXP 5
signalled-bandwidth 10000
destination 172.16.255.2
policy-class 5
path-option 10 explicit name PATH1
path-option 20 dynamic
! tunnel-te2 will carry
interface tunnel-te2
packets with MPLS EXP
ipv4 unnumbered Loopback0
autoroute announce
OTHER than 5 (default
signalled-bandwidth 50000 tunnel)
destination 172.16.255.2
path-option 10 explicit name PATH2
path-option 20 dynamic
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 62
Per-Service Tunnel Selection
Services (L2VPN / L3VPN) generally
Static routing
receive a path automatically
mapping Recursive resolution of BGP next hops
loopback0
loopback1 Recursive resolution of LDP peers
loopback2
to specific paths BGP Update Loopback0 L2VPN provides granular per-tunnel
Loopback1
Loopback2 control using pseudowire tunnel selection
PE1

PE2 When using BGP (L2VPN, L3VPN, IP):


On tail end, add loopback at destination for
Policy
route-policy INBOUND
if (community matches-any 65172:10) then
set forwarding-group 10
elseif (community matches-any 65172:20) then
each service that needs separate forwarding
set forwarding-group 20
endif
end-policy
On tail end, add policy to modify next-hop on
BGP updates
On head end, add static route to force BGP
next hops down specific paths

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 63
Service Path Preference (SPP)
Color Automatic mechanism for mapping
services to specific TE LSPs
Service LSP
Path Preference signaled via BGP
community tag
BGP Update
PE maps color (Forward-Class) to
PE1 received prefix
PE2
Tunnel with matching Forward-Class is
selected to forward traffic
Ability to define ordered list of
Forwarding-Classes
Essentially BGP-driven PSTS

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 64
Configuring Service Path Preference (SPP)
(Cisco IOS XR)
route-policy Class1
if community matches-any (6500:1) then
set forward-class 1 Match tag and set forward-class
end-if
end-policy
!

router bgp 55
bgp router-id 20.0.0.1
address-family ipv4 unicast
table-policy Class1 Enable policy for specific address family
!
!
!
interface tunnel-te1
forward-class 1 Apply forward-class to tunnel interface
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 65
Centralized Tunnel
Creation and Control
Path Computational Element (PCE)
Stateful PCE
PCE (Controller) maintains
topology databases LSP DB

Centralized path computation TED

Enables centralized control of


LSP initiation and modifications PCEP

Essentially SDN driven TE


PCC

PCE-initiated
LSP

*Path Computational Client (Router)


*Path Computational Element (Controller)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 67
Topological Database Visibility Stateful PCE

An external PCE requires some form of LSP DB


topological acquisition PCE

A PCE may learn topology using BGP-LS, TED

IGP, SNMP, screen scraps, etc.


BGP-LS
BGP-LS characteristics
Aggregates topology across one or more domains
RR
Well understood operational models (e.g. RR)
Leverages existing Control Plane BGP-LS
BGP-LS
Minimal overhead PCC

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 68
PCE-Initiated Tunnels
Treated as dynamically created tunnels Stateful PCE
(auto-tunnel)
LSP DB
Router does NOT verify or compute path
that PCE provides (NO CSPF)
TED
Signaled as verbatim path
PCEP
PCE responsible for LSP re-optimization Initiate /
Create
PCE sends an PCEP Update when a better
path exists
PCC
Tunnels may be inter-area
*PCE Initiated tunnel does not appear in
configuration
show mpls traffic-eng tunnels

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 69
Configuring PCC to Accept PCE-Initiated Tunnels
(Cisco IOS XR)
ipv4 unnumbered mpls traffic-eng Loopback0
! Source interface for tunnels
mpls traffic-eng
pce
peer source ipv4 192.168.1.1
PCE / XTC peering
peer ipv4 172.16.255.3
stateful-client
instantiation Allow PCE to create / modify LSPs
delegation
!
! Range of tunnel-te interfaces for PCE
auto-tunnel pcc initiated LSPs
tunnel-id min 1000 max 5000
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 70
Future
Direction
Segment Routing Traffic Engineering

Simplified Control Plane (IGP only)


Reduce state in network
C
Explicit Routing at source
A
Z
Tunnel configuration SR Policy
O
instead
Multi-Domain: (XTC compute and
BSID for scale)
Path encoded as label stack

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 72
Segment Routing

A
Z
O

Path is computed by source


Path is encoded by the source in the packet header via SID List
(i.e. label stack)
Segment Identifier (SID) assigned by Adjacency or Node
MPLS data plane
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 73
Summary
Summary
Technology Overview
Bandwidth Optimization
Traffic Protection
General Deployment Considerations
Forwarding Traffic
Centralized Tunnel Creation and Control
Segment Routing
***Additional Configuration Outputs Provided***

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 75
Recommended Reading

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 76
Complete Your Online
Session Evaluation
Give us your feedback to be
entered into a Daily Survey
Drawing. A daily winner will
receive a $750 gift card.
Complete your session surveys
through the Cisco Live mobile
app or on www.CiscoLive.com/us.

Dont forget: Cisco Live sessions will be


available for viewing on demand after the
event at www.CiscoLive.com/Online.

2017 Cisco and/or its affiliates. All rights reserved. Cisco Public
Continue Your Education
Demos in the Cisco campus
Walk-in Self-Paced Labs
Lunch & Learn
Meet the Engineer 1:1 meetings
Related sessions
BRKRST-3122 Segment Routing: Technology deep dive and advanced use cases
BRKMPL-2118 - Evolving Network Application Use-Cases Using Segment Routing in
the Enterprise

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 78
Thank you
Backup
Configuring MPLS TE and Link Information
Distribution Using IS-IS (Cisco NX-OS)
feature isis
feature mpls traffic-eng
Enable MPLS TE on this device
interface Ethernet1/1
mpls traffic-eng tunnels
mpls traffic-eng administrative-weight 20
mpls traffic-eng attribute-flags 0xf
Enable MPLS TE on this interface,
mpls traffic-eng bandwidth 10000000 specify attribute flags (colors), TE metric
no switchport and maximum reservable bandwidth
ip address 172.16.0.14/31
ip router isis DEFAULT
no shutdown

router isis DEFAULT


mpls traffic-eng level-2 Enable TE extensions (TE Id, router
mpls traffic-eng router-id loopback0 level)
net 49.0001.1720.1625.5202.00
is-type level-2

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 82
Configuring Tunnel at Head End
(Cisco NX-OS)
mpls traffic-eng
explicit-path name PATH1
Explicit path definition
index 10 next-address 172.16.0.15
index 20 next-address 172.16.0.13

interface tunnel-te1 MPLS TE point-to-point tunnel


description FROM-ROUTER-TO-DST1
ip unnumbered loopback0
no shutdown
Tunnel destination
destination 172.16.255.5 Consider links with 0xF/0xF as attribute
affinity 0xf mask 0xf
flags (colors)
bandwidth 10000
path-option 10 explicit name PATH1 Signaled bandwidth
path-option 20 dynamic
priority 0 0 Tunnel path options (explicit, otherwise,
dynamic)

Signaled priority
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 83
Statically Mapping Multicast Groups to a P2MP Tunnel
(Cisco IOS XE)
mpls traffic-eng destination list name P2MP-LIST-DST1
ip 172.16.255.1 path-option 10 explicit name PATH1
Destination list with one path-option
ip 172.16.255.2 path-option 10 dynamic per destination
ip 172.16.255.3 path-option 10 dynamic
ip 172.16.255.4 path-option 10 dynamic
!
interface Tunnel1
description FROM-ROUTER-TO-LIST-DST1
ip unnumbered Loopback0
ip pim passive Multicast groups mapped to tunnel
ip igmp static-group 232.0.0.1 source 192.168.5.1
ip igmp static-group 232.0.0.2 source 192.168.5.1 P2MP TE Tunnel
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP-LIST-DST1
tunnel mpls traffic-eng priority 7 7
Destination list
tunnel mpls traffic-eng bandwidth 1000
! Signaled bandwidth and setup / hold
priorities

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 84
Configuring RPF Check at P2MP Tunnel Tail End
(Cisco IOS XE)
ip multicast mpls traffic-eng
Enable IPv4 multicast over P2MP TE LSP
ip mroute 192.168.5.1 255.255.255.255 172.16.255.5
!
Tunnel source (172.16.255.5) as
next-hop for IP Multicast source
(192.168.5.1) RPF check

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 85
Statically Mapping Multicast Groups to a P2MP Tunnel
(Cisco IOS XR)
interface tunnel-mte1
ipv4 unnumbered Loopback0 MPLS TE P2MP tunnel
destination 172.16.255.129
path-option 10 explicit name PATH1
path-option 20 dynamic Destination with path-option list
!
destination 172.16.255.130
path-option 10 dynamic
!
Destination with single path-option
priority 0 0
signalled-bandwidth 100000
!
Signaled bandwidth and setup / hold priorities
node-capability label-switched-multicast
multicast-routing
address-family ipv4
Enable MPLS multicast
interface tunnel-mte1
enable
! Enable multicast forwarding over tunnel-mte1
interface all enable
!
!
router igmp
vrf default
interface tunnel-mte1
static-group 232.0.0.1 192.168.5.1 Multicast groups mapped to tunnel-mte1
static-group 232.0.0.2 192.168.5.1
!
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 86
Configuring RPF Check at P2MP Tunnel Tail End
(Cisco IOS XR)
multicast-routing
address-family ipv4 Enable IPv4/v6 multicast over P2MP TE LSP
core-tree-protocol rsvp-te
static-rpf 192.168.5.1 32 mpls 172.16.255.3
interface all enable Tunnel source (172.16.255.3) as next-
! hop for IP Multicast source (192.168.5.1)
! RPF check

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 87
Configuring MPLS TE and Link Information
Distribution Using OSPF (Cisco IOS XE)
mpls traffic-eng tunnels Enable MPLS TE
! on this node
interface TenGigabitEthernet0/1/0
ip address 172.16.0.0 255.255.255.254
Enable MPLS TE
mpls traffic-eng tunnels
on this interface
mpls traffic-eng attribute-flags 0xF Attribute flags
mpls traffic-eng administrative-weight 20
ip rsvp bandwidth 100000 TE metric
! Maximum
router ospf 100 reservable
log-adjacency-changes bandwidth
passive-interface Loopback0
network 172.16.0.0 0.0.255.255 area 0 Enable TE
mpls traffic-eng router-id Loopback0 extensions (TE
mpls traffic-eng area 0 router id and area)
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 88
Configuring MPLS TE and Link Information
Distribution Using IS-IS (Cisco IOS XR)
router isis DEFAULT
is-type level-2-only Enable wide metric
net 49.0001.1720.1625.5129.00 format and TE
address-family ipv4 unicast extensions (TE Id,
metric-style wide
mpls traffic-eng level 2 router level)
mpls traffic-eng router-id Loopback0
! Configuration mode
interface Loopback0 for RSVP global and
passive
address-family ipv4 unicast interface commands
!
! Maximum
interface TenGigE0/0/0/0 reservable
address-family ipv4 unicast bandwidth
!
!
! Configuration mode
rsvp for MPLS TE global
interface TenGigE0/0/0/0 and interface
bandwidth 100000
! commands
!
mpls traffic-eng TE metric
interface TenGigE0/0/0/0
admin-weight 5 Attribute flags
attribute-flags 0x8
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 89
Configuring DS-TE Classes and Bandwidth
Constraints (Cisco IOS)
RDM
mpls traffic-eng tunnels
mpls traffic-eng ds-te mode ietf
Enable IETF DS-TE
mpls traffic-eng ds-te te-classes
te-class 0 class-type 1 priority 0
te-class 1 class-type 1 priority 1
te-class 2 class-type 1 priority 2 Explicit TE-Class definition
te-class 3 class-type 1 priority 3
te-class 4 class-type 0 priority 4
te-class 5 class-type 0 priority 5
te-class 6 class-type 0 priority 6
RDM bandwidth
te-class 7 class-type 0 priority 7 constraints
!
interface TenGigabitEthernet0/1/0
ip address 172.16.0.0 255.255.255.254
mpls traffic-eng tunnels
ip rsvp bandwidth rdm bc0 155000 bc1 55000
!

MAM Enable IETF DS-TE and


use default TE-Class
mpls traffic-eng tunnels definition
mpls traffic-eng ds-te mode ietf
mpl traffic-eng ds-te bc-model mam
!
Enable MAM
interface TenGigabitEthernet0/1/0 MAM bandwidth
ip address 172.16.0.0 255.255.255.254
constraints
mpls traffic-eng tunnels
ip rsvp bandwidth mam max-reservable-bw 155000 bc0 100000 bc1 55000
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 90
Configuring DS-TE Tunnel (Cisco IOS)
Signal Tunnel1
interface Tunnel1 with CT0 (priority
description FROM-ROUTER-TO-DST1-CT0
ip unnumbered Loopback0 and CT must
no ip directed-broadcast match valid TE-
tunnel destination 172.16.255.3 Class)
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 5 5
tunnel mpls traffic-eng bandwidth 100000 class-type 0
tunnel mpls traffic-eng path-option 10 dynamic
!
interface Tunnel2
description FROM-ROUTER-TO-DST1-CT1 Signal Tunnel2
ip unnumbered Loopback0 with CT1 (priority
no ip directed-broadcast and CT must
tunnel destination 172.16.255.3
tunnel mode mpls traffic-eng match valid TE-
tunnel mpls traffic-eng priority 0 0 Class)
tunnel mpls traffic-eng bandwidth 50000 class-type 1
tunnel mpls traffic-eng path-option 10 dynamic
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 91
Configuring DS-TE Classes and Bandwidth
Constraints (Cisco IOS XR)
RDM
rsvp
interface TenGigE0/0/0/0 RDM bandwidth
bandwidth rdm bc0 155000 bc1 55000 constraints
!
!
mpls traffic-eng
interface TenGigE0/0/0/0
!
ds-te mode ietf
ds-te te-classes Enable IETF DS-TE
te-class 0 class-type 1 priority 0
te-class 1 class-type 1 priority 1
te-class 2 class-type 1 priority 2
te-class 3 class-type 1 priority 3
te-class 4 class-type 0 priority 4 Explicit TE-Class
te-class 5 class-type 0 priority 5
te-class 6 class-type 0 priority 6
definition
te-class 7 class-type 0 priority 7
!
!

MAM MAM bandwidth


rsvp
constraints
interface TenGigE0/0/0/0
bandwidth mam max-reservable-bw 155000 bc0 100000 bc1 55000 Enable IETF DS-TE and
!
! use default TE-Class
mpls traffic-eng definition
interface TenGigE0/0/0/0
!
ds-te mode ietf Enable MAM
ds-te bc-model mam
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 92
Configuring DS-TE Tunnels
(Cisco IOS XR)
interface tunnel-te1 Signal tunnel-te1
description FROM-ROUTER-TO-DST1-CT0 with CT0 (priority
ipv4 unnumbered Loopback0
priority 5 5
and CT must match
signalled-bandwidth 100000 class-type 0 valid TE-Class)
destination 172.16.255.2
path-option 10 dynamic
!
interface tunnel-te2
description FROM-ROUTER-TO-DST1-CT1
ipv4 unnumbered Loopback0
priority 0 0
signalled-bandwidth 50000 class-type 1 Signal tunnel-te2
destination 172.16.255.2 with CT1 (priority
path-option 10 dynamic and CT must match
! valid TE-Class)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 93
Configuration for PCE-Initiated Tunnels
(Cisco IOS XR)
ipv4 unnumbered mpls traffic-eng Loopback0
! Source interface for tunnels
mpls traffic-eng
pce
peer ipv4 172.16.255.3
stateful-client PCE server
instantiation
delegation
Allow PCE-initiated LSP
!
!
auto-tunnel pcc
tunnel-id min 1000 max 5000 Range of tunnel-te interfaces for PCE
! initiated LSPs
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 94
Configuring Tunnel-based Admission Control
(Cisco IOS XE)
interface Tunnel1 Signaled bandwidth
ip unnumbered Loopback0
tunnel destination 172.16.255.2 RSVP local policy (200
tunnel mode mpls traffic-eng flows max, 1Mbps per
tunnel mpls traffic-eng autoroute announce flow max)
tunnel mpls traffic-eng priority 7 7
Maximum reservable
tunnel mpls traffic-eng bandwidth 100000
bandwidth
tunnel mpls traffic-eng path-option 10 dynamic
ip rsvp policy local default
Interface QoS policy
maximum senders 200
(DiffServ)
maximum bandwidth single 1000
forward all Maximum reservable
ip rsvp bandwidth 100000 bandwidth
!
interface GigabitEthernet3/3/0 Act as RSVP receiver
ip address 192.168.0.1 255.255.255.254 proxy on this interface
service-policy output OUT-POLICY
ip rsvp bandwidth percent 10 No RSVP flow
ip rsvp listener outbound reply classification
ip rsvp data-packet classification none
ip rsvp resource-provider none No RSVP flow queuing
!
ip rsvp qos Enable per-flow RSVP
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 95
Configuring Path Enhanced Protection
(Cisco IOS XE)
List of standby
mpls traffic-eng path-option list name PATH-LST
path-option 10 explicit name PE1-P3-P4-PE2
paths
path-option 20 explicit name PE1-P5-P6-PE2
path-option 30 explicit name PE1-P7-P8-PE2
!
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.255.2
tunnel mpls traffic-eng autoroute announce Use path list to
tunnel mpls traffic-eng path-option 10 explicit name PE1-P1-P2-PE2 protect primary
tunnel mpls traffic-eng path-option protect 10 list name PATH-LST path
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 96
Configuring Inter-Area Tunnels
(Cisco IOS XE)
mpls traffic-eng tunnels
!
interface Tunnel1 Loose-hop path
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 172.16.255.7
tunnel mode mpls traffic-eng Static route mapping
tunnel mpls traffic-eng path-option 10 explicit name LOOSE-PATH IP traffic to Tunnel1
!
ip route 172.16.255.7 255.255.255.255 Tunnel1
!
ip explicit-path name LOOSE-PATH enable List of ABRs as
next-address loose 172.16.255.3 loose hops
next-address loose 172.16.255.5
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 97
Configuring Inter-Area Tunnels with Autoroute
Destinations (Cisco IOS XE)
interface Tunnel1 Create static route
ip unnumbered Loopback0 to tunnel destination
tunnel mode mpls traffic-eng (172.16.255.7)
tunnel destination 172.16.255.7
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng path-option 10 explicit name LOOSE-PATH Loose-hop path
!
ip explicit-path name LOOSE-PATH enable
next-address loose 172.16.255.3 List of ABRs as
next-address loose 172.16.255.5 loose hops
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 98
Configuring Inter-Area Tunnels
(Cisco IOS XR)
explicit-path name LOOSE-PATH List of ABRs as
index 1 next-address loose ipv4 unicast 172.16.255.129 loose hops
index 2 next-address loose ipv4 unicast 172.16.255.131
!
interface tunnel-te1 Loose-hop path
description FROM-ROUTER-TO-DST3
ipv4 unnumbered Loopback0
destination 172.16.255.2
path-option 10 explicit name LOOSE-PATH
Static route
mapping IP traffic
!
to tunnel-te1
router static
address-family ipv4 unicast
172.16.255.2/32 tunnel-te1
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 99
Configuring Inter-AS Tunnels
(Cisco IOS XE)
mpls traffic-eng tunnels
Loose-hop path
!
interface Tunnel1
ip unnumbered Loopback0 Static route
no ip directed-broadcast mapping IP traffic to
tunnel destination 172.31.255.5 Tunnel1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 1000 List of ASBRs as
tunnel mpls traffic-eng path-option 10 explicit name LOOSE-PATH loose hops
!
ip route 172.31.255.5 255.255.255.255 Tunnel1
!
ip explicit-path name LOOSE-PATH enable
next-address loose 172.24.255.1
next-address loose 172.31.255.1
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 100
Configuring Inter-AS TE at ASBR
(Cisco IOS XE)
mpls traffic-eng tunnels Authentication key
!
key chain A-ASBR1-key
key 1
key-string 7 151E0E18092F222A
! Add ASBR link to TE
interface Serial1/0 topology database
ip address 192.168.0.1 255.255.255.252
mpls traffic-eng tunnels
mpls traffic-eng passive-interface nbr-te-id 172.16.255.4 nbr-igp-id ospf
172.16.255.4
Enable RSVP
ip rsvp bandwidth
ip rsvp authentication key-chain A-ASBR1-key
authentication
ip rsvp authentication type sha-1
ip rsvp authentication
!
router bgp 65024
no synchronization Process signaling from
bgp log-neighbor-changes
AS 65016 if FRR not
neighbor 172.24.255.3 remote-as 65024
neighbor 172.24.255.3 update-source Loopback0
requested and 10M or
neighbor 192.168.0.2 remote-as 65016
less
no auto-summary
!
ip rsvp policy local origin-as 65016
no fast-reroute
maximum bandwidth single 10000
forward all
!
BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 101
Configuring MPLS TE and LDP Simultaneously
(Cisco IOS XE)
Enable LDP
mpls label protocol ldp
mpls traffic-eng tunnels Enable MPLS TE
!
interface TenGigabitEthernet0/1/0
ip address 172.16.0.0 255.255.255.254 Enable MPLS TE on
mpls traffic-eng tunnels
interface
mpls ip Enable MPLS
ip rsvp bandwidth 155000 forwarding for IP
! (LDP)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 102
Configuring MPLS TE and LDP Simultaneously
(Cisco IOS XR)
rsvp Configuration mode
interface TenGigE0/0/0/0
for RSVP global and
interface commands
bandwidth 155000
!
! Configuration mode
mpls traffic-eng for MPLS TE global
interface TenGigE0/0/0/0 and interface
! commands
!
mpls ldp
interface TenGigE0/0/0/0
Configuration mode
!
for LDP global and
! interface commands

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 103
Configuring LDP Over a TE Tunnel
(Cisco IOS XE)
mpls label protocol ldp
Enable LDP
mpls traffic-eng tunnels
!
interface Tunnel1
ip unnumbered Loopback0
mpls ip Enable MPLS
tunnel destination 172.16.255.3 forwarding for IP
tunnel mode mpls traffic-eng (LDP) on Tunnel1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 10 dynamic
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 104
Configuring LDP Over a TE Tunnel (Cisco IOS XR)
interface tunnel-te1
ipv4 unnumbered Loopback0
priority 0 0
signalled-bandwidth 80000
autoroute announce
destination 172.16.255.130
path-option 10 dynamic
!
rsvp
interface TenGigE0/0/0/1
bandwidth 155000
!
!
mpls traffic-eng
Enable LDP
interface TenGigE0/0/0/1
!
!
mpls ldp
Enable LDP on
interface TenGigE0/0/0/0 tunnel-te1
!
interface tunnel-te1
!
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 105
MPLS TE on Ethernet Bundle (Cisco IOS XE)
Enable MPLS TE on this
interface Port-channel1 interface
ip address 172.16.0.0 255.255.255.254
mpls traffic-eng tunnels Attribute flags
mpls traffic-eng attribute-flags 0xF TE metric
mpls traffic-eng administrative-weight 20
ip rsvp bandwidth percent 100 Maximum reservable
bandwidth (100% of total
! bundle bandwidth)
interface GigabitEthernet2/0/0
no ip address LACP as channel protocol
channel-protocol lacp
channel-group 1 mode active Associate with Port-
! channel1 and enable
LACP (non-passive)
interface GigabitEthernet2/0/1
no ip address LACP as channel protocol
channel-protocol lacp
channel-group 1 mode active Associate with Port-
channel1 and enable
! LACP (non-passive)

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 106
MPLS TE on Ethernet Bundle (Cisco IOS XR)
interface Bundle-Ether1
Interface for bundle id 1
ipv4 address 172.16.0.1 255.255.255.254
!
interface GigabitEthernet0/1/0/0
bundle id 1 mode active
Associate with bundle id
negotiation auto 1 (Bundle-Ether1) and
! enable LACP (non-
interface GigabitEthernet0/1/0/1
bundle id 1 mode active passive)
negotiation auto
!
router ospf 172
area 0 Associate with bundle id
mpls traffic-eng
interface Bundle-Ether1
1 (Bundle-Ether1) and
network point-to-point enable LACP (non-
! passive)
interface Loopback0
passive enable
!
!
mpls traffic-eng router-id Loopback0 Enable OSPF on bundle
!
rsvp
interface Bundle-Ether1
bandwidth 2000000 Maximum reservable
! bandwidth on bundle
!
mpls traffic-eng
interface Bundle-Ether1
! Enable MPLS TE on
! bundle

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 107
Per-VRF Tunnel Selection (Cisco IOS XE)
ip vrf RED Loopback1
rd 65172:2 advertised as next
route-target export 65172:2 hop for VRF RED
route-target import 65172:2
bgp next-hop Loopback1
!
interface Loopback0
ip address 172.16.255.1 255.255.255.255
!
interface Loopback1
ip address 172.16.255.101 255.255.255.255
!
interface Tunnel1
description FROM-ROUTER-VRF-TO-DST1
ip unnumbered Loopback0 Remote next hop
tunnel destination 172.16.255.2 mapped to Tunnel1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 10 dynamic
!
ip route 172.16.255.102 255.255.255.255 Tunnel1
!

BRKMPL-2100 2017 Cisco and/or its affiliates. All rights reserved. Cisco Public 108