You are on page 1of 12

COMANDOS PARA CONFIGURAR SWITCH CISCO

El siguiente es un pequeo resumen sobre comandos para configurar un switch cisco y


algunos de router, espero que les sea til como lo es para m.

Rip
NewYork(config)#interface fastethernet0/0
NewYork(config-if)#ip address 192.168.50.129 255.255.255.192
NewYork(config-if)#ip rip send version 1
NewYork(config-if)#ip rip receive version 1
NewYork(config)#interface fastethernet0/1
NewYork(config-if)#ip address 172.25.150.193 255.255.255.240
NewYork(config-if)#ip rip send version 1 2

Show ip protocols
show interface interface
show ip interface interface
show running-config
Show ip rip database
OSPF
Router(config)#router ospf process-id
Router(config-router)#network address wildcard-mask area area-id

Router(config)#interface lookback 0
Router(config-if)#ip address 192.168.3.33 255.255.255.255

Rtr(config-if)# bandwidth 64
Rtr(config-if)# ip ospf cost 1562

Autenticacin sin md5


Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area-number authentication

Autenticacin con md5


Router(config-if)#ip ospf message-digest-key key-id encryption-type md5 key
Router(config-router)#area area-id authentication message-digest

Router(config-if)#ip ospf hello-interval seconds


Router(config-if)#ip ospf dead-interval seconds
debug ip ospf events
--aumentar la prioridad para elegir un router DR
sw(config)#interface fasethernet 0/0
sw(config-if)#ip osfp priority 50
sw(config-if)#end
EIGRP

Router(config)#router eigrp as-id


Router(config-router)#network 192.168.3.0
Router(config-router)#end
Router# show ip eigrp topology

eigrp log-neighbor-changes
resumen de rutas: router(config-router)#no auto-summary

Switch

Switch# dir flash:


Switch#show flash
Switch#show vlan

Switch#vlan database
Switch(vlan)#vlan vlan_number
Switch(vlan)#exit
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number
Switch#vlan database
Switch(vlan)#no vlan 300
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan vlan_number

Sw1#delete flash:vlan.dat
Sw1#erase startup-config
Sw1#reload

Interface web
Sw1(config)#ip http port 80

Ver la tabla MAC:


Switch#show mac-address-table (? Mas opciones)
Switch#clear mac-address-table

Asignar una mac estatica

Switch(config)#mac-address-table static interface FastEthernet vlan


Switch(config)#no mac-address-table static interface FastEthernet vlan
Seguridad de Puerto
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#switchport port-security ?(sale las opciones)

Limitar la cantidad de host por puerto


1900:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#port secure mas-mac-count 1

2950:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#switchport port-security maximum 1

Configuracion del Puerto que se desconecte cuando se produce una violacion de seguridad

Sw(config-if)#switchport port-security violation shutdown

2900xl:
Sw(config-if)#port security action shutdown

Poner Ip a la Vlan1

Catalyst 2950
Sw(config)#interface Vlan1
Sw(config-if)#ip address 192.168.1.2 255.255.255.0
Sw(config-if)#no shutdown

Sw(config)# ip default-gateway 192.168.1.1

Catalyst 1900
Sw(config)#ip address 192.168.1.2 255.255.255.0

Sw(config)# ip default-gateway 192.168.1.1

Archivos de configuracion

Sw# copy running-config startup-config

1900:
Sw#copy nvram tftp://tftp server ip add/destination_filename

COnfiguracion de la velocidad
Switch(config)#interface fastethernet 0/9
Switch(config-if)#duplex full
Switch(config-if)#speed 100

Crear el trunk del switch

Sw(config)#interface fastethernet 0/1


Sw(config-if)#swicthport mode trunk
Sw(config-if)#end

2900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

1900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end

Trunk en el router

Router(config)#interface fastethernet 0/0


Router(config-if)#no shutdown
Router(config-if)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1q vlan-number
Router(config-subif)#ip address.

router1#copy running-config tftp

Quitar un Puerto de una VLAN


Switch(config)#interface fasethernet 0/9
Switch(config-if)#no switchport access vlan 300

Eliminar una vlan

Switch#vlan database
Switch(vlan)#no vlan 300

Spanning tree
show spanning-tree
Configuracion de VTP
switch#vlan database
switch#vtp v2-mode

switch(vlan)#vtp domain password

switch#vtp {client | server | transparent}

Copiar el IOS a un server tftp

Sw#copy flash tftp

2900: sw#copy flash:nombre_del_archivo tftp

Copiar IOS desde un Server tftp


Sw#copy TFTP flash

Sw# copy Start tftp

1900: sw#copy nvram tftp://numero-ip/name

Sw#copy tftp startup-config

1900: sw#copy tftp://numero-ip/name nvram

Recuperar el acceso al switch

1. Apagar el switch, Vuelva a encenderlo mientras presiona el boton MODE en la parte


delantera del switch. Deje de presionar el boton MODE una vez que se apague el led de
STAT
2. introducir los siguientes comandos:
flash_init
load_helper
dir flash:
3. rename flash:config.text flash:config.old
4. reiniciar el sistema original:
4.1 despues de entrar al switch hacer: rename flash:config.old flash:config.text
4.2 sw#copy flash:config.text system:running-config
4.3 Cambiar los password

Actualizar el firmware

Sw#show boot (muestra el archive de boteo)


Cambiar el nombre del archivo de la ios,con el commando #rename flash:nombre
flash:Nuevo_nombre

Sw(config)#no ip http Server


Sw# delete flash:html/*

Extraer la nueva version del IOS

Sw#archive tar /x tftp://192.168.1.3/nombre_del_archivo.tar flash:


Sw(config)#ip http Server
Sw(config)#boot system flash:nombre.bin

Spanning-Tree

#show spanning-tree brief


Cambiar prioridad: ios 12.0 sw(config)#spanning-tree priority 1
sw(config)#exit

ios 12.1 sw(config)#spanning-tree vlan 1 priority 4096


sw(config)#exit

Configurar VLAN

Sw#vlan database
Sw(vlan)#vlan 2 name Logistica
Sw(vlan)#vlan 3 name Licitaciones
Sw(vlan)#end

1900:
Sw#config terminal
Sw(config)#vlan 2 name VLAN2
Sw(config)#vlan 3 name VLAN3

Configurar puertos en las VLAN

Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan2
Sw(config-if)#end

Elminar el Puerto de la vlan


Sw(config-if)#no switchport access vlan2
Sw(config-if)#end
1900:
Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#vlan static 2

Para eliminar un Puerto de la vlan


Sw(config-if)#no vlan-membership 2

Sw#show vlan
Sw#show vlan id 2

1900: Show vlan-membership


Show vlan 2

Eliminar un vlan

Sw#valn database
Sw(vlan)#no vlan 3
Sw(vlan)# exit

1900: sw(confgi)# interface ethernet 0/7


sw(confgi)#no vlan 3

enlacen troncal ISL

sw(Config.)#interafce fastethernet 0/1


sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation isl
sw(Config-if)#end
enlace troncal 802.1q

2950: por defecto dotiq


sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk

2900:
sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation dot1q

Vtp , servidor y cliente

Sw# Vlan database


Sw(vlan)# vtp server
Sw(vlan)# vtp domain group1
Sw(vlan)# exit

Sw# Vlan database


Sw(vlan)# vtp client
Sw(vlan)# vtp domain group1
Sw(vlan)# exit

Ruteo entre VLAN

Poner el encapsulamiento en las subinterfaces del router

(config-if)#interface fastethernet 0/0.1


(config-subif)#encapsulation dot1q 1 (1 es la vlan a la que esta)

Escrito por lgonzalez el 23/01/2008 16:53 | Comentarios (0)

Configuracin de EtherChannel

EtherChannel maneja dos protocolos:

Port Aggregation Control Protocol (PAgP, propietario de Cisco) [1].


Link Aggregation Conrol Protocol (LACP, IEEE 802.3ad) [2].
Los protocolos ya mencionados son incompatibles.

Los modos de configuracin son:

on: en este modo, un EtherChannel til existe si dos grupos de puertos en modo on estn
conectados entre s. En este modo no existe trfico de negociacin.
auto: modo PAgP que coloca un puerto en estado de negociacin pasiva, slo responde a
los paquetes PAgP.
desirable: modo PAgP que coloca un puerto es estado de negociacin activa, es decir, el
puerto inicia el envo de paquetes PAgP a otros puertos LAN.
pasive: modo LACP que pone a un puerto en modo pasivo de negociacin, slo recibe
paquetes LACP.
active: modo LACP que coloca a un puerto en modo activo de negociacin.

Ejemplos:

1) Tenemos dos switches, SW1 y SW2, de la misma marca (Cisco), cuyas interfases Fast
Ethernet 0/1 y 0/2 de cada switch sern configurados como EtherChannels en modo trunk,
dentro de la VLAN 99 (para esto, los puertos 0/1 y 0/2 deben estar en la VLAN 99).
SW1#config t
SW1(config)#int range fast 0/1 2
SW1(config-if)#no switchport mode access
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk native vlan 99
SW1(config-if)#channel-group 2 mode active // El rango de nmero asignado a un grupo
EtherChannel es de 1 64
SW1(config-if)#end

SW2#config t
SW2(config)#int range fast 0/1 2
SW2(config-if)#no switchport mode access
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk native vlan 99
SW2(config-if)#channel-group 2 mode pasive
SW2(config-if)#end

* Nota: En caso los puertos se encuentren en la VLAN nativa por defecto (VLAN 1), se
pueden omitir las lneas de color negro.

2) Configuraremos un switch SW3 para crear un EtherChannel PAgP y asociarlo a la


VLAN 5. Tomarenos cuatro interfases Gigabit Ethernet, 0/1 al 0/4.

SW3#config t
SW3(config)#interface range gigabitethernet 0/1 4
SW3(config-if)#switchport mode access
SW3(config-if)#switchport access vlan 5
SW3(config-if)#channel-group 3 mode desirable
SW3(config-if)#end

3) Ahora realizaremos una configuracin de Capa 3 para el switch SW3 del ejemplo
anterior, asignndole una direccin IP.

SW3#config t
SW3(config)#interface port-channel 3
SW3(config-if)#no switchport //Este comando funciona para switches multicapas, el cual es
para entrar a configuracin de Capa 3
SW3(config-if)#ip address 192.168.20.10 255.255.255.0
SW3(config-if)#end

4) Ahora, si ya tenemos un EtherChannel, conformado por Fast Ethernets, ya configurado


en el switch SW4 y queremos agregar una interfase ms a ese puerto, debemos configurarlo
de la siguiente manera:

SW4#config t
SW4(config)#interface range fast 0/6 7
SW4(config-if)#no ip address
SW4(config-if)#channel-group 4 mode desirable
SW4(config-if)#end

5) Para configurar un switch con EtherChannel y agregarle balanceo de cargas, basta con
seguir las siguientes lneas:

SW5#config t
SW5(config)#port channel load-balance {dst-mac | src-mac} // balanceo por MAC address
destino u origen, respectivamente. Por defecto src-mac
SW5(config)#end

* Comandos de control EtherChannel

#show etherchannel X port-channel


#show interface {fastethernet | gigabitethernet} X/X etherchannel
#show etherchannel load-balance

Escrito por lgonzalez el 19/05/2011 01:01 | Comentarios (0)

Cambiar las password en los switches CISCO Catalyst 2900XL, 3500XL,


2950, 3550

Tutorial de cmo truncar las password en los switches CISCO Catalyst 2900XL, 3500XL,
2950, 3550 y conmutadores de la serie. Recuerden hacerlo con un buen fin XD jaja.

Paso a paso:

1) Conecte un terminal o un PC con un emulador de terminal (por ejemplo, Hyper


Terminal) para el puerto de consola del conmutador

2) Sino recuerda la configuracin de Hyperterminal, esta debe ser:

Bits por segundo (baudios): 9600


Bits de datos: 8
Paridad: Ninguno
Bits de parada: 1
Control de flujo: Xon / Xoff

3) Desconecte el cable de alimentacin.

4) Mantenga pulsado el botn de modo situado en la parte izquierda del panel frontal,
mientras que reconectas el cable de alimentacin al conmutador.
Para 2900/3500XL y conmutadores 3550 Series: liberar el botn de modo despus de que el
LED por encima de 1x Puerto sale.
Para 2950 la Serie interruptores: liberar el botn de modo STAT despus de que el LED se
apaga
Dependiendo el modelo del switch la imagen puede cambiar un tanto:

Las instrucciones que aparecen:


Los siguientes comandos se inicializa el sistema de archivos flash, y termina de cargar el
software del sistema operativo: flashinit loadhelper interruptor de arranque:! --- Este
producto es de un switch 3500XL.
Producto de una 2900XL, 2950 o 3550 puede variar ligeramente.

5) Ejecute el comando flash_init


Switch: Flash flash_init Inicializando flashfs [0]: 143 archivos, 4 directorios flashfs [0]:
0 hurfanos archivos, 0 directorios que han quedado hurfanos flashfs [0]: Total bytes:
3612672 flashfs [0]: Bytes utilizados: 2729472 flashfs [0]: Bytes disponibles: 883200
flashfs [0]: flashfs fsck tom 86 segundos .... hecho Inicializacin de Flash Del sector de
arranque del sistema de archivos (bs:) instalado, fsid: 3 Parmetro Bloque del sistema de
archivos (pb:) instalado, fsid: 4 interruptor:! --- Este producto es de un switch 2900XL.
Producto de una 3500XL, 3550 o 2950 puede variar ligeramente.

6) Ejecute el comando load_helper


7) Ejecute el comando dir flash: (los : son importantes). Se desplegara el sistema de
archivo

8) Cambie el nombre de flash: config.text a flash: config.old a cambiar el nombre del


archivo de configuracin. Esto es porque config.text es donde quedo la contrasea que se
establecio, entonces lo cambiamos por config.old, para dejarlo de fabrica.

9) Ejecutamos comando boot, iniciamos todo normalmente, podremos entrar a modo


Enable. Entramos a modo enable

10) Ahora debemos renombrar de nuevo el archivo que cambiamos anteriormente. (esto fue
lo que nos permitio entrar)
Switch# rename flash:config.old flash:config.text

11) Copie el archivo de configuracin en la memoria:


Switch# copy flash:config.text system:running-config Destination filename [running-
config]?

Que hicimos? Renombramos un archivo que contenia la password anterior, lo cambiamos


por el de fabrica para entrar, ahora que estamos dentro de enable, tenemos que cargar el
anterior para sacar la clave, sino cada ves que deseemos entrar al switch tendremos que
hacer lo mismo. Entonces, debemos volver a renombrar el archvio de configuracin para
eliminar definitivamente cualquier password.
Ahora estamos dentro del switch como si hubiesemos conocido la clave.
Ultimo paso

12) Cambiar la clave:


Nos metemos a configure Terminal, y ejecutamos comando NO enable secret, para
asegurarnos que no haya clave secreta. Y luego enable password clave nueva Hacemos en
WR para guardar y listo.

Escrito por lgonzalez el 19/05/2011 01:07 | Comentarios (0)