You are on page 1of 18

UNIVERSIDAD NACIONAL

SANTIAGO ANTÚNEZ DE MAYOLO

FACULTAD DE INGENIERÍA DE MINAS, GEOLOGÍA Y METALURGIA

RESOLUCION DE PROBLEMAS CON EL USO DEL


SOFTWARE “PSEINT”

ASIGNATURA: LENGUAJE DE PROGRAMACION DE INGENIERIA

PRESENTADO POR:

 APARICIO LLIUYA Rober.

 CERNA IBAÑEZ Yair.

 SOLANO LLIUYA David.

Huaraz, Junio del 2017


RESOLUCION DEL PROBLEMA 01

Algoritmo PROBLEMA_01
//HALLAR EL VOLUMEN DE UNA CAJA DADO SUS 3 LADOS
Escribir "INTRODUZCA LOS LADOS DE LA CAJA"
Escribir ""
Leer A
Leer B
Leer C
Si A*B*C<0 Entonces
Escribir "NUMEROS NO VALIDOS"
Sino
Escribir "TECLA PARA CONTINUAR"
Esperar Tecla
Limpiar Pantalla
V<-A*B*C
Escribir "EL VOLUMEN DE LA CAJA ES = " V
Fin Si
FinAlgoritmo
RESOLUCION DEL PROBLEMA 02

Algoritmo PROBLEMA_02
//CAMBIO QUE RECIBIRA UN COMPRADOR
Escribir "INGRESE EL PRECIO DEL PRODUCTO"
Leer P
Escribir ""
Escribir "INGRESE EL MONTO RECIVIDO POR EL CLIENTE"
Leer P1
Si P1<P Entonces
Escribir "EL DINERO ES INSUFICIENTE"
Sino
C<-(P1-P)
Escribir "SU CAMBIO ES DE " C " NUEVOS SOLES"
Fin Si
FinAlgoritmo
RESOLUCION DEL PROBLEMA 03

Algoritmo PROBLEMA_03
//PROMEDIO PONDERADO DE UN ESTUDIANTE
Escribir "INGRESE LA NOTA DE CADA EXAMEN"
Leer E1
Leer E2
Leer E3
Leer E4
Escribir ""
Escribir "INGRESE EL FACTOR DE PONDERACION A USAR"
Leer F
P<-(E1*F+E2*F+E3*F+E4*F)/ (F+F+F+F)
Escribir ""
Escribir "EL PROMEDIO DE NOTAS ES: " P
FinAlgoritmo
RESOLUCION DEL PROBLEMA 04

Algoritmo PROBLEMA_04
//COSTO DE UN TERRENO CON FORMA TRAPESOIDAL
Escribir "INTRODUZCA LOS DATOS SOLICITADOS"
Escribir ""
Escribir "BASE 1"
Leer B
Escribir "BASE 2"
Leer b
Escribir "ALTURA"
Leer H
Limpiar Pantalla
Si B*b*H<0 Entonces
Escribir "DATOS INVALIDOS"
Sino
A<-(B+b)*H/2
Escribir "EL AREA DEL TERRENO ES : " A " METROS
CUADRADOS"
Fin Si
Escribir ""
Escribir "INTRODUZCA EL PRECIO DE UN METRO CUADRADO"
Leer P
C<-P*A
Escribir ""
Escribir "EL COSTO DEL TERRENO ES: " C " DOLARES"
FinAlgoritmo
RESOLUCION DEL PROBLEMA 05

Algoritmo PROBLEMA_05
//REMUNERACION POR LITRO DE LECHE VENDIDA
Escribir "INTRODUCIR LA PRODUCCION DE LECHE DEL DIA, GALONES"
Leer C
Escribir "INTRODUZCA EL PAGO QUE RECIBIO POR SU PRODUCCION"
Leer C1
CL<-C1/(C*3.785)
Escribir ""
Escribir "HA RECIBIDO " entero CL " NUEVOS SOLES/LITRO"
FinAlgoritmo

RESOLUCION DEL PROBLEMA 06

Algoritmo problema_06
//PAGO DE UN TRABAJADOR EN BASE A LAS HORAS TRABAJADAS
Escribir "6 DIAS DE TRABAJO A LA SEMANA"
Escribir ""
Escribir "INTRODUZCA EL MONTO QUE PAGA POR HORA DE TRABAJO"
LEER P
Limpiar Pantalla
Escribir "INTRODUZCA LAS HORAS DE TRABAJO POR DIA"
Para K<-1 Hasta 6 Con Paso 1 Hacer
Leer H
S<-S+H
Fin Para
PA<-S*P
Limpiar Pantalla
Escribir "SUELDO DE LA SEMANA DEL TRABAJADOR: " PA " NUEVOS
SOLES"
FinAlgoritmo
RESOLUCION DEL PROBLEMA 07

Algoritmo PROBLEMA_07
//MONTO QUE DEBEN PAGAR POR METRO CUBICO
Escribir "INDRODUZCA LAS DIMENSIONES DEL CUBO"
Escribir "ANCHO"
Leer A
Escribir "LARGO"
Leer L
Escribir "ALTO"
Leer H
V<-H*L*A
Limpiar Pantalla
Escribir "VOLUMEN TOTAL = " V " METROS CUBICOS"
Escribir ""
P<-V*3.45
Escribir "PRECIO A PAGAR: " P " NUEVOS SOLES"
FinAlgoritmo
RESOLUCION DEL PROBLEMA 08

Proceso EJEMPLO_8
ESCRIBIR "LOS DATOS DE KILOMETROS RECORRIDOS Y PAGO POR
BOLETO"
LEER KR, CKR
ESCRIBIR " ESCRIBA LOS KILOMTROS A RECORRER"
LEER KR
ESCRIBIR " ESCRIBA EL COSTO POR KILOMETRO”
LEER CKR
PV<- KR*CKR
ESCRIBIR " EL PRECIO DEL BOLETO EN SOLES ES = " PV
FinProceso
RESOLUCION DEL PROBLEMA 09

Algoritmo PROBLEMA_09
//PRECIO FINAL DE UN ARTICULO
Escribir "INDRODUZCA EL PRECIO DEL ARTICULO"
Leer P1
Escribir ""
Escribir " DESCUENTO A APLICAR SOBRE EL ARTICULO %"
Leer D
P2<-(P1-(P1*D/100))
P3<-(P2+(P2*18/100))
Limpiar Pantalla
Escribir ""
Escribir "PRECIO DEL ARICULO CON DESCUENTO: " P2 " NUEVOS
SOLES"
Escribir ""
Escribir "PRECIO FINAL A PAGAR POR EL ARTICULO: " P3 " NUEVOS
SOLES"
FinAlgoritmo
RESOLUCION DEL PROBLEMA 10

Algoritmo PROBLEMA_10
//MONTO A PAGAR POR K LAPICES
Escribir "INTRODUZCA LA CANTIDAD DE LAPICES A VENDER"
Escribir ""
Leer K
Escribir ""
Si K>=1000 Entonces
C<-K*85
Escribir "EL MONTO A PAGAR ES DE: " C " NUEVOS SOLES"
Sino
C1<-K*101
Escribir "EL MONTO A PAGAR ES DE: " C1 " NUEVOS SOLES"
Fin Si
FinAlgoritmo
RESOLUCION DEL PROBLEMA 11

Algoritmo PROBLEMA_11
//PRECIO A PAGAR POR UN TRAJE
Escribir "INTRODUCIR EL PRECIO DEL TRAJE A VENDER"
Leer P
Escribir ""
Si P>500 Entonces
P1<-(P-(P*12/100))
Escribir "MONTO A PAGAR POR EL TRAJE: " P1 " NUEVOS SOLES"
Sino
P2<-(P-(P*6/100))
Escribir "MONTO A PAGAR POR EL TRAJE: " P2 " NUEVOS SOLES"
Fin Si
Escribir ""
FinAlgoritmo
RESOLUCION DEL PROBLEMA 12

Algoritmo PROBLEMA_12
//PRESUPUESTO A PRESENTAR PARA LOS CLIENTES
Escribir "INTRODUZCA EL NUMERO DE PERSONAS DEL BANQUETE"
Leer N
Escribir ""
Si N>200 Entonces
Si N<=300 Entonces
C<-N*55
Escribir "PRESUPUESTO DEL BANQUETE: " C " NUEVOS
SOLES"
Sino
C1<-N*35
Escribir "PRESUPUESTO DEL BANQUETE: " C1 " NUEVOS
SOLES"
Fin Si
Sino
C2<-N*75
Escribir "PRESUPUESTO DEL BANQUETE: " C2 " NUEVOS SOLES"
Fin Si
Escribir ""
FinAlgoritmo