You are on page 1of 9

Facultad de Ingeniería de Sistemas y Electrónica

Escuela de Ingeniería de Sistemas

Guía de Practica No. 01

Curso : Principios de Algoritmos

Contenido
I. OBJETIVOS ........................................................................................................................................2
II. ESPECIFICACIÓN DEL EJERCICIO .......................................................................................................2
2.1. Enunciado del problema ..........................................................................................................2
III. DESARROLLO DE LA SOLUCION ....................................................................................................3
3.1. Descripción de la solución (explicación) ..................................................................................3
3.2. Desarrollo de la solución en pseudocodigo .............................................................................4
3.3. Pantalla de PSeInt con el Pseudocódigo ..................................................................................6
3.4. Resultado del ejercicio .............................................................................................................7
IV. EJERCICIOS PROPUESTOS .............................................................................................................8

Página 1|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

I. OBJETIVOS
 El alumno analiza cada una de las etapas en el desarrollo de un algoritmo.
 Desarrollo de algoritmos repetitivos.

II. ESPECIFICACIÓN DEL EJERCICIO

2.1. Enunciado del problema

Una empresa vende licencias de un programa a los precios dados en la siguiente tabla:

Versión Precio
Estudiante S/. 90.0
Profesional S/. 120.0
Empresarial S/. 150.0

Como oferta especial la empresa aplica un porcentaje de descuento sobre el importe de la


compra de acuerdo a la siguiente tabla:

Cantidad de licencias Descuento


<5 11%
≥ 5 𝑦 < 10 13%
≥ 10 14%

Diseñe un programa que permita efectuar ventas y muestre luego de cada una de ellas la
siguiente información:

 El importe de la compra
 El importe del descuento
 El importe a pagar
 La cantidad de licencias vendidas de cada tipo entre todas las ventas.
 El importe total acumulado de todas las ventas

Página 2|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

III. DESARROLLO DE LA SOLUCION

3.1. Descripción de la solución (explicación)

Datos de Entrada Proceso Salida

 Cantidad de  Validar Cantidad de ventas (mientras)  Importe compra (ic)


ventas(cv)  Validar cantidad licencias (mientras)  Importe descuento
 Cantidad de  Validar y seleccionar el tipo de versión desc (tr)
licencias (cl) (mientras). Asignar el precio y contar las  Importe a Pagar(ip)
 Indique el licencias según la versión.  Cantidad licencias
Tipo versión  Calcular el importe de compra igual a la estudiante(cles)
(tv) cantidad de licencias por el precio  Cantidad licencias
 Evaluar el rango de cantidad de licencias profesional(clpr)
con la ayuda de >=, <= para Asignar el  Cantidad licencias
descuento. empresarial(clem)
 Calcular el importe de descuento igual al  Importe total a
importe de compra por el descuento. pagar(itp)
 Calcular el importe a pagar igual importe
de compra menos el importe de
descuento.
 Acumular el importe total a pagar.

Página 3|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

3.2. Desarrollo de la solución en pseudocodigo

Proceso ejemploRepetitivo01Guia01
definir cv,n,sw,cles,clpr,clem, cl, tv Como Entero
definir desc,itp,idesc,precio,ic,ip como real
cv<-0
mientras cv<=0 hacer
escribir "Cantidad de Ventas"
leer cv
fin mientras
n<-1
cles<-0
clpr<-0
clem<-0
itp<-0
Mientras n<=cv Hacer
escribir "Venta nro : ",n
cl<-0
mientras cl<=0 Hacer
escribir "cantidad de licencias "
leer cl
Fin Mientras
tv<-0
mientras tv<=0 hacer
escribir "Ingrese versión [1]Estudiante, [2]Profesional, [3]Empresarial "
leer tv
Segun tv Hacer
1:
precio<-90
cles<-cles+cl
2:
precio<-120
clpr<-clpr+cl
3:
precio<-150
clem<-clem+cl
De Otro Modo:
escribir "error en la version"
tv<-0
Fin Segun
Fin Mientras
ic<-cl*precio
si cl<5 entonces
desc<-0.11
sino si cl<=10 entonces
desc<-0.13
Sino
Página 4|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

desc<-0.14
FinSi
FinSi
idesc<-desc*ic
ip<-ic-idesc
itp<-itp+ip
escribir "importe de la compra ",ic
escribir "importe del descuento ",idesc
escribir "importe a pagar ",ip
n<-n+1
fin mientras
escribir "Cantidad de licencias version estudiante ",cles
escribir "Cantidad de licencias version profesional ",clpr
escribir "Cantidad de licencias version empresarial ",clem
escribir "Importe total de ventas acumulado ",itp

FinProceso

Página 5|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

3.3. Pantalla de PSeInt con el Pseudocódigo

Página 6|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

3.4. Resultado del ejercicio


 Se muestran pantallazos con la solución obtenida.

Página 7|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

 Pantalla de PSeInt con error de ingreso en los datos

IV. EJERCICIOS PROPUESTOS


4.1. Diseñe un programa que permita registrar la cantidad de pasajeros que pasan por un peaje
en ómnibus, minivans y combis. Por cada vehículo se ingresará el tipo de vehículo y la
cantidad de pasajeros y el turno (mañana, tarde y noche)

Vehículo Peaje
Ómnibus S/. 15
Minivan S/. 8
Combi S/. 10

 El total de peajes por turno


 El total de peajes por vehículo
 La cantidad de vehículos por tipo
 El promedio total de los peajes

Página 8|9
Facultad de Ingeniería de Sistemas y Electrónica
Escuela de Ingeniería de Sistemas

4.2. En una feria educativa, se realiza una encuesta a todas las personas se acerquen al stand,
en un proceso repetitivo se registra la edad de cada persona, sexo y el grado de instrucción
(Primaria, Secundaria y Superior). Se necesita calcular:

 La mayor edad de todos


 El promedio de edades en las personas con instrucción Primaria
 El promedio de edades en las personas con instrucción Secundaria
 El promedio de edades en las personas con instrucción Superior
 La cantidad de personas del sexo masculino y femenino
El proceso repetitivo debe terminar cuando la edad ingresada sea cero o negativo.

4.3. Un supermercado ha puesto en oferta la venta de postres a los precios dados en la


siguiente tabla:
Postre Precio
Flan Royal S/. 2.8
Pudín Royal S/. 3.7
Gelatina Royal S/. 4.8

Como oferta especial la tienda aplica un porcentaje de descuento sobre el importe de la


compra de acuerdo a la siguiente tabla:

Cantidad de postres Descuento


≥ 12 13%
≥ 8 𝑦 < 12 11%
≥4 𝑦<8 9%
<4 7%

Diseñe un programa que permita efectuar ventas y muestre luego de cada una de ellas
la siguiente información:

 El importe de la compra
 El importe del descuento
 El importe a pagar
 La cantidad de postres vendidos de cada tipo entre todas las ventas
 La cantidad de ventas efectuadas de cada tipo de postre entre todas las ventas
 El importe total acumulado de cada tipo de postre entre todas las ventas

Página 9|9