Excel – Entrada de dados duplicados.Validação. Função CONTAR.

SE() Será que é possível arranjar um aviso de cada vez que se colocar informação duplicada numa coluna.

Ex : Numa folha de Excel com uma tabela onde apliquei filtros nas colunas. A B 1 12456 José 2 12354 Maria 3 12456 Manuel Portanto, ao introduzir o nº em A3 aparecer um aviso de que aquele numero já estava escrito. O que se pretende será, então o seguinte:

Para obter o resultado, podemos optar pela denominada “Validação de Dados” e criar uma fórmula que nos permita saber se o valor digitado já consta no Range estabelecido e, nesse caso, apresentar a mensagem de aviso. Seguem-se os passos a dar: 1. Marca-se o Range pretendido. No caso do exemplo, o Range será A1:A3, devendo iniciar-se a marcação sempre na célula de numeração mais baixa (ex: A1); 2. De seguida, clica-se no menu “DADOS” e escolhe-se o item “Validação de Dados”. 3. De seguida, escolhe-se o tabulador “Definições. É aqui que iremos escolher o critério de validação, no exemplo: “Personalizar” e inserirmos a fórmula: =CONTAR.SE($A$1:$A$3;A1)=1

Formador:

VÍTOR PINTO

Excel Avançado – Dicas e Truques

[1]

4. Depois, para termos o aviso de erro, escolhemos o tabulador com o mesmo nome

Assim, se digitarmos o valor duplicado em A3, irá aparecer a mensagem acima apresentada. De notar que, na mensagem há duas opções relevantes: Ou para continuar (SIM) ou para não continuar (NÃO). Se clicar,os em SIM:

Formador:

VÍTOR PINTO

Excel Avançado – Dicas e Truques

[2]

o resultado será o da aceitação do valor duplicado

Se for NÃO, o resultado será a activação da célula em causa, para permitir a correcção

Excel – As funções SE() e OU() Numa coluna tenho várias leituras, uma por cada dia: Dia Leitura Consumo Dia 150 160 10 165 5

1 2 3

O "problema" é que depois posso ter dia(s) sem leituras e isso baralha as contas do consumo: Dia Leitura Consumo Dia 150 160 10 165 5 -165 180 180
Excel Avançado – Dicas e Truques [3]

1 2 3 4 5

Formador:

VÍTOR PINTO

se. A coluna B. como sendo a leitura do final do mês anterior. no dia 3 a leitura for zero (0) ou sem valor (como no dia 8). sendo o consumo do dia igualmente zero (0). por exemplo. será a coluna onde serão inseridos os valores correspondentes às leituras diárias. procurou-se criar uma tabela na coluna E (a partir de E2). Então. 162). que será sempre superior ao valor acumulado. como segue: Esta tabela.Existe alguma maneira "simples" de dar a volta à questão? É que posso ter um dia ou vários sem serem preenchidos (a solução básica é dizer ao utilizador quando não há leitura para copiar a anterior mas estava a ver se conseguia dar a volta à questão). a tabela terá que reflectir que o valor acumulado se mantém o mesmo do(s) dia(s) anterior(es) (no exemplo. iniciando em E2. serve para ir dando os valores acumulados diariamente. na coluna E. no dia 4. ao fazerse uma leitura. Bom. o que se pretende é: Para se conseguir este efeito. Assim. irá dar um valor de Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [4] . reflectido na coluna C (Consumo/Dia). a partir dos dados inseridos na coluna B (Leitura).

”P”) e se existir algum “P” no range E5:K5. se incorporarmos o “T” e o “L”.B3-E2) Na coluna E.B3=0). com a fórmula adequada ao resultado pretendido.consumo igual à diferença entre o último dia com consumo e o presente (no exemplo. de 162.SE(E5:K5. começando em C3 e depois copiando a fórmula até ao dia pretendido (normalmente 30 ou 31 – no exemplo. começando em E3 e depois copiando a fórmula até ao dia pretendido (normalmente 30 ou 31 – no exemplo.-(B3-E2). 8).0. “T” e “L”? Vejamos o exemplo: O resultado será 2. a célula é contada.B3) Excel – Somar sob determinados critérios “ Se eu digitar a seguinte fórmula numa célula = CONTAR. passando. Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [5] . E se eu quiser contar nesse mesmo range as células que contenham “P”. Mas. Agora. apenas até C12 – dia 10): =SE(OU(E2=FALSO. Novamente o exemplo. na tabela de referência. para 170 (162 + 8 = 170). apenas até E12 – dia 10): =SE(B3=0. o resultado será 4. vamos às fórmulas necessárias para se conseguir o resultado pretendido: Na coluna C. assim.

se pretendermos ter a soma(A5:A15) sem termos o segmento do range “A15”. podemos digitar o seguinte.Excel – Localizar e Substituir “ Preciso saber como alterar o conteúdo de um conjunto de células mas tenho a seguinte dificuldade: Numa célula ou em várias tenho. se pretendermos utilizar o “Localizar e Substituir”: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [6] . por exemplo em E5: =SOMA(A5:INDIRECTO(E200)) O resultado esperado seria 14. teremos que nos socorrer de algum expediente. Agora. para obtermos o componente Range “A15”. na célula E200: ="A"&14+1. mas sim. Assim. em sua substituição. quero alterar o "5" para "6" passando a ter =soma(a6:a15) e o que obtenho é =soma(a6:a16). sem que o mesmo possa ser alterado quando estamos a efectuar a substituição do algarismo “5”. por exemplo. apesar de não ter nenhum algarismo “5”: Então. digitaríamos. o conteúdo de E200 (que será A15). como posso apenas alterar o primeiro "5" sem mexer no segundo "5"?” Para obstar tal situação. o que irá mostrar o conteúdo da célula como “A15”. por exemplo =soma(a5:a15).

o mesmo que SOMA(A6:A15). o resultado esperado: 13 Ou seja.. Alguém pode ajudar?” Vejamos o exemplo dado: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [7] . quando for para substituir "fórmulas" (em Opções>>).Teríamos. Excel – Formatação de células “Copiei uma tabela da Net e na coluna que tem 1-1 ou 1-2 o Excel assume como um de Janeiro e um de Fevereiro respectivamente. para que fique na forma original.. de 5 para 6. ele coloca um numero 32 mil e qualquer coisa. então. vai dar o resultado que se teria com a alteração da fórmula para =SOMA(A6:INDIRECTO(E200)). Quando tento formatar a célula para texto. ou seja.

copiando-a até B3: =TEXTO(A1. foi colocada a questão de encontrar uma data que esteja entre a Data inicial e a Data final (por exemplo. 1-1. nas células B1. para ultrapassarmos a situação e para que consigamos ter."d-m") Excel – As Funções SE(). A2 e A3. irá aparecer o seguinte: Então. por exemplo. 1-2 e 1-3. ARRED() e PROCV() Ainda a propósito do post anterior. A imagem do que se pretende: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [8] . B2 e B3. respectivamente os dados pretendidos a partir do conteúdo das células A1. para que fique assim: Devemos construir a seguinte fórmula em B1. 14/03/2007-11/05/2008) e depois partir daí para a contagem dos dias até à data final (que poderá estar também entre uma data inicial e final mais abaixo).Se tentarmos formatar as células como texto. ou seja.

$A$2:$C$4.1107 = 55.E2 Resultado pretendido: De 14/03/2007 a 30/06/2007 . teremos: Em F2:=SE(D2="".2)) Em F4:=SE(D4="".ARRED(C4*((B4A4)+1)/365*$E$2.2). Assim. Campos a preencher: .50 -------------------------------------------------.ARRED(PROCV(D2.1058 = 31.60 De 01/07/2007 a 31/12/2007 .2)) Em F3:=SE(D3="".Capital (será 1000) .$A$2:$C$4.184 dias à taxa de 0.D2 .ARRED(PROCV(D4. com a utilização da função PROCV().2)) Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [9] .3)*((D4A4)+1)/365*$E$2.ARRED(C3*((B3A3)+1)/365*$E$2.Total de juros: 127.2).2).132 dias à taxa de 0.Ou seja.3)*((B3D3)+1)/365*$E$2.1120 = 40.$A$2:$C$4.Data de início (será 14/03/2007) .3)*((B2D2)+1)/365*$E$2.90 Então.ARRED(PROCV(D3.Data de fim (será 11/05/2008) -D4 .ARRED(C2*((B2A2)+1)/365*$E$2. poderemos chegar ao resultado pretendido.80 De 01/01/2008 a 11/05/2008 .109 dias à taxa de 0.

"". fizeram-me a seguinte pergunta (adaptada): ". por exemplo: tenho 5 cortes com 112."". escolher valores cuja soma fosse o mais perto possivel dos 6 metros. a mensagem ao utilizador fosse por exemplo: de uma barra cortas 5 com 112 e uma com 30." Bom.Excel . cortar as 5 barras da medida 112. 1 com 30. vejamos a imagem da possível resolução do problema: As fórmulas: Em E5: =ARRED.ARRED.0)) Em E7: =SE(C7="". isto é.. aceitando a alteração..BAIXO((I6/C7). e se não quisermos."".A Função ROUNDDOWN() ou ARRED.PARA.PARA.. no exemplo. harmonizar o número de cortes relativos às outras medidas? Vejamos então.BAIXO((I5/C6)."".PARA. 2 com 4 etc etc..ARRED.0)) Em I5: =C1-(C5*E5) Em I6: SE(C6="".I6-(C7*E7)) Mas.BAIXO() Por mail..PARA. mas apenas 4? Como faríamos para. as barras têm 6 metros e a intenção era tirar o maior aproveitamento no corte.BAIXO((C1/C5).I5-(C6*E6)) Em I7: SE(C7="".gostava de incluir a informação ao utilizador quais as medidas a cortar de uma barra para maior aproveitamento. na outra cortas tantas com tanto e outras ou outra com tanto etc.0) Em E6: =SE(C6="". para as sobras serem o menor possivel. o exemplo do que agora referi: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [10] .

SE(C6="".1107 0.132 dias à taxa de 0. é possível obter o valor dos juros na totalidade.""."".80 De 01/01/2008 a 11/05/2008 . Eu pretendia obter no final valores parcelares. entre as datas indicadas aplicam-se as taxas que estão à frente.1058 0."".1107 = 55.184 dias à taxa de 0.C1-(C5*E5).50 “ Representemos então. assim: De 14/03/2007 a 30/06/2007 .1058 = 31."".SE(C7="".I5(C6*F6))) Em I7: =SE(F7="". A 1 01/01/07 2 01/07/07 3 01/01/08 4 01/07/08 B 30/06/07 31/12/07 30/06/08 31/12/08 C 0. o que se pretende: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [11] .SE(C7="". referentes à coluna I: Em I5: =SE(F5="".I5-(C6*E6)).I6-(C7*E7)).1120 (Em que A= Data de Início Em que B= Data de Fim Em que C= Taxa a Aplicar) Se um documento for emitido em 14/03/07 e contar juros até 11/05/08.109 dias à taxa de 0.C1-(C5*F5)) Em I6: =SE(F6="". isto é.1120 = 40.SE(C6="".Eis as fórmulas.I6(C7*F7))) Excel – Novamente a Função ARRED() “A tabela abaixo representa valores de taxas de juros aplicáveis nas datas indicadas.60 De 01/07/2007 a 31/12/2007 .1120 0.

em que as células da coluna B contêm determinados números. de forma parcelar. nenhum número que termine em 0 [zero] (ex: 12500)".VLOOKUP(). apareça. na tabela da folha2.2) Em F2: =ARRED(C2*E2/365*1000.Para calcularmos o número de dias entre as duas datas que contêm a mesma taxa de juro a aplicar.2) (A formatação destas células deverá ser “Número”. para calcularmos os valores dos juros. por exemplo. digitando uma sequência de 3 algarismos numa determinada célula da Folha1. na coluna B. o resultado da pesquisa na Folha2. cujos primeiros 3 algarismos. Vejamos o exemplo: Resultado que se pretende na Coluna B da Folha1. RIGHT() & VALUE() "Como posso fazer com que.2) Em F3: =ARRED(C3*E3/365*1000. na mencionada célula A1 da Folha1. podem ou não conter os algarismos digitados. em A1. ao inserir em A1 os algarismos 125: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [12] . Especificidade: não existe. utilizaremos a seguinte fórmula: Em E1: =(B1-A1)+1 Em E2: =(B2-A2)+1 Em E3: =(B3-A3)+1 (A formatação destas células deverá ser “Número”. teremos: Em F1: =ARRED(C1*E1/365*1000. com 2 casas decimais) Excel . a contar da esquerda. sem casas decimais) E agora.

procurando pelos 3 algarismos digitados. teremos que digitar. digitamos na célula B3.VLOOKUP() "Numa folha e na célula B1 temos um valor que é um somatório de valores de células."".1))))) Excel . E e F). copiando para tantas células dessa coluna (B4.2)=$B$1. todos os números que.Sheet2!$A$1:$B$10.IF(RIGHT(B1.2)= $B$1. para terminar. digitamos a seguinte fórmula: =IF(B1="".1)=1. para obter a percentagem em função do valor contido em B1: =VLOOKUP(B1.). na célula A1: Assim.Sheet2!$A$1:$B$10. contenham os algarismos digitados na Folha1.3) Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [13] . B6. O valor percentual é diferente conforme o intervalo de valores de referência (os valores de referência e respectivas percentagens encontramse nas colunas D. na Coluna B. quantas aquelas que sejam necessárias. na célula A1 pretendia o cálculo automático de um valor percentual em função do resultado obtido em B1. B5.D1:F3.IF(VALUE(RIGHT(B2.IF(VLOOKUP($A$1. etc.1))=1.Sheet2!$A$1: $B$10."".$B$1-VALUE(RIGHT(B2. a seguinte fórmula: VLOOKUP(A1. para mostrar todas as ocorrências que contenham os 3 algarismos mencionados: =IF(B2="". devendo dar como resultado.$B$1-1))) E. Ora..IF(VLOOKUP($A$1.""."". a seguinte fórmula.. na célula B2. na célula B1 fa Folha 1. na Folha2.A pesquisa a ser efectuada. Será possível? Como? O exemplo: Como possível solução. em C1.2) Por sua vez.

resultado em M6: III). Preciso de preencher a coluna M com o código da 1ª tabela associada a A + B (exemplo: B5=a.MATCH(G6&H6. O exemplo.Procurar com 2 variáveis .ou seja.Código: III -. para obter como um array.$B$2:$B$10&$C$2:$C$10.Index & Match() "Tenho uma tabela em que uma determinada combinação de 2 variáveis. de 2 para 3.0))} NOTA: Ctrl + Shift + Enter na célula activa. Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [14] . nas imagens: Se alterar em H6. como resultado pretendido: =B1*C1 Excel . em M6 (copiada para as células pretendidas da coluna M): {=INDEX($D$2:$D$10. então em M6 o resultado será IV: A fórmula. preciso colocar o código que corresponde a cada combinação de 2 variáveis.e em A1. Numa outra tabela. a que corresponde o conjunto das variáveis C + D( exemplo: G6 + H6 -. C5=2 . onde tenho estas variáveis. corresponde a um código. com {}.

">="&DATE(2007.2)="MG")) ="MV" & " " &SUMPRODUCT(--(RIGHT(A1:F2.MONTH(6). na coluna B e na coluna C tenho valores. mediante a utilização da formula=SUMIF(A1:A1000.">"&DATE(2007.B1:B1000)SUMIF(A1:A1000.30). Possível solução: =SUMPRODUCT((MÊS(A1:A1000)=6)*B1:B1000) Alternativa: {=SUM((MONTH(A1:A1000)=6)*(B1:B1000))}'como um array.6. SUM() ou SUMIF()? "Tenho uma folha em que na coluna A.B1:B1000).SUMPRODUCT(). "VM". somar todos os valores da coluna B correspondentes ao mês 6" . "PR" e "MD".B1:B1000) Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [15] . ou seja com CTRL+SHIFT+ENTER para obter {} Uma terceira possível solução: =SUMIF(A1:A1000.Excel .2)="MD")) Excel .2)="VM")) ="PR" & " " &SUMPRODUCT(--(RIGHT(A1:F2.2)="PR")) ="MD" & " " &SUMPRODUCT(--(RIGHT(A1:F2. sejam as ocorrências "MG". Não estou a conseguir. como no seguinte exemplo: podemos utilizar a seguinte fórmula.SUMPRODUCT() Se pretendermos verificar o número de ocorrências num determinado Range. tenho datas no seguinte formato"06-092007". adaptada a cada uma das ocorrências: ="MG" & " " &SUMPRODUCT(--(RIGHT(A1:F2.1).6.

contudo. Max(). Uma delas.. Mas.. Match() e Row() "Estou a criar um registo de membros.Excel . será a utilização de "Data Validation".. dado que o seu número facilmente poderá chegar aos 50. Agradeço.. a solução apresentada não me pareceu funcionar com texto. No exemplo seguinte. por exemplo.. Assim. vai dar uma mensagem: Como fazer: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [16] .. corro o risco de criar entradas duplicadas. e depois de mais uma visita ao Exceler encontrei um post sobre o assunto [post de 2004-12-16]. " Várias soluções se podem apresentar. a informação de se será possível aplicar ou não a texto. Countif(). sempre que se escrever numa das células do Range um conteúdo duplicado.Data Validation. se possível.

"Duplicado!"."")) e copiando de F1 até F10: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [17] ."". no exemplo.IF(MATCH(D1. então teremos. é utilizar uma fórmula [com o mesmo Range de exemplo (D1:D10)] . Outra possibilidade ainda será. em F1: =IF(D1=""."Duplicado".Outra possibilidade.0)<ROW(D1).Neste caso.na célula E1: IF(MAX(COUNTIF($D$1:$D$10. ou seja. considera entrada duplicada as duas entradas:.D$1:D$10."") e copiando até ao fim do range [no exemplo. vai dar TODAS as entradas duplicadas no range D1:D10.E1:E10] . se se pretender que apenas as entradas duplicadas sejam consideradas.$D$1:$D$10))>1.

sempre que altere um destes valores parcelares.2)&"+"&MID(A1. LEN() e FIND(): Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [18] . o seguinte: 2+300 e. tenha como resultado numa terceira célula. como no exemplo: podemos utilizar.4.e 18+200.3)-RIGHT(B1.Left(). o resultado reflicta essa alteração?" O exemplo: A fórmula: =LEFT(A1. partindo do seguinte conteúdo em duas células: 20+500. LEN() e FIND() Se pretendermos extrair um determinado conteúdo de uma célula que contém letras e números. no mesmo formato. as Funções LEFT() e FIND() e no segundo.2)-LEFT(B1. Mid() & Right() "Como hei-de fazer para que. no primeiro caso.Excel .3) Funções LEFT() e RIGHT(). as Funções RIGHT().

.LEN(A1)-SEARCH(" ". Tomemos. Utilizando as Funções LEN() e SUBSTITUTE(). os seguintes métodos: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [19] ."")) Calcular diferença entre horas. por exemplo.FIND(" ". em A1.02.LEN(A1)-FIND(" ".A1)) ou =MID(A1.TRIM(A1))+1.FIND(" ".04? A célula A1 neste caso é do tipo texto.CARACT(SUBSTITUIR(A1. O resultado deveria ser 3.03..A1.".".LEN(A1)) Excel: As Funções LEN() e SUBSTITUTE() Quantos caracteres ".1)) ou =MID(TRIM(A1). podemos utilizar.FIND(" ".A1)-1) ou =LEFT(TRIM(A1). por exemplo.256) ou =RIGHT(A1.Vários métodos para um mesmo fim. com resultado em minutos Se pretendermos efectuar um cálculo para obter a diferença entre dois horários e sabermos o resultado em minutos." tem na célula A1 cujo conteúdo é 01. obtém-se o resultado desejado: A fórmula em B1: =NÚM. o seguinte Nome + Apelido: "Jorge Rodrigues" Para inserir o Nome numa outra célula: =LEFT(A1.CARACT(A1)-NÚM.FIND(" ".A1)+1.TRIM(A1))-1) Para inserir o Apelido: =RIGHT(A1.

E se a hora final for inferior à hora inicial. podemos utilizar a seguinte fórmula: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [20] . como no caso de a hora final ser já depois da meianoite? Aqui.

1 (3 semanas e 1 dia) Mas."d"). a totalidade de dias - 22 dias em B6: =INT(B2)&". Então. Numa abordagem um pouco simplista. Se pretendermos saber quantas semanas estão contidas entre estas duas datas e quantos dias remanescem. teríamos: em B2: =DATEDIF(A1. mas demasiado elaborada (só para melhor compreensão).Excel: Ainda a Diferença entre duas datas . 3 semanas [ à Função DATEDIF() corresponde em português a Função DATADIF() ] em B3: =DATEDIF(A1.A2."d")/7. E o resultado seria: ou seja. então podemos utilizar as Funções INT() [ em português é a mesma) e MOD() (RESTO() em português ]: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [21] . verificamos que são 3 semanas (7x 3 = 21). podemos criar várias fórmulas tendo em consideração o que atrás foi escrito."&INT(B3)-INT(B2)*7.resultado em semanas e dias Suponhamos que temos duas datas: 01-01-2005 e 23-01-2005. restando 1 dia. se quisermos ser menos elaborados.A2. mas com uma fórmula mais correcta. ou seja. ou seja: 3.

o ano Em M9: Em N9: =WEEKDAY($O$6&"-"&$O$7) =M9+1 Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [22] .7)=0.em B6: =INT((A2-A1)/7)&".INT((A2-A1)/7)& _ Excel: Funções de data Um calendário básico: Em O6 . se quisermos ter uma apresentação mais cuidada.7) Para finalizar.7)&" dia(s)") semana(s)".INT((A2-A1)/7)&" " semana(s) e "&MOD(A2-A1."&MOD(A2-A1. podemos escrever a fórmula do seguinte modo: em B6: =IF(MOD(A2-A1.o mês Em O7 .

porque não se está a tomar como início da semana o domingo. mostro como se pode incluir o número da semana correspondente.22 e 29 do mês em referência: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [23] . utilizando esse mesmo calendário.Em O9: =N9+1 O mesmo até S9.15. ou seja. teremos que construir a seguinte fórmula. no terceiro campo da condição.8. na célula onde deve ficar o algarismo 29. como no exemplo.MONTH(DATEVALUE(O6&"-"&O7))+1. no exemplo.29) Na célula correspondente a 30: =IF(S6<30.31."". meses com 31 dias e Fevereiro com 29 ou 28 dias. Para mostrar o dia corrente noutra cor. para que os dias do mês coincidam com o mês em causa.0)) Por último. Hoje. meses com 30 dias. coloca-se a fórmula: =DAY(TODAY()) Agora. em M14. no exemplo. marca-se a tabela com os 31 algarismos correspondentes aos dias do mês: Escolhe-se Formatar Condicionalmente: e. colocamos a seguinte fórmula: =IF(S6=28. os dias 1."") Excel: Ainda funções de data No post anterior foi apresentado um modelo básico de calendário. conforme seja ano bissexto ou comum. em S6: =DAY(DATE(O7. embora não seja totalmente correcto.30) E na célula correspondente a 31: =IF(S6=31. ou seja. mas sim e sempre."".

ou seja.(M10&"-"&$O$6&"-"&$O$7))/7+1-5400 Nota: A célula M4 é uma célula vazia. apenas representando a data de início para a Função Days360().A Fórmula em L10 (com Copy & Paste até L14): =DAYS360($M$4. o valor 0 (zero): Excel: Somar dois tipos de ocorrências Se pretendermos somar dois tipos de ocorrências. como no exemplo Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [24] .

esta última. de modo a saber que se encontram vazias e. por isso. por exemplo a um critério. mas que obedeça. obedecendo ao critério de lhe corresponder o algarismo 2 na coluna B: Excel: Utilização da Função SUBTOTAL() Como se pode verificar. pode mencionar-se o Range que inclui os subtotais. utilizando as Funções SUM() e COUNTIF(). pura e simplesmente. ignorados! Excel: Formatação Condicional Se pretendermos inserir valores ou texto em determinadas células pré-definidas."muito bom"})) Excel: Ainda a Função SUMPRODUCT() Se pretendermos "contar" uma determinada ocorrência. pretendemos contar o número de vezes em que o nome "joão" aparece na coluna A. Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [25] . para uma maior comodidade. porque estes são. ao utilizar-se a Função para dar o Total. podemos colori-las. O Código: =SUM(COUNTIF(A1:A20. com um array. podemos utilizar a Função SUMPRODUCT() ou SOMARPRODUTO().podemos criar uma pequena fórmula.{"bom". No exemplo.

se houver células em branco. as células deixam de estar coloridas. Tomemos o exemplo: Depois de inserirmos valores. voltando a ter coloração se ficarem novamente vazias: O método. estas são igualmente contadas como se contivessem a ocorrência "Jan". para verificar a quantidade de ocorrências contidas num determinado Range.CÉL.C3 e D4. apresentei um post com uma fórmula que junta as funções Sumproduct()e Text().: Excel: As Funções SUMPRODUCT() e TEXT(). como mostra a figura seguinte. associada à função ISBLANK() ou É. no exemplo nas células A1. ISBLANK(B2) etc.VAZIA(). No entanto. a fórmula apenas funciona correctamente (problema só em relação a "Jan") se o Range estiver completamente preenchido.mais fáceis de serem identificadas. Utilização com a Função ISBLANK() No dia 2 de Fevereiro. ou seja ISBLANK(A1). é a utilização da Formatação Condicional. como se pode verificar no exemplo seguinte: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [26] .B2. o mesmo não acontecendo com outras ocorrências.

A1)+COUNTIF(C1:C13. p. em A3. agora com a incorporação da Função IsBlank(): Excel: Múltiplos CountIf() Se pretendermos contar as ocorrências contidas num determinado Range ( no exemplo C1:C13) e que obedeçam a critérios estabelecidos em certas células (no exemplo. a seguinte Fórmula. com a utilização de múltiplos COUNTIF() [ou CONTAR. é a seguinte. ex. com as células vazias como fazendo parte da ocorrência).SE()]: =COUNTIF(C1:C13. as células A1 e B1). para que a contagem das ocorrências seja correcta (não contando.B1) Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [27] . por isso. então podemos inserir.A fórmula a executar.

C16 corresponderá ao nº 2 e E16 ao 7): Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [28] . E6 corresponderá ao nº 4. E8 ao 16. com Fórmula como condição A título de exemplo.Excel: Formatação Condicional. etc): A formatação condicional para a grelha de estrelas. partindo do princípio que os campos a verde correspondem aos números escolhidos (no exemplo. sendo que A1:E1 são os 5 números saídos e F1:G1. partindo do princípio que os campos a azul correspondem aos números escolhidos (no exemplo. as 2 estrelas saídas: A formatação condicional para a grelha de números. uma grelha de números e de estrelas.

Branco. Amarelo. No exemplo.. Verde.Excel: Formatos personalizados . seleccionaram-se as quatro primeiras(Azul para valores positivos.. Amarelo para valores zero e Verde para texto): Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [29] . Vemelho para valores negativos. podem seleccionar-se até quatro cores (das oito cores possíveis: Azul. Vermelho.O formato nulo O formato nulo (.) oculta o conteúdo da célula A2: Antes da formatação: Depois da formatação: Excel: Formatação personalizada . Preto. Magenta e Turquesa).Cor Na formatação personalizada.

Cor II No entanto. pode usar-se mais do que oito cores.Cinzento Escuro) e utilizar-se igualmente símbolos. através das 56 cores da palette de escolhas de cor..Formatação personalizada . 2= 2ª cor da lista .. utilizando o tipo [Color#].Preto. em que # se refere a um número entre 1 e 56 da palette (1= 1ª cor da lista . 56= última cor da lista .Branco . como seja o adicionar (+) e o subtrair (-) Exemplo: Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [30] .

SEG.VAZIO() [COUNTBLANK()] conta as células vazias num determinado Range: Exemplo das Funções CONCATENAR() e VALOR() Funções de Texto Exemplos da utilização das Funções de texto ESQUERDA().VAZIO() A Função CONTAR.TEXTO() e DIREITA() Somar Colunas Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [31] .Exemplo da Função CONTAR.

ou seja: =SOMA(3:4) (port) Excel . pode utilizar-se a seguinte fórmula: =SOMA(B:C) (port. que a célula do dividendo é A1 e que a célula do divisor é B1. Solução: Utilizando uma fórmula na célula do resultado: Ex ."". encontra-se vazio.O problema do aparecimento de: "#/DIV0!" Às vezes. quando se pretende efectuar uma divisão. teremos: =SE(É. o dividendo é menor que o divisor. no EXCEL. ou a célula que funciona como dividendo. aparecerá na célula do resultado aquela mensagem abominável que todos nós conhecemos:"#/DIV0!".ERRO(A1/B1).Para somar Colunas sem a preocupação de as limitar.A1/B1) Formador: VÍTOR PINTO Excel Avançado – Dicas e Truques [32] . porque fazendo parte de uma fórmula.assumindo que a célula do resultado é C1.) Somar Linhas É claro que para somar Linhas o método é semelhante. Neste caso.

Sign up to vote on this title
UsefulNot useful