You are on page 1of 6

COMPUTACIÓN Y ALGORITMOS I FECHA: 30-12-2017

Ejercicio Resuelto N° 02. Ingresar 5 números e indicar cuántos números son múltiplos de 3.

a) ANÁLISIS DEL PROBLEMA


Sean:

num = número.
cm3 = cantidad de múltiplos de 3.
c = contador.

5 repeticiones
num Condicion: num mod3=0 cm3
cm3=cm3+1

c=c+1

Nota: Emplearemos la estructura MIENTRAS …. HACER (pero se puede resolver con cualquiera
de las 3 estructuras repetitivas)

b) DISEÑO DEL ALGORITMO


Pseudocódigo
Inicio
Entero num, cm3, c
c=0
cm3=0

Escribir "Ingresar 5 números"


Mientras (c<5) hacer
Leer num
Si (num mod 3=0) entonces
cm3=cm3+1
FinSi
c=c+1
Fin Mientras
Escribir "Cantidad de Múltiplos de 3: ", cm3
Fin
Diagrama de Flujo
Diagrama N/S

c) PRUEBA DE ESCRITORIO

N° N° C=0 num num mod 3=0 cm3=0 c Pantalla


Ejec. Iter. C<5 cm3
1 1 V 6 V 1 1
2 V 4 F 1 2
3 V 5 F 1 3
4 V 3 V 2 4
5 V 2 F 2 5
6 F - - - - Cantidad de Multiplos de 3: 2

Ejercicio Resuelto N° 04. Pedir 10 números. Mostrar la media de los números positivos, la media
de los números negativos y la cantidad de ceros.

a) ANÁLISIS DEL PROBLEMA


Sean:

num = número. mp = media de núm. positivos.


sp = suma de números positivos. mn = media de núm. negativos.
sn = suma de núm. negativos. cc = cantidad de ceros.
cp = contador de núm. positivos. i = contador.
cn = contador de núm. negativos.
num 10 repeticiones media_p,media,n,cc
Condicion: num >=0
(V)sp=sp+1
cp=cp+1
(F)sn=sn+1
cn=cn+1
mp=sp/cp
mn=sn/cn

Nota: Emplearemos la estructura DESDE …. HASTA (pero se puede resolver con cualquiera de
las 3 estructuras repetitivas)

b) DISEÑO DEL ALGORITMO


Pseudocódigo

INICIO
Entero num, sp=0, sn=0, cp=0, cn=0, cc=0, i
Real mp, mn
Escribir "Ingresar 10 números: "
Desde i=1 hasta i=10 incremento i++
Leer num
Si (num >0) entonces
sp=sp+num
cp=cp+1
Sino
Si(num<0) Entonces
sn=sn+num
cn=cn+1
SiNo
cc=cc+1
FinSi
FinSi
FinDesde
mp=sp/cp
mn=sn/cn
Escribir "Media de núm. positivos: ",mp
Escribir "Media de núm. negativos: ",mn
Escribir "Cantidad de ceros: ",cc
FIN
Diagrama de Flujo

También se puede
representar con un
hexágono
c) PRUEBA DE ESCRITORIO

N° N°
i=1 num num>0 sp cp num<0 sn cn cc mp nn Pantalla
Ejec. Iter.
1 1 1 3 V 3 1 - - - -
2 2 4 V 7 2 - - - -
3 3 -5 F - - V -5 1 -
4 4 1 V 8 3 - - - -
5 5 -3 F - - V -8 2 -
6 6 0 F - - F 1
7 7 6 V 14 4 - - - -
8 8 -2 F - - V -10 3 -
9 9 3 V 17 5 - - - -
10 10 0 F - - F - - 2 3.4 -3.33 Media de núm. positivos: , 3.4
Media de núm. negativos: , -3.33
Cantidad de ceros: , 2