You are on page 1of 5

B’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ

Ενδεικτικές Απαντήσεις Γ’ ΓΕ.Λ. Νοέμβριος 2017

Ανάπτυξη Εφαρμογών
προσανατολισμού

ΘΕΜΑ Α
Α1.
i. ΑΚΕΡΑΙΕΣ, π.χ. α 5
ii. ΠΡΑΓΜΑΤΙΚΕΣ, π.χ. α 5.3
iii. ΧΑΡΑΚΤΗΡΕΣ, π.χ. α ’ΤΙΜΗ’
iv ΛΟΓΙΚΕΣ, π.χ. α ΑΛΗΘΗΣ

Α2. Βλέπε σχολικό βιβλίο σελ. 153

Α3. Βλέπε Σχολικό Βιβλίο σελ. 180

Α4.
1. Λ
2. Σ
3. Λ
4. Σ
5. Σ

Α5.
ΓΙΑ i ΑΠΟ 20 ΜΕΧΡΙ 12 ΜΕ_ΒΗΜΑ -2
ΑΝ iMOD4 = 0 ΤΟΤΕ
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
α i–1
ΓΡΑΨΕ α
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
B’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Ενδεικτικές Απαντήσεις Γ’ ΓΕ.Λ. Νοέμβριος 2017

ΘΕΜΑ Β

Β1.
Αριθμός Χ Υ i Οθόνη
γραμμής
1 14
2 4
3 8
4 10
5 10
6 9
3 11
7 6
8 6
2 1
3 8
7 3
8 3

Β2.
Διάβασε Χ
Αρχή επανάληψης
Υ ΧMOD5
i 8
Όσο i < = X επανάλαβε
Χ Χ-Υ
Γράψε Χ
Χ Χ–1
i i+3
Τέλος_Επανάληψης
X X–3
Γράψε Χ
Μέχρις_ότου Χ < 5

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
B’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Ενδεικτικές Απαντήσεις Γ’ ΓΕ.Λ. Νοέμβριος 2017
Β3.
κ -1
β ΑΛΗΘΗΣ
Αρχή_επανάληψης
Διάβασε α
Αν α > = 0 και β = ΑΛΗΘΗΣ τότε
β (α > = κ)
κ α
Τέλος_αν
Μέχρις_ότου α < 0
Αν κ < > -1 τότε
Αν β ΑΛΗΘΗΣ τότε
Γράψε ‘Οι αριθμοί είναι σε αύξουσα σειρά’
Αλλιώς
Γράψε ‘Οι αριθμοί δεν είναι σε αύξουσα σειρά’
Τέλος_αν
Αλλιώς
Γράψε ‘Δεν δόθηκαν μη αρνητικοί αριθμοί’
Τέλος_αν

ΘΕΜΑ Γ

ΠΡΟΓΡΑΜΜΑ ΕΤΑΙΡΕΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΑΠΟΘ, ΠΛ_ΑΓ, ΠΛ_Π, ΜΑΧ, ΜΑΧ_Π, ΧΩΡΟΣ, ΤΕΜ
ΧΑΡΑΚΤΗΡΕΣ: ΕΝ
ΑΡΧΗ
ΑΠΟΘ 50000
ΠΛ_ΑΓ 0
ΠΛ_Π 0
ΜΑΧ -1
ΜΑΧ_Π -1
ΟΣΟ ΑΠΟΘ > 0 ΕΠΑΝΑΛΑΒΕ
ΧΩΡΟΣ 50000 - ΑΠΟΘ
ΔΙΑΒΑΣΕ ΤΕΜ, ΕΝ
ΑΝ ΕΝ = ‘ΑΓΟΡΑ’ ΤΟΤΕ
ΑΝ ΤΕΜ < = ΧΩΡΟΣ ΤΟΤΕ
ΑΠΟΘ ΑΠΟΘ + ΤΕΜ
ΠΛ_ΑΓ ΠΛ_ΑΓ + 1
ΑΝ ΠΛ_Π > ΜΑΧ_Π ΤΟΤΕ
ΜΑΧ_Π ΠΛ_Π
ΤΕΛΟΣ_ΑΝ

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
B’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Ενδεικτικές Απαντήσεις Γ’ ΓΕ.Λ. Νοέμβριος 2017
ΠΛ_Π 0
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘Ο ΜΕΓΙΣΤΟΣ ΑΡΙΘΜΟΣ ΠΟΥ ΧΩΡΑΕΙ Η ΑΠΟΘΗΚΗ ΕΙΝΑΙ’,
& ΧΩΡΟΣ
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
ΑΝ ΤΕΜ < = ΑΠΟΘ ΤΟΤΕ
ΑΠΟΘ ΑΠΟΘ – ΤΕΜ
ΠΛ_Π ΠΛ_Π + 1
ΑΝ ΤΕΜ > ΜΑΧ ΤΟΤΕ
ΜΑΧ ΤΕΜ
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘Ο ΜΕΓΙΣΤΟΣ ΑΡΙΘΜΟΣ ΠΟΥ ΔΙΑΘΕΤΕΙ Η ΑΠΟΘΗΚΗ ΕΙΝΑΙ’,
& ΑΠΟΘ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΕΓΙΝΑΝ’, ΠΛ_Α, ‘ΑΓΟΡΕΣ’
ΓΡΑΨΕ ‘ΤΑ ΤΕΜΑΧΙΑ ΤΗΣ ΜΕΓΑΛΥΤΕΡΗΣ ΠΩΛΗΣΗΣ ΕΙΝΑΙ’, ΜΑΧ
ΓΡΑΨΕ ‘ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΠΛΗΘΟΣ ΣΥΝΕΧΟΜΕΝΩΝ ΠΩΛΗΣΕΩΝ ΕΙΝΑΙ’, ΜΑΧ_Π
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ ΔΙΑΓΩΝΙΣΜΟΣ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: i, j, Κ, ΠΛ, ΒΑΘ, SUM, ΜΑΧ, ΜΙΝ, ΜΑΧ_ΠΡ, ΜΑΧ_ΜΕΓ
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ, ΜΕΓΙΣΤΟ, ΟΛ_ΜΕΓ
ΧΑΡΑΚΤΗΡΕΣ: ΟΝ, ΟΝΜΑΧ
ΑΡΧΗ
ΟΛ_ΜΕΓ -1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 300
ΔΙΑΒΑΣΕ ΟΝ
ΠΛ 0
ΜΕΓΙΣΤΟ -1
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
ΜΑΧ -1
ΜΙΝ 11
SUM 0
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
ΔΙΑΒΑΣΕ ΒΑΘ
SUM SUM + ΒΑΘ

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
B’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Ενδεικτικές Απαντήσεις Γ’ ΓΕ.Λ. Νοέμβριος 2017
ΑΝ ΒΑΘ > MAX ΤΟΤΕ
ΜΑΧ ΒΑΘ
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘ < MΙΝ ΤΟΤΕ
ΜΙΝ ΒΑΘ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ (SUM – ΜΑΧ – ΜΙΝ)/8
ΓΡΑΨΕ ‘Ο’, ΟΝ, ‘ΠΗΡΕ ΣΤΟ ΕΙΔΟΣ’, j, ‘ΤΕΛΙΚΟ ΒΑΘΜΟ:’, ΜΟ
ΑΝ j = 1 ΤΟΤΕ
ΜΑΧ_ΠΡ ΜΑΧ
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΟ > 8 ΤΟΤΕ
ΠΛ ΠΛ + 1
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΟ > MΕΓΙΣΤΟ ΤΟΤΕ
ΜΕΓΙΣΤΟ ΜΟ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΠΛ > 2 ΤΟΤΕ
ΓΡΑΨΕ ‘Ο’, ΟΝ, ‘ΕΙΧΕ ΣΤΟΥΣ ΠΕΡΙΣΣΟΤΕΡΟΥΣ ΧΟΡΟΥΣ, ΒΑΘΜΟ ΠΑΝΩ
ΑΠΟ 8’
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΕΓΙΣΤΟ > ΟΛ_ΜΕΓ ΤΟΤΕ
ΟΛ_ΜΕΓ ΜΕΓΙΣΤΟ
ΟΝΜΑΧ ΟΝ
ΜΑΧ_ΜΕΓ ΜΑΧ_ΠΡ
ΑΛΛΙΩΣ_ΑΝ ΜΕΓΙΣΤΟ = ΟΛ_ΜΕΓ ΤΟΤΕ
ΑΝ ΜΑΧ_ΠΡ > ΜΑΧ_ΜΕΓ ΤΟΤΕ
ΟΝΜΑΧ ΟΝ
ΜΑΧ_ΜΕΓ ΜΑΧ_ΠΡ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘Ο’, ΟΝΜΑΧ, ‘ΕΙΧΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΤΕΛΙΚΟ ΒΑΘΜΟ’
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr