You are on page 1of 5

Β’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ

Προτεινόμενα Θέματα Γ’ ΓΕ.Λ. Νοέμβριος 2017

Ανάπτυξη Εφαρμογών
προσανατολισμού

ΘΕΜΑ Α
Α1. Να αναφέρετε τους τύπους δεδομένων που υποστηρίζει η «ΓΛΩΣΣΑ» και να δώσετε ένα
παράδειγμα για καθένα από αυτούς.
Μονάδες 8
Α2. Να αναφέρετε ποιες συναρτήσεις περιέχονται στη «ΓΛΩΣΣΑ».
Μονάδες 8
Α3. Ποιοι κανόνες πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων;
Μονάδες 6
Α4. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις ως σωστή (Σ) ή λάθος (Λ).
1. Η ολίσθηση προς τα δεξιά ισοδυναμεί με τον πολλαπλασιασμό επί δύο.
2. Μία «ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ» μπορεί πάντα να μετατραπεί σε
«ΟΣΟ…ΕΠΑΝΑΛΑΒΕ».
3. Όταν ξέρουμε τον αριθμό των επαναλήψεων, χρησιμοποιούμε
μόνο την «ΟΣΟ…ΕΠΑΝΑΛΑΒΕ».
4. Οι εντολές της «ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣ_ΟΤΟΥ»
εκτελούνται τουλάχιστον μία φορά.
5. Αν Α είναι μία λογική μεταβλητή, τότε η έκφραση ΟΧΙ(ΑΚΑΙ(ΟΧΙΑ)) είναι πάντα αληθής.
Μονάδες 10
Α5. Να συμπληρωθεί το παρακάτω τμήμα προγράμματος, ώστε να εμφανίζονται οι αριθμοί
20, 17, 16, 13, 12 με τη σειρά που δίνονται.

ΓΙΑ i ΑΠΟ ……… ΜΕΧΡΙ ………….. ΜΕ_ΒΗΜΑ -2


ΑΝ …………. ΤΟΤΕ
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
α …………
ΓΡΑΨΕ α
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μονάδες 8

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
Β’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Προτεινόμενα Θέματα Γ’ ΓΕ.Λ. Νοέμβριος 2017

ΘΕΜΑ B
Β1. Δίνεται το παρακάτω τμήμα προγράμματος, στο οποίο έχουν αριθμηθεί οι γραμμές:

1 ΔΙΑΒΑΣΕ Χ
Αρχή επανάληψης
2 Υ  ΧMOD5
3 Για i από 8 μέχρι Χ με_βήμα 3
4 Χ Χ - Υ
5 Γράψε Χ
6 Χ Χ - 1
Τέλος_Επανάληψης
7 X X – 3
8 Γράψε Χ
Μέχρις_ότου Χ < 5

Επίσης δίνεται το ακόλουθο υπόδειγμα πίνακα μεταβλητών:


Αριθμός Χ Υ i Οθόνη
γραμμής
1 14
… … … …

Στη στήλη με τίτλο «Αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που
εκτελείται.
Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγόριθμου.
Στη τελευταία στήλη καταγράφονται οι τιμές των μεταβλητών όπως εμφανίζονται.
Να μεταφέρεται στο τετράδιο σας τον πίνακα και να τον συμπληρώσετε εκτελώντας τις
εντολές του τμήματος αλγορίθμου ως εξής:
Για κάθε εντολή που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον αριθμό της
γραμμής της και το αποτέλεσμά της στην αντίστοιχη στήλη.
Μονάδες 12
Β2. Να γράψετε ξανά το παραπάνω τμήμα αλγορίθμου, χρησιμοποιώντας την
επαναληπτική «Όσο… Επανάλαβε» στη θέση της «Για… από… μέχρι», ώστε να επιτελείται η
ίδια λειτουργία.
Μονάδες 3

ΑΠΑΝΤΗΣΕΙΣ ΤΩΝ ΘΕΜΑΤΩΝ ΣΤΗΝ ΙΣΤΟΣΕΛΙΔΑ ΤΟΥ ΦΡΟΝΤΙΣΤΗΡΙΟΥ


www.sygchrono-edu.gr / 210 8941383 / 210 9610057
Β’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Προτεινόμενα Θέματα Γ’ ΓΕ.Λ. Νοέμβριος 2017

Β3. Να συμπληρωθεί το παρακάτω τμήμα προγράμματος ώστε να διαβάζει αριθμούς μέχρι


να δοθεί αρνητικός αριθμός και να εμφανίζει μήνυμα σχετικά με το αν είναι σε αύξουσα
σειρά:

κ -1
β ΑΛΗΘΗΣ
Αρχή_επανάληψης
Διάβασε α
Αν α > = 0 και ………… τότε
β …………..
κ …………….
Τέλος_αν
Μέχρις_ότου …………..
Αν ……………. τότε
Αν β ΑΛΗΘΗΣ τότε
Γράψε ‘Οι αριθμοί είναι σε αύξουσα σειρά’
Αλλιώς
Γράψε ‘Οι αριθμοί δεν είναι σε αύξουσα σειρά’
Τέλος_αν
Αλλιώς
Γράψε ‘Δεν δόθηκαν μη αρνητικοί αριθμοί’
Τέλος_αν
Μονάδες 5
ΘΕΜΑ Γ
Η εταιρεία ‘HALIA’ εισάγει στην Ελλάδα τη διάσημη ηλεκτρική σκούπα ‘DEN TRAVAEI’. Η
εταιρεία αγοράζει τις σκούπες από το εργοστάσιο της Κίνας (αγορά) και τις πουλάει σε
καταστήματα (πώληση).
Η αποθήκη της μπορεί να χωρέσει μέχρι και 50.000 συσκευασίες σκούπας και στην αρχή είναι
γεμάτη.
Να δοθεί πρόγραμμα που:
Γ1. Να έχει κατάλληλο τμήμα δηλώσεων.
Μονάδες 1
Γ2. Να διαβάζει τον αριθμό τεμαχίων κι αν πρόκειται για αγορά ή πώληση.
Μονάδες 2
Γ3. Στην περίπτωση αγοράς, να ελέγχει την ποσότητα και να τη δέχεται μόνο αν χωράει
στην αποθήκη. Σε αντίθετη περίπτωση να εμφανίζει το μέγιστο αριθμό τεμαχίων που μπορεί
να δεχτεί η αποθήκη.

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr
Β’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Προτεινόμενα Θέματα Γ’ ΓΕ.Λ. Νοέμβριος 2017
Μονάδες 2
Γ4. Στην περίπτωση πώλησης, θα ελέγχει αν υπάρχει το κατάλληλο απόθεμα στην αποθήκη
και να προβεί στην πώληση αν υπάρχουν τα ζητούμενα τεμάχια, αλλιώς να εμφανίζει το
μέγιστο αριθμό τεμαχίων που μπορεί να διαθέσει η εταιρεία.
Μονάδες 3
Γ5. Να υπολογίζει και να εμφανίζει το πλήθος των αγορών που έγιναν.
Μονάδες 3
Γ6. Να εμφανίζει πόσα τεμάχια ήταν η μεγαλύτερη πώληση. Θεωρείστε ότι είναι μόνο μία.
Μονάδες 3
Γ7. Να εμφανίζει το μεγαλύτερο πλήθος συνεχόμενων πωλήσεων που έγιναν.
Μονάδες 5
Γ8. Η διαδικασία να σταματάει όταν αδειάσει η αποθήκη.
Μονάδες 1
ΘΕΜΑ Δ
Σε ένα διαγωνισμό χορού παίρνουν μέρος 300 χορευτές. Κάθε χορευτής διαγωνίζεται σε 5 είδη
χορού και για κάθε χορό, ο διαγωνιζόμενος βαθμολογείται από 10
κριτές, με κλίμακα από 0 έως και 10. Για να υπολογιστεί ο τελικός
βαθμός κάθε χορού, εξαιρείται ο μεγαλύτερος και ο μικρότερος
βαθμός και υπολογίζεται ο μέσος όρος των υπολοίπων βαθμών.
Να δοθεί πρόγραμμα που:
Δ1. Να έχει τμήμα δηλώσεων μεταβλητών.
Μονάδες 1
Δ2. Να διαβάζει τα ονόματα των χορευτών και τους βαθμούς τους για κάθε είδος χορού.
Μονάδες 3
Δ3. Να υπολογίζει και να εμφανίζει για κάθε χορευτή, την τελική βαθμολογία του σε κάθε
χορό.
Μονάδες 6
Δ4. Να εμφανίζει τα ονόματα των χορευτών που στα περισσότερα είδη χορού είχε τελική
βαθμολογία πάνω από 8.
Μονάδες 4
Δ5. Να εμφανίζει το όνομα του χορευτή με το μεγαλύτερο τελικό βαθμό σε κάποιο είδος. Αν
υπάρχουν διαγωνιζόμενοι που ισοβαθμούν, θα εμφανίζεται το όνομα του χορευτή που είχε
στο πρώτο είδος χορού, τον μεγαλύτερο βαθμό από κάποιον κριτή. Θεωρείστε ότι είναι μόνο
ένας.
Μονάδες 6
Σημείωση: Οι βαθμοί που δίνουν οι κριτές είναι ακέραιοι αριθμοί και δεν χρειάζεται έλεγχος
εγκυρότητας.

ΑΠΑΝΤΗΣΕΙΣ ΤΩΝ ΘΕΜΑΤΩΝ ΣΤΗΝ ΙΣΤΟΣΕΛΙΔΑ ΤΟΥ ΦΡΟΝΤΙΣΤΗΡΙΟΥ


www.sygchrono-edu.gr / 210 8941383 / 210 9610057
Β’ ΚΥΚΛΟΣ ΠΡΟΣΟΜΟΙΩΤΙΚΩΝ ΔΙΑΓΩΝΙΣΜΑΤΩΝ ΣΥΓΧΡΟΝΟ
Προτεινόμενα Θέματα Γ’ ΓΕ.Λ. Νοέμβριος 2017

ΟΔΗΓΙΕΣ (για τους εξεταζομένους)


1. Στο εξώφυλλο να γράψετε το εξεταζόμενο μάθημα. Στο εσώφυλλο πάνω-πάνω να συμπληρώσετε τα Ατομικά στοιχεία μαθητή.
Στην αρχή των απαντήσεών σας να γράψετε πάνω-πάνω την ημερομηνία και το εξεταζόμενο μάθημα). Να μην αντιγράψετε τα
θέματα στο τετράδιο και να μη γράψετε πουθενά στις απαντήσεις το όνομά σας.
2. Να γράψετε το Ονοματεπώνυμό σας στο πάνω μέρος των φωτοαντιγράφων αμέσως μόλις σας παραδοθούν. Τυχόν σημειώσεις
σας πάνω στα θέματα δε θα βαθμολογηθούν σε καμία περίπτωση. Κατά την αποχώρησή σας να παραδώσετε μαζί με το
τετράδιο και τα φωτοαντίγραφα.
3. Να απαντήσετε στο τετράδιό σας σε όλα τα θέματα μόνο με μπλε ή μόνο με μαύρο στυλό με μελάνι που δε σβήνει.
4. Κάθε απάντηση τεκμηριωμένη είναι αποδεκτή.
5. Διάρκεια εξέτασης: τρεις(3) ώρες.
6. Χρόνος δυνατής αποχώρησης: μετά τη συμπλήρωση 2 ωρών.
ΑΠΑΓΟΡΕΥΟΝΤΑΙ ΤΑ ΚΙΝΗΤΑ ΤΗΛΕΦΩΝΑ

ΓΛΥΦΑΔΑ: ΑΛΕΚΟΥ ΠΑΝΑΓΟΥΛΗ 52, ΤΗΛ. 210 8941040 – 210 8941383 - 210 9610057
ΑΘΗΝΑ – ΑΓ. ΠΑΡΑΣΚΕΥΗ – ΓΛ. ΝΕΡΑ - ΠΑΛΛΗΝΗ
www. sygchrono-edu.gr