You are on page 1of 18

República Bolivariana de Venezuela

Ministerio de Educación Superior
Fundación Misión Sucre

Programa Nacional de Formación en Sistemas e Informática

EJEMPLOS Y EJERCICIOS

ALGORITMIA

Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 50

“Es el No Si mayor” A> B 9. determinar cual de los dos valores es el mayor y escribirlo.Asignarlos a las variables A y B 6. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 1 Desarrolle un algoritmo que permita leer dos valores distintos.Fin_Si B “Es el mayor” A “Es el mayor” 10.Si A = B Entonces vuelve a 3 porque los valores deben ser A. determinar cual de los dos valores es el menor y escríbalo Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 51 . Fin Fin Ejercicios propuesto: a. B = 0 3.Solicitar la introducción de dos “Introduzca dos valores distintos valores distintos” 4. “Es el mayor” No 8. distintos B Si 7.Si A>B Entonces A= B Escribir A.De lo contrario: Escribir B.Inicializar variables: A = 0.Inicio Inicio 2.Leer los dos valores 5. Pseudocódigo Diagrama de Flujo 1. Realizar un algoritmo que permita leer dos valores.

Ejercicio No: 2 Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. Escribir A “Es el mayor” >C A “Es el mayor” 7. B y C 3. C yC 5. Inicializar las variables A. De ser necesario ¿qué cambios deberá realizar? Indíquelos. c. Almacenar en las variables A. Escribir B “Es el mayor” C “Es el mayor” 10. Sino Si B>A y B>C 8. Inicio Inicio 2. El algoritmo debe imprimir cual es el mayor y cual es el menor. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 52 . Fin_Si 14. Realizar un algoritmo que sume dos números. Leer los tres valores 4. B. y C respectivamente. B y C respectivamente. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Fin_Si Fin 13. Si B > A y B > C Entonces No B “Es el mayor” 9. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales. B A. Si A > B y A > C Entonces No Si A>B y A 6. Fin Ejercicios propuestos: a. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática b. B. Escribir C “Es el mayor” 12. d. Asumiendo que los tres valores introducidos por el teclado son valores distintos. Sino 11. El algoritmo debe indicar cual es el menor. ¿Es este algoritmo la solución perfecta al ejercicio anterior? Razone su respuesta. Desarrolle un algoritmo que lea cuatro números diferentes y a continuación imprima el mayor de los cuatro números introducidos y también el menor de ellos. Pseudocódigo Diagrama de Flujo 1. b. Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A.

República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 3 Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. es decir. Pseudocódigo Diagrama de Flujo 1. + 100. Asignación Contador : N N=0 =N+1 Suma = 0 4. El programa deberá imprimir los números en cuestión y finalmente su sumatoria b. Escribir Suma N = 10 7. Repetir desde el Si paso 3 Suma 8. El programa deberá imprimir los números en cuestión y finalmente su sumatoria c. 5 + 10 + 15 +…. Fin_Si 8. comprendidos entre el 1 y el 100. Si N = 10 Entonces No 6. Desarrolle un algoritmo que lea los primeros 300 números enteros y determine cuántos de ellos son Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 53 . + 100. 1 + 2 + 3 + …. Declaración de variables: Inicio N= 0. es decir. Suma = 0 3. De lo contrario. + 10. Desarrolle un algoritmo que realice la sumatoria de los números enteros múltiplos de 5. 2 + 4 + 6 +…. Fin Fin Ejercicios propuestos: a. Desarrolle un algoritmo que realice la sumatoria de los números enteros pares comprendidos entre el 1 y el 100. es decir. Inicio 2. Asignación Acumulador: N=N+1 Suma = Suma + N Suma = Suma + N 5.

República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática impares. Declaración de Variables: CatA= 0. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 54 . Calcular el valor de Hip con la formula indicada 6. Ejercicio No: 4 Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. al final deberá indicar su sumatoria. Desarrollar un algoritmo que calcule el área de un cuadrado. Almacenarlo en la variable CatA y CatB CatB Hip =√CatA + CatB 5. 4. Leer el valor de cada cateto CatA. ¿Qué falta en este algoritmo? ¿ Qué errores presenta? b. Fin Fin Ejercicio propuestos: a. CatB=0 CatA=0. Escribir el valor de la Hipotenusa Hipotenusa 7. Desarrolle el algoritmo correspondiente. CatB=0 3. Inicio Inicio 2. Pseudocódigo Diagrama de Flujo 1.

Leer el valor de Radio (R) y Altura (H) 4. Realiza un algoritmo que le permita determinar el área de un rectángulo. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 55 . República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 5 Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H). Calcular el valor del área aplicando la fórmula respectiva 6.Inicio 2. Pseudocódigo Diagrama de Flujo 1.Fin Ejercicio: a.Escribir el valor del Área y del Volumen 7.Declaración de variables: R = 0.Calcular el Volumen aplicando la fórmula 5. H = 0 3.

Fin Fin Ejercicios propuesto: a. Desarrolle un algoritmo que le permita determinar de una lista de números: b. Asignarlo a la variable N 5. Declaración de variables: N Inicio 3. Pseudocódigo Diagrama de Flujo 1. Complete el algoritmo con la instrucción o instrucciones necesarias. ¿Cuántos mayores de 80? b.3. Fin_Si 9. ambos inclusive? b. Inicio 2. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 56 .2. ¿Cuántos están entre el 50 y 75. sea igual a 0.1. Sino: Escribir “Es impar” N es Impar N es Par 8. Si es Si: Entonces: Escribir “ Es par” No Si 7. ¿Cuántos menores de 30? El algoritmo debe finalizar cuando n (el total de números de la lista). b. Si el residuo de dividir a N entre 2 es igual a cero N 6. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 6 Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Leer un número N=0 4.

Si no (De lo contrario) Si Nota>=19 OR NuevaNota = “A” 7. D = 10. Si no (De lo contrario) OR Nota<=18 10. según la siguiente tabla: A = 19 y 20. Inicio Inicio 2. Declaración de variables: NuevaNota =”A” NuevaNota = Carácter 3. E = 1 hasta el 9. NuevaNota= “A” No 6. NuevaNota= “E” Registro. 11 y 12. Si Nota>=19 OR Nota<=20 Entonces Si Fin Fin Archivo? 5. NuevaNota 18. Se asume que la nota está comprendida entre 1 y 20. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 7 Desarrolle un algoritmo que permita convertir calificaciones numéricas. Leer registros hasta fin de archivo Registro 4. Fin_Si Retorno Ejercicio propuesto: Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 57 . Si Nota>=1 OR Nota<=9 Entonces No 17. NuevaNota= “C” Nota>=13 NuevaNota = “C” OR Nota<=15 12. Si no (De lo contrario) 19. Pseudocódigo Diagrama de Flujo 1. Si no (De lo contrario) Si Nota>=1 OR NuevaNota = “E” Nota<= 9 16. B =16. NuevaNota= “D” No 15. Si Nota>=16 OR Nota<=18 Entonces Nota<=20 No 8. C = 13. 14 y 15. Si no (De lo contrario) No Si 13. Si Nota>=13 OR Nota<=15 Entonces No Si 11. NuevaNota= “B” Si Nota>=16 NuevaNota = “B” 9. 17 y 18. Si Nota>=10 OR Nota<=12 Entonces Nota>=10 NuevaNota = “D” OR Nota<=12 14.

Si no (De lo contrario) B =A 9. Inicio Inicio 2. Declaración de Variables: A = 0. Fin_Si A = Temporal” 10 Escribir “Orden = “. B 4. B = 0. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática a. B 11. Temporal = 0 3. B=0. B Fin Ejercicio Propuesto: a. Asignar a A = Temporal 8. Desarrolle un algoritmo que permita realizar la escritura de los primeros 100 números naturales utilizando la estructura Mientras (While). Asignar a Temporal = B A> B 6. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 58 . Fin “Orden = “ A . Pseudocódigo Diagrama de Flujo 1. Realiza el mismo algoritmo utilizando Mientras (While). Temporal = 0 A=0. Asignar a B = A No Temporal = B Si 7. si es el caso. Leer A y B A. Si A<B Entonces Si 5. también hazlo utilizando En Caso (Case) Ejercicio No: 8 Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. A.

Fin_Si 2 9. ¿Qué falta en este algoritmo? ¿ Qué errores presenta? b. c. Realice un algoritmo que determine cuantos minutos hay en 5 horas. Declaración de variables: J = 2. Fin_Si 15. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 9 Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. Fin del ciclo mientras <= Si 10. S =0 Inicio 3. Realice un algoritmo que determine los veinte primeros números. Inicio 2. Mientras J<= N / 2 hacer N 5. J=J+1 J= N/ 8. Leer N J =2. Sino (De lo contrario) 0 N. Si N / J =0 6. “no es N. S=S+1 No > 7. S = 0 4. Fin Fin Ejercicio propuesto: a. Escribir N “es primo” 0 S=S+1 N/J= 12. Si S = 0 Entonces N/J= No Si 11. Pseudocódigo Diagrama de Flujo 1. Escribir N “no es primo” J=J+1 14. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 59 . “es primo” primo” 13. ¿Cuáles son múltiplos de 2?.

HS 4. Si HoraFraccion >= 1 Entonces No HoraEstadia> Pago = 1000 8. Inicio Inicio 2. Fin “Paga”. De lo contrario HorasRestante=HoraEstadia . Hora Restante = HoraEstadia – 1 Si No HoraEstadia=HoraEstadia +1 11. HoraEstadia=HoraEstadia + 1 =1 9. iniciada una hora se contabiliza como hora total. Realice un algoritmo que calcule el monto a pagar por el servicio de estacionamiento. Imprimir resultado Pago = 1000 + (Horas Restantes * 600) 15. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 60 . HS = 0 Pago = 0 Pagor = 0 3. Leer Datos: HE. Pago Fin Ejercicio propuesto: a. Fin_SI Si Fraccion>=1 10. Pago = 1000 + (HoraRestante * 600) 12. donde al costo de dos entradas se les descuenta el 10%. Si HoraEstadia>= 1 Entonces 7.1 13. teniendo en cuenta que por la primera hora de estadía se tiene una tarifa de 1000 bolívares y las restantes tienen un costo de 600 bolívares. Realice un algoritmo que determine el pago a realizar por la entrada a un espectáculo donde se pueden comprar sólo hasta cuatro entrada. HoraEstadia = HS – HE HE. al de tres entrada el 15% y a la compra de cuatro tickets se le descuenta el 20 %. encuéntrelos y corrijalos. Pseudocódigo Diagrama de Flujo 1. HoraFracción = HoraEstadia–HoraEstadia HoraEstadia = HS – HE Fraccion = 6. Se tiene como datos: hora de entrada. HS 5. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 10 Tanto el Pseudocódigo como el Diagrama de flujo presentan errores. Pago = 1000 14. Declaración de Variables HE = 0 (Hora Entrada) HS = 0 (Hora Salida) HE = 0. hora de salida (formato militar).

República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Ejercicio No: 11 Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. Declaración de Variables: Vel = 0 3. Desarrolle un algoritmo que lea la velocidad en metros por segundo y la convierta a kilómetros por hora. Versal = (Vel * 1000) / 3600 5. Inicio 2. expresada en kilómetros por hora. Ejercicio No: 12 Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 61 . Pseudocódigo Elabore Diagrama de Flujo 1. proporcione la velocidad en metros por segundo. Fin Ejercicio propuesto: a. Imprimir resultado 6. Leer Datos: Vel 4.

Acumula= 0 4. Leer N N = 0. Promedio = Acumula/Cuenta Cuenta = Cuenta + 1 9. Acumula = Acumula + N No N <>0 7. Fin Acumula = Acumula + N Retorn o Promedio = Acumula / Cuenta “Promedio: ”.A. Ejercicio No: 13 Desarrolle un algoritmo para la empresa Constructora Tecnovivir Casas C. Suma = 0. Promedio 10. que le permita calcular e Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 62 . Promedio Fin Ejercicio propuesto: a. Mientras N <> 0 hacer N 5. Pseudocódigo Diagrama de Flujo 1. Fin Mientras Si 8.. Promedio = 0. Imprimir “Promedio:”. Acumula= 0 3. Cuenta= 0. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Desarrolle un algoritmo que permita calcular Promedio de Notas. Declaración de Variables: Inicio N = 0. finaliza cuando N = 0. Inicio 2. Desarrolle un algoritmo que permita calcular la media aritmética. Cuenta = Cuenta + 1 6.

Leer Datos 5. Total_nómina= Totalnómina + Salario 8. Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 63 . Total_nomina Fin Ejercicios propuestos: a. Realice el mismo algoritmo utilizando la herramienta REPEAT. Declaración de Variables: Numero_Horas_Trabajadas=0 Numero_Obreros =50 Numero_Hora_Trabajadas = 0 Titulos Total_nomina = 0 3. Numero_Obreros = Numero_Obreros .1 Registro Datos Retorn o “Total:”. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Pseudocódigo Diagrama de Flujo Inicio 1. Imprimir líneas de títulos de la nómina Datos 4. Ejercicio No: 14 Desarrolle un algoritmo que funcione como caja registradora. ¿Qué pasaría si no se decrementa al número de obreros en uno? b. Leer Datos 11. Mientras Numero_Obreros>0 No Número_Obreros 6. Fin Numero_Obreros = Numero_Obreros . La hora trabajada se pautó en 30. Total_nómina Total_nomina=Total_nomina + Salario 13. c. Total_nomina=0. 2. Inicio Numero_Obreros=50. Salario = Numero_Hora_Trabajada * 30 >0 7.1 Si 9. Fin_Mientras 12. Imprimir “Total : “.000 Bolívares. Realice el mismo algoritmo utilizando la herramienta FOR. Imprimir Registro Salario = Numero_Hora_Trabajada * 30000 10.

Mientras Código_Producto <> “ “ Código_Producto<>” “ Si 7. Ingrese “Código de Producto y Código_Producto. Total Fin Ejercicios propuestos: Realice el mismo algoritmo utilizando la herramienta IF-THEN – ELSE. Fin_Mientras Código_Producto. Declaración de Variables: Sub_total=0. Total “SubTotal:”. Total = 0 3. 11. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Pseudocódigo Diagrama de Flujo 1. Subtotal = Subtotal + Precio Subtotal = Subtotal + Precio 8. Imprimir “Total: “. Almacenar Codigo_Producto.15 Precio 12. Imprimir “Sub Total : “.15. Precio 4. Imprimir líneas de títulos del recibo de pago No 6. Imprimir Codigo_Producto. IVA 16. Inicio Inicio 2. ingresado por pantalla. Precio Titulos 5. ¿Cuántos Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 64 . Precio:” Precio 10. IVA 15.Total = 0 Subtotal = 0. Imprimir “ IVA : “. Ingrese “Código de Producto y Precio:” Codigo_Producto. Total = Subtotal + IVA Retorn o 13. Fin “Total:”. Ejercicio No: 15 Desarrolle un algoritmo que permita determinar a partir de un número de días. IVA = Subtotal * 0. Subtotal “IVA:”. Subtotal IVA= Subtotal *0. Precio 9. Total = Subtotal + IVA 14.

Desarrolle el algoritmo anterior utilizando la herramienta Si-Entonces-De lo contrario-Fin_SI (IF-THEN-ELSE- END-IF) Ejercicio No: 16 Determine el resultado del siguiente diagrama de flujo. ”. “ Días” “Hay :“. “ Años. Meses= 0.365 365 No Mientras Meses = Meses +1 Dias Retorno Dias > Dias = Dias . Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 65 . Num_dias. Elabore su enunciado. Meses. Pseudocódigo Diagrama de Flujo Elabore el pseudocódigo Inicio Años=0. meses.30 30 Mientras Meses = Meses +1 Dias Retorno Dias > 7 Dias = Dias . constituyen el número de días proporcionado utilizando la estructura Mientras o While. Desarrolle el algoritmo anterior utilizando la herramienta Repetir (REPEAT). Semanas=0.7 “En ”. Dias=0 Num_dias Dias = Num_dias Si Mientras Años = Años+ 1 Dias Retorno Dias > Dias = Dias . “ Meses y ” Dias. realice el pseudocódigo. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática años. semanas y días. Años. b. “ Dïas” Fin Ejercicios propuestos: a.

1000 No Resto = C N. BD. República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Pseudocódigo Diagrama de Flujo Elabore el Inicio pseudocódigo BC=0. Resto Fin Enunciado: Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 66 . BC. BM.20000 C Retorno 20000 No Si BD = BD +1 C Retorno N >= C = C .50000 50000 No Si BV = BV +1 N >= C = C . BV. BD=0. BC2=0. BM=0 N C=N Si BC = BC + 1 C Retorno N >= C = C .5000 No Si BM = BM +1 C Retorno N >= 1000 C = C . BC2. BV= 0.10000 10000 No No Si BC2 = BC2 +1 C Retorno N >= 5000 C = C .

República Bolivariana de Venezuela Ministerio de Educación Superior Fundación Misión Sucre Programa Nacional de Formación en Sistemas e Informática Bibliografía Barcons Gloria T (1991): Cardivillo Carlos J y Ramírez Jesús Alberto. Universidad Nacional Abierta. McGraw-Hill. Joyanes Aguilar. Caracas. Torrealba Javier (2004): Computación I. Algoritmos y Estructuras de datos y Objetos. Universidad Nacional Abierta. y Bratley P(2000): Fundamentos de Algoritmia. Caracas Misión Sucre y la Municipalización del Programa Nacional en Sistemas e Informática 67 . Computación II. Brassard G. Prentice may. L (2003): Fundamentos de programación. Madrid.