You are on page 1of 28

CentralTECH

Curso de Redes IP

1 © Copyright
© Copyright 2016-CentralTECH
2013 CentralTECH www.cteducacion.com-- www.cteducacion.com
masinfo@cteducacion.com - masinfo@cteducacion.com
Índice
Ruteo estático en IPv6

OSPFv3

EIGRPv6

Laboratorios

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (Configuración: rutas estáticas -1)
Rutas estáticas:
Al igual que en IPv4 con el comando ip route, en IPv6 es similar utilizando el comando ipv6 route.

Ruta estática utilizando interface de salida:


R1(config)# ipv6 route 2001:db8:1111:2::/64 s0/0/0

R1# show ipv6 route static


! Legend omitted for brevity
S 2001:DB8:1111:2::/64 [1/0]
via Serial0/0/0, directly connected

R1# show ipv6 route 2001:db8:1111:2::22


Routing entry for 2001:DB8:1111:2::/64
Known via "static", distance 1, metric 0
Route count is 1/1, share count 0
Routing paths:
directly connected via Serial0/0/0
Last updated 00:01:29 ago

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (Configuración: rutas estáticas -2)

Ruta estática utilizando como NEXT-HOP una IPv6 Global Unicast Address:
R1(config)# ipv6 route 2001:db8:1111:2::/64 2001:DB8:1111:4::2

R1# show ipv6 route static


! Legend omitted for brevity
S 2001:DB8:1111:2::/64 [1/0]
via 2001:DB8:1111:4::2

R1# show ipv6 route 2001:db8:1111:2::22/64


Routing entry for 2001:DB8:1111:2::/64
Known via "static", distance 1, metric 0
Backup from "ospf 1 [110]"
Route count is 1/1, share count 0
Routing paths:
2001:DB8:1111:4::2
Last updated 00:07:43 ago

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (Configuración: rutas estáticas -3)

Ruta estática utilizando como NEXT-HOP una IPv6 Link-Local Address:


R1(config)# ipv6 route 2001:db8:1111:2::/64 S0/0/0 FE80::FF:FE00:2
(IMPORTANTE: en este caso se debe especificar además la interface de salida)

R1# show ipv6 route static


! Legend omitted for brevity
S 2001:DB8:1111:2::/64 [1/0]
via FE80::FF:FE00:2, Serial0/0/0

R1# show ipv6 route 2001:db8:1111:2::22


Routing entry for 2001:DB8:1111:2::/64
Known via "static", distance 1, metric 0
Backup from "ospf 1 [110]"
Route count is 1/1, share count 0
Routing paths:
FE80::FF:FE00:2, Serial0/0/0
Last updated 00:08:10 ago

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (Configuración: ruta por defecto –default-route)
Ruta por defecto:
La ruta por default se identifica con la red todos “0”. Al igual que en IPv4 es la 0.0.0.0/0, en IPv6 la
ruta por default se identifica con ::/0

Ejemplo ruta default utilizando interface de salida:

R1(config)# ipv6 route ::/0 s0/0/0

R1#show ipv6 route


IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, Serial0/0/0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: semejanzas OSPFv2)
OSPFv3 vs OSPFv2 - Semejanzas:

• Ambos son protocolos de estado de enlace (link-state).


• Ambos utilizan el mismo concepto de diseño por áreas.
• Ambos requieren que el protocolo de enrutamiento debe estar habilitado en una interfaz
• Una vez habilitado, ambos tratan de decubrir los vecinos directamente conectados a una interface.
• Ambos chequean casi los mismos parámetros para que un router se pueda convertir en vecino y
formar adyacencia con otro (la excepción es que OSPFv3 no necesita estar en la misma subred como
en OSPFv2).
• Luego de convertirse en vecinos, ambos protocolos proceden al intercambio de sus bases de
datos. de estado de enlace (LSDB) y anuncios de estado de enlace (LSA) que describen la topología
de red.
• Una vez intercambiados todos los LSA, ambos protocolos utilizan el algoritmo SPF para calcular la
mejor ruta a cada subred.
• Ambos utilizan el mismo concepto de métrica , con base en el costo de cada interfaz, con los
mismos valores de costo predeterminados.

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


OSPFv3

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com 8


IPv6 (OSPFv3: diferencias OSPFv2)
OSPFv3 vs OSPFv2 - Diferencias:
• En OSPFv3, Instance ID es un nuevo campo que se utiliza para tener varias instancias del proceso
OSPF por enlace (link).

• Multicast Addressess:
Multicast Address OSPFv3 OSPFv2
All-SPF Routers FF02::5 224.0.0.5
224.0.0.5
All-DR Routers FF02::6 224.0.0.6
224.0.0.6

• Tipos LSA:

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: configuración)
Al momento de habilitar el protocolo OSPFv3 sobre una interface, no se utiliza el subcomando
network dentro del modo de configuración global de ospf para identificar dicha interface como en
OSPFv2, sino que se habilita con un subcomando dentro de la interface:
OSFPv2:

Define el Process ID
Define el Router.ID (opcional)
Indirectamente habilita el proceso OSPF en la interface

Define el número de área

OSPFv3:
Define el Process ID
Define el Router.ID (opcional)

Directamente habilita el proceso OSPF en la interface

Define el número de área

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Router-ID & Interface)
Router-ID:
OSPFv3 utiliza las mismas reglas que OSPFv2 para definir el Router-ID. El router ID sigue siendo de
32 bits, con lo cual se debe configurar manualmente si el router no tiene ninguna IPv4 configurada.
Interface:
Para habilitar una interface se utiliza el subcomando dentro de la interface:
ipv6 ospf process area area

Para pasivar una interface se realiza de la misma forma que en OSPFv2 con el subcomando:
passive-interface interface

Ejemplo:
R1(config)# ipv6 router ospf 1
Jan 4 21:03:50.622: %OSPFv3-4-NORTRID: OSPFv3 process 1 could not pick a router-id,
please configure manually
R1(config-rtr)# router-id 1.1.1.1
R1(config-rtr)# passive-interface serial0/0/0
R1(config-rtr)# interface serial0/0/0
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface serial0/0/1
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface GigabitEthernet0/0
R1(config-if)# ipv6 ospf 1 area 0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Resumen comandos configuración)
Resumen comandos configuración OSPFv6:

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Verificación)
La siguiente lista muestra las equivalencias de comandos entre OSPFv2 y OSPFv3

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Verificación -ejemplos)
Ejemplo verificación configuración OSPFv3:
R1# show ipv6 ospf
Routing Process "ospfv3 1" with ID 1.1.1.1
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 3
SPF algorithm executed 4 times
Number of LSA 13. Checksum Sum 0x074B38
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Verificación -ejemplos)
Ejemplo verificación interfaces:
R1# show ipv6 ospf interface brief
Interface PID Area Intf ID Cost State Nbrs F/C
Gi0/0 1 0 3 1 DR 0/0
Se0/0/1 1 0 7 64 P2P 1/1
Se0/0/0 1 0 6 64 P2P 1/1

Ejemplo verificación protocolo:


R1# show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
Interfaces (Area 0):
GigabitEthernet0/0
Serial0/0/1
Serial0/0/0
Redistribution:
None

Ejemplo verificación vecinos:


R1# show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
3.3.3.3 0 FULL/ - 00:00:39 6 Serial0/0/1
2.2.2.2 0 FULL/ - 00:00:31 7 Serial0/0/0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (OSPFv3: Verificación -ejemplos)
Ejemplo verificación rutas:

R2# show ipv6 route ospf


IPv6 Routing Table - default - 9 entries
! Legend omitted for brevity
O 2001:DB8:1111:1::/64 [110/65]
via FE80::FF:FE00:1, Serial0/0/1
O 2001:DB8:1111:5::/64 [110/65]
via FE80::FF:FE00:3, GigabitEthernet0/0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


EIGRPv6

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com 17


IPv6 (EIGRPv6: Diferencia configuración v4)
EIGRP para IPv6 es similar a la versión para IPv4. El cálculo de la métrica es exactamente igual.
La única diferencia radica en la forma de configurarlo y hay que tener en cuenta las mismas
consideraciones que OSPFv6 en cuanto a la forma de habilitar las interfaces y el router-id.

Define el Número de Sistema Autónomo


Define el Router.ID (opcional)

Directamente se habilita el proceso EIGRP sobre la interface por SA

El router-id se vuelve mandatorio si el router no tiene ninguna IPv4 configurada, dado que mantiene
el mismo campo de 32bits como en OSPFv6.
Además EIGRPv6 tiene la característica de poder estar deshabilitado (shutdown), por lo tanto dentro
del modo de configuración de EIGRP ejecutar el comando no shutdown. Dependiendo del IOS el
modo default puede ser shutdown o no shutdown.

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (EIGRPv6: similitudes configuración v4)
El resto de las configuraciones es similar a EIGRPv2.
A continuación las equivalencias de comandos:

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (EIGRPv6: ejemplo configuración)
Ejemplo configuración:

ipv6 unicast-routing
!
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
!
interface GigabitEthernet0/0
ipv6 address 2001:db8:1:2::2/64
ipv6 eigrp 1
!
interface serial 0/0/0
description link to R3
ipv6 address 2001:db8:1:6::2/64
ipv6 eigrp 1
!
interface serial 0/0/1
description link to R1
ipv6 address 2001:db8:1:5::2/64
ipv6 eigrp 1
!

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (EIGRPv6: Verificación)
Proceso de verificación y comandos relacionados:

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (EIGRPv6: ejemplo verificación)
Ejemplo verificación:
Router#show ipv6 eigrp interfaces
IPv6-EIGRP interfaces for process 6

Xmit Queue Mean Pacing Time Multicast Pending


Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/1 0 0/0 1236 0/10 0 0
Se0/0/0 1 0/0 1236 0/10 0 0

Router#show ipv6 protocols


IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "static
IPv6 Routing Protocol is "eigrp 6 "
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Interfaces:
FastEthernet0/0
FastEthernet0/1
Serial0/0/0
Serial0/1/0
Redistributing: eigrp 6
Maximum path: 16
Distance: internal 90 external 170

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 (EIGRPv6: ejemplo verificación)
Ejemplo verificación:
Router#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 6
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 Link-local address: Fa0/1 10 00:00:17 40 1000 0 9
FE80::201:C9FF:FED3:A302
1 Link-local address: Se0/0/0 11 00:00:10 40 1000 0 13
FE80::2E0:B0FF:FEBA:5315

Router#show ipv6 eigrp topology


IPv6-EIGRP Topology Table for AS 6/ID(1.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,


r - Reply status

P 2000:12::/64, 1 successors, FD is 28160


via Connected, FastEthernet0/1
P 2000:1::/64, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 2000:23::/64, 1 successors, FD is 20514560
via FE80::201:C9FF:FED3:A302 (20514560/20512000), FastEthernet0/1
via FE80::2E0:B0FF:FEBA:5315 (21024000/20512000), Serial0/0/0
P 2000:2::/64, 1 successors, FD is 30720
via FE80::201:C9FF:FED3:A302 (30720/28160), FastEthernet0/1
P 2000:13::/64, 1 successors, FD is 20512000
via Connected, Serial0/0/0
P 2000:3::/64, 1 successors, FD is 20514560
via FE80::2E0:B0FF:FEBA:5315 (20514560/28160), Serial0/0/0

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


Laboratorios

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com 24


IPv6 - PRACTICA - ( Ruteo Estático)
1.Arme la siguiente topología.
2. Configure el direccionamiento IPv6.
de forma estática - Manual, según la red asignada.
3. Realice las rutas estáticas necesarias para
Tener conectividad de extremo a extremo.
4. Verifique mediante ping la conectividad
entre todos los dos host.

RECUERDE:
- HABILIBAR el ruteo IPv6 con el comando
<ipv6 unicast-routing>
- Puede verificar la ip asignada con el comando:
show ipv6 interface <tipo> <numero>
- La sintaxis del comando ping es: ping ipv6 <d>
- Utilice el método abreviado para simplificar la
red

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 - PRACTICA - ( Ruteo dinámico –OSPFv3)
1.Arme la siguiente topología. (en otro archivo)
2. Configure el direccionamiento IPv6.
de forma estática - Manual, según la red asignada.
3. Realice la configuración necesaria para levantar
Ospfv3 como protocolo de ruteo dinámico.
4. Verifique mediante ping la conectividad
entre todos los dos host.

RECUERDE:
- HABILIBAR el ruteo IPv6 con el comando
<ipv6 unicast-routing>
- Puede verificar la ip asignada con el comando:
show ipv6 interface <tipo> <numero>
- La sintaxis del comando ping es:
ping ipv6 <destino ipv6>
- Utilice el método abreviado para simplificar
la red

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


IPv6 - PRACTICA - ( Ruteo dinámico –EIGRPv6)
1.Arme la siguiente topología. (en otro archivo)
2. Configure el direccionamiento IPv6.
de forma estática - Manual, según la red asignada.
3. Realice la configuración necesaria para levantar
EIGRPv6 como protocolo de ruteo dinámico.
4. Verifique mediante ping la conectividad
entre todos los dos host.

RECUERDE:
- HABILIBAR el ruteo IPv6 con el comando
<ipv6 unicast-routing>
- Puede verificar la ip asignada con el comando:
show ipv6 interface <tipo> <numero>
- La sintaxis del comando ping es:
ping ipv6 <destino ipv6>
- Utilice el método abreviado para simplificar
la red

© Copyright 2016 CentralTECH - www.cteducacion.com - masinfo@cteducacion.com


¿Preguntas?

28 © Copyright
© Copyright 2016-CentralTECH
2013 CentralTECH www.cteducacion.com-- www.cteducacion.com
masinfo@cteducacion.com - masinfo@cteducacion.com