You are on page 1of 7

``

Año del Dialogo y la Reconciliaciòn Nacional’’

FACULTAD DE INGENERÌA DE SISTEMAS

Escuela: Ing. Sistemas
Docente: Martin Salcedo Quiñones
Curso: Algoritmos y Estructura de Datos
Ciclo: I
Integrantes:
 Ramos Fernandez Aaròn
 Castañeda López Eli Sayes
 Carrera Valverde Dani
 Zavaleta Zavaleta Miguel Ángel
 Gonzales Castro Flavio

Fin Si FinProceso DESARROLLO PROBLEMA 2 Proceso problema2 Escribir c1. Si prom>=10.prom. Sino Escribir "Alumno desaprobado".5 Entonces Escribir "Alumno aprobado". Escribir "Ingrese el valor c1".c3.c2. Leer c3 prom<-(c1+c2+c3)/3. prom. Fin Si FinProceso .c3. Leer c2 Escribir "Ingrese el valor c3". Sino Escribir "Alumno desaprobado".DESARROLLO DE PROBLEMAS RESPUESTA 1 PROBLEMA Proceso problema1 Leer c1.c2. prom<-(c1+c2+c3)/3 Si prom>=10. Leer c1 Escribir "Ingrese el valor c2".5 Entonces Escribir "Alumno aprobado".

Sino descuento<-0. descuento. Fin Si totaldepago<-Compra-descuento. descuento. Mostrar "Costo por las camisas". Leer Compra. Si Compra>1000 Entonces descuento<-Compra*0. Sino descuento<-compra*0. totaldepago.20.DESARROLLO PROBLEMA 3 Proceso problema3 Escribir Compra. Escribir "Cuantas camisas va a comprar?" Leer compra Si compra>3 Entonces descuento<-compra*0. Mostrar totalpago FinProceso . Mostrar "total de pago es".20.10. totalpago. Mostrar totaldepago FinProceso DESARROLLO PROBLEMA 4 Proceso problema4 Escribir compra. Fin Si totalpago<-compra-descuento.

Mostrar costodelauto FinProceso DESARROLLO PROBLEMA 6 Proceso problema6 Escribir "Cuantas horas trabajo el obrero?" Leer horasdetrabajo si horasdetrabajo<=40 Entonces salario<-horasdetrabajo*16 Escribir "El salario del trabajador es ". Leer precio. Fin Si costodelauto<-precio-descuento.horasdetrabajo-40 salario<-(40*16)+(Horasextras*20). Escribir "El salario del trabajador es ". descuento. Sino Horasextras<. costodelauto.05. Mostrar "Precio del auto".10. salario FinSi FinProceso . Si precio>15000 Entonces descuento<-precio*0. Escribir "Precio del auto". salario.DESARROLLO PROBLEMA 5 Proceso problema5 Escribir precio. Sino descuento<-precio*0.

n2.n1.n2. Fin Si FinProceso DESARROLLO PROBLEMA 8 Proceso problema8 Escribir "Quien es mayor?" Leer Antony.DESARROLLO PROBLEMA 7 Proceso problema7 Leer n1. " y el menor es Antonty".n1. " y el menor es: " . " y el menor es Ruben". Sino Escribir "El mayor es: " .n2. Ruben. Sino Escribir "El mayor es Ruben". si Antony>Ruben Entonces Escribir "El mayor es Antony". " y el menor es: " . FinSi FinProceso . Si n1 > n2 Entonces Escribir "El mayor es: " .

DESARROLLO PROBLEMA 9 Proceso problema9 Mostrar "Menu" Mostrar "1. Total.80*cant_dolares Mostrar "El total es: ". Convertir Dolares a soles" Mostrar "2. " nuevo soles" Sino Leer cant_soles Total=cant_soles/2. " dolares americanos" Fin Si FinProceso .83 Mostrar "El total es: ". Convertir Soles a Dolares" Mostrar "Elija la opción (1 o 2):" Leer opcion Si opcion=1 Entonces Leer cant_dolares Total=2. Total.

Convertir Soles a Dolares" Mostrar "Elija la opción (1 o 2):" Leer opcion Si opcion=1 Entonces Leer cant_dolares Total=Dolar*cant_dolares Mostrar "El total es: ". " dolares americanos" Fin Si FinProceso . Total. Total.DESARROLLO PROBLEMA 10 Proceso problema10 Mostrar "Menu" Escribir "Precio del dolar?" leer Dolar Mostrar "1. " nuevo soles" Sino Leer cant_soles Total=cant_soles/Dolar Mostrar "El total es: ". Convertir Dolares a soles" Mostrar "2.