You are on page 1of 4

Universidad Técnica Particular de Loja

UNIVERSIDAD TÉCNICA PARTICULAR DE LOJA


La Universidad Católica de Loja

Electrónica y Telecomunicaciones
Nombre: Bryan A. Gordillo P.
Ciclo: I Fecha: 10/11/12
FACTORIAL DE NUMEROS PRIMOS
PSEINT C++
Proceso primos_factorial #include <iostream>
c=2; using namespace std;
escribir "ingrese rango" int main(){
leer n; int c,n,cd,d;
escribir "los # primos con sus factoriales hasta el: long long int factorial,cont;
",n," son:"
c=2;
mientras (c<=n) hacer
cout<<"ingrese rango1:"<<endl;
d=2;
cin>>n;
cd=0; cout<<"los # primos con sus factoriales hasta el: "<<n<<"
mientras (d<c) hacer son: "<<endl;
si (c mod d = 0) entonces while (c<=n)
cd=cd+1; {
finsi d=2;
d=d+1; cd=0;
finmientras while (d<c)
{
factorial=1;
if (c%d==0)
cont=2;
{
mientras (cont<=c) hacer cd=cd+1;
factorial = factorial*cont; }
cont= cont+1 d=d+1;
FinMientras }
si (cd=0) entonces factorial=1;
escribir " ", c ,"! =", factorial for(cont=2;cont<=c;cont++)
finsi {
factorial*=cont;
c=c+1;
}
FinMientras
if (cd==0)
{
FinProceso cout<<c<<"! =\t"<<factorial<<endl;
}
c=c+1;
}
return 0;
}

Electronica y Telecomunicaciones
Universidad Técnica Particular de Loja

Diagrama de flujo Ejecuciones “PseInt” , ”c++”

CORRIDA MANUAL
n c d cd C<=n D<c CmodD=0 Factorial cont Cont<=c c Factorial(fac*cont) C!=factorial
10 2 2 0 2<=10 2<2 ------------ 1 2 2<=2 2 2 2!=2
3 3 0 3<=10 2<3 3mod2=1 2 3 3<=3 3 (2*3) =6 3!=6
4 4 1 4<=10 3<4 4mod3=1 6 4 4<=4 (6*4)=24
5 5 0 5<=10 4<5 5mod4=1 24 5 5<=5 5 (24*5)=120 5!=120
6 6 2 6<=10 5<6 6mod5=1 720 6 6<=6 (120*6)=720
7 7 0 7<=10 6<7 7mod6=1 5040 7 7<=7 7 (720*7)=5040 7!=5040
8 8 3 8<=10 7<8 8mod7=1 8 8<=8 (5040*8)=40320
9 9 4 9<=10 8<9 9mod8=1 9 9<=9 (40320*9)=362880
10 10 5 10<=10 9<10 10mod9=1 10 10<=10 (362880*10)=3628800
11 11<=10 10<10 ----------------

Electronica y Telecomunicaciones
Universidad Técnica Particular de Loja

TRIANGULO DE PASCAL

#include<iostream>
#include <iomanip>
using namespace std;
Proceso sin_titulo int factorial(int numero);
Escribir "(2x-4y)^7=1(2x)^7 + int formula(int numero,int posicion);
int main()
7(2x)^6(4y) + 21(2x)^5(4y)^2 + {
35(2x)^4(4y)^3 + 35(2x)^3(4y)^4 + int numero;
21(2x)^2(4y)^5 + 7(2x)(4y)^6 + 1(4y)^" cout<<"Ingrese la potencia: ";
Escribir " " cin>>numero;
Escribir " " int x = numero * 2;
for(int i = 0; i <= numero;++i,x -= 2)
Escribir " " {
Escribir " " for(int s = 0; s <= x;s++)
escribir "0| 1" cout<<" ";
Escribir "1| 1 1" for(int k = 0; k <= i;++k)
Escribir "2| 1 2 1" {
cout<<setw(4)<<formula(i,k);
Escribir "3| 1 3 3 1" }
Escribir "4| 1 4 6 4 1" cout<<endl;
Escribir "5| 1 5 10 10 5 1" }
Escribir "6| 1 6 15 20 15 6 1" cin.get();
Escribir "7| 1 7 21 35 35 21 7 1" cin.get();
return 0;
FinProceso }
int factorial(int numero)
{
int factorial = 1;
for(int i = 1; i <= numero;++i)
{
factorial *= i;
}
return factorial;
}
int formula(int numero,int posicion)
{
int combinacion;
combinacion = factorial(numero)/
(factorial(numero-posicion)* factorial(posicion));
return combinacion;
}

Electronica y Telecomunicaciones
Universidad Técnica Particular de Loja

DIAGRAMA DE FLUJO EJECUCIONES PSEINT, C++

CORRIDA MANUAL

7 1 1<=7 1 “ “ -> 1
7 1 1<=7 11 + -> 11
7 2 2<=7 121 + -> 121
7 3 3<=7 1331 + -> 1331
7 4 1<=7 14 6 41 + -> 14 6 41
7 5 1<=7 15101051 + -> 1 5 10 10 5 1
7 6 1<=7 1615201561 + -> 1 6 15 20 15 6 1
7 7 1<=7 17213535217 1 -> 1 7 21 35 35 21 7 1

Electronica y Telecomunicaciones