You are on page 1of 7

CCNA Discovery

Trabajar en una pequeña o mediana empresa o ISP

Práctica de laboratorio 5.3.8 Configuración de NAT y DHCP


con CLI de IOS

Dirección y máscara
Designación Nombre de subred de Fast Dirección y máscara Tipo de Dirección
del router del router Ethernet 0 de subred de serial 0 interfaz de loopback
192.168.1.1 209.165.200.225
Router 1 Cliente 255.255.255.0 255.255.255.224 DCE No aplicable
209.165.200.226 209.165.200.1
Router 2 ISP No aplicable 255.255.255.224 DTE 255.255.255.224

Objetivos
 Configurar un router y un host del cliente para DHCP.
 Configurar un router en las instalaciones del cliente para NAT sobrecargada, también denominada
Traducción de la dirección del puerto (PAT).
 Verificar las traducciones DHCP y NAT desde el interior de la red del cliente a ISP.

Información básica/Preparación
Establezca una red similar a la que se muestra en el diagrama de topología. Se puede usar cualquier router
que cumpla con los requisitos de interfaz que se ven en dicho diagrama, como los routers 800, 1600, 1700,
1800, 2500, 2600, o una combinación de estos. Consulte la tabla del resumen de la interfaz del router al final
de esta práctica de laboratorio para determinar correctamente los identificadores de interfaz que se deben
usar según el equipo disponible en el laboratorio. El resultado puede ser distinto del que aparece en esta
práctica de laboratorio según el modelo del router. Se deben ejecutar los pasos de esta práctica de
laboratorio en cada router a menos que se especifique lo contrario.

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 1 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Se necesitan los siguientes recursos:


 Dos routers, uno con una interfaz Ethernet y una serial y el otro con una interfaz serial
 Una computadora con Windows XP
 Cable Ethernet de conexión directa categoría 5 (PC1 a switch)
 Cable serial nulo
 Cables de consola (desde PC 1 a los routers R1 y R2)
 Acceso al indicador de comando de la PC
 Acceso a la configuración TCP/IP de red de la PC

Desde la PC, inicie una sesión HyperTerminal con el router.


NOTA: Diríjase a las instrucciones de “Borrar y recargar el router” que aparecen al final de esta práctica de
laboratorio. Realice esos pasos en todos los routers asignados a esta práctica antes de continuar.
NOTA: Routers SDM: si se elimina startup-config en un router SDM, SDM ya no aparecerá de manera
predeterminada cuando se reinicie el router. Será necesario establecer una configuración básica de router
usando los comandos IOS. Consulte el procedimiento que aparece al final de esta práctica de laboratorio
o comuníquese con su instructor.

Paso 1: Cablear y configurar los routers


a. Siguiendo el diagrama de la topología, conecte la PC, el switch y los routers utilizando el cableado
adecuado.
b. Configure cada router con los siguientes parámetros: nombre del host, acceso y contraseña de
consola, acceso y contraseña vty y contraseña secreta de enable. Si fuera necesario, consulte la
Práctica de laboratorio 5.3.5, “Configuración de parámetros básicos del router con la CLI de IOS”,
para ver las instrucciones para configurar el nombre del host, las contraseñas y las direcciones de
interfaces.
c. Configure las interfaces del router con la dirección IP y máscara de subred correspondientes.
Asegúrese de que las interfaces se encuentren en condiciones de uso y que puedan hacer ping
a una interfaz o host conectados directamente.
d. Configure el router del ISP con una dirección de loopback para utilizarla para probar el router del
cliente. La dirección de loopback representa una red distante.
ISP(config)#interface loopback 0
ISP(config-if)#ip address 209.165.200.1 255.255.255.224

Paso 2: Configurar una ruta por defecto en el router del cliente


a. En el router del cliente, configure un ruta por defecto con dirección al ISP. Todos los paquetes
destinados a redes que no se encuentren en la tabla de enrutamiento del cliente son enviados al
router del ISP, que posee una tabla de enrutamiento y conexiones bastante mayores en comparación
con los otros proveedores de Internet. Observe cómo esta ruta por defecto utiliza la dirección IP del
router vecino como el último número.
Customer(config)#ip route 0.0.0.0 0.0.0.0 209.165.200.226
b. ¿Por qué no se utiliza una ruta por defecto en el SP? Una ruta por defecto en el router del ISP sería
una mala configuración si está dirigida a un sitio del cliente. Toda ruta que no se encuentre en la tabla
de enrutamiento del ISP será enviada automáticamente al router del cliente. El router del cliente no
sabría qué hacer con el paquete y lo enviaría a la ruta por defecto del router del cliente, que es el ISP.
Se producirá un routing loop.

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 2 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Paso 3: Configurar y probar el pool de DHCP


a. En el router del cliente, configure un pool de DHCP para los clientes internos.
Customer(config)#ip dhcp excluded-address 192.168.1.1
Customer(config)#ip dhcp pool INTERNAL
Customer(dhcp-config)#network 192.168.1.0 255.255.255.0
Customer(dhcp-config)#domain-name abc-xyz-widgets.inc
Customer(dhcp-config)#default-router 192.168.1.1
b. En la PC host del cliente, haga clic en Inicio > Panel de control > Conexiones de red para verificar
que la NIC esté configurada para DHCP. Si fuera necesario, abra una solicitud de entrada de comandos
y ejecute los comandos ipconfig /release e ipconfig /renew.
c. En la PC host del cliente, abra una solicitud de entrada de comandos. Haga clic en Inicio > Ejecutar,
y luego escriba cmd y presione Intro. También puede hacer clic en Inicio > Todos los programas >
Accesorios > Indicador de comandos. Emita el comando ipconfig /all.
d. ¿Qué dirección IP se envía a la PC? __________________________
e. ¿Cuál es la dirección MAC de la PC host? __________________________
f. Desde la PC host, haga ping al gateway por defecto (la interfaz Ethernet del router). ¿Fue exitoso el
ping? _______ Sí Resuelva el problema si fuera necesario y no continúe hasta que el ping tenga éxito.

Paso 4: Mostrar la asignación DHCP en el router del cliente


a. Para visualizar la combinación de la dirección IP y la dirección de hardware del host (MAC) asignada
por el servidor DHCP en el router, emita el comando show ip dhcp binding en el router del cliente.
Customer#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.2 0100.0bdb.04a5.cd May 26 2007 11:19 AM Automatic
b. ¿Las direcciones IP y la de hardware que se muestran coinciden con las registradas para la PC host
en el Paso 3? ______

Paso 5: Configurar NAT/PAT


a. En el router del cliente, utilice el comando access-list para identificar las direcciones que necesitan
ser traducidas. Se indica el número de red, pero en lugar de una máscara normal que generalmente
le sigue, se utiliza una máscara wildcard (0.0.0.255).
Customer(config)#access-list 1 permit 192.168.1.0 0.0.0.255
b. En el router del cliente, defina dónde busca la NAT las direcciones IP que deben ser traducidas
(la lista de origen 1 se refiere a la lista de acceso 1 que usted creó). Defina también qué dirección IP
de la interfaz debe utilizar como la dirección real para cada paquete que atraviese la interfaz
FastEthernet destinado a la interfaz serial. El parámetro overload al final del comando que se
muestra a continuación significa que se utiliza la dirección IP del puerto serial y que se utilizan los
números de puertos para rastrear los paquetes. Aproximadamente, en realidad se pueden traducir
4.000 direcciones usando este método, aunque es técnicamente posible traducir incluso más.
Customer(config)#ip nat inside source list 1 interface serial 0/0 overload
c. Aplique NAT a las interfaces internas y externas.
Customer(config)#interface serial 0/0
Customer(config-if)#ip nat outside
Customer(config-if)#exit
Customer(config)#interface fastethernet 0/0
Customer(config)#ip nat inside
Customer(config)#end
Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 3 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Paso 6: Probar NAT/PAT


a. Desde la solicitud de entrada de comandos de la PC host, haga ping a la dirección de loopback
del router.
ping 209.165.200.1
b. ¿Fue exitoso el ping? ________ Caso contrario, resuelva el problema.
c. En el router del cliente, emita el comando para verificar la traducción NAT.
Customer#show ip nat translation
Pro Inside global Inside local Outside local Outside global
icmp 209.165.200.225:512 192.168.1.2:512 209.165.200.1:512 209.165.200.1:512
d. Enumere las siguiente direcciones IP:
¿Cuál es la dirección IP global interna que aparece? ______________________________________
¿Cuál es la dirección IP local interna que aparece? _______________________________________
¿Cuál es la dirección IP local externa que aparece? _______________________________________
¿Cuál es la dirección IP global externa que aparece? ______________________________________
e. En el router del ISP, configure el router para mostrar todos los paquetes ICMP que ingresan a él.
ISP#debug ip icmp
ICMP packet debugging is on
f. Desde la solicitud de entrada de comandos de la PC host, emita un ping continuo.
ping 209.165.200.1 –t
g. En el router del ISP, observe el resultado de la depuración.
ISP#
00:49:10: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:11: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:12: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:13: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:14: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:15: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:16: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
h. ¿Cuál es la dirección IP de origen de la respuesta ICMP? __________________________________
i. ¿Cuál es la dirección IP de destino de la respuesta ICMP? _________________________________
j. ¿Esta depuración prueba o refuta el hecho de que las direcciones IP internas están ocultas?
y ¿cómo puede usted saberlo?
______________________________________________________________________________
______________________________________________________________________________
k. En la PC host, detenga el ping presionando CTRL-X.
l. En el router del ISP, detenga el proceso de depuración. Observe que el router se toma unos
segundos para que el resultado desaparezca de pantalla.
ISP#undebug all

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 4 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Paso 7: Eliminar las traducciones NAT

a. Desde la solicitud de entrada de comandos de la PC host, abra una sesión Telnet al router del ISP.
telnet 209.165.200.226
La sesión Telnet creará otra traducción en el router del cliente.
b. En el router del cliente, emita el comando para verificar la traducción NAT.
Customer#show ip nat translation
Pro Inside global Inside local Outside local Outside global
tcp 209.165.200.225:1297 192.168.1.2:1297 209.165.200.226:23 209.165.200.226:23
El número de puerto en las direcciones internas puede ser diferente ya que son números de puerto
de origen generados de manera aleatoria.
c. Cierre la ventana de comandos en la PC host del cliente para terminar la sesión Telnet.
d. En el router del cliente, emita el comando para verificar la traducción NAT.
Customer#show ip nat translation
e. ¿La traducción para la PC host del cliente aún permanece activa en el router del cliente? _________
Las traducciones NAT permanecen activas durante diferentes períodos de tiempo, según el tipo
de traducción. Las traducciones TCP NAT pueden permanecer activas hasta 24 horas de manera
predeterminada. Las traducciones de puertos poseen límites de tiempo menores pero pueden
permanecer activas durante minutos e incluso horas después de que la sesión entre dos host haya
expirado. Los tiempos de espera predeterminados para UDP varían entre 1 y 5 minutos. Para
obtener más información sobre los tiempos de espera de NAT, consulte el informe Información
general sobre traducción de la dirección de red de IOS de Cisco en el sitio Web Cisco.com.
http://cisco.com/en/US/tech/tk648/tk361/technologies_white_paper09186a0080091cb9.shtml
f. En el router del cliente, emita el comando para eliminar todas las traducciones NAT activas en el router.
Customer#clear ip nat translation *

Verifique que la traducción para la PC host del cliente ya no esté activa en el router del cliente.

Paso 8: Reflexión
a. ¿Cuál sería la ventaja de utilizar el método NAT que aparece en esta práctica de laboratorio en
contraposición a la configuración estática que se muestra en el programa?
______________________________________________________________________________
______________________________________________________________________________
b. Mencione un ejemplo de cuándo una compañía no podría utilizar NAT/PAT.
______________________________________________________________________________
______________________________________________________________________________

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 5 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Borrar y recargar el router


a. Ingrese al modo EXEC privilegiado escribiendo enable.
Router>enable
b. En el modo EXEC privilegiado, ingrese el comando erase startup-config.
Router#erase startup-config
La solicitud de entrada de línea de respuesta es:
Erasing the nvram filesystem will remove all files! Continue?
[confirm]
c. Presione Intro para confirmar.
La respuesta es:
Erase of nvram: complete
d. En el modo EXEC privilegiado, introduzca el comando reload.
Router(config)#reload
La solicitud de entrada de línea de respuesta es:
System configuration has been modified. Save? [yes/no]:
e. Escriba n y luego presione Intro.
La solicitud de entrada de línea de respuesta es:
Proceed with reload? [confirm]
f. Presione Intro para confirmar.
La primera línea de la respuesta será:
Reload requested by console.
La solicitud de entrada de línea aparece después de que el router se recarga:
Would you like to enter the initial configuration dialog? [yes/no]:
g. Escriba n y luego presione Intro.
La solicitud de entrada de línea de respuesta es:
Press RETURN to get started!
h. Presione Intro.
El router está listo para iniciar la práctica de laboratorio asignada.

Resumen de la interfaz del router


Modelo de router Interfaz Ethernet #1 Interfaz Ethernet #2 Interfaz serial #1 Interfaz serial #2
800 (806) Ethernet 0 (E0) Ethernet 1 (E1)
1600 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)
1700 Fast Ethernet 0 Fast Ethernet 1 Serial 0 (S0) Serial 1 (S1)
(FA0) (FA1)
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 Serial 0/0/1
(FA0/0) (FA0/1) (S0/0/0) (S0/0/1)
2500 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 6 de 7
CCNA Discovery
Trabajar en una pequeña o mediana empresa o ISP

Resumen de la interfaz del router


2600 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0 (S0/0) Serial 0/1 (S0/1)
(FA0/0) (FA0/1)
NOTA: Para conocer la configuración exacta del router, consulte las interfaces. Esto le permitirá
identificar el tipo de router y la cantidad de interfaces que éste posee. No existe una forma eficaz
de confeccionar una lista de todas las combinaciones de configuraciones para cada clase de router.
Lo que se ha presentado son los identificadores de las posibles combinaciones de interfaces en el
dispositivo. Esta tabla de interfaces no incluye ningún otro tipo de interfaz aunque puede existir
otro tipo en un router determinado. La interfaz BRI RDSI es un ejemplo de esto. La cadena entre
paréntesis es la abreviatura legal que se puede utilizar en un comando IOS para representar la
interfaz.

Configuración IOS básica del router SDM para activar SDM


Si se elimina startup-config en un router SDM, SDM ya no aparecerá de manera predeterminada
cuando se reinicie el router. Se deberá establecer una configuración básica tal como se muestra
a continuación. La Guía de inicio rápido de SDM contiene más detalles sobre la configuración y el
uso de SDM:
http://www.cisco.com/en/US/products/sw/secursw/
ps5318/products_quick_start09186a0080511c89.html#wp44788
1) Configure la dirección IP Fa0/0 del router
(Ésta es la interfaz a la que se conectará una PC para usar un explorador
para activar el SDM. Se debe establecer la dirección IP de la PC en
10.10.10.2 255.255.255.248)

NOTA: Un router SDM que no sea el 1841 puede requerir conexión a un puerto diferente para
acceder a SDM.

Router(config)# interface Fa0/0


Router(config-if)# ip address 10.10.10.1 255.255.255.248
Router(config-if)# no shutdown

2) Habilite el servidor HTTP/HTTPS del router usando los siguientes


comandos del IOS de Cisco:
Router(config)#ip http server
Router(config)#ip http secure-server
Router(config)#ip http authentication local

3) Cree una cuenta de usuario con nivel 15 de privilegio (habilitar


privilegios).
Router(config)# username <username> privilege 15 password 0 <password>

Reemplace <username> y <password> con el nombre de usuario y la


contraseña que desea configurar.

4) Configure SSH y Telnet para el inicio de sesión local y el nivel de


privilegio 15.
Router(config)# line vty 0 4
Router(config-line)# privilege level 15
Router(config-line)# login local
Router(config-line)# transport input telnet
Router(config-line)# transport input telnet ssh
Router(config-line)# exit

Todo el contenido es Copyright © 1992 – 2007 de Cisco Systems, Inc. Todos los derechos reservados.
Este documento es información pública de Cisco. Página 7 de 7