You are on page 1of 5

2ª AVALIAÇÃO DO SEMESTRE (GABARITO)

1) Linearize a seguinte expressão:


3 1
√ + 𝑥2 − 𝑦2
𝑥
𝑧= − 𝑥2 − 𝑦
𝑥 + 𝑦2
( )

2) Resolva a expressão lógica:


C=B OR E<A AND D>C OR D-B<A AND E>D
A+B=C
B=A
D<A+B
C<E

3) Elaborar um algoritmo que mostra a tabuada de 1 ate 10 na tela do micro. É obrigatório o


uso de repetição.

var
i,j: inteiro
inicio
para i de 1 ate 10 faca
Escreval ("Tabuada do ",i)
para j de 1 ate 10 faca
escreval (i, " X ", j, " = ", i*j)
fimpara
fimpara
fimalgoritmo

4) Dado o seguinte algoritmo:

algoritmo "triângulo"
var
a, b, c: inteiro
inicio
leia (a, b, c)
se (a<b+c) e (b<a+c) e (c<b+a) entao
se (a=b) e (b=c) entao
escreval ("Triângulo equilátero")
senao
se (a<>b) e (a<>c) e (b<>c) entao
escreval ("Triângulo escaleno")
senao
escreval ("Triângulo isósceles")
fimse
fimse
senao
escreval ("Estes lados não formam um triângulo")
fimse
fimalgoritmo

Modificar o código de maneira que, quando o usuário digitar os três valores e estes não
formarem um triângulo, uma mensagem deve ser exibida e os valores devem ser digitados
novamente. Após três tentaivas consecutivas sem sucesso, exibir a mensagem "Abortando a
execução" e terminar o algoritmo.
_______________________________________________________________
var
a, b, c: inteiro
inicio
leia (a, b, c)
se (a<b+c) e (b<a+c) e (c<b+a) entao
se (a=b) e (b=c) entao
escreval ("Triângulo equilátero")
senao
se (a<>b) e (a<>c) e (b<>c) entao
escreval ("Triângulo escaleno")
senao
escreval ("Triângulo isósceles")
fimse
fimse
senao
escreval ("Estes lados não formam um triângulo. Digite novamente.")
leia (a, b, c)
se (a<b+c) e (b<a+c) e (c<b+a) entao
se (a=b) e (b=c) entao
escreval ("Triângulo equilátero")
senao
se (a<>b) e (a<>c) e (b<>c) entao
escreval ("Triângulo escaleno")
senao
escreval ("Triângulo isósceles")
fimse
fimse
senao
escreval ("Estes lados não formam um triângulo. Digite novamente.")
leia (a, b, c)
se (a<b+c) e (b<a+c) e (c<b+a) entao
se (a=b) e (b=c) entao
escreval ("Triângulo equilátero")
senao
se (a<>b) e (a<>c) e (b<>c) entao
escreval ("Triângulo escaleno")
senao
escreval ("Triângulo isósceles")
fimse
fimse
senao
escreval ("Abortando a execução.")
fimse
fimse
fimse
fimalgoritmo

5) Dado o algoritmo:

algoritmo "questão 3"


var
a,c,x: inteiro
m:real
inicio
a<-0
c<-0
para x de 9 ate 101 faca
se int(x/2)*2=x entao
a<-a+x
c<-c+1
fimse
fimpara
m<-a/c
escreva (m)
fimalgoritmo
a) Escreva o enunciado para a questão, de maneira que a solução seja o algoritmo apresentado
acima.

Elabore um algoritmo que...............


calcule a média dos números pares de 9 até 101.

6) Faça um algoritmo para ler valores inteiros para um vetor de 30 posições. Após a leitura
escrever o vetor. Posteriormente, trocar os valores d vetor de maneira que o primeiro seja
trocado com o último, o segundo com o penúltimo, e assim respectivamente. Escreva
novamente o vetor.

var
x,y: vetor [1..30] de inteiro
i,j: inteiro
inicio
aleatorio on
para i de 1 ate 30 faca
leia (x[i])
y[i]<-x[i]
fimpara
para i de 1 ate 30 faca
escreva (x[i])
fimpara
escreval
para i de 1 ate 30 faca
x[i]<-y[31-i]
fimpara
para i de 1 ate 30 faca
escreva (x[i])
fimpara
// Seção de Comandos
fimalgoritmo

7) Elabore um algoritmo que lê valores naturais para uma matriz a[6][6]. A seguir, calcule a
média aritmética dos valores lidos. Escreva a matriz, a média e informe um dos valores mais
próximos da média (ou o mais próximo) e sua respectiva posição.

Considerações:
- A leitura deve ser aleatória, limitando os valores de 1 até 50;
- Se o valor mais próximo da média for encontrado em mais de uma posição da matriz,
escrever o último que for encontrado.

var
x: vetor [1..6,1..6] de inteiro
i,j,m,n: inteiro
media, comp:real
inicio
aleatorio on
para i de 1 ate 6 faca
para j de 1 ate 6 faca
leia (x[i,j])
media<- x[i,j]+media
fimpara
fimpara
media<-media/36
comp<-0
para i de 1 ate 6 faca
para j de 1 ate 6 faca
//1
se (media>x[i,j])e(comp>media)entao
se (comp-media>media-x[i,j]) entao
comp<-x[i,j]
m<-i
n<-j
fimse
fimse
//2
se (media>x[i,j])e(comp<media)entao
se (media-comp>media-x[i,j]) entao
comp<-x[i,j]
m<-i
n<-j
fimse
fimse
//3
se (media<x[i,j])e(comp>media)entao
se (comp-media>x[i,j]-media) entao
comp<-x[i,j]
m<-i
n<-j
fimse
fimse
//4
se (media<x[i,j])e(comp<media)entao
se (media-comp>x[i,j]-media) entao
comp<-x[i,j]
m<-i
n<-j
fimse
fimse
fimpara
fimpara

para i de 1 ate 6 faca


para j de 1 ate 6 faca
escreva (x[i,j])
fimpara
escreval
fimpara
escreval ("A média dos valores da matriz é: ", media)
Escreval ("O valor mais próximo da média é ", x[m,n], " e sua posição é ",m,"X",n)
fimalgoritmo